Full Description

This compact and comprehensive book systematically unveils what resolute users of the new Windows XP operating system will find interesting and useful, with little-known details, utility programs, and configuration settings all captured in a consistent reference format.

A hands-on guide, *Windows XP in a Nutshell* cuts through the hype and gives practical details you can use every day. It’s written by David A. Karp, the best-selling author whose no-nonsense “Annoyances” books and web site (Annoyances.org) have helped thousands of users solve problems and improve their experience with Windows®. The co-author is none other than Tim O’Reilly, founder of O’Reilly & Associates, whose books have revolutionized computer book publishing with their commonsense approach and depth of detail.

At the heart of the book is a 200-plus-page reference section titled "Windows XP Applications and Tools," containing:

- Detailed information on most of the commands and utilities available with Windows XP, including Start Menu accessories, command prompt tools, hidden system administration utilities such as the Registry Editor, Microsoft Management Console, and TweakUI.
- A comprehensive "Where to Find It?" section designed to give Windows 9x/Me and Windows NT/2000 users a guide to the XP counterparts to previously familiar features, plus information on installing and upgrading.
- The Task and Setting Index, which provides users with quick access to locations of the hundreds of settings in Windows XP, organized alphabetically.
- A complete reference to the command prompt-- not only covering the basics of the command line and the different ways to use it, but also the advanced commands and scripting features at Windows XP's disposal.

Packed with numerous tips and tricks, while warning of potential pitfalls, *Windows XP in a Nutshell* enables anyone to get the most out of all the resources available in XP.
Windows XP in a Nutshell
by David A. Karp, Tim O'Reilly, Troy Mott

This errata page lists errors outstanding in the most recent printing.

If you have technical questions or error reports, you can send them to booktech@oreilly.com. Please specify the printing date of your copy.

This page was updated July 18, 2002.

Here's a key to the markup:

- [page-number]: serious technical mistake
- {page-number}: minor technical mistake
- #: important language/formatting problem
- (page-number): language change or minor formatting problem
- ?: page-number?: reader question or request for clarification

Confirmed errors:

(Page 10)
Some of the callouts in Figure 2-4 are wrong. The arrows in the picture for items #7, #V, and #8 should be changed as follows:

1. should point to the gray area between the scrollbar thumb (current #7) and the down arrow (#6)
2. should point to the scrollbar thumb (current #7)
8. should point to the up arrow (current #V)

Page 21
The last sentence in the (a) Grayed-out (inactive) controls paragraph should read: "In the dialog box shown in Figure 2-0, the currently selected screensaver doesn't have any applicable settings, so the Settings button is disabled."

Page 824
Reference to Appendix C should be to Chapter 8.

Page 96
At the end of the first paragraph, "Comp.exe" should be "fc.exe."
Page 20
The word "Several" shouldn't be capitalized.

Page 211
1st paragraph, 1st sentence: "then" should be "than"

Page 249
The text "new values" should not be set apart in a mono-spaced font

Page 292
The "System Properties" section is out of order (alphabetically).

Page 310
"Windows Messenger" should be "Windows Messenger"

Page 431
Fourth paragraph, first line: "it's" should be "its"

Page 440
In tip #7, "Try something new with My Computer," there's a step missing. In order for this tip to work, you'll also need to navigate to HKEY_CLASSES_ROOT\CLSID\{1D404FE-5AEAC-11E8-A2D-101E01B505D0\}shell and change the (default) value to open.

Page 504
The showhello code example should read as follows:

```vba
Sub showhello(strMessage, strMessage$)
   WScript.Echo strMessage & " " & strMessage$
End Sub
showhello "Hello", "World"
```

Page 517
The code example near the top of the page should read as follows:

```vba
' display a popup with yes/no buttons and question mark icon
Set objShell = CreateObject("Wscript.Shell")
intValue = objShell.Popup("Do you wish to continue?",,,5)
'test if the Yes button was selected
```
If intValue = 1
    'do something
End If

Page 000
The first paragraph on this page discusses the missing My Computer icon on the desktop, but
the tip immediately following is wrong. Instead, it should read as follows: "By default, the My
Computer icon is not shown on the Windows XP desktop, but it's there if you need it. Go to
Control Panel -> Display -> Desktop tab -> Customize Desktop and turn on the My Computer
option."

Page 001
Although the alphabetical listing of filename extensions is not intended to include every
extension in existence, the following extensions should've been included here:
.pot  PowerPoint Template
.pps  PowerPoint Presentation that opens into slide show
.ppt  PowerPoint Presentation (document)
.pst  Outlook personal folder file
Windows XP in a Nutshell

Preface
Considerations and Scope
Organization of the Book
We'd Like to Hear from You
Windows XP Resource Links
Acknowledgments

I: The Big Picture

\ The Lay of the Land
  \ The Big Picture
  \ What's New in Windows XP
  \ Windows XP Home and Professional Editions
  \ Windows Update

\ Using Windows XP
  \ The Desktop
  \ Point and Click Operations
  \ Starting Up Applications
  \ Styles and Consequences of Styles
  \ Windows and Menus
  \ Keyboard Accelerators
  \ Common Controls
  \ Files, Folders, and Disks
  \ The Command Line
  \ Online Help
  \ Shutting Down

II: Alphabetical Reference

\ The User Interface
  Address Bar
  Buttons
  Checkboxes
  Clipboard
  Combo Boxes
  Context Menus
  Control Menus
  Desktop
  Details
  Dialog Boxes
  Drop-Down Listboxes
  File Open/Save Dialogs
  Icons
  Input Fields
  Labels
  Listboxes
  Log Off
  Menus
  My Computer
  My Network Places
  Notification Area
  Progress Indicators
  Properties
  Radio Buttons
Recycle Bin
Run
Scroll Bars
Send To
Shortcuts
Shut Down
Start Menu
Status Bar
System Tray
Tabbed Dialogs
Taskbar
Text Boxes
Title Bars
Toolbars
Tray
Trees
Turn Off Computer
Windows

1. Windows XP Applications and Tools
2. Using the Command Prompt
3. Alphabetical Reference to Windows Components

Accessibility Options
Accessibility Wizard
Activate Windows
Active Connections Utility
Add Hardware Wizard
Add or Remove Programs
Address Book
Administrative Tools
At
Attrib
Backup
Boot Configuration Manager
Cabinet (CAB) Maker
Calculator
Character Map
Chat
Chkdsk
Chkntfs
Clipboard Viewer
Command Prompt
Component Services
Computer Management
Connection Manager Profile Installer
Control Panel
Create Shared Folder
Date and Time Properties
DDE Share
Device Manager
DirectX Management Tool
Disk Cleanup
Disk Defragmenter
DiskPart
Display Properties
Dr. Watson
Driver Verifier Manager
DriverQuery
Event Viewer
Explorer
FAT to NTFS Conversion Utility
Fax Console
Fax Cover Page Editor
File Compare (comp)
File Compare (fc)
File Expansion Utility
File and Settings Transfer Wizard
Finger
Folder Options
Font Viewer
Fonts Folder
ForceDOS
Format
FreeCell
FTP
Game Controllers
Group Policy Refresh Utility
Hearts
Help and Support Center
HyperTerminal
IExpress
Internet Backgammon
Internet Checkers
Internet Explorer
Internet Hearts
Internet Reversi
Internet Options
Internet Spades
Java Command-Line Loader
Keyboard Properties
Label
Local Security Policy
Logoff
Microsoft Chat
Microsoft Magnifier
Microsoft Management Console
Microsoft NetMeeting
Minesweeper
Mouse Properties
Msg
MSN Explorer
MSN Gaming Zone
My Computer
My Network Places
Narrator
Net
Netstat
Network Connections
Network Setup Wizard
New Connection Wizard
Notepad
NSLookup
NTFS Compression Utility
NTFS Encryption Utility
Object Packager
ODBC Data Source Administrator
On-Screen Keyboard
OpenFiles
Outlook Express
Paint
Pentium Bug Checker
Performance Log Manager
Performance Logs and Alerts
Phone and Modem Options
Phone Dialer
Pinball
Ping
Power Options
Printers and Faxes
Private Character Editor
Product Activation
Program Manager
Query Process
Regional and Language Options
Recycle Bin
Registry Console Utility
Registry Editor
Remote Assistance
Remote Copy
Remote Desktop Connection
Route
Rundll32
Run As
Scanners and Cameras
Scheduled Tasks
Scheduled Tasks Console
Security Template Utility
Send a Fax
Services
Shutdown
Signature Verification Tool
Solitaire
Sound Recorder
Sounds and Audio Devices
Speech Properties
Spider Solitaire
SQL Server Client Network Utility
Start Menu
Subst
Synchronization Manager
System Properties
System Configuration Editor
System Configuration Utility
System Information
System Restore
Task Manager
Taskbar and Start Menu Properties
Taskkill
Tasklist
Telnet
Telnet Administrator
Windows Explorer

1. The Command Prompt
   1.1 Using the Command Line
   1.2 Command Prompt Choices
   1.3 Wildcards, Pipes, and Redirection
   1.4 Alphabetical Reference to DOS Commands
      cd or chdir
      cls
      copy
      date
      del or erase
      dir
      echo
      exit
      find
      md or mkdir
      more
      move
      path
      prompt
      rd or rmdir
      ren or rename
      set
      sort
      type
      time
      ver
      xcopy
   1.5 MS-DOS Batch Files
      call
      choice
      errorlevel
      for
      goto
      if
      pause
      rem
      shift

III: Advanced Topics

2. Networking
   2.1 Networking Terminology
   2.2 General Procedures

2. The Registry
   2.1 What's in the Registry
   2.2 Adding and Deleting Registry Keys and Values
   2.3 Organization of the Registry
   2.4 Hives
   2.5 Backing Up the Registry
   2.6 Exporting and Importing Registry Data with Patches
   2.7 Ten Cool Things You Can Do in Your Registry

4. The Windows Script Host
What Is WSH?
Additional Resources
Executing Scripts
Creating a Script
VBScript
Object Model
Wscript Object
Shell Object
Registry Routines
Shortcuts
Popup
Network Object
Network Printer-Related Functions
FileSystem Object
TextStream Object
Object Browser
Database Example
Messaging

IV: Appendixes

A. Installing Windows XP
   A.1 Installation on a New (Clean) System

B. Migrating to Windows XP
   B.1 Before Upgrading to Windows XP

C. Keyboard Shortcuts
   C.1 Keyboard Accelerators Listed by Key
   C.2 Keyboard Accelerators Listed by Function

D. Power Toys and TweakUI
   D.1 Inside TweakUI

E. Keyboard Equivalents for Symbols and International Characters

F. Common Filename Extensions

G. Services

Colophon
Preface

Windows XP is the latest product in a long line of operating systems from Microsoft. Although it's superficially similar to earlier versions of Windows, there's quite a bit new under the hood, and on the surface as well. A consumer-friendly, almost cartoonish interface sits on top of the most complex Windows version yet. A graphical user interface, like the one in Windows XP, is not a substitute for good, thorough documentation. Naturally, colorful icons and animated interface elements make the interface more inviting and help uninitiated users stumble through the basics of opening programs and printing documents. There are only so many hours in the day, though, and spending most of them trying to figure out the new networking system, sorting through the thousands of settings in the Registry, discovering all of the hidden tools, or even learning to be productive with the new Windows Movie Maker, is really not good use of your time. By taking the undocumented or otherwise hidden features and settings in Windows XP and placing them in context with more conspicuous and familiar components, this book provides the complete picture necessary to truly understand the operating system and what is involved in completing just about any task.

There are many books on Windows XP, but most of them get bogged down with elementary tutorials and the scrappiest tasks most of us could perform in our sleep. That's where this book comes in. *Windows XP in a Nutshell* provides a condensed but thorough reference to Windows XP, with an organization that helps you get right to the task at hand.

For example, there are literally hundreds of settings and features in Windows XP, scattered throughout dozens of dialog boxes. Some are plainly accessible through the Start menu or in the Control Panel, while others are hidden under layers of application menus. A few aren't apparent at all without knowledge of hidden features. In Chapter 0, all these settings are listed in the same place, sorted alphabetically from A-Z. So, instead of wading through menus and flipping through dialogs looking for a way to stop Windows from disconnecting your dial-up connection to the Internet (or for the setting that affects sounds in web pages) just look in Chapter 0, under "Dialing" and "Sounds," respectively.

Considerations and Scope

Our focus is on user applications, however, not on system or network administration. While we give you a basic understanding of these deeper levels and what's available, specific installation details and detailed configuration information for system and network administrators are largely beyond the scope of the book. There are also settings that depend on decisions made by your network administrator or Internet Service Provider (ISP), especially with networks systems. Whenever possible, we give you the information you need, but there are times when all we can tell you is where to go for additional information. We have tried to speak universal truths about Windows XP, but sometimes we are forced to make assumptions about your settings or installed options. Microsoft gives so many configuration options that the truth is, for better or worse, that each user's machine represents a slightly different installation of Windows XP. Of all the code and data Microsoft ships on the Windows XP CD-ROM, only about half is used in any particular user's configuration. What we say about Windows XP may or may not be quite true about Windows XP as it's installed on your system. For example, there's a setting in Control Panel ➔Folder Options that instructs Windows to open icons with either a double-click or a single-click, according to your preference. While most users tend to prefer the double-click option, and double-
clicking is the default on most systems, your system might be different (it might even be the default, depending on the operating system you had installed previously). Although both setups are clearly defined in Chapter 1, some procedures elsewhere in this book will instruct you to double-click where you may only need to single-click. This "knowledge gap" is an unfortunate consequence of the malleable nature of the Windows operating system.

Consider another oddity in Windows XP: categories in Control Panel. This new addition in Windows XP (discussed further in Chapter 2) splits the components of the Control Panel into distinct categories, rather than simply listing them alphabetically, as in previous versions of Windows. What's more, the Control Panel can be accessed in any of three different ways, (as a menu in the Start menu, as a standalone folder window, or as an entry in the folder tree in Windows Explorer) and the category interface (which can be disabled completely, if desired) is used only in some cases. This means that it's difficult (and laborious) to predict when you'll need to open the "Appearance and Themes" category before you can get to the Display Properties dialog. We've compensated for this ambivalence by enclosing the category name in "maybe" brackets, like this: Control Panel ➔ [Appearance and Themes] ➔ Display Properties.

Also, for all the statements (from Microsoft and others) that Windows XP is "integrated" and "seamless," the fact is that the system is actually amazingly modular, customizable, and "seamy." This is a good thing. This book shows a lot of different ways to modify Windows XP to suit your needs, a theme that is expanded further in the Annoyances books (O'Reilly & Associates), also by David A. Karp. This almost infinite customizability and modularity of Windows XP means that many of our statements about the product — such as saying that the My Computer window has an icon for Control Panel, or that the Desktop corresponds to the \Documents and Settings\Administrator\Desktop folder, or that Windows XP is faster than Windows Me — may, strictly speaking, be false, or at least serious oversimplifications.

Basically, Windows XP is a platform and set of capabilities, not a single stable product with a fixed set of features. In this book, we give you the information you need to tap into all of Windows XP's capabilities, not just those that are showcased on Microsoft's web site or the Windows Desktop.

**Organization of the Book**

This book is divided into four parts.

**Part I**

This part of the book is designed to give you the lay of the land and to introduce the concepts used throughout the rest of the book. It consists of two chapters: Chapter 1 gives a brief review of Windows XP, what's new in this release, and where it fits into the grand scheme of things. Chapter 2 covers the basics of using Windows, such as starting applications, manipulating files, and getting around the interface. If you're familiar with any modern version of Windows, much of this is probably old hat.

**Part II**

This part of the book contains alphabetically organized references for each major element of Windows XP. Once you're at a given point in the system, what can you do there?
**Chapter 5** is a thorough examination of the elements that make up the Windows XP graphical user interface. In addition to the basics of windows, menus, buttons, listboxes, and scrollbars, you'll learn about the new visual styles in Windows XP, how to make the most of the Taskbar, and how to use any component of Windows with only the keyboard.

**Chapter 6** is the comprehensive reference that covers all the programs that come with Windows XP, those listed in the Start menu and Control Panel, and as those available only if you know where to look. For GUI-based applications, we don't document every menu, button, and dialog box — the GUI is often self-evident. Instead, we focus on nonobvious features and provide helpful hints about power user features and things that will make your life easier. For command-line based programs, we cover every option, since these programs are not as obviously self-documenting (though many do support the conventional `/?` command-line option for help).

**Chapter 7** is the way to find that elusive setting or feature without having to know ahead of time where Microsoft has decided to hide it away. Every option in every dialog box, as well as many common tasks, are presented in a single, straightforward reference. Options that affect how Windows plays sounds, for example, are scattered in a half-dozen different dialogs; here, they're all under "S."

**Chapter 1** provides complete documentation on this often overlooked and underestimated part of the operating system. In addition to learning the ins and outs of the Command Prompt application, you can look up any command and find exactly what options it supports. Batch files, a quick and easy way to automate repetitive tasks, are also covered.

**Part III**

This part, encompassing the final three chapters, covers the more advanced topics in Windows XP:

**Chapter 8** is your one-stop shop for setting up home networking, connecting to the Internet, and everything in between. Furthermore, security is a genuine concern for home users and businesses alike, and is covered throughout the chapter as well. **Chapter 9** describes the organization of the Windows XP Registry, the central configuration database upon which Windows and all of your applications rely to function and remember your settings. The Registry Editor, the primary interface to the Registry, is covered here, along with some of the more interesting entries scattered throughout this massive database. **Chapter 10** describes the Windows Script Host (WSH), the built-in scripting subsystem that is surprisingly flexible and powerful. Use the scripting language of your choice to automate common tasks and access features not available elsewhere.

**Part IV**

This section includes various quick reference lists. **Appendix A** covers everyone's least-favorite activity. In addition to documenting the various installers and options, the chapter includes a number of pitfalls and solutions that will apply to nearly every installation. **Appendix B** presents some of the factors you should take into consideration before you upgrade to Windows XP, as well as some of the adjustments you'll need to make after you take the plunge. Among other things, you'll learn how to make Windows XP look and feel more like previous versions of Windows by turning off some of the most annoying bells and whistles. **Appendix C** gives a list of keyboard accelerators (also known as hotkeys or keyboard shortcuts) used in all parts of the Windows interface.
Appendix D covers the add-on suite of tools Microsoft has provided for "power users" of Windows XP. TweakUI is easily the most important tool in the bunch. It provides many features and settings that should have been included in the operating system in the first place.

Appendix E explains how to type the symbols and international characters normally only accessible with Character Map (discussed in Chapter 4).

Appendix F lists many file types and their descriptions. This appendix is useful when you're trying to figure out how to open a specific file and all you know is the filename extension.

Appendix G lists the background services that come with Windows XP and their respective filenames. If you need to find a service, or simply need to determine the purpose of a particular program shown to be running in the Windows Task Manager (see Chapter 4), this appendix will provide the answer.

Conventions Used in This Book

The following typographical conventions are used in this book:

**Constant width** is used to indicate anything typed, as well as command-line computer output and code examples.

**Constant-width bold** is used to indicate user input in code.

**Constant-width italic** is used to indicate variables in examples and so-called "replaceable" text. For instance, to open a document in Notepad from the command line, you'd type `notepad filename`, where `filename` is the full path and name of the document you wish to open.

**[Square Brackets]** Square brackets around an option (usually a command-line parameter) means that the parameter is optional. Include or omit the option, as needed. Parameters not shown in square brackets are typically mandatory. See Section P.1.1, which follows, for another use of square brackets in this book.

**Italic** is used to introduce new terms and to indicate URLs, variables in text, user-defined files and directories, commands, file extensions, filenames, directory or folder names, and UNC pathnames.

The following symbols are used in this book:

- This symbol indicates a tip.
- This symbol indicates a warning.

Path Notation

Rather than using procedural steps to tell you how to reach a given Windows XP user interface element or application, we use a shorthand path notation. For example, we don't say, "Click on the Start menu, then click on Search, then For Files or Folders, and then type a filename in the Named: field." We simply say: Start ➔ Find ➔ Files or Folders ➔ Named. We generally don't distinguish between menus, dialog boxes, buttons, checkboxes, etc., unless it's not clear from the context. Just look for a GUI element whose label matches an element in the path.
The path notation is relative to the Desktop or some other well-known location. For example, the following path:
Start → Programs → Accessories → Calculator
means "Open the Start menu (on the Desktop), then choose Programs, then choose Accessories, and then click Calculator." But rather than saying:
Start → Settings → Control Panel → Add or Remove Programs
we just say:
Control Panel → Add or Remove Programs
since Control Panel is a "well-known location" and the path can therefore be made less cumbersome. As stated earlier in this preface, the elements of the Control Panel may or may not be divided into categories, depending on context and a setting on your computer. Thus, rather than a cumbersome explanation of this unfortunate design every time the Control Panel comes up, the following notation is used:
Control Panel → [Performance and Maintenance] → Scheduled Tasks
where the category, "Performance and Maintenance," in this case, is shown in square brackets, implying that you may or may not encounter this step.
Paths will typically consist of clickable user interface elements, but they sometimes include text typed in from the keyboard (shown in constant-width text):
Start → Run → telnet
or:
Ctrl-Alt-Del → Shut Down
There is often more than one way to reach a given location in the user interface. We often list multiple paths to reach the same location, even though some are longer than others, because it can be helpful to see how multiple paths lead to the same destination.
The following well-known locations are used as starting points for user interface paths:

**Control Panel**
Start → Control Panel (if you're using the new Windows XP Start menu)
Start → Settings → Control Panel (if you're using the classic Start menu)

**Explorer**
The two-pane folder view, commonly referred to as "Explorer:" Start → Programs → Accessories → System Tools → Windows Explorer

**My Computer**
The My Computer icon on the Desktop (which may or may not be visible)

**My Network Places**
The My Network Places icon on the Desktop (which may or may not be visible)

**Recycle Bin**
The Recycle Bin icon on the Desktop

**Start**
The Start button on the Taskbar

**xxxx menu**
Menu xxxx in the application currently being discussed (e.g., File or Edit)

**Command-Line Syntax**

Further conventions used for representing command-line options and arguments are described in the introduction to Chapter y.

**Windows XP Resource Links**

There is a web site for this book, which lists errata, examples, or any additional information. You can access this page at:
http://www.oreilly.com/catalog/winxpnut/
or view David A. Karp's Windows resource on the Web at:
http://www.annoyances.org/

Acknowledgments

This is the third In a Nutshell book covering a version of Microsoft Windows. Although this book has evolved substantially from its progenitors, Windows 95 in a Nutshell and Windows 98 in a Nutshell (as Windows itself has evolved), its existence is due to the hard work of those who worked on those earlier volumes. Tim O'Reilly developed the original concept for the book; he and Troy Mott were the principal authors of the first edition. Andrew Schulman was also instrumental in helping get the first edition of this book off the ground, and it was he who insisted on the importance of the command line. Walter Glenn was a major contributor to the second edition. Thanks to John Fronckowiak, Stein Borge, and Ron Petrusha for their efforts, which formed the basis of the Windows Script Host chapter. This new edition was developed by David Karp and incorporates some material from his bestselling Windows Annoyances series. Tim O'Reilly was the editor of this new edition. He had help from Bob Herbtsman and Maeve O'Meara, who managed the day to day details of the project, and in Maeve's case, entered hundreds of last minute edits.

We are also indebted to the generosity of hundreds of Windows users who've shared tips, insights, and detailed documentation on particular aspects of the system they've uncovered, either through their own web sites, posts to the Annoyances.org discussion forums, or emails at r.r. in the morning. We refer to some of these sites in the book, but many others have contributed to our understanding of Windows, taught us useful tips, or corrected our assumptions. David adds: This book was a big job, much more so than I anticipated. But it was an important book for me to write, giving me a new perspective and appreciation for the attention and focus required to document such a complex and confusing product as Windows XP. I'd like to thank my friends and family, not only for keeping me grounded with their incessant computer questions as they were discovering Windows XP in their own highly individual and bizarre ways, but for distracting me when I needed it most with movies, food, cards, fresh air, Wei Qi, skiing, and of course, the Simpsons. D'oh!
Part I: The Big Picture

Chapter 8. The Lay of the Land

In many ways, Windows XP is a bit of an anachronism. On one hand, it is technically only an incremental upgrade to Windows 2000, released only a year earlier. On the other hand, it is the first consumer-level operating system based on a powerful and robust platform previously available only to advanced users and network administrators.

Windows XP is easily the most technically sophisticated operating system Microsoft has ever released, but it is adorned with an almost cartoonish interface. It has an advanced, scalable networking system built in, but networking is easier to set up in Windows XP than in any other release. It has the heftiest system requirements of any Windows to date, but given the same hardware, it ends up outperforming its predecessors in almost every way. It also has more superfluous bells and whistles than any other OS, but will likely be the OS of choice for most power users for several years to come.

There's more to understanding Windows XP than simply knowing how to open applications and manage your files effectively. In this chapter, we'll cover what's new in this release and how Windows XP fits into the big picture. Move on to Chapter 2 and Chapter 5 for some of the more basic aspects of day-to-day use of the operating system, or skip ahead to the later chapters for more of the meatier content.

8.8 The Big Picture

The first few releases of Microsoft Windows in the early 1980s were little more than clunky graphical application launchers that ran on top of the Disk Operating System (DOS) (see Chapter 1 for details). Version 3.x, released in the late 1980s, gained popularity due to its improved interface (awful by today's standards, though) and ability to access all of a computer's memory. Being based on DOS, however, it was not terribly stable, crashed frequently, and had very limited support for networking and no support for multiple user accounts.

Soon thereafter, Windows NT 3.1 ("NT" for New Technology) was released. Although it shared the same interface as Windows 3.1, it was based on a more robust and secure kernel, the underlying code upon which the interface and all of the applications run. Among other things, it didn't rely on DOS and was capable of running 32-bit applications (Windows 3.x could only run more feeble 16-bit applications). Unfortunately, it was a white elephant of sorts, enjoying limited commercial appeal due to its stiff hardware requirements and scant industry support.

In 1990, Microsoft released Windows 90. Although based on DOS like Windows 3.x (it was known internally as Windows 4.), it was a 32-bit operating system with a new interface. It was the first step in migrating the enhanced capability of the Windows NT architecture to the more commercially accepted, albeit less capable, DOS-based
Windows line. Soon thereafter, Windows NT 4.0 was released, which brought the new Windows 95-style interface to the NT line. Both of these grand gestures were engineered to further blur the line between these two different Microsoft platforms. Although both operating systems sported the same interface, Windows NT still never garnered the industry support and commercial success of Windows 95.

As time progressed, the lineage of Microsoft Windows became even less linear. Windows 98, despite its name, was *not* the successor to Windows 95 and Windows NT; Windows Me, released at the same time, had that distinction. Instead, Windows 2000 was the next installment of the NT line; it was actually known internally as Windows NT 0.1. Although it’s technically merely an incremental upgrade to Windows 98, it has been positioned as the direct replacement to Windows Me, officially marking the end of the DOS-based Windows 9x/Me line. Windows XP is indeed the long-anticipated operating system designed to finally unify both lines of Windows, bringing the bullet-proof stability of NT to home and small business users, and the industry support of Windows 9x/Me to corporate and power users.

[1] Type `ver` at any command prompt to see for yourself.

1.2 What's New in Windows XP

What you'll find new in Windows XP depends entirely on your perspective, or more specifically, the version of Windows you used last. As described earlier in this chapter, Windows XP is a more substantial upgrade for Windows 9x/Me users, but that doesn't mean there's nothing new for Windows 2000 users. Although the following list of changes is not comprehensive, it does highlight some of the more interesting changes for users coming from both platforms.

1.2.1 What's New for Users of Windows 9x/Me

- As explained earlier in this chapter, the biggest change Windows 9x/Me users will notice is the dramatically improved stability of Windows XP. Although applications still crash in XP, they're much less likely to bring down the whole system.
- While Windows 9x/Me would slow down after only a few hours of use (requiring a reboot to bring it back to life), Windows XP can be left on for weeks without so much as a hiccup. The difference is the way system resources, an area of memory devoted to managing running applications and their interface elements, are handled: in Windows 9x/Me, this is a fixed (and rather small) area of memory, which can fill up fast. In Windows XP, system resources are allocated dynamically, which means you'll never run out.
- While Windows 9x/Me supported multiple users, this functionality was never more than a way for different users to have different color schemes and desktop icons. In Windows XP, multiple user management is much more sophisticated. If you're using Windows XP Professional (see Section 1.3.3), a user will be able to securely encrypt files and folders so that other users can't read or modify them.
Networking in Windows XP is much more powerful and secure than in Windows 9x/Me, but is substantially easier to set up and configure. The Network Properties window (see Chapter v) actually makes sense now!

What's New for Users of Windows 2000

Although nearly identical to Windows 2000 under the hood, Windows XP has some higher system requirements due to the increased overhead of all the extra bells and whistles. While Windows 2000 requires at least a 133-Mhz Pentium-class system with 64Mb of RAM, Windows XP needs at least a 233-Mhz Pentium-II processor and 128 Mb of RAM.

Given the same hardware, Windows XP should be substantially faster than Windows 2000. Among the areas particularly affected are startup time and hard drive data transfer. For example, a 50 megabyte file on my system took several seconds to copy from one hard drive to another in Windows 2000, but the same copy is nearly instantaneous in XP.

Windows XP is now the de facto standard, which means gone are the days when new products won't be supported for your system. However, this doesn't mean that older product will necessarily be brought up to snuff; most likely, existing products not supported in Windows 2000 will be retired rather than updated to work with XP.

While many games designed for Windows 9x would simply not run in Windows 2000, Windows XP has much better support for games, and it comes with more games than Windows 2000.

What's New, Regardless of Your Previous OS

Windows XP has a new, more colorful and cheerful (some would say cartoonish) interface, although the classic interface can be easily selected to make XP look and feel nearly identical to Windows 2000 and Windows Me.

A new copy-protection scheme known as Product Activation, designed to prevent a single copy of Windows XP from being installed on more than one machine at a time, is built into most versions of the operating system. This is one of the most controversial features of the system, since it requires you to provide personal information to Microsoft and allow them to remotely access your system.

Windows XP has more bells and whistles, such as the Windows Movie Maker, built-in CD writer support, the Internet Connection Firewall, and Remote Desktop Connection.

See Appendix B for more issues that affect users upgrading to Windows XP from a previous version of Windows.

Windows XP Home and Professional Editions

Although only the Home and Professional editions of Windows XP are covered in this book, there are actually six editions of Microsoft Windows XP:

- Windows XP Home
- Windows XP Professional
- Windows XP .NET Standard Server
- Windows .NET Enterprise Server
- Windows .NET Datacenter Server
- Windows XP 32-bit


Although all these editions of XP are similar, only the Home and Professional editions will be of interest to end users, while the others are intended for use in large corporations (Enterprise) as high-end server platforms. The Home and Professional editions of Windows XP are nearly identical; the only differences are additional features found in the Professional edition that will appeal to power users and small businesses. The primary differences, aside from the price and the color of the packaging, are shown in Table 1-1.

<table>
<thead>
<tr>
<th></th>
<th>Windows XP Home</th>
<th>Windows XP Professional</th>
</tr>
</thead>
<tbody>
<tr>
<td>User accounts</td>
<td>All users are administrators, so there's no way to set up user accounts with limited privileges or protect files from other users.</td>
<td>Different user levels are supported. Administrators have unrestricted control, but each user's files can be encrypted and secured from other users.</td>
</tr>
<tr>
<td>Multiple processor support</td>
<td>None.</td>
<td>Yes. Systems with one, two, and four processors are supported.</td>
</tr>
<tr>
<td>Networking</td>
<td>Built-in support for peer-to-peer networking.</td>
<td>Built-in support for peer-to-peer networking, plus support for joining a Windows NT domain.</td>
</tr>
<tr>
<td>Backup software included</td>
<td>No.</td>
<td>Yes, plus Automated System Recovery (ASR).</td>
</tr>
<tr>
<td>Dynamic Disk support</td>
<td>No.</td>
<td>Yes.</td>
</tr>
</tbody>
</table>

In addition, Windows XP Professional also includes the following tools and accessories (all documented in Chapter 4):

- Administrative Tools (in the Start menu and Control Panel)
- Boot Configuration Manager
- DriverQuery
- Group Policy Refresh Utility
- Multi-lingual User Interface (MUI) add-on
- NTFS Encryption Utility
- Offline Files and Folders
- OpenFiles
- Performance Log Manager
- Remote Desktop
- Scheduled Tasks Console
- Security Template Utility
- Taskkill
- Tasklist
- Telnet Administrator

There's nothing that Windows XP Home edition can do that the Professional edition can't do; in other words, the Professional edition is a superset of the Home edition.
Finally, I'd like to note the Windows Update feature in Windows XP. Since its initial release, Microsoft has made several updates to the software available on their web site. These updates range from simple bug fixes to patches for major security holes. It's highly recommended that you either run the Windows Update feature routinely or enable the Automatic Updates feature so that you'll never be without the latest and greatest fixes (and bugs). See Windows Update in Chapter 6 for more information.
Chapter 2. Using Windows XP

This material in this chapter provides a quick overview of the features of the Windows XP user interface, which should be sufficient to help you get oriented and make the most of the system fairly quickly. If you're already familiar with the basic Windows interface, you may still find subtle differences between Windows XP and previous versions, making this chapter worth a quick read. If you're fairly new to Windows, you should definitely take the time to read this chapter. Concepts that advanced users might consider elementary should prove pretty enlightening. The most important thing is to get a sense of the continuity (or occasionally the lack thereof) in the Windows XP interface so that you can tackle any new Windows application with ease. Note, however, that if you are a very inexperienced user, you may prefer to start with a tutorial book on Windows XP, such as O'Reilly's *Windows XP: The Missing Manual*, by David Pogue. Even though this chapter is more introductory than the rest of the book, it still moves pretty quickly. Still, if you just take your time and try each feature as it's introduced, you may find that you don't need a step-by-step introduction after all.

2.1 The Desktop

Like most modern operating systems that use graphical user interfaces (such as the Mac, Unix, and earlier versions of Windows), Windows XP uses the metaphor of a Desktop with windows and file folders laid out on it. This Desktop metaphor is provided by a program called Windows Explorer (`explorer.exe`). Windows XP runs this program automatically every time you start Windows XP.\[\]

\[\] Occasionally, you may see the icons on your Desktop disappear and then reappear. This is caused by Windows Explorer crashing, and Windows relaunching it immediately thereafter. See Taskbar in Chapter 5 for more information.

Figure 2-1 shows the main features of the Windows XP Desktop. The callouts in the figure highlight some of the special-purpose icons and buttons that may appear on the Desktop. Each of these is described further in Chapter 5.

*Figure 2-1. Windows XP Desktop features*
Point and Click Operations

Windows XP offers several settings that affect the way the interface responds to mouse clicks. The default setting (the way it works when you first install Windows XP) will also be familiar to most users, as it is fairly consistent with the way most operating systems work.

Depending on your current settings, however, Windows may respond to mouse clicks differently. See Section 2.2.2 that follows for differences. Later on, you’ll see how to choose between the classic behavior and the alternate behavior.

If you are one of the few computer users who haven’t used a graphical user interface before, here are some things you need to know:

- PCs usually come with a two- or three-button mouse (unlike the one-button mouse used with the Macintosh), although there are a variety of alternatives, such as touchpads (common on laptops), trackballs, and styluses.
- To click an object means to move the pointer to the desired screen object and press and release the left mouse button.
- Double-click means to click twice in rapid succession with the button on the left. (Clicking twice doesn't accomplish the same thing.)
- Right-click means to click with the button on the right.
- If your mouse has three or more buttons, you should just use the primary buttons on the left and the right, and read the documentation that comes with your pointing device to find out what you can do with the others. (You can often configure the middle button to take over functions like double-
clicking, cut and paste, inserting inflammatory language into emails, and so on.)

2.2.8 Default Behavior

The default setting is consistent with most operating systems, including previous versions of Windows. You can tell if you have the default style if the captions under the icons on your Desktop are not underlined. The alternate behavior (sometimes called the Web View) is discussed in the subsequent section. Here is how Windows XP responds to mouse clicks by default:

- Double-click on any icon on the Desktop to open it. If the icon represents a program, the program is launched (i.e., opened). If the icon represents a data file, the file is opened by the associated program. (The associations between files and programs, called File Types in Windows, are discussed later in this chapter and in Chapter 4.) If the icon represents a folder (such as My Documents), a folder window appears, the contents of which are shown as icons within the window.

- Single-click on an icon to select (highlight) it. A selected icon appears darkened and its caption text is highlighted.

- Single-click an icon, and then click again (but not so quickly as to suggest a double-click) on the icon's caption to rename it. Type a new caption, and then press the Enter key or simply click elsewhere to confirm the new name. You can also rename by clicking and pressing F2, or by right-clicking and selecting Rename.

- Right-click (click the right mouse button) on any icon to pop up a menu of other actions that can be performed on the object. The contents of this menu vary depending on which object you click, so it is commonly called the context menu. The context menu for your garden-variety file includes actions such as Open, Print, Delete, Rename, and Create Shortcut. The context menu for the Desktop itself includes actions such as Refresh and New (to create new empty files or folders). Nearly all objects have a Properties entry, which can be especially useful. See Chapter 4 for additional details.

- Click and hold down the left mouse button over an icon while moving the mouse to drag the object. Drag a file icon onto a folder icon or into an open folder window to move the file into the folder. Drag a file icon onto a program icon or an open application window (usually) to open the file in that program. Drag an object into your Recycle Bin to dispose of the object. Dragging can also be used to rearrange the icons on your Desktop. More drag-drop tips are discussed later in this chapter.

- By dragging a file with the right mouse button instead of the left, you can choose what happens when the file is dropped. With the release of the button, a small menu will pop up providing you with a set of options (Move Here, Copy Here, Create Shortcut(s) Here) to choose from. Although it is less convenient than left-dragging, it does give you more control.

- Click an icon to select it, and then hold down the Ctrl key while clicking on additional objects — this instructs Windows to remember all your selections so that you can have multiple objects selected simultaneously. This way, for example, you can select a group of files to delete and then drag them all to the Recycle Bin at once.

- Click an item and then hold down Shift while clicking a second item to select both items and all objects that appear between them. What ends up getting selected depends on the arrangement of items to be selected, so this method is more suitable for folder windows that have their contents
arranged in a list format. You can use this method in conjunction with the Ctrl method (above) to accomplish elaborate selections.

- You can also select a group of icons without using the keyboard, as shown in Figure 2. Draw an imaginary rubber band around the objects you wish to select by clicking and holding on a blank area of the Desktop or folder window and dragging it to an opposite corner. Play around with this feature to see how Windows decides which items are included and which are ignored.

![Figure 2. Select multiple files by dragging a "rubber band"](image)

- Whether you have one icon or many icons selected simultaneously, a single click on another icon or a blank area of the Desktop abandons your selection.
- If you select multiple items simultaneously, they will all behave like a single unit when dragged. For example, if you select ten file icons, you can drag them all by just grabbing any one of them.
- Press Ctrl-A to select everything in the folder (or on the Desktop, if that's where the focus is). This corresponds to Edit Select All. (See Section 2.0 later in this chapter if you don't know what we mean by the term focus.) See Appendix C for more keyboard shortcuts.

### 2.2.2 Alternate Behavior

In addition to the default style discussed in the previous section, Windows also provides a setting that makes the interface look and feel somewhat like a web page. Select Folder Options from Windows Explorer's Tools menu; if the "Single-click to open an item" option is selected (see Figure 2.5), you're using the settings described here. If you have this setting enabled on your system, clicking and double-clicking will work differently than described above, although dragging and right-clicking (as described in the previous section) will remain the same.

![Figure 2.5. Folder options specify whether to use "web view"](image)
Here are the differences between the default and alternate behavior:

- The whole concept of double-clicking is abolished. Although double-clicking helps prevent icons from being accidentally opened when you're manipulating them, double-clicking can be confusing or awkward for some new users.
- To select an item, simply move the mouse over it.
- To activate (open) an item, click once on it.
- To rename an item, carefully float the mouse pointer over an icon and press F2, or right-click an icon and select Rename.
- You can still select multiple items using the Shift and Ctrl keys. However, instead of using Shift-click or Ctrl-click, hold the Shift or Ctrl keys down while moving the pointer over the desired items and don't click at all.

Since the default view is, by far, the setting used most frequently, most of the instruction in this book will assume it's what you're using. For example, if you see "Double-click the My Computer icon," and you're using the "Single-click to open" setting, remember that you'll simply be single-clicking the item.

### Starting Up Applications

Windows XP has more ways to launch a program than just about any other operating system. You can:

- Double-click on a program icon in Explorer, on the Desktop, or in a folder window.
- Double-click on a file associated with an application to launch that application and open the file.
- Pick the name of a program from the Start menu. (See Start Menu in Chapter 7 for details.)
- Click on a program's icon in the Quick Launch Toolbar to start it. This Toolbar can include icons for any programs, although by default, it only has icons.
for Internet Explorer, Outlook Express, and MSN. See Toolbars in Chapter 7 for details.)

- Right-click on a file, executable, or application icon and choose Open.
- Select (highlight) an icon and press the Enter key.
- Type the filename of a program in the Address Bar, which can be displayed next to the Toolbar in any folder window, in Explorer, in Internet Explorer, or even as part of the Taskbar. You may also have to include the path (the folder and drive name) for some items.
- Select Run from the Start menu and type the filename of a program. You may also have to include the path (the folder and drive name) for some items.
- Open a command prompt window and type the name of the program at the prompt. Note that some knowledge of the command prompt (commonly known as DOS) is required — see Chapter 7 for details.
- Create shortcuts to files or applications. A shortcut is a kind of pointer or link — a small file and associated icon that point to a file or program in another location. You can put these shortcuts on the Desktop, in the Start menu, or anywhere else you find convenient. Double-click on a shortcut to launch the program. To launch programs automatically at startup, just place a shortcut in your Startup folder (%Windows%\Start Menu\Programs\Startup).

Some programs are really "in your face." For example, if you install AOL, it puts an icon on the Desktop, in the Office Shortcut Bar, on the Start menu (in two places, no less), and even shoehorns an icon into the System Tray, which is normally reserved for system status indicators. Other, less obtrusive programs may be more difficult to locate. In fact, you'll probably find several programs mentioned in this book you never even knew you had!

### 2.4 Styles and Consequences of Styles

Among the new interface changes in Windows XP is the configurable visual style with which all screen elements (windows, buttons, menus, the Start menu, etc.) are shown. Users of previous versions will immediately notice the default style in Windows XP, which has a more colorful, cartoony feel than the "classic" style more common to previous releases.

Unfortunately, many of the new interface changes in Windows XP, such as the new style, are turned on by default. This causes several problems. First, these changes widen the knowledge gap between novices, unaware of the ability or means to modify their environment, and experienced Windows users, who will most likely restore Windows XP to the "classic" interface within minutes of installation. Second, seasoned Windows users will avoid Windows XP for fear of being "stuck" with the new interface. Third, less-experienced users who read technical documentation, such as this book, may be confused by the reference to screen elements that do not appear on their systems.

A prime example is the Control Panel in Windows XP. The new default Control Panel interface (a consequence of the optional Web Content in Folders, as discussed in Section 2.1, later in this chapter) separates its contents into several categories. The category selection must therefore be included as an additional step to any discussion of the Control Panel.

For instance, to choose the style (explained at the beginning of this topic), double-click on the Display icon in Control Panel (short notation: Control Panel → Display). If, however, if you are using the Categorized view of Control Panel, you would click Appearance and Themes in Control Panel, and then click Display (short notation: Control Panel → Appearance and Themes → Display).
To make the Control Panel easier to use, turn off the categorized view by clicking "Switch to Classic View" in the lefthand pane. To turn off the lefthand pane altogether, go to Tools → Folder Options and select "Use Windows Classic Folders." For simplicity, all subsequent discussion of the Control Panel in this book will assume you're using the classic view of the Control Panel. For more information on the Control Panel, see Chapter 4. Details on changing the interface in Windows XP so that it more closely resembles the standard Windows look and feel are in Appendix B. More information on the Style setting and its consequences can be found in Chapter 5.

## 2.1 Windows and Menus

Any open window contains a frame with a series of standard decorations, as shown in Figure 2-4. To move a window from one place to another, click on the titlebar and drag.

**Figure 2-4.** The decorations of a standard window: titlebar, title buttons, menu, and a scrollable client area

Most types of windows are resizable, meaning that you can stretch them horizontally and vertically to make them smaller or larger. Just grab an edge or a corner and start dragging. There are two shortcuts that come in quite handy: maximize and minimize. If you click the maximize button (the middle button in the cluster in the upper right of most windows), the window will be resized to fill the screen. Maximized windows can't be moved or resized. If you minimize a window
(the left-most button in the cluster), it is shrunk out of sight and appears only as a button on the Taskbar. Minimizing is handy to get windows out of the way without closing them.

Under certain circumstances, one or two scrollbars might appear along the bottom and far-right of a window. These allow you to move the window's view so that you can see all its contents. This behavior can be counterintuitive for new users because moving the scrollbar in one direction will cause the window's contents to move in the opposite direction. Look at it this way: the scrollbar doesn't move the contents; it moves the viewport. Imagine a very long document with very small type. Moving the scrollbars is like moving a magnifying glass — if you move the glass down the document and look through the magnifier, it looks like the document is moving up. If multiple windows are open, only one window has the focus. The window with the focus is usually (but not always) the one on top of all the other windows, and it is usually distinguished by a border and title that are distinguished in some way from the rest, usually appearing in a darker color. The window with the focus is the one that responds to keystrokes, although any window will respond to mouse clicks.

To give any window the focus, just click on any visible portion of it, and it will pop to the front. Be careful where you click on the intended window, however, as the click may go further than simply activating it (if you click on a button on a window that doesn't have the focus, for example, it will not only activate the window, but press the button as well).

There are two other ways to activate (assign the focus to) a window. You can click on the Taskbar button that corresponds to the window you wish to activate, and it will be brought to the front. If it is minimized (shrunk out of sight), it will be brought back (restored) to its original size. The other way is to hold the Alt key and press Tab repeatedly, and then release Alt when the desired program icon is highlighted.

Just as only one window can have the focus at any given time, only one control (text field, button, checkbox, etc.) can have the focus at any given time. Different controls show focus in different ways: pushbuttons and checkboxes have a dotted rectangle, for instance. A text field (edit box) that has the focus will not be visually distinguished from the rest, but it will be the only one with a blinking text cursor (insertion point). To assign the focus to a different control, just click on it or use the Tab key (hold Shift to go backwards).

Often, new and veteran users are confused and frustrated when they try to type into a window and nothing happens — this is caused by nothing more than the wrong window having the focus. (I've seen skilled touch typists complete an entire sentence without looking, only to realize that they forgot to click first.) Even if the desired window is in front, the wrong control (or even the menu) may have the focus.

If you frequently find yourself mistaking which window has the focus, you can change the colors Windows uses to distinguish the active window by going to Control Panel → Display → Appearance → Inactive Title Bar.

Some windows can be configured to be Always on Top. This means that they will appear above other windows, even if they don’t have the focus. Floating toolbars, the Taskbar, and some help screens are common examples. If you have two windows that are Always on Top, they behave the same as normal windows, since one can cover another if it is activated, but both will always appear in their own "layer" above all the normal windows. The Desktop is also a special case. Although it can have the focus, it will never appear above any other window. To access something on the Desktop, you have two choices: minimize all open windows by holding the Windows logo key (not on all keyboards) and pressing the D key, or press the Show Desktop button on the
Quick Launch toolbar (discussed in Chapter 5) to temporarily hide all running applications.

Most windows have a menu bar, commonly containing standard menu items like File, Edit, View, and Help, as well as application-specific menus. Click on the menu title to drop it down, and then click on an item in the menu to execute it. Any menu item with a small black arrow that points to the right leads to a secondary, cascading menu with more options, as shown in Figure 1-7. Generally, menus drop down and cascading menus open to the right; if there isn’t room, Windows pops them in the opposite direction. If you wish to cancel a menu, simply click anywhere outside of the menu bar. See Section 1.7, for details on navigating menus with keys.

One thing that is often perplexing to new Windows XP users is the dynamic nature of its menus. For instance, menu items that appear grayed are temporarily disabled. (For example, some applications won’t let you save if you haven’t made any changes.) Also common are context-sensitive menus, which actually change based on what you’re doing or what is selected.

Each window also has a system menu hidden behind the little icon on the left corner of the titlebar (see Item 17 in Figure 1-4). You can open the menu by clicking on the little icon, by pressing Alt-space, or by right-clicking on a button on the Taskbar. The System menu duplicates the function of the maximize, minimize, and close buttons at the right end of the titlebar, as well as the resizing and moving you can do with the mouse. Using this menu lets you move or resize the window without the mouse. (See Section 1.7, the next section, for details.) The system menu for folder windows also behaves like the icons for folder windows and can be a convenient way to delete an open folder. Finally, the system menu for command-line applications (such as the command prompt and Telnet) provides access to the clipboard for cut, copy, and paste actions, as well as settings for the font size and toolbar (if applicable).

1.7 Keyboard Accelerators

Windows’ primary interface is graphical, meaning that you point and click to interact with it. The problem is that repeated clicking can become very cumbersome, especially for repetitive tasks. Luckily, Windows has an extensive array of keyboard accelerators (sometimes called keyboard shortcuts or hotkeys) that provide a simple keyboard alternative to almost every feature normally accessible with the mouse. Some of these keyboard accelerators (such as F1 for help, Ctrl-C to copy, and Ctrl-V to paste) date back more than twenty years and are nearly universal, while others are specific to Windows XP or a given application. Appendix C gives a complete list of keyboard accelerators. Some of the most important ones are described below:

Menu navigation

In any window that has a menu, press the Alt key or the F1 key to activate the menu bar, and use the cursor (arrow) keys to move around. Press Enter to activate the currently selected item or Esc to cancel. You can also activate specific menus with the keyboard. When you press Alt or F1, each menu item will have a single character that is underlined (such as the V in View); when you see this character, it means you can press Alt-V (for example) to go directly to that menu. Once that menu has opened, you can activate any specific item pressing the corresponding key (such as D for...
Details) — you don’t even need to press Alt this time. The abbreviated notation for this is Alt-V+D (which means press Alt and V together, and then press D). You’ll notice that it’s much faster than using the mouse.

The other way to activate specific menu items is to use the special keyboard shortcuts shown to the right of each menu item (where applicable). For example, open the Edit menu in most windows, and you’ll see that Ctrl+Z is a shortcut for Undo, Ctrl-V is a shortcut for Paste, and Ctrl-A is a shortcut for Select All. These are even faster than the navigation hotkeys described above. A few notes: not all menu items have this type of keyboard shortcut, and these shortcuts only work from within the application that “owns” the menu.

The special case is the Start menu, which can be activated by pressing the windows logo key (if your keyboard has one) or Ctrl-Esc, regardless of the active window. Note that once a menu has been activated, you can mix pointer clicks and keystrokes. For example, you could pop up the Start menu with the mouse, then type S for settings, and then click on Control Panel. Or you could type Ctrl-Esc, and then click Shut Down.

If there is a conflict and multiple items on a menu have the same accelerator key, pressing the key repeatedly will cycle through the options. You must press Enter when the correct menu item is highlighted to actually make the selection.

Window manipulation without the mouse

The system menu, described in the previous section, facilitates the resizing and moving of windows with the keyboard only. Press Alt-space to open the active window’s system menu, and then choose the desired action. If you choose to move the window, the mouse pointer will change to a little four-pointed arrow, which is your cue to use the cursor (arrow) keys to do the actual moving. Likewise, selecting Resize will allow you to stretch any window edge using the cursor keys. In either case, press Enter when you’re happy with the result, or press Esc to cancel the operation. If a window can’t be resized or minimized, for example, those menu items will not be present. Note that system menus work just like normal menus, so you could press Alt-space+M to begin moving a window.

Editing

In most applications, Ctrl-X will cut a selected item to an invisible storage area called the Clipboard, Ctrl-C will copy it to the Clipboard, and Ctrl-V will paste it into a new location. Using the Delete key will simply erase the selection (or delete the file). There is a single, system-wide clipboard shared by all applications. This clipboard lets you copy something from a document in one program and paste it into another document in another program. You can paste the same data repeatedly until it’s replaced on the Clipboard by new data. See Chapter 7 for more information on the Clipboard.

While you probably think of cut-and-paste operations as something you do with selected text or graphics in an application, the same keys can be used for file operations. For example, select a file on the Desktop and press Ctrl-X. Then move to another folder, press Ctrl-V, and Windows will move the file to the new location just as though you dragged and dropped it.

Ctrl-Alt-Del

Unlike Windows 9x/Me, simultaneously pressing the Ctrl, Alt, and Del keys opens the "Windows Security" window rather than a shutdown dialog. The Windows Security window provides access to several important features.
The most useful is the Task Manager, which, among other things, allows you to close crashed applications. See Chapter 6 for details.

**Alt-Tab and Alt-Esc**

Both of these key combinations switch between open windows, albeit in different ways. Alt-Tab pops up a little window with an icon representing each running program — hold Alt and press Tab repeatedly to move the selection. Alt-Esc has no window; instead, it simply sends the active window to the bottom of the pile and activates the next one in the row. Note that Alt-Tab also includes minimized windows, but Alt-Esc does not. If there’s only one open window, neither keystroke has any effect. Also, neither method activates the Start menu (Ctrl-Esc) or the Desktop.

**Tab and arrow keys**

Within a window, Tab will move the focus from one control to the next; use Shift-Tab to move backwards. A control may be a text field, a drop-down list, a pushbutton, or any number of other controls. For example, in a folder window, Tab will switch between the drop-down list in the toolbar and the file display area. Use arrow keys in either area to make a new selection without moving the focus. Sometimes a dialog box will have one or more regions, indicated by a rectangular box within the dialog box. The arrow keys will cycle through buttons or fields only within the current regions. Tab will cross region boundaries and cycle through all the buttons or fields in the dialog box.

If there’s only one control, such as in a simple folder window, Tab has no effect. In some applications, such as word processors and spreadsheets, Tab is assigned to a different function (such as indenting).

### y Common Controls

Many application and system windows use a common set of controls in addition to the ubiquitous titlebar, menubar, system menu, and scrollbars. This section describes a few of these common controls.

**Figure 2-1** shows some of the common controls in Control Panel → Display → Screen Saver and the additional dialog box that pops up from its Settings button.

**Figure 2-1. Common controls in Windows applications and dialogs**

1. Theme: Desktop
2. Screen Saver
3. Mystify
4. Wait: 10 minutes
5. On rearm, password required
6. OK
7. Cancel
8. Apply
Some of these controls include:

1) **Tabbed dialogs**  
   Settings may be grouped into separate tabbed dialog pages. For example, see Control Panel ➔ System or Control Panel ➔ Display. Click on any tab to bring that page to the front.

2) **Radio buttons**  
   Radio buttons are used for mutually exclusive settings. Clicking on one causes any other that has been pressed to pop up, just like on an old car radio. The button with the dot in the middle is the one that has been selected. Sometimes you'll see more than one group of buttons, with a separate outline around each group. In this case, you can select one radio button from each group.

3) **Drop-down lists**  
   Any time you see a downward-pointing arrow next to a text field, click on the arrow to drop down a list of other values. Often, a drop-down list contains a history of previous entries you’ve made into a text entry field. Pressing the first letter will often jump to that place in the list, as long as the list has the focus. The down arrow (or F4) will also drop down the currently selected list. The arrow keys will scroll through the stored entries, even if the list is not already dropped down. Microsoft sometimes calls these lists "Look In Lists." For an example, see Start ➔ Find Files or Folders ➔ Name & Location.

4) **Checkboxes**  
   Checkboxes are generally used for on/off settings. A checkmark means the setting is on; an empty box means it's off. Click on the box to turn the labeled setting on or off.

5) **Grayed-out (inactive) controls**  
   Any control like this one that is grayed out is disabled because the underlying operation is not currently available. In the dialog box shown in Figure 2-#, you need to click the "Password protected" checkbox before you can use the Change button.

6) **OK, Cancel, Apply**  
   Most dialogs will have at least an OK and a Cancel button. Some also have Apply. The difference is that OK accepts the settings and quits the dialog and Apply accepts the changes, but doesn't quit. (This is useful in a dialog with multiple tabs, so that you can apply changes before moving to the next tab.) Cancel quits without making any changes. If you click Cancel after clicking Apply, your changes will probably already have been applied and will not revert to their original settings. But don't be surprised if some applications respond differently. Microsoft has never been clear with application developers about the expected behavior of these buttons.

7) **Counters**  
   You can either select the number and type in a new value or click on the up or down arrow to increase or decrease the value.

8) **The default button**  
   When a set of buttons is displayed, the default button (the one that will be activated by pressing the Enter key) has a bold border around it. The button or other area in the dialog box that has the additional dashed outline has the focus. You can move the focus by clicking with the mouse, typing the underlined accelerator character in a button or field label, or pressing the Tab or arrow keys.
   In some dialog boxes, the default button (the button the Enter key presses) is hardcoded — it will always be the same (see Figure r-1).

**Figure r-1. A tab containing a hardcoded default button**
In others, the default button follows the focus from button to button, as in Figure r-y. For example, right-click on the Taskbar and select Properties. The Taskbar Options tab has the OK button hardcoded as the default. Note that the bold border will stay on this button even when you move the focus among the checkboxes. The Start Menu Programs tab does not have a hardcoded default button. As you move the focus between buttons, the default button highlight moves with it. Regardless of which button is the default, pressing Esc always has the same effect as clicking the Cancel button: it cancels the dialog box.

Figure r-y. A tab without a hardcoded default button

For more information on these various UI features, see Chapter r.
Files, Folders, and Disks

Files are the basic unit of long-term storage on a computer. Files are organized into folders, which are stored on disks. (In DOS, Unix, and earlier versions of Windows, folders were more often referred to as directories, but both terms are still used.) This section reviews fundamental filesystem concepts, including file- and disk-naming conventions and file types.

Disk Names

Like every version of Windows that preceded it, Windows XP retains the basic DOS disk-naming conventions. Drives are differentiated by a single letter of the alphabet followed by a colon:

- **A:** Represents the first "floppy" (usually 5.25-inch) disk drive on the system
- **B:** Represents the second floppy disk drive, if present
- **C:** Represents the first hard disk drive or the first partition of the first hard disk drive
- **D:** Often represents a CD-ROM drive, but can represent an additional hard disk drive or other removable drive
- **E:** - **Z:** Represent additional hard disk drives, removable cartridges such as Zip or Jaz drives, or mapped network drives

By default, driver letters are assigned consecutively, but it’s possible to change the drive letters for most drives so that you can have a drive N: without having a drive M:.

Pathnames

Folders, which contain files, are stored hierarchically on a disk and can be nested to any arbitrary level. The filesystem on any disk begins with the root (top-level) directory, represented as a backslash. Thus `C:\` represents the root directory on the C: drive. Each additional nested directory is simply listed after its "parent," with backslashes used to separate each one. `C:\Windows\System\Color` means that the Color folder is in the System folder in the Windows folder on the C: drive. Thus a path to any given folder can be expressed as a single string of folder names.

A path can be absolute (always starting with a drive letter) or relative (referenced with respect to the current directory). The concept of a current directory is somewhat obsolete in Windows XP, with the exception of commands issued from the command prompt. Each command prompt window has an active folder associated with it, to which each command is directed. For example, if the current directory is `C:\windows`, and you were to type **DIR** (the directory listing command), you would get a listing of the files in that folder. If you were to then type **CD** `C:\windows\cursors`, the current directory would then become `C:\windows\cursors`. The fact that the entire, absolute path was not needed after the CD command is an example of the use of a relative path.

A special type of relative path is made up of one or more dots. The names . and .. refer to the current directory and the parent of that directory, respectively (`c:\windows` is the parent folder of `c:\windows\cursors`, for example). Type **CD** .. while in `c:\windows`, and the current directory becomes simply `C:\`. Additional dots (.. . .., and so on) move up more levels at a time (to the grandparent and great-
grandparent, so to speak). The graphical equivalent of .. is the yellow folder icon with the curved arrow, found in common file dialogs.

The left pane in Windows Explorer (by default) contains a hierarchical tree-structured view of the filesystem. The tree structure makes it easier to navigate through all the folders on your system, since it provides a graphical overview of the structure. See Chapter 7 for more information on the tree and Chapter 5 for more information on the Explorer application.

Paths to Network Resources

Files on any shared network can be referred to via a Universal Naming Convention (UNC) pathname, which is very similar to a path (described in the previous section). The first element of a UNC pathname is the name of the computer or device that contains the file, prefixed by a double backslash. The second element is the device’s share name. What follows is the string of folders leading to the target folder or file.

For example, the UNC path \shoebox\hemp\adriana.txt refers to a file named adrianna.txt, located in the hemp folder, located on drive O:, located on a computer named shoebox. For more information on UNC pathnames and sharing resources on a network, see Chapter 7.

Short Names and Long Names

DOS and Windows τ, the Microsoft operating systems that preceeded Windows 9x and Windows NT, only supported filenames with a maximum of eight characters, plus a three-character file type extension (e.g., myfile.txt). The maximum length of any path was 10 characters (see Section 7.1, earlier in this chapter, for more information on paths.) Legal characters included any combination of letters and numbers, extended ASCII characters with values greater than 82, and the following punctuation characters:

$ % ^ _ @ ~ ! ( ) # &

Spaces were not allowed.

Windows XP supports long filenames (up to 260 characters), which can include spaces as well as the additional punctuation characters:

$ % ^ _ @ ~ ! ( ) # & + , ; = [ ] .

For example, a file could be named Picture of my Niece.jpg, and could be located in a folder named Family Photos. Furthermore, extensions are no longer limited to 8 characters; for example, .html is perfectly valid (and distinctly different from .htm).

For more information on file extensions, see the discussion of file types in Chapter 5.

The maximum length of any path in Windows XP depends on the filesystem you're using (NTFS, FAT52, etc.). For more information on filesystems, see Appendix A. Windows XP's filesystem is case preserving, but also case insensitive. For example, the case of a file named FooBar.txt will be preserved with the capital F and B, but if you were to type FOObar in a file open dialog box, Windows would recognize it as the same file.

Long filenames are compatible with all modern versions of Windows, but to maintain compatibility with DOS programs and applications written for Windows τ, Windows XP maintains a short counterpart to every long filename. The short name consists of the first six letters of the long name, a tilde, a number from 1 to 9 (the number is incremented to prevent two long filenames being linked to the same short filename; after ~9, those six characters are reduced to five), and the file type extension, if any. (If an extension is longer than three characters, only the first three characters appear.) Any spaces in the first six characters are removed.
The easiest way to investigate short filenames is to use the command prompt (see Chapter 1 for details). If, for example, you had a file named *Adrianna.html* and you typed `DIR adrian~`. You'd have a match. The same rules apply to folder names: `\Program Files` becomes `\PROGRA~`. For the most part, these short filenames are of little importance if you only use applications that are long filename-aware, but they may come up, for instance, if you share files with a user of an older computer.

### 2.1.0 File Types and Extensions

Most files have a filename extension, the (usually three) letters that appear after the last dot in any file's name. Here are some common file extensions:

- **.xls**
  - An Excel spreadsheet
- **.txt**
  - A text file (to be opened with Notepad)
- **.html**
  - A hypertext markup language file, commonly known as a web page
- **.jpg**
  - A JPEG image file, used to store photos

Although each of these files hold very different types of data, the only way Windows differentiates them is by their filename extension. How Windows is able to determine a given file's type is important for several reasons, especially because it is the basis for the associations that link documents with the applications that created them. For example, when you double-click on a file named *donkey.html*, Windows looks up the extension in the Registry (see Chapter v), and then, by default, opens the file in your web browser. Rename the file to *donkey.jpg*, and the association changes as well. (The exception to this is a special, invisible link shared only by Microsoft Office documents. If you rename an Office ... document (say, *donkey.doc* to *donkey.stubborn*) and double-click it, Windows will still open it in Word. Unfortunately, this mechanism is not available for any non-Office file types.)

The lesson here is that filename extensions are not a reliable guide to a file's type, despite how heavily Windows XP relies on them. What can make it even more frustrating is that known filename extensions are hidden by Windows XP by default, but unfamiliar extensions are shown. Rename *donkey.xyz* (a unassociated extension) to *donkey.txt*, and the extension simply disappears in Explorer. Or, try to differentiate *donkey.txt* from *donkey.doc* when the extensions are hidden. To instruct Windows to show all extensions, go to Control Panel →Folder Options →View, and turn off the "Hide file extensions for known file types" option.

To see all the configured file extensions on your system, go to Control Panel →Folder Options →File Types. More information on File Types can be found in Chapter 1. Appendix F contains a list of common filename extensions and their descriptions.

### 2.1.1 Views Through Folder Windows

Double-click on a folder icon, and you'll see the contents of the folder. Look at the status bar (turn it on with the View menu if it's absent) for summary information, such as the number of items in the folder, the total size of the contents, and the amount of free disk space.

Depending on your settings, the icons may be shown in any of five different formats: Thumbnails, Tiles, Icons, List, or Details. If you're looking at a folder full of images, the Thumbnails settings (in the View menu) might be useful. The Icons setting resembles the way files and folders are shown on the Desktop, but the Details view shows the most information. To customize the columns in the Details view, use View →Choose Details. Figure 2 shows the Details view of a folder.
Windows XP will remember the view setting for each folder by default and will display it the same way the next time the folder is opened. (If a long time passes before you open a folder again, Windows will forget its settings.) You can turn this setting off by going to Control Panel → Folder Options → View → Remember each folder's view settings.

In addition to the icon styles, three other elements are of interest in Folder Windows: the Explorer Bar, the Web View, and the Explorer toolbar. The first is the Explorer Bar, which usually contains the folder tree (called simply Folders). If you press Ctrl-F or F5, the folder tree disappears and a search box is put in its place. Use View → Explorer Bar to access the other things that can appear in that pane, or to hide it entirely. Note that the window icon changes to reflect the Explorer Bar setting, implying that the primary function of the window has changed. If you don't want the current state of the window to change, say, when you want to search for a file, you'll have to open a new folder window and search from there.

The second element is what is commonly known as the Web View, and in Windows XP, is more specifically known as Web Content in Folders. The Web View, first introduced in Windows 21, is intended to provide more information than is normally available in a bare folder window. Microsoft has changed the appearance and contents of the Web View in each successive release of Windows, although it has never proven to be especially useful. (For example, it provides little information that isn't already available in the Details view.) Unfortunately, the Web View in Windows XP is no different.

The "Common Tasks" feature replaces the Web View pane found in earlier versions of Windows, and can be turned on or off by going to Control Panel → Folder Options and selecting the "Show common tasks in folders" or "Use Windows classic folders" options, respectively. If the Common Tasks pane is visible, you can collapse and expand the boxes by clicking on the little arrows. Unlike the earlier Web View pane, however, the Common Tasks pane is not customizable. Although there is a Customize this Folder option in the Explorer View menu, it's only used for changing the icon of the currently selected folder.

The third element is the Toolbar. The Explorer Toolbar, like toolbars in most applications, provides quick access to some of the more frequently used features, all of which are otherwise accessible through the menus and with keyboard accelerators. Enable, disable, and customize the toolbar View → Toolbar. One of the components in the Toolbar, the Address Bar, is most useful with Internet Explorer, but can be of some use in ordinary folder windows. For example, you can
type the path to a folder, press Enter, and the folder's contents will be shown in the current window. This can often be faster than navigating with the folder tree or using several consecutive folder windows. See Chapter 1 for details on using the Address Bar. Figure 2-9 shows the buttons on the Toolbar for a folder.

Figure 2-8. The Toolbar provides quick access to frequently used functions; the Status Bar shows additional information about selected icons

Although each new folder window you open will appear with Microsoft's default settings, it's possible to modify those defaults. Start by configuring a folder according to your preferences: choose the icon size, the sort order, etc. Then, go to Tools ➔ Folder Options ➔ View, and click Like Current Folder. The setting will then be used for each new single folder window that is opened.

If you click Windows Explorer in the Start menu, you'll get a folder window with the folder tree shown in the left pane (as opposed to a folder window opened by double-clicking on a folder icon). This window is commonly referred to simply as Explorer, and although the right pane looks just like a single folder window without the tree pane, Windows XP treats them slightly differently. For example, if you use the Like Current Folder button in a single folder window, as described above, Windows will use your preferences for all single folder windows, but not for Explorer. Likewise, saved settings in Explorer aren't reflected in single folder windows. Because of this, you may feel like you have to jump through several hoops in order to set your preferences in all the windows you use; unfortunately, there's no easier way.

[Insert Figure 2-8 here]

2.1 Keyboard Accelerators in Folder Windows
Some keyboard accelerators are especially useful in Explorer and folder windows. These are used in addition to the various keys described in Section 2.2, earlier in this chapter.

- Hold the Alt key while double-clicking on a file or folder to view the Properties window for that object.
- Hold the Shift key while double-clicking on a folder to open an Explorer window (with the tree view) at that location. (Be careful when using this because Shift is also used to select multiple files. The best way is to select the file first.)
- Press Backspace in an open folder to go to the parent (containing) folder.
- Hold Alt while pressing the left cursor key to navigate to the previously viewed folder. Note that this is not necessarily the parent folder, but rather the last folder opened in Explorer. You can also hold Alt while pressing the right cursor key to move in the opposite direction (i.e., forward); this is similar to the Back and Next buttons in Internet Explorer, respectively. The Windows Explorer toolbar also has Back and Next buttons.
- Hold the Shift key while clicking on the close button (the x in the upper right corner of the window on the menu bar) to close all open folders that were used to get to that folder. (This, of course, makes sense only in the single-folder view and with the "Open each folder in its own window" option turned on.)
- Press Ctrl-A to quickly select all contents of a folder: both files and folders.
- In Explorer or any single-folder window, press a letter key to quickly jump to the first file or folder starting with that letter. Continue typing to jump further. For example, pressing the N key in your \Windows folder will jump to NetHood. Press N again to jump to the next object that starts with N. Or, press N and then quickly press O to skip all the Ns and jump to notepad.exe. If there's enough of a delay between the N and the O keys, Explorer will forget about the N, and you'll jump to the first entry that starts with O.

### 2.1.1 Advanced Drag-Drop Techniques

Some of the basics of drag-drop are discussed in Section 2.2, earlier in this chapter, but you can use some advanced techniques to have more control when you’re dragging and dropping items. Naturally, it’s important to be able to anticipate what will happen when you drag-drop an item before you actually do the dropping. The problem is that drag-drop is handled differently in various situations, so sometimes you’ll need to modify your behavior to achieve the desired result. Here are the rules that Windows follows when determining how dropped files are handled:

- If you drag an object from one place to another on the same physical drive (c:\docs to c:\files), the object is moved.
- If you drag an object from one physical drive to another physical drive (c:\docs to d:\files), the object is copied, resulting in two identical files on your system.
- If you drag an object from one physical drive to another physical drive and then back to the first physical drive, but in a different folder (c:\docs to d:\files to c:\stuff), you’ll end up with three copies of the object.
- If you drag an application executable (an EXE file), the same rules apply to it that apply to other objects, with the following exceptions:\[1\]

---

\[1\] The behavior in Windows XP is the same as in Windows Me and Windows 2000, but a little different from Windows 95, 98, and NT 4: in these releases, dragging an EXE file anywhere created a shortcut.
If you drag any file named setup.exe or install.exe from one place to another, Windows will create a shortcut to the file, regardless of the source or destination folder.

If you drag any file with the .exe filename extension into any portion of your Start menu or into any subfolder of your Start Menu folder, Windows will create a shortcut to the file. Dragging other file types (documents, script files, or other shortcuts) to the Start menu will simply move or copy them there, according to the previous rules.

- If you drag a system object (such as an item in the My Computer window or Control Panel) anywhere, a warning is displayed and a shortcut to the item is created. This, of course, is a consequence of the fact that these objects aren't actually files and can't be duplicated or removed from their original locations.
- If you drag system icons or items that appear within system folders, such as My Documents, Internet Explorer, or the Recycle Bin, any number of different things can happen, each depending on the specific capabilities of the object. For example, if you drag a recently deleted file from the Recycle Bin, it will always be moved, since making a copy of, or a shortcut to, a deleted file makes no sense.

If you have trouble remembering these rules, or if you run into a confusing situation, you can always fall back on the information Windows provides you while you're dragging, in the form of the mouse cursor. A small plus sign (+) appears next to the pointer when copying, and a curved arrow appears when creating a shortcut. If you see no symbol, the object will be moved. This visual feedback is very important; it can eliminate a lot of stupid mistakes if you pay attention to it.

Here's how to control what happens when you drag-drop an item:

- To copy an object under any situation, hold the Ctrl key while dragging. If you press Ctrl before you click, Windows assumes you're still selecting files, so make sure to press it only after you've started dragging but before you let go of that mouse button. Of course, this won't work for system objects like Control Panel items — a shortcut will be created regardless. Using the Ctrl key in this way will also work when dragging a file from one part of a folder to another part of the same folder, which is an easy way to duplicate a file or folder.
- To move an object under any situation, hold the Shift key while dragging. Likewise, if you press Shift before you click, Windows assumes you're still selecting files, so make sure to press it only after you've started dragging but before you let go of that mouse button. This also won't work for system objects like Control Panel items — a shortcut will be created regardless.
- To create a shortcut to an object under any situation, hold the Ctrl and Shift keys simultaneously while dragging. If you try to make a shortcut that points to another shortcut, the shortcut will simply be copied (duplicated).
- To choose what happens to dragged files each time without having to press any keys, drag your files with the right mouse button and a special menu will appear when the files are dropped. This context menu is especially helpful because it will display only options appropriate to the type of object you're dragging and the place where you've dropped it.

## 2.2 The Command Line

Many of those who are new to computers will never have heard of the command line, also known as the command prompt or the Disk Operating System (DOS)
prompt. (DOS was the operating system used by most PCs before Windows became ubiquitous. The command line in DOS was the only way to start programs and manage files.) Those who might have used older PCs may remember the command line, but may be under the impression that it's purely a thing of the past. Advanced users, on the other hand, whether they remember the old days of the DOS command line or not, have probably learned the advantages of the command-line interface, even when using Windows XP on a day-to-day basis. Many tasks can be performed more quickly by typing one or more commands into the command prompt window. In addition, many of the programs listed in Chapter 4 are command-line based tools, and some familiarity with the command prompt is necessary if you plan to use them.

For full documentation on the command line and the Command Prompt application, see Chapter 1. Also see Chapter 5 for information on the Address Bar and Start Run, two alternatives to the Command Prompt window.

Here are a few examples that show how the command line can be used as an alternative to the GUI:

- To create a folder called sample in the root directory of your hard disk, and then copy all the files from another folder into the new folder, for example, it can be quicker and easier to type:

  C:\> mkdir sample
  C:\> copy d:\stuff\*.* sample

  than it would to open Windows Explorer, navigate to your d:\stuff folder, select all the files, click File ➔ Copy (or Ctrl-C), navigate to the new location, click New ➔ Folder, type the folder name, open the new folder; and then click Edit ➔ Paste (or Ctrl-V) to copy in the files. That's a heck of a sentence, and a heck of a lot of steps for what can be accomplished with the two simple commands shown above.

- Once you learn the actual filename of a program rather than its Start menu shortcut name (as described in Chapter 4), it's almost always quicker to start it from the Run prompt or the Address Bar (see below) than it is to navigate the Start menu hierarchy. Which is really easier? Clicking your way through four menus:

  Start ➔ Programs ➔ Accessories ➔ System Tools ➔ Character Map

  or typing:

  charmap

  into the Run prompt or Address Bar and pressing the Enter key? Typing a command is much faster than carefully dragging the mouse through cascading menus, where an unintentional slip of the mouse can get you somewhere entirely different than you planned.

- Finally, many useful programs don't appear on any menu in the Start menu. Once you know what you're doing, you can put shortcuts to such programs in the Start menu or on the Desktop — but once you know what you're doing, you might just find it easier to type the program name.
### 2.8.1 Online Help

Most windows have some degree of online documentation, in the form of a Help menu that you can pull down with the mouse or by typing Alt-H. In addition, you can press F1 at almost any time to display help. In some situations, pressing F1 will only display a tiny yellow message (known as a *tooltip*) with a brief description of the item with the focus; at other times, F1 will launch an online index to help topics. Sometimes, F1 will have no effect whatsoever. Furthermore, if you hold the pointer over many screen objects (such as items on the Taskbar or a window's toolbar), a tooltip may appear. A tooltip may display nothing more than the name of the object to which you're pointing, but in other cases, it may provide additional information. For example, placing the pointer on the system clock pops up the date. You can turn tooltips off in the Windows interface by going to Control Panel ➔ Folder Options ➔ View and turning off the option "Show pop-up description for folder and Desktop items." Note that this won't necessarily turn off tooltips in other applications — only Explorer.

At the command prompt, you can get help on the available command-line options by typing:

```
commandname /?
```

Finally, Windows XP includes a number of readme files, which typically contain release notes — information about special handling required for specific applications or hardware devices. The file `c:\Windows\readme.txt` contains a list of all the other readme files on the system. Or, you can just look in the `\Windows` directory for any file with the `.txt` extension. Use Notepad or any other ASCII text editor or word processor to read them.

### 2.8.1 Shutting Down

You shouldn't just turn off the power to a Windows XP machine, since it caches a lot of data in memory and needs to write it out before shutting down. See [Shut Down](#) in Chapter 7 for additional details.
Part II: Alphabetical Reference

Chapter 5. The User Interface

One of the responsibilities of a graphical operating system like Windows XP is to provide a common set of interface controls not only for itself, but for all the applications that run on it. This chapter provides an alphabetical reference to the elements of the Windows XP user interface, how they’re used, and what tricks can be performed with them. Also included are some of the building blocks of the Windows XP shell (commonly known as Explorer), such as the Desktop and the various toolbars. Chapter 4 provides a similar alphabetical reference to the individual programs and utilities that make up Windows, whether they are accessible through the graphical user interface or the command line. The alphabetical reference entries in this chapter are as follows:

<table>
<thead>
<tr>
<th>Address Bar</th>
<th>Labels</th>
<th>Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Buttons</td>
<td>Listboxes</td>
<td>Shut Down</td>
</tr>
<tr>
<td>Checkboxes</td>
<td>Log Off</td>
<td>Start Menu</td>
</tr>
<tr>
<td>Clipboard</td>
<td>Menus</td>
<td>Status Bar</td>
</tr>
<tr>
<td>Combo Boxes</td>
<td>My Computer</td>
<td>System Tray</td>
</tr>
<tr>
<td>Context Menus</td>
<td>My Network Places</td>
<td>Tabbed Dialogs</td>
</tr>
<tr>
<td>Control Menus</td>
<td>Notification Area</td>
<td>Taskbar</td>
</tr>
<tr>
<td>Desktop</td>
<td>Progress Indicators</td>
<td>Text Boxes</td>
</tr>
<tr>
<td>Details</td>
<td>Properties</td>
<td>Title Bars</td>
</tr>
<tr>
<td>Dialog Boxes</td>
<td>Radio Buttons</td>
<td>Toolbars</td>
</tr>
<tr>
<td>Drop-Down Listboxes</td>
<td>Recycle Bin</td>
<td>Tray</td>
</tr>
<tr>
<td>File Open/Save Dialogs</td>
<td>Run</td>
<td>Trees</td>
</tr>
<tr>
<td>Icons</td>
<td>Scroll Bars</td>
<td>Turn Off Computer</td>
</tr>
<tr>
<td>Input Fields</td>
<td>Send To</td>
<td>Windows</td>
</tr>
</tbody>
</table>

In addition to imposing a certain level of user interface consistency, these common elements allow programmers to quickly piece together the interfaces for their applications with a "toolbox" of parts. While these interface elements are available to all applications, some application designers choose instead to implement their own custom controls and interface paradigms. Sometimes this can lead to an innovative and clever design, but more often than not, it just results in a mess. A poor result typically comes not so much from the choice not to use Windows common controls, but from a failure to follow the rules of good user interface design.

The following are a few guidelines that apply to all elements of the Windows interface, which should provide some understanding of why certain elements are designed the way they are in Windows XP.

**Visual clues (perceived affordances)**

One of the most basic advantages of a graphical operating system is that the elements of the interface contain visual clues on how they’re used. For example, buttons have a 3D look, implying that you’re supposed to push them in. Folder icons look like actual yellow folders you’d see in a file cabinet, reinforcing the notion that they are containers that hold your documents. They also light up when you’re dragging items over them, signalling that they can accept dropped objects. Even the mouse pointer provides visual feedback, changing to a resize arrow when it’s over the edge of the window, or changing to a circle with a line though it when you’re
dragging over an object that can't accept the object you're holding. (Don Norman, author of the book *The Design of Everyday Things* (Doubleday)), calls these *visual clues*, which are intended to recall the way the physical world affords opportunities to interact with objects, "perceived affordances.") These clues are present in nearly every aspect of the Windows interface; learn to recognize them, and you quickly find even the most unfamiliar interface more intuitive and easier to use.

**Constraints**

Many controls have limits, or *constraints*, that permit only certain values to be entered. Scrollbars have a maximum and minimum limit, for instance, so you can't scroll past the end of a document.

**Grayed-out (inactive) controls**

Any control that appears "grayed out" is disabled because the underlying operation is not currently available. For example, in the dialog box shown in Figure 5-8, you need to click the "Password protected" checkbox before you can use the Change button.

**Figure 5-8. Some options are disabled (grayed-out) when unavailable or not applicable**

Gray items typically don't respond at all when clicked, and sometimes it's not obvious what action must be taken in order to "un-gray" a menu item. If you're stuck, try to imagine in what context the menu item is used, and then try to put the application in the correct state for that menu item to be appropriate. For example, some menu items in your word processor will be grayed out when graphics are selected, or if the spelling checker is open.

**Ellipses (…)**

You'll commonly see ellipses on menu items and command buttons, and occasionally on other interface elements. This notation implies that a new window will appear when the control is activated.

**Focus**

The focus (explained in greater detail in Chapter 7) is the visual highlighting of a single control, identifying which element will receive input from keyboard. Since there's only one keyboard, only one control can have the focus at a time, and since only one window can be active at a time, you should always be able to determine what will happen when you press keys on the keyboard by simply looking for the focus. For example, if a button
has the focus, a dotted line will appear around its inner parameter; if an input field has the focus, a blinking cursor will appear where text is to be typed (this is known as the "insertion point"). You can usually click an item to give it focus, or use the Tab key to move the focus from one control to another.

**Style**

A new concept in Windows XP is the user-selectable style of all your windows and interface elements. The cheerful, brightly colored style that is the default when Windows XP is first installed is known as "Windows XP style." As shown in Figure 5-2, you can choose another style, such as "Windows Classic style," by going to Control Panel ➔ Display Properties ➔ Appearance. Windows XP only ships with these two styles, but additional styles can be added with third-party utilities (available at [http://www.annoyances.org/exec/show/article_02_008](http://www.annoyances.org/exec/show/article_02_008)). Using these tools, you can choose the look and feel of all of the controls documented in this chapter, including titlebars, buttons, scrollbars, and even the Start button and Taskbar.

**Figure 5-2.** The Display Properties dialog allows you to choose between the two visual styles available in Windows XP

Don't confuse styles with themes. A theme is a collection of settings. Once you’ve chosen the style, specified colors, and selected a screensaver, go to Control Panel ➔ Display Properties ➔ Themes tab to "save" your settings under a single theme name. See Display Properties in Chapter 4 for more information on these settings.

**Address Bar**

The Address Bar (see Figure 5-5) is a special toolbar with an input field and (optionally) a "Go" button. It appears in Internet Explorer, Windows Explorer, and on the Taskbar. When you type an Internet address, the name of a program, or the path of a folder, and then press Enter, the Address Bar will respond in one of many ways, depending on its location and your system's settings.

**Figure 5-5.** The Address Bar, shown here on the Windows Taskbar, allows you to quickly open programs and web sites by typing their filenames and addresses, respectively
The Address Bar is one of my favorite features in Windows. While its main purpose is to make it easy to type in a web address and point your browser to that address, it also can be used to type a command or application to launch, just like Start → Run. This means that you can easily choose between point and click and command-line operations — whichever is easier for completing a given task. Because I keep the Address Bar visible in the Taskbar all the time as well as in each open folder window (which makes it easy to jump to any folder without having to hunt for it in the branches), it's become my primary command-line interface.

One major difference between the Run prompt and the Address Bar is how they treat an unknown address or command. The Address Bar assumes that any unknown text string is a web address. So, for example, typing oreilly in the Address Bar will launch your browser and start looking for http://www.oreilly.com. If you type the same string at the Run prompt, you'll get the message "Windows cannot find 'oreilly'. Make sure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search." The Run Prompt's behavior is the reverse. It will treat a line beginning with http:// or www. as a web address and launch the browser, but will assume that any other string is the name of an application or command.

Like the Run prompt, the Address Bar features a drop-down list containing the history of all recently entered URLs and command lines. Pick an item from the drop-down list to re-execute the command or revisit the specified web site. Although it is useful for issuing commands, the Address Bar does have one drawback when used in this fashion. When you issue a command, the command is opened in a new window. Once the command has finished, that window closes instantly. If you are issuing a command that does not normally leave the Window open, but that you need to see a response (like ping or dir), you'll have to have very fast eyes. For these types of commands, you're better off using the Command Prompt. See the discussion of the Address Bar in Section 1.1 in Chapter 1 for more details on its use.

**Buttons**

Just click a button to make it do what its label says. In Figure r-ε, the Browse button is typically used to display a file dialog box. When you choose a file and click OK, the name and location (also known as the path) of the file is automatically entered into the text field. This synergy of controls is common, saves typing, and prevents typos. Some applications place a small folder icon next to a text field rather than the full-sized text field, but the usage is the same.

**Figure r-ε.** The Browse button is marked with ellipses (...), implying that another window will appear when it is clicked
If the button has the focus, press the spacebar to activate it. In dialogs with more than one button, often one of them has a thicker border than the rest (usually the OK button) — this is the "default" button and can be activated by pressing Enter, regardless of which control has the focus. Similarly, there is usually a cancel button (usually labeled "Cancel") that responds to the Esc key, but that has no visual distinction. If in doubt, use Tab to cycle through the buttons, and then press Space. Figure 1-6 shows some special cases in which buttons work differently or have special meaning:

**Figure 1-6. Toggle buttons, typically on application toolbars, allow you to turn options on or off by clicking**

**Toggle buttons**

Some buttons, typically custom controls or buttons on toolbars, are used to change a setting, and will simply stay pushed in until clicked a second time. There's no rule that makes these buttons look different from standard buttons, so you'll have to rely on experience to determine which are "toggles." For example, the B or I buttons (corresponding to bold and italic, respectively) commonly found on word processor toolbars are toggles, but the Save and Print buttons are traditional buttons and are used to carry out a command rather than to change a setting.

**The default button**

When a set of buttons is displayed, typically at the bottom of a dialog box, one button will be the "default," meaning that it will be the one activated by the Enter key. It's identified by a thicker border (not to be confused with the dotted rectangle signifying the focus, discussed at the beginning of this chapter). Not all dialog boxes have a default button, but when it's there, it's usually the OK button.

**The Cancel button**

Much like the default button, a single button is often set as the Cancel button, meaning that it will be activated when the Esc key is pressed (regardless of which control has the focus). The Cancel button has no visual distinction from any other buttons.

**OK, Cancel, Apply**

Most dialogs will have at least an OK and a Cancel button, and many also have an Apply button. Typically, OK is the "default button," and Cancel is the "cancel button." Both the OK and Apply buttons accept whatever settings you've entered, but the OK button closes the window, while Apply leaves it open, allowing you to make more changes. Finally, Cancel closes the window without applying your settings. (See Figure 1-7.)

**Figure 1-7. Click OK to accept your changes and close the dialog, Cancel to discard your changes, or Apply to accept your changes while leaving the dialog open for later changes**
What may be confusing is what happens when you click Apply and then Cancel. The assumption is that the settings that were "applied" are not lost, but any that were made after Apply was clicked are ignored. Theoretically, the behavior should be the same as though you clicked OK, then reopened the dialog, and then clicked Cancel. But don't be surprised if some applications respond differently; Microsoft has never been clear with application developers about the expected behavior in this situation.

**Checkboxes**

Checkboxes are generally used for on/off settings. A checkmark means the setting is on; an empty box means it's off. Click on the box to turn the labeled setting on or off.

*Figure 5. Checkboxes allow you to turn settings on or off*
In some instances, the checkmark may be shown in a light gray color. This doesn't necessarily mean that the control is disabled (see "Grayed-out (inactive) controls", at the beginning of this chapter), but rather that the value is neither on nor off. Here's an example: select some files in Explorer or on your Desktop, right-click on one of them, select Properties, and you'll get a dialog similar to Figure 5-4. The checkmark is missing for the Read-only and Hidden attributes, but appears gray for the Archive attribute because some of the selected files have it enabled, and others don't.

**Clipboard**

A shared, system-wide storage area for temporarily holding and moving data.

**To Open**

Edit → Cut (Ctrl-X)
Edit → Copy (Ctrl-C)
Edit → Paste (Ctrl-V)

The Clipboard is an invisible portion of memory, used to temporarily hold data as it's moved or copied from one application to another. Although you won't ever "see" the clipboard, it's used every time you cut, copy, or paste something. Using the clipboard is easy. Select a portion of text in your word processor, an image in your graphics program, or a file in Explorer, and then select Cut from the Edit menu; the selected object(s) will disappear and will be stored in the clipboard. (Use Copy instead of Cut if you don't want the original data erased.) Then, move to another location and select Paste from the Edit menu to place a copy of the object on the clipboard in that location. You can repeatedly paste the data as many times as you like.

**Notes**

- The Clipboard works like the penalty box in hockey; it holds only one item at a time. If you place new data in the clipboard, its previous contents are erased. If you never got around to pasting the previous data, it's lost for good.
• You can paste only data that an application is prepared to receive. For example, you cannot paste an image into some applications that recognize only text (such as the Command Prompt or Notepad).

• Even without an Edit menu, you can usually still access the clipboard using either keyboard shortcuts or the right mouse button. For example, web browsers have a Copy command in the Edit menu, but this command is used only for copying portions of the currently displayed web page to the clipboard. To cut, copy, or paste text in the Address Bar, just right-click on the text or use Ctrl-X, Ctrl-C, and Ctrl-V.

• You can use the Clipbook Viewer (discussed in Chapter 4) to view the data currently stored on the Clipboard or save it into a file or share it across a network.

• See Chapter 1 for help with copying and pasting data with the command prompt window.

• The keyboard shortcuts (Ctrl-X, Ctrl-C, and Ctrl-V) may not be intuitive at first, but when you consider that they appear all together on the keyboard and are located very close to the Ctrl key, the decision to use these keys becomes clear. As a holdover from earlier versions of Windows, Shift-Del, Ctrl-Ins, and Shift-Ins can also be used for Cut, Copy, and Paste, respectively.

• Also see Clipbook Viewer in Chapter 6

---

**Combo Boxes**

See Listboxes.

---

**Context Menus**

In Figure 5-1, I've right-clicked on the Recycle Bin icon to display its context menu, which is a list of special actions or commands that affect only that object. The idea is that the options available for any given object in Windows depend upon the context, the set of circumstances under which you're operating. The "Empty Recycle Bin" option is shown here, since it is relevant to the context of the Recycle Bin, but since the Recycle Bin is currently empty here, the option is grayed out (disabled). Nearly all objects in Windows have their own context menus, almost always accessible with the right mouse button. See Windows Explorer in Chapter 4 for details on customizing the context menus for your files, folders, and certain Desktop items, and Chapter 4 for details on the way Windows stores file type information.

Figure 5-1. Right-click nearly any object to display its context menu, a list of actions that can be performed with the selected object
When a file or other object is selected (highlighted), press Shift-F8 to display the context menu. If you have a special Windows keyboard, there is a special key for this purpose, usually located to the right of the spacebar. The most frequently used item in most context menus is Properties, which can be more quickly accessed by pressing Alt-Enter. Other shortcuts for context menu items include Del, Fr, Ctrl-X, Ctrl-C, and Ctrl-V for Delete, Rename, Cut, Copy, and Paste, respectively.

**Notes**

- The bold item (usually, but not always, at the top of any given context menu) is the default action, carried out when you double-click.
- Most new keyboards also include a context key (which looks like a menu with a pointer on it) that will open the context menu of any selected item.

Any program or command line on the system can be made into a new "verb" on a context menu using View → Options → File Types → Edit from any folder or Explorer window. (To create new verbs directly in the Registry, see O'Reilly's *Windows XP Annoyances*, by David Karp. Note that customizing the context menu for HKEY_CLASSES_ROOT\shell lets you create verbs for all files; normally they'll apply to particular file types, based in turn on file extensions; objects — drive, folder, unknown, etc.; or URL prefixes — http, ftp, etc.)

- Context menus exist for all major interface elements — files, folders (including system folders like My Computer, Network Neighborhood, Recycle Bin, and My Briefcase), the Desktop, the Taskbar, the System Tray, and so on — but they often also exist for elements within an application window or dialog. If you're ever stuck, try right-clicking on a user-interface element and see if anything helpful pops up.

- Individual buttons or other user interface elements often have a context menu consisting of the single entry "What's This?", which gives a short description of what that element is used for. In other cases, the context menu is more extensive. For example, right-clicking on the files on your Desktop (or even on an empty area of the Desktop) provides access to the features that would otherwise be unavailable due to the absence of a standard menu. Of particular use is the New entry, which allows you to create a new Folder, Shortcut, or empty file.
Right-clicking on the titlebar or the Taskbar button for an open application displays the context menu for the window, commonly known as the Control menu, also accessible by clicking on the upper-left icon (see Windows later in this chapter). Right-clicking in the body of the window gives you the context menu for the application or the selected element within the application, if one exists. Note that this is different from the context menu that you get by clicking on the program's shortcut icon when it is not running.

- See Send To later in this chapter, for details on the Send To command found in the context menu for files and folders.

**Control Menus**

See Windows.

**Desktop**

The Desktop is the basis for the modern GUI paradigm. The Desktop is considered a container for all other resources on your computer, as well as a backdrop for your Windows workspace. The Desktop is always underneath any open windows — to access the Desktop if it's covered, you need to minimize or close any open windows (press the Windows logo key and D, or right-click on the Taskbar and select Minimize All Windows to accomplish this quickly).

As shown in Figure r-9, the Desktop contains two types of icons; namespace icons and file icons.

**Figure r-9.** Of the icons shown on the Desktop, some are virtual objects and some are files; those that are actual files are also shown in your Desktop folder.
File icons can be files or folders (actually located in your `{username}\Desktop` folder on your hard disk) — you can drag-drop them to and from the Desktop as though it were any other ordinary folder. The Desktop is a good place to store newly downloaded files from the Internet, email attachments, items from floppies, and other files you're currently working on. Namespace icons, on the other hand, such as My Computer, My Network Places, and the Recycle Bin, aren't files, but rather specific resources built in to Windows. All of these icons can be renamed or even hidden, although the process isn't always obvious. (See Chapter 6 for details specific to the object you wish to customize or remove.) The exception is that the Recycle Bin cannot be renamed, unless you have Norton Utilities or edit the Registry manually. (See directions at http://www.annoyances.org.)

As with most other components of the Windows interface, the Desktop has properties you can customize. Right-click on an empty portion of the Desktop and click Properties to change the wallpaper, color, screensaver, and settings for the display. (This is the same property sheet that you will get by opening Display Properties in Control Panel).

**Notes**

- The Arrange Icons By entry is also available in the Desktop's context menu. Icons can be arranged on the Desktop by type (system facilities, folders, and files, in that order), alphabetically by name, by date (with the most recent first), and by size (with the smallest first). Select AutoArrange if you want the icons to go into neat rows automatically; unselect it if you want to be able to drag them anywhere on the Desktop. When the Desktop is full, auto-arrange stops working.

- The Line Up Icons feature found here in earlier versions of Windows has been removed in Windows XP. In its place, Microsoft has added the Align to Grid option in the Arrange Icons By menu. Unfortunately, this is a toggle; to simply align the icons on your Desktop without restricting their future placement, you'll have to turn on the Align to Grid option and then turn it back off.

- The Quick Launch toolbar (see Taskbar and Toolbars, later in this chapter) includes a Show Desktop button that instantly hides all open windows, thus allowing access to your Desktop. If you click the button a second time without opening any new items, all windows are restored to their original state.

- The "Active Desktop" functionality found in earlier versions of Windows has been taken out of Windows XP.
- Various options for customizing the Desktop, as well as the icons on it, are detailed in Chapter 6.

**Details**

See Listboxes.

**Dialog Boxes**

Dialog boxes are temporary windows that applications use to request your attention or input. Dialog boxes usually don't have a resizable border (although File Open/Save Dialogs do), and they almost always have OK, Cancel, and Apply buttons. Dialog boxes are usually "modal," which means that when they're open, you can't use any other part of the owning application until they're closed. See Windows, later in this chapter, for more information.

**Drop-Down Listboxes**

See Listboxes.

**File Open/Save Dialogs**

There's a reason why File Open and File Save dialogs look the same in nearly all applications; they're common dialogs, provided by Windows. Strangely, one of the few applications that doesn't use these common dialogs is Microsoft Office, which instead employs custom dialogs that actually have more limited functionality than their standard, common counterparts.

The main part of the standard file dialog is really just a folder window as shown in Figure 7-1.; you can even drag and drop items into and out of this window, as well as display the contents in the same Details, Icons, and List views found in Windows Explorer.
Another standard component in file dialogs is the gray stripe on the left side, called the Places Bar. Here, five (or more) shortcuts to special system folders are shown; click an icon to quickly jump to the corresponding location. However, most of the default entries will be of little use to the average user, so you may want to customize this area, a task possible only with the TweakUI add-on described in Appendix D.

Along the top of the window, you'll find the "Look in" list, and several buttons. The yellow folder icon with the curved arrow is used to jump to the parent folder, and the yellow folder icon with the star is used to create a new subfolder. The last button allows you to choose the way icons are shown in the main listing. Unfortunately, the full path of the current folder is not shown anywhere in this window (this has been a problem with Windows for years), but if you open the "Look in" list, you'll see the abbreviated hierarchy that reveals the location of the folder.

You can type any filename below, including the full path desired, to open or save. Finally, the "Files of type" list is used to filter the display of files in the main listing. This is often most confusing part of this window for new users, since, in most cases, only certain files are shown. If the file you’re looking for does not match the file type selection, it won’t show up at all. Typically, the last entry in this list is All Files (*.*); choose this item to turn off the filter and display all files, regardless of type.

**Notes**

- Like most dialog boxes, File Open/Save dialogs are modal, which means that they must be closed before you can use another part of the application.
- An alternative to opening an application and then using File → Open is to navigate to the folder containing your document and then double-click it to open it in its default application. (This default can be changed by going to the Tools → Folder Options → Files Types tab in Explorer.) You can also drag-drop a document icon into an open application window to open the file in that program.
In some applications, if you drop a file icon into an already-open document, the dropped icon will be inserted as an "object" into that document, rather than simply opening the document as you'd expect. The solution is to drop the icon onto the Application's titlebar.

**Icons**

Strictly speaking, an icon is any small picture used to symbolize an object or a function in the interface. Icons commonly appear in menus and on toolbars, but the term is most often used to describe the objects that represent files and folders on your Desktop and in Windows Explorer.

Chapter 2 covers the basic use of icons, especially in the way they can be opened, moved, copied, and deleted. Right-click any icon to display its context menu. (See Context Menus, earlier in this chapter.)

The image used for a given icon depends on the type of object it represents, as does the procedure for customizing that icon. For example, the icons for My Computer, Recycle Bin and other Desktop "namespace" objects can be customized by right-clicking on an empty area of the Desktop and going to Properties ➔ Desktop tab ➔ Customize Desktop.

The icon used for a document depends on its type; all .txt files use the same icon, all .jpg files use the same icon, and so on. Icons for most file types can be changed by going to Tools ➔ Folder Options ➔ Files Types tab in Explorer (see Figure r-11). The exceptions are application executables (.exe files), which have their own icons. All folders (except special folders, like My Documents and My Pictures) use the same icon, and cannot be changed without a third-party add-on like Microangelo (Version 0.0 or later; available from http://www.impactsoftware.com/).

You can change the icon for any Windows Shortcut or Internet Shortcut by right-clicking, and selecting Properties ➔ Change Icon. By default, the Change Icon dialog box for a shortcut usually points to \Windows\System\shellrrr.dll, which contains over 100 different icons, including the standard icons for folders, disks, and so on. A browse button lets you search for other sources of icons, but where do you browse?

Icons can be stored in a variety of files, including .exe and .dll files (program components) and .ico files (standalone icon files). Even .bmp (Windows bitmap files) can be used for icons. Browsing for icons can be time consuming, though, since the Change Icon dialog can only look inside one file at a time. The alternative is to use Explorer: the standard file icon for .ico files is the actual icon it contains, making it easy to peruse an entire folder full of icon files (although you'll have to switch to the Thumbnails view to see your .bmp files).

Although other Windows files (such as \windows\explorer.exe) have additional icons, you may want to look on the Web for decent icons to decorate your
workspace (and there's no end to web sites that contain freely downloadable icon libraries). Since I have a particular fondness for the NeXT interface from the '80s, I've found the icons at http://pcdesktops.emuunlim.com/ to be especially nice.

**Figure 3-11. Windows XP comes with a large collection of images for your shortcuts**

![Change Icon](image)

**Notes**

- On the Desktop, icons are shown in their full size, but in folder windows and in Windows Explorer, you can choose to display icons in a "list" or "details" view.
- Paint, the rudimentary image editor included with Windows XP (and every version of Windows since the '80s), allows you to create and modify .bmp files, but it doesn't support .ico format. Furthermore, its tools for doing detail (essential when creating the tiny images used for icons) are pretty lousy. The Microangelo package, available from http://www.impactsoftware.com/, is about the best icon editor I've used.

**Input Fields**

As their name suggests, input fields are small controls (usually found in a dialog box that allows you to provide required information). (See Figure 3-11.) A textbox is one of the most common forms of input field. Essentially a mini word processor, the textbox is used for entering text. Most input fields allow only a single line of text (such as the Address Bar or the Filename field in File Open/Save dialogs), but some allow multiple lines. You can almost always right-click in a textbox to display a quick menu for Cut, Copy, Paste, and Undo (see Clipboard, earlier in this chapter).

There are four common variations of input fields. The first type are the input fields made to look like labels (see Labels, later in this chapter). The second are combo boxes (see Listboxes, later in this chapter). The third are known as counters, which
are simply input fields with up and down arrows to the right, allowing you increment or decrement a numeric value without typing (some even have a tiny divider between the arrows, allowing you to quickly "scroll" to any value). Finally, we have password fields (Figure 7-17), which look and act just like standard input boxes, except that their contents are masked with asterisks to hide them from prying eyes.

Figure 7-17. A simple input field (textbox) allows you to type a small bit of text; right-click to display Cut, Copy, Paste, and Select All commands

![Image](https://example.com/image.png)

Figure 7-17. Password fields work like standard input fields, except that the characters you type are masked with round bullets

Change your password

Type your current password:

```
************
```

Type a new password:

```
******
```

Type the new password again to confirm:

```
******
```

If your password contains capital letters, be sure to type them the same way every time you log on.

Type a word or phrase to use as a password hint:

```

```

The password hint will be visible to everyone who uses this computer.

Since the Tab key is used to shift the focus to the next control, you'll need to press Ctrl-Tab if you actually want to type a tab character into an input field. Likewise, Enter is often used to move between controls (or to press the default button; see Buttons, earlier in this chapter), press Ctrl-Enter to insert a new line (multiline textboxes only). Hold Shift and use the arrow keys to select text without using the mouse (or Ctrl-A to select everything), and then use Ctrl-X, Ctrl-C, and Ctrl-V for Cut, Copy, and Paste, respectively. Press Ctrl-Z to undo.

Notes

- Right-click in an input field to display additional options. In addition to the clipboard operations (Cut, Copy, and Paste), you'll see Select All, Right to Left Reading order (to make the text right-justified), and two options for using Unicode characters (useful primarily for programmers).
- Some nonstandard input fields allow formatting (bold, italics, font selection, etc.). These "rich text" fields typically work the same as standard input
fields, although they often have additional features specific to the application.

**Labels**

Labels are basically noninteractive pieces of text placed on dialogs used to describe a control (such as the slides shown in Figure 5-84) that doesn't have a place for a description. Clicking labels usually has no effect.

**Figure 5-84. Labels are noninteractive captions for other controls (like these sliders) that don't have captions of their own**

The important thing to note about labels is that they often contain a single underlined letter. Holding Alt and pressing the key for that letter will send the focus to the next control. This is useful because the input field in this example doesn't have a shortcut key of its own.

**Notes**

Some labels allow you to select and copy text and are distinguished because the mouse pointer changes to an "I-beam" when over the label. Strictly speaking, these are just standard input fields (without borders) that have been made to look like labels. Examples of this type of field can be seen by right-clicking on a file and selecting properties.

**Listboxes**

A listbox is a list of items from which you can choose one or many. There are four common types of listboxes:

*Standard listbox*
A simple listbox is a rectangular control that contains one or more entries. If there are more entries than can be displayed in the space allotted, scrollbars will appear as well. Click an entry to select it. If the listbox allows multiple items to be selected simultaneously, hold down the Ctrl key while clicking or pressing the spacebar to select additional items, one-by-one, or use Shift-click to select a range of items (see Figure 5-10).

Use the arrow keys to move up and down the list. Type a letter to jump to the first entry that begins with that letter; if there are a lot of items, you can type several letters, quickly in succession, to jump to the first item the begins with those letters.

**Figure 5-10.** This listbox shows the bitmap files in your Windows folder, from which you can choose one to be your Desktop background image

---

*Drop-down listbox*

A drop-down listbox (see Figure 5-11) works much like a standard listbox, except that only the currently selected entry is shown. Click the down arrow to open the list and choose another item. Drop-down listboxes never allow multiple selections.

**Figure 5-11.** Drop-down listboxes work much like standard listboxes, except that they consume less screen real estate
Shortcuts
With the focus on a drop-down listbox, press the down arrow key to open the list, the arrow keys to navigate, and then the Tab key to jump to the next control, which will close the list automatically (press Esc to close the list without selecting a new item). If you press Enter to commit your selection, though, it might activate the default button (see Buttons, earlier in this chapter).

Combo box
A combo box is a hybrid between an input field and a drop-down listbox. You can type just like in an ordinary input field, or you can click the down arrow to choose an item from the list. If you click an item, that item’s caption will be placed into the text field, at which point you can edit or move on. Often, a drop-down list contains a history of previous entries you’ve made into a text entry field; the Address Bar is essentially a glorified combo box. The keyboard shortcuts are the same as for drop-down listboxes, shown above, and input fields (discussed earlier in this chapter). Additionally, you can begin typing, and then press the down arrow, and the first entry in the list that matches what you’ve typed (if any) will be selected automatically.

ListView (commonly known as Details)
An enhanced version of the standard listbox, the ListView control is what appears in folder windows and File Open/Save dialogs. It’s commonly used to display lists of files, but it’s not unusual to see this presentation for other types of data as well. (See Figure r-1v.) The main advantage of this control is that it supports multiple, resizable columns, each of which has a header that can usually be clicked to sort the contents of the list (click again to reverse the sort order). Drag the lines dividing the headers to resize the width of columns or drag the headers to rearrange them. Double-click on column header separators to resize columns automatically to the widest contents. See Chapter r for more information on working with the folder window. Since folders use the common ListView control, almost anything that works with a folder will work with other ListView controls. For example, in addition to selecting multiple items with Ctrl and Shift, as described for standard listboxes, above, you can usually select multiple items by drawing a rubber band with your mouse as well.
ListView controls, like the one used for Explorer's Details View, are enhanced listboxes with multiple columns of information.

![ListView diagram](image)

1. Drag boundary left or right to adjust column width. Double-click on the boundary to shrink or expand the column to fit the text.
2. Click on any heading to sort by that heading.
3. The arrow and faint shading on the column shows the current sort order.
4. A scrollbar appears if there is not enough room for all columns.

**Log Off**

Logs off the current user.

**To Open**

Start → Log Off `{username}`
Ctrl-Alt-Del → Log Off
See [User Accounts](#) in Chapter 4 for more information on logging on, logging off, and managing multiple users.

**Menus**

The menu is a place where you can cram all the functionality of a program. Rather than littering your screen with all available commands, they are categorically arranged into cascading lists, as shown in Figure 5-81. Modern applications have become so elaborate, however, that menus are often very complex, making it a pain to have to sift through them all to find the command you want. Thus, designers invented toolbars (discussed later in this chapter) as shortcuts for the items we actually use. It makes us wonder, then, why we need menus in the first place?

**Figure 5-81.** Nested (cascading) menus provide access to all options and features of an application
If you ever get lost, menus tend to be pretty consistent across applications. For example, you can almost always find Open, Save, Print, and Exit in the File menu, just as Cut, Copy, Paste, and Undo are always in the Edit menu. See Chapter 2 for more information on using menus. See Context Menus, earlier in this chapter, for details on the menu that appears when you right-click on something.

Press F1 or Alt (by itself) to enter the menu, use the cursor keys to navigate, and press Enter to select an item. Once you're in the menus, press the underlined letter of a menu item to quickly jump to that item, or if no letter is underlined, press the first letter of the item's caption. You can also jump right to a specific menu from anywhere else in the application by pressing the key of the underlined letter while holding Alt. Look to the right of many menu items for additional keyboard shortcuts. For example, open the Edit menu in most applications, and you'll see Ctrl-X, Ctrl-C, and Ctrl-V alongside the Cut, Copy, and Paste commands, respectively.

My Computer

See Windows Explorer in Chapter 6.

My Network Places

See My Network Places in Chapter 6.

Notification Area
The notification area, commonly known as the Tray, is the small area at the far right (or bottom) of the Taskbar, which, by default, holds the clock and the tiny, yellow speaker icon. With the exception of the clock, the purpose of the tray is to hold status icons (see Figure 5-82) placed there by Windows and other running applications. Hold the mouse cursor over the clock to see the date temporarily or right-click on an empty area of the Taskbar and click Properties to turn the clock on or off and change other settings. (Sorry, no permanent date is available without a third-party utility — see http://www.annoyances.org/.)

Figure 5-82. The Notification Area (Tray), located on the far end of your Taskbar, holds the clock and icons for some running processes

The Tray can be a convenient place for applications to display information and quick access to certain features, but there is little standardization among Tray icons. Some icons are clicked, others are double-clicked, others require a right-click, and some don’t get clicked at all. Some flash, some don’t. Most icons can be disabled, but some just won’t go away. Most support tooltips, so you can find out what each icon does by holding the mouse over it for a second or two.

The only way to turn the notification area off completely is to hide each of the icons (and the clock) individually. However, you can selectively hide icons by going to Control Panel ➔ [Appearance and Themes] ➔ Taskbar and Start Menu ➔ Taskbar tab ➔ Customize. See Taskbar and Start Menu Properties in Chapter 4 for more information, and See Chapter 6 for additional settings that affect the Taskbar, the notification area, and the icons that routinely appear there.

Notes

- Right-click or double-click on the clock when it is displayed to adjust the system date and time. (You can also get there by opening the Date and Time properties in the Control Panel.)
- The System Tray is available to any application that chooses to use — or misuse — it. For example, both AOL and RealPlayer install a startup icon in the System Tray (as well as just about anywhere else they can put one) — a clear abuse of the intended purpose.
- The language indicator is useful only if multiple keyboard layouts are enabled. Click on the indicator to display a pop-up menu that lets you switch between available keyboard layouts.
- The power status indicator is generally useful only on laptops. It shows a plug when the system is connected to AC power, and a battery when the system is running on the battery. The height of the color in the battery gives a rough idea of how much power is left; to get a more precise estimate, hold the pointer over the indicator until a Tooltips bubble pops up showing the percentage of the remaining charge.
- The PC card indicator gives you a quick way to get to the Control Panel ➔ PC Card property sheet. This indicator is useful if you will be taking PC cards in and out of your system frequently, since the system prefers to be notified before you do so.
- The "Super-Fast User Switcher" is a notification area-based tool that allows you to switch between configured users simply by clicking on its tray icon; see Appendix D for details.
**Progress Indicators**

The progress indicator is a linear gauge that graphically shows the completion of a particular task, allowing you to roughly estimate the time to completion (see Figure 5-20). The annoying part is that the accuracy of progress indicators is typically not very good; the value (zero to 100 percent) displayed by an indicator is based entirely on approximations made by the application. What's worse is that some programs, especially application installers, often have several, consecutive progress indicators; unfortunately, these only display the progress of a particular task rather than the entire process, which obviously is not terribly helpful.

**Figure 5-20.** Often a dialog will show two progress indicators: one showing the completion of the current task and one showing the progress of the entire job

---

**Properties**

The Properties window (sometimes called the Properties sheet) is a dialog box that serves a very specific purpose: to display and allow changes to the settings associated with a file, folder, or other object in Windows. Most objects have Properties sheets, almost always accessible by right-clicking and selecting Properties, as shown in Figure 5-21. (You can also display Properties by holding Alt and double-clicking, or if the item is already highlighted, by pressing Alt-Enter.) Many items in the Control Panel can be quickly accessed by right-clicking on various interface elements and selecting Properties; for example:

**Figure 5-21.** Right-click an item and select Properties to display the item's Properties dialog, often a good place to find extra features and settings
• My Network Places icon → Properties points to Network Connections
• Empty portion of the Desktop → Properties points to Display Properties
• My Computer icon → Properties points to System Properties
• Taskbar or Start button → Properties points to Taskbar and Start Menu Properties
• Clock (in the notification area) → Properties points to Time and Date Properties

At minimum, most Properties sheets will have a General tab, but most have more. Note that the particular information and settings available depend entirely on the object that was clicked.

Notes

• Folders, printers, and disk drives have a second property tab called Sharing. See Chapter 5 for details. Shortcuts to MS-DOS and command-line-based programs have additional settings for legacy support.
• To see the amount of disk space used by a group of files, select them and then view the Properties entry for the selected list. On the first tab, you’ll see the size of the whole group. Change any of the attributes, and the change will be applied to all of the files in the selected group. (Unfortunately, if any of the files in the selected group has a different attribute from other files in the group, the checkbox for that attribute will be grayed out, so this does not work in all cases. This poor user interface design was discussed in Combo Boxes, earlier in this chapter.)
• Certain types of files, such as Microsoft Word files, will have additional property pages that are generated by the application that created them. Word files, for example, have pages that let you summarize and view the statistics for documents.
• Among the settings in a Properties sheet for files are the Attributes (Read-only, Hidden, and Archive). See Attr ib in Chapter 4 for details.
• In previous versions of Windows, the Properties sheet also contained the "MS-DOS name," the eight-character "short filename," plus a three-character extension. Since Windows XP has better support for long filenames, it's assumed that this information is no longer necessary. If you need a short filename for a file or folder, type dir /x at a command prompt (see Chapter 7 for details).
**Radio Buttons**

Radio buttons are used for mutually exclusive settings. Clicking on one causes any other that has been pressed to pop up, just like on an old car radio. The button with the dot in the middle is the one that has been selected. Sometimes you'll see more than one group of buttons, with a separate outline around each group. In this case, you can select one radio button from each group. Functionally, a group of radio buttons works like a standard listbox. (See Figure 5.

**Figure 5.** Two radio buttons are used to allow you to choose only one of the available Start menu styles

Navigating radio buttons with the keyboard can be confusing. When using the Tab key to jump between controls, Windows considers a group of radio buttons to be a single control. When the Tab key places the focus on a single radio button, you'll need to use the arrow keys to select a different one; otherwise, another press of the Tab key will jump to a different control, seemingly skipping a whole bunch of radio buttons.

**Recycle Bin**

In the early days of computing, once you deleted a file, it was gone. An unerase tool (available as part of Norton Utilities) was commonly used to recover accidentally deleted files, and can even be used in Windows XP to recover items emptied from the Recycle Bin. Thus, the Recycle Bin was implemented — a feature that gives nearly every file a second chance, so to speak.
Drag any item from the Desktop to the Recycle Bin icon to delete it, as shown in Figure 5.3. File → Delete on the menubar of a folder also moves items to the Recycle Bin, as does selecting the item and then pressing the Delete key. By default, files are not deleted immediately, but are stored until the Recycle Bin runs out of space, at which point they are deleted, oldest first, to make space. Until that time, they can be retrieved by double-clicking on the Recycle Bin icon, browsing through the contents of the Recycle Bin window, and dragging or sending the file elsewhere.

**Figure 5.3.** Drag nearly any icon onto your Recycle Bin to delete it; subsequently open the Recycle Bin folder to retrieve it

Use the Delete key to move any selected files to the Recycle Bin. To access the Recycle Bin with the keyboard, it’s easiest to simply open Windows Explorer and navigate to your Recycled folder (there’s one on each drive, if you have more than one).

Files dragged to the Recycle Bin (or that are otherwise deleted) from floppies, network drives, or other external drives such as Zip drives will not be stored in the Recycle Bin. They are simply deleted.

The following settings are available in the Recycle Bin's Properties window:

- A slider allows you to specify how much of each drive can be allocated to the Recycle Bin. The default is 10 percent. You can specify the same value for all drives or set a separate value for each drive. Keep in mind that on today's huge drives, 10 percent can be a lot: 10 percent of a 4 gigabyte disk is 4 full gigabytes of stored junk. The amount of space actually used by the files in the Recycle Bin is displayed in the Bin's status bar when you open it.

- A checkbox allows you to specify that deleted files are not to be stored in the Recycle Bin, but removed immediately from the disk. Check this box if you don't want to have to remember to empty your Recycle Bin to delete files, although it can be rather dangerous if you're careless with the Del key.

- A checkbox asks if you want to display a delete confirmation dialog. Unlike some earlier versions of Windows, it's possible to have the delete confirmation turned off at the same time that the "Do not move files to the Recycle Bin" setting is turned on. This means that it's possible to permanently delete files without any warnings at all.

To delete a single file without sending it to the Recycle Bin, use Shift-Delete or the del command at the command prompt.

**Notes**

- With the Details view (the default), you can sort the contents of the Recycle Bin by name, by original location (useful in case you want to put something back where it was), by the date deleted, by type, or by size. Click on any of
the headings to sort contents by that heading. Click again on the same heading to reverse the order of the sort.

- You can delete the entire contents of a floppy disk by dragging the disk icon to the Recycle Bin. You will be prompted for confirmation. You cannot drag a hard disk (such as C:) to the Recycle Bin, however, nor can you drag key components of the user interface, such as the My Computer, the Control Panel, or My Network Places to the Recycle Bin. (Well, you can drag them there, but they won't go in.) Note that some of these Desktop items can be removed by right-clicking and selecting Delete. See Chapter 6 for more ways to control what appears on your Desktop.

**Run**

The Start menu lists many common Windows XP applications and accessories, plus any third-party applications you've installed. It is far from complete, though, and navigating to the program you want is often fairly tedious.

Ironically, the increasing complexity of the system pushes even the most graphically oriented user back in the direction of the command line. Just about the quickest way to run any program that isn't already on your Desktop is to type the name of the program at the command line. Windows XP offers three different command lines: the Address Bar, the Run dialog, and the command prompt window.

If you keep an Address Bar visible at all times (see Address Bar, earlier in this chapter), it is by far the most convenient of the three command lines. The Run Dialog is a close second. However, if you are a heavy user of command-line utilities, you may still find a command prompt window most useful. The command prompt window has an advantage in that it provides useful file management commands such as `dir`, `del`, `copy`, and so on.

For the most part, though, you can use the three command lines interchangeably. If you type the name of a Windows GUI application, it will launch in its own window. If you type the name of a text-based program (for example, `ping`) it will display its output in the current command prompt window, or, if issued from the Address Bar or Run dialog, will launch its own command prompt window, which will last only as long as the command itself executes.

**Notes**

- You'll only be able to launch a program using the Run command if that program's `.exe` file is in a folder listed in the system path. See Chapter 7 for details.
- One important difference between the one-line prompts (Address or Run) and a command prompt window is the context in which commands run. A command interpreter, or shell, always has a particular context, or environment, in which it runs. This environment can create significant differences in the results when you type a command name.
There are a number of commands you can issue only at a command prompt window (documented in Chapter 1), all of which are unavailable from the Run prompt or Address Bar.

See Also

See Address Bar, earlier in this chapter, and Chapter 1.

**Scroll Bars**

A scrollbar is a vertical or horizontal bar on a window with a little box inside it (called the slider or “thumb”) that can be dragged along it with the mouse. Applications use the scrollbar not only to set the position of something (such as the text cursor in a textbox or the currently displayed page of a word processor document), but to give us visual feedback of where we are and how much stuff we can't see. The thumb shows us where we are in the entire piece of text, and the size of the thumb shows us what percentage we’re viewing. (A large thumb means that most of what's there is visible and a small thumb means that there's a lot we can't see.) The scrollbar usually becomes disabled (grayed-out) if there’s no scrolling to be done.

Click the up or down arrows to move the scroll bar incrementally, or drag the thumb with the mouse to move to the desired position. You can also click in the gray areas between the arrows and the thumb to move up or down a page at a time.

It is possible to use the cursor keys and PgUp/PgDn keys to control the scrollbar if it has the focus. If the scrollbar is part of another control, such as the textbox shown in Figure 5-24, then it cannot receive the focus to receive keyboard input directly. Instead, use the cursor keys to navigate in the listbox or input field with which the scrollbar is associated. The thumb blinks if it has the focus.

**Figure 5-24. Use scrollbars to view all of the items in a folder when the folder window is not sufficiently large**
Send To

Send a selected item to a program, disk drive, or folder.

To Open

File or folder’s context menu → Send To
Right-click on any file or folder and select Send To to send it to one of the shortcuts in your SendTo folder. The result is the same as though you drag-dropped the icon onto the shortcut (see Figure r-rq).

Figure r-rq. Right-clicking any file or folder, selecting Send To, and choosing a destination has the same result as dragging and dropping the item to the destination, but Send To is often more convenient

For example, if the destination is an application, the application will be started and the selected file(s) will be opened. If the destination is a folder or a drive, the item(s) will be copied or moved (depending on several circumstances described in Chapter r).

Notes

- The options that appear in the Send To menu are determined by the contents of the \Documents and Settings\{username}\SendTo folder. To add another Send To recipient, create a shortcut in that folder. For example, if you put a shortcut to notepad.exe into that folder (which I find extremely handy), you could easily open any file in Notepad, regardless of the file type.

Send To works a bit differently, depending on the destination. Sending to a folder (including the Recycle Bin) actually moves the file there or copies if the source and destination are on different drives; sending to a program simply opens the file. You can
use Send To on shortcuts with impunity, but when you use it on an original file, remember that you may actually be moving the file.

- If you place a shortcut to your SendTo folder in your SendTo folder, you can create new Send To destinations simply by sending them to the SendTo folder! (Say that five times fast.)

- Place shortcuts to folders in Send To for an easy way to organize your files. You can work on files on the Desktop then use Send To to move them to their storage location when you're done. You can even create shortcuts to shared folders on other machines.

- If you want to have a lot of Send To locations, create subfolders in \Windows\SendTo. They will show up as cascading submenus on the Send To menu.

**Shortcuts**

A Shortcut is a link to a program, file, folder, drive, system object, printer, or URL. Shortcuts are actually small files that come in two flavors: Windows Shortcuts (.lnk) and Internet Shortcuts (.url). (See Figure 5-2#)

**Figure 5-2#** A standard shortcut icon is distinguishable from other icons by the little curved arrow

While you can start a program or open a folder by double-clicking on its icon on the Desktop or selecting its icon in the Start menu, odds are that the application is stored elsewhere and you're using a shortcut only to access the application executable. If you find that there's a program, document, folder, or web site you use often, it's easy to create a shortcut to the object.

There are several ways to create a shortcut:

- Use the Explorer to navigate to the directory where the program's executable (.exe) is stored; if the program is a Windows component (listed in Chapter 4), it's executable is probably in the \Windows\System32 folder. Otherwise, the executable is probably located in a subfolder of \Program Files. Once you've located the .exe file, use the right mouse button to drag it to the location of your choice (typically the Desktop or the Start menu) and select "Create shortcut here" from the context menu that appears. The same procedure works for folders, drives, and documents, as well. In some earlier versions of Windows, dragging an .exe file with the left mouse button (in most situations) automatically created a shortcut, regardless of the destination. This feature, which nobody liked, has been removed in Windows XP. More information on right-dragging can be found in Chapter 5.

- Right-click on an empty area of the Desktop (or any folder), and select New → Shortcut. This four-page wizard prompts you for only two pieces of
information: the full path of the object and the name of the resulting shortcut. This procedure is more laborious than the others listed here, but it does have the advantage of allowing you to create a shortcut to a program with command-line parameters.

- A quick way to create a shortcut to a folder (or drive) is to open the folder and then drag the control icon (the small icon in the upper-left of the window) onto the Desktop or other destination.
- Right-click any file, system object (such as an item in Control Panel or the Printers and Faxes folder), and select Create Shortcut. A shortcut to the selected object will be created in the same folder; if the folder is a "virtual folder" (like Control Panel) and does not allow new items, you'll be prompted to create the shortcut on the Desktop. Once the shortcut has been created, it can be moved anywhere you like.
- Open any web page in Internet Explorer, Netscape, or Mozilla and drag the little icon in the Address Bar (immediately to the left of the http://) onto the Desktop or other destination, as shown in Figure 1-ryv.

Figure 1-ryv. Quickly create an Internet Shortcut by dragging the icon from the Address Bar to your Desktop or Favorites menu

Shortcuts are commonly placed on the Desktop and Start menu for quick access to programs and documents, but can really be placed anywhere. One of the purposes of having a central My Documents folder is to enforce the notion that documents and personal files should be arranged by project, not by application. This means that Internet Shortcuts and Windows Shortcuts might be placed in the same folder as WordPerfect and Excel documents, making it easy to group all the resources for a particular project together and decreasing the time spent repeatedly trying to locate files and data.

You can also create a shortcut to a local or network printer. Dragging a file onto the shortcut sends that file to the printer without requiring you to open the associated program, which is handy if you do a lot of printing. Putting printer shortcuts in your Send To menu lets you conveniently send files to printers other than your default printer.

Shortcut properties

You'll notice that the names of shortcuts, by default, begin with the phrase "Shortcut to...," and their icons have a small curved arrow superimposed on the lower left. This arrow helps distinguish shortcuts from the files to which they're linked, but it is not set in stone. To change the default visual characteristics of shortcuts, use TweakUI (see Appendix D). There's also a feature in Windows that is supposed to automatically stop adding "Shortcut to" to the your shortcut names if it sees you removing it manually several times in a row, but I've never been able to get this feature to work reliably. TweakUI is much more direct and much less hassle.

To get more information about a shortcut, go to its Properties sheet (right-click it and select Properties). Figure 1-rya shows an example of the second page of a shortcut's properties.
Figure 21. View the Properties of a Windows Shortcut to view or change its target, choose a new icon, or assign a hotkey to it

Target
This field appears in the Properties sheet of Windows Shortcuts (see the URL below for its counterpart in Internet Shortcuts). If the shortcut is to an executable with a command-line equivalent (including, but not limited to, command prompt programs), or even to a folder, the full command line required to activate the target is specified here. If it's a shortcut to Notepad, you'll just see Notepad.exe here. If it's a shortcut to Adobe Photoshop, it will look like c:\Program Files\Adobe\Photoshop\Photoshop.exe. Note that the full path is required for Photoshop, but not for Notepad because Notepad is already in a folder in the system path (described in Chapter 3).

This field is also convenient for adding command-line parameters that are typically used to pass options to the target program, so you don't have to do it manually every time it's started. For example, instead of creating an ordinary shortcut to Explorer.exe, create a shortcut to Explorer.exe /n,e,/select,c:\ to launch Explorer rooted at My Computer with drive C:\ selected. See Windows Explorer in Chapter 4 for details on this syntax.

Start in
If the shortcut is to a program, this option specifies the working folder in which the program will first look for files to open or save.

Shortcut key
You can map a keyboard sequence to open or execute the shortcut (sometimes called a keyboard accelerator), allowing you to activate the shortcut without having to hunt for the shortcut icon. For instance, you might want to map the keys Ctrl+Alt+E to a shortcut to Explorer. Press any key on the keyboard here and you will see Ctrl+Alt+key appear as the shortcut key sequence. Type that sequence to launch the shortcut without clicking on it. You should check Appendix C to make sure you aren't creating conflicts with any existing keyboard accelerator.

Bug alert: If you delete a shortcut with a keyboard accelerator configured, Windows may not release the accelerator, which means it might warn you if you...
then try to use that accelerator in another shortcut. To avoid this problem, clear a shortcut's keyboard accelerator before deleting the shortcut.

Run
A drop-down list allows you to specify whether the target application should run in its normal window, be maximized, or be minimized. The Minimized option can be useful for applications you’d like to have started automatically when Windows starts (see Notes, below). The Maximized option can be useful for applications you’d like to run in full-screen mode, but don’t automatically remember their window state from session to session.

Find Target
Click this button to open the folder containing the original file to which this shortcut is a link. The original file will be selected in the folder window.

Change Icon
By default, the icon used for the shortcut is the same as its target; in the case of Internet Shortcuts, the icon is simply an Internet Explorer logo. See Icons, earlier in this chapter, for more information on customizing icons.

URL
The URL field is the Internet Shortcut counterpart to the Target field, described above. It simply contains the full address (URL) of the page to which it's linked.

Make this page available offline
This option, available only with Internet Shortcuts, instructs Windows to download web pages to your hard disk so they can be viewed when you’re not online. I find this feature most useful for saving web sites I’m concerned won’t be available the next time I check. See Internet Explorer in Chapter 4 for more information.

Compatibility tab
The Compatibility tab appears only in Windows Shortcuts and is not available for Windows components or applications Windows knows to be fully compatible with Windows XP. Generally, you’ll never need to mess with these settings, unless you’re using an older Windows or DOS program that behaves strangely in Windows XP. You'll probably need to experiment with these settings, or possibly contact the manufacturer of the application for suggestions, to get the program to work most reliably.

Options, Font, Layout, and Colors
Shortcuts to Command Prompt applications have four additional tabs — Options, Font, Layout, and Colors — all used to control the options of the Command Prompt environment in which the program will run. This applies to older DOS programs as well as the newer Windows XP command prompt programs, such as Telnet (see Chapter 4). The settings in these extra tabs are described in Chapter 4 and are also available from the control menu of the command prompt window.

Notes

- Since shortcuts are merely links to applications and not the applications themselves, shortcuts can be deleted without fear of any permanent damage. If you wish to actually delete an application, use Add or Remove Programs, and the associated shortcuts will probably be removed as part of the uninstall process.

- To have one or more shortcuts launched automatically when Windows starts, place them in your Start ➔ Programs ➔ Startup menu. See Start Menu, later in this chapter for details.
Shut Down

Shut down the system, restart the computer, or put it in power-saving mode.

To Open

Start → Turn off Computer (or Start → Shut Down)
Ctrl-Alt-Del → Shut Down

A Windows XP machine should never be simply turned off because the system caches data in memory and needs time to write it out to disk before it is turned off. Always use Shut Down before you turn off the power.

Depending on your settings, you may see "Turn off Computer" or "Shut Down" at the bottom of your Start menu. Both do the same thing, but the interface is slightly different. "Shut Down" displays the Shut Down dialog found in earlier versions of Windows, allowing you to Log off, Shut down, Restart, or Stand by. "Turn off Computer" displays the same choices, except as new Windows XP-style buttons instead of a drop-down listbox. To choose between these two Shut Down dialog styles, go to Control Panel → User Accounts → Change the way users log on or off. Turn off the "Use the Welcome screen" option to use the classic Shut Down dialog, or turn it on to use the new XP-style dialog. Keep in mind that this option also affects the logon dialog; when you use the Welcome screen, an icon is shown for each user. When you use the classic logon dialog, you'll need to type the username to log on.

The classic logon dialog may not be as friendly as the Welcome screen, but it offers better security because any user must know both the username and password to log on. Furthermore, the classic logon dialog is the only way to log into the Administrator account, which is not shown at all in the Welcome screen.

Notes

- If Windows displays the "It is now safe to turn off your computer" message instead of simply cutting power automatically, your computer is not properly set up for APM (Advanced Power Management). There are two requirements for auto-power off: your computer must have an ATX-compliant power supply and APM support must be enabled in your system BIOS. Check with your system or motherboard documentation for details.
- Windows XP also has a new option that, at least in theory, will go through the proper shutdown procedure when you press the power button on your computer. Go to Control Panel → Power Options → Advanced tab, and change the "When I press the power button on my computer" option to "Shut down." Whether this works or not depends on how APM-compliant your motherboard is.
Start Menu

The central location for your application shortcuts and many Windows features.

To Open

Desktop → Start
Press the Windows logo key, if you've got one
Ctrl-Esc

The Start menu was one of Microsoft's answers to the growing size and complexity of the Windows operating system when it was introduced in Windows 95. Since then, other features have been introduced to compensate for the Start menu's inadequacies, such as the QuickLaunch toolbar and the new Windows XP-style Start menu. (See the discussion of "Style" at the beginning of this chapter).

Here is a quick rundown of the items you'll find in the Start menu. Note that some of these items may be hidden as a result of settings described in Chapter 6. (Also see Figure 5-22.)

Figure 5-22. Start menu items can be rearranged by dragging and dropping

Programs (or All Programs)
While the Desktop is commonly used to hold icons for the most frequently used programs, the Programs menu (or All Programs menu, with the new Windows XP style Start menu) is designed to hold icons for every program installed on your computer. See Shortcuts, earlier in this chapter, for details.

Programs (or All Programs) → Startup
To have a program run automatically when Windows starts, place a shortcut to the program in this special folder. If you have more than one user set up on your computer, you'll want to control whether the program starts up automatically for just you or for all users, so instead of dropping it right in your Start menu, open Explorer and navigate to either Documents and Settings\{username\}\Start Menu\Programs\Startup or Documents and Settings\All Users\Start Menu\Programs\Startup.
Documents

The Documents menu is a list of automatically generated links to the last dozen or so documents that were opened. Click the links to open the documents in their default applications.

The shortcuts in this menu are stored in the `Documents and Settings\{username}\Recent` folder. To clear this menu, delete the shortcuts in the Recent folder, or go to Control Panel → Taskbar and Start Menu → Start Menu tab → Customize, and click Clear (or Clear List, if you're using the Windows XP style Start menu).

For security reasons, you may wish to disable this menu; see Appendix D for information on TweakUI, which has a feature to clear this list every time Windows is shut down, or even to hide the Documents menu entirely.

Favorites

This is a mirror of the current user's Favorites folder (`Documents and Settings\{username\}\Favorites`) and the All Users' Favorites folder (`Documents and Settings\All Users\Favorites`). Although this is the same menu you'll see in Windows Explorer and Internet Explorer, the shortcuts in this menu will launch whatever browser is currently registered as the default.

Internet, E-mail (Windows XP style Start menu only)

These two items are user-customizable links to your favorite web browser and email program, respectively. By default, they're set to Internet Explorer and Outlook Express, but can be replaced with any programs properly registered as web browsers and email clients. See Chapter 6 for details on choosing your own programs here.

Shut Down

See Shut Down earlier in this chapter.

Log Off

See Log Off earlier in this chapter.

Run

See Run earlier in this chapter.

Search

See Windows Explorer in Chapter 6.

Settings (classic Start menu only) or Control Panel (Windows XP style Start menu only)

See Control Panel in Chapter 6.

Notes

- If you want to place a new shortcut in your Start menu, remove an existing shortcut from your Start menu, or rearrange your Start menu shortcuts, you can drag-drop shortcuts in your Start menu almost as easily as you can in Explorer or on your Desktop. When you start dragging, an insertion line will appear where you can drop the shortcut; if the mouse pointer changes to a circle with a line through it, you're over a portion of the Start menu that can't be customized. To drag new shortcuts into the Start menu, start dragging and hover the mouse cursor over the Start button for a second or two; it will open automatically, allowing you to complete your drag. Finally, you can right-click any shortcut in your Start menu, allowing you to delete it, change its properties, or even rename it in place. I frequently use this feature to make certain application shortcuts more accessible by placing items on the Desktop that otherwise would be buried many menus deep.

- When you first install Windows XP, the shortcuts in your Start menu will be sorted alphabetically. Any subsequent items added to your Start menu will appear at the end of the menu, and will not be sorted automatically. To sort
any single menu, right-click on one of its entries and select Sort by Name. To sort all folders in your Start menu, go to Control Panel → Taskbar and Start Menu → Start Menu tab → Classic Start menu → Customize, and click Sort. (Note that this feature is only available in the Customize dialog for the Classic Start menu, so if you’re using the new Windows XP-style menu, you’ll need to temporarily switch to the classic menu to sort all the folders at once. (See Chapter A for another solution.)

- You can also add programs and folders to the top level of the Start menu by dragging and dropping their icons onto the Start button, or by waiting until the Start menu is open and then dropping items onto the space above the built-in entries (see Figure r-τ.).

**Figure r-τ.. Drag and drop items in your Start menu to re-order or reorganize them in place**

- This will place a shortcut directly into the \Documents and Settings\{username}\Start Menu folder, as opposed to \Documents and Settings\{username}\Programs. You should do this only for programs that you use fairly often. Good programs to add there might be the Explorer and the Command Prompt (DOS). Adding folders at this level is a great way of organizing all of your programs into categories. Once you have created new folders, you can move the program shortcuts from the Start Menu → Programs folders into your own folders and leave all the other shortcuts (uninstalls, readmes, etc.) behind.

- By default, dragging any files or other objects directly into the Start menu will create shortcuts to those items, which is inconsistent with the way Windows handles drag-drop elsewhere (see Chapter t). If you’re dragging an existing shortcut or a folder full of shortcuts into the Start menu, hold the Shift key to force Windows to move (or the Ctrl key to copy) the items, rather than create shortcuts to them.

- Start → Programs can get fairly cluttered, since most programs add shortcuts to this menu as part of their installation process. Don’t be afraid to rearrange and consolidate your shortcuts here; most of them are probably never used anyway.
If you want programs in the Startup folder to run in a particular order, instead of putting in shortcuts to each program, create a single batch file (see Chapter 7) or a WSH Script (see Chapter 8) that launches the applications in the desired order.

To bypass the programs in the Startup folder, hold down the Shift key while the system is booting. Keep holding it down until the Desktop has completely loaded.

In addition to the Startup folder, there are other ways programs can be configured to run at Startup. Services (see Chapter 4) lists many background programs that are run, even if no user has logged on; the Startup folder, since it's a per-user setting, launches programs only after the user has logged in. Other locations include the Registry key, HKEY_LOCAL_MACHINE\Microsoft\Windows\CurrentVersion\Run.

If you're migrating from Windows 98 or Windows NT 4.0, you may have become accustomed to the way menus are split into multiple columns when there are too many shortcuts. In Windows 95/Me, Windows 2000, and now Windows XP, the default is scrolling menus, which tends to be awkward. This setting can be changed by going to the Start menu, and then to Control Panel ➔ Taskbar and Start Menu ➔ Start Menu tab ➔ Customize and turning off the Scroll Programs option. (It's in the Advanced tab if you're using the Windows XP-style Start menu.)

Shortcuts that appear in Start ➔ Programs and Start ➔ Favorites are saved for the currently logged-on user, as noted several times throughout this section. If you have more than one user configured on your machine and you want any of these items to appear for all of those users (as everyone may wish to use the installed word processor, for example), open Explorer and navigate to the Documents and Settings folder. There's a folder for each configured user, as well as an All Users folder, and a Default User folder (a template for subsequently added users). You may wish to delegate shortcuts to these various folders, depending on their use. Note that if a shortcut is listed in a user's personal Start Menu folder as well as the All Users Start Menu folder, it will appear twice in that user's Start menu. The same goes for the Desktop and Send To folders (both discussed earlier in this chapter).

**Status Bar**

The Status Bar is a panel at the bottom of each window (part of the same frame that contains the titlebar) that gives information about the contents of the window. The standard status bar shown in Figure 5-58 has several sections, each of which is used to show a relevant statistic or setting.

Figure 5-58. The Status Bar often shows useful information; in Windows Explorer, the free disk space or the combined size of the selected objects is shown.
Some elements of the status bar respond to clicks and double-clicks, although there's no standard for any user interaction. If an application has a status bar, it can usually be hidden or made visible as an entry in the View menu. Some programs even let you configure the status bar with the information that is important to you. (Try right-clicking on the status bar for configuration options.) The Status Bar in the Windows Explorer, for example, shows the number and combined size of the selected files, as well as the amount of free space on the drive. And when you're navigating through menus, you'll see a tip for the currently selected menu item in the Status Bar. One especially useful tip is the one that appears for Edit → Undo, as it shows exactly which file operation(s) will be undone.

**System Tray**

See Notification Area.

**Tabbed Dialogs**

Tabs are used in dialog boxes when there are too many settings to fit on the same page. (See Figure r-rr.)

**Figure r-rr. Settings in dialog boxes like this one are often divided into separate Tabs; the OK and Apply buttons apply to all tabs simultaneously**

Activate a tab by clicking on it. The active tab (or page) is visibly more prominent than the rest, and the displayed settings typically fall within the category depicted by the caption of the selected tab.

The rule, when changing settings in a dialog box, is that all settings behave as though they were all on the same page. That is, if you change a setting under one tab, switch to another tab and change a setting there, and then click OK, both settings will be implemented. Unfortunately, some application developers don't follow these rules. Sometimes the tab selection itself is a setting; in the example
above, this means that only one of these settings would be implemented and the other would be lost. The other problem occurs when settings are saved when you flip between tabs. Press Ctrl-Tab to move to the next tabbed page or Shift-Ctrl-Tab to move in reverse.

**Taskbar**

The Taskbar, shown in Figure r-rr, contains the Start Menu button, buttons representing all open application windows, the notification area (also known as the Tray, discussed earlier in this chapter), and any optional toolbars (see Toolbars, later).

Figure r-rr. In addition to your Start button and the notification area, a Taskbar button appears for each open window; click a button to activate the window

The Start button isn't terribly complicated: just click on it to open the Start menu (discussed earlier in this chapter). There are two choices for the look of the Start button, each part of the currently selected style (see "Style," at the beginning of this chapter). Unfortunately, there's no way to customize the look of the Start button without a third-party add-on.

You can keep tabs on all running applications by looking in the portion of the Taskbar between the Start button and the notification area (Tray). Nearly every currently open window is represented by a button on your Taskbar. Click the button of a corresponding window to bring that window to the top (if it happens to be obscured) and shift focus to that window. If the window is currently active, clicking its Taskbar button will minimize (hide) it. The currently active window appears pushed in, while any others (if any) appear as normal buttons. If a window has been minimized (see Windows, later in this chapter), it will also appear as a normal button, indistinguishable from those for visible windows. Right-click on a Taskbar button to access the window's control menu (see Windows), allowing you, among other things, to close a window without first having to restore it.

If an application is busy, clicking a Taskbar icon sometimes won't activate the window. If this happens, try right-clicking on the Taskbar icon and selecting Restore. If an application has crashed and you're unable to shut it down gracefully, you can often close it by right-clicking its Taskbar button and selecting Close. Although this doesn't always work, it is much quicker and more convenient than using the Windows Task Manager (discussed in Chapter e).

By default, the Taskbar appears at the bottom of the screen, but it can be dragged to the top or either side by grabbing any empty portion of the Taskbar with the mouse (unless it's locked — see below). You can also resize the Taskbar by grabbing its edge. Right-click on an empty area of the Taskbar to pop up its context menu.

**Toolbars**
Show or hide any of the Taskbar toolbars (discussed later in this chapter) or the Address Bar (discussed earlier in this chapter).

**Cascade Windows**
Arrange all windows (except those that are minimized) so that they appear "cascaded:" the window on the bottom of the pile will be moved to the upper-left of your Desktop, the next will appear just slightly lower and to the right, and so on.

**Tile Windows Horizontally, Vertically**
Arrange all windows (except those that are minimized) so that they don't overlap and that, together, they fill the screen. Horizontal tiling results in wider windows and vertical tiling results in taller, narrower windows.

**Show the Desktop**
Bring the Desktop to the top of the pile, covering all open windows. This has the same effect as minimizing all open windows, except that you can then use Show Open Windows to quickly drop the Desktop back down to the bottom and restore all windows to their previous states. Note that the "Minimize all Windows" option found here in previous versions of Windows has been removed in Windows XP, but you can still quickly minimize all open windows by holding the Windows logo key and pressing D.

**Task Manager**
Open the Windows Task Manager (see Chapter 4).

**Lock the Taskbar**
If you lock the Taskbar, you won't be able to move or resize it, nor will you be able to move or resize any Taskbar toolbars that happen to be docked. If you find yourself accidentally messing up the Taskbar, locking it will eliminate the problem. Most toolbars in Windows can be locked in this way. Note also that locking the toolbar will hide the resize handles, giving you a little more Taskbar real estate for your task buttons.

**Properties**
This is the same as Control Panel → Taskbar and Start Menu, which is the same as Start → Settings → Taskbar and Start Menu and as right-clicking the Start button and selecting Properties. See Taskbar and Start Menu Properties properties in Chapter 4 for details on these settings, as well as "Style," at the beginning of this chapter.

**Notes**
- To activate the Taskbar buttons with the keyboard, first press Ctrl-Esc to show the Start menu, then Esc to close it, and then Tab to send focus to the task buttons. Use the cursor keys to navigate, and press the spacebar to activate a window or Shift-F1 to display it's control menu. It's usually preferable to simply use Alt-Tab (or Shift-Alt-Tab to go in reverse) to cycle through the open windows rather than this elaborate procedure. While we're at it, you can also press Alt-Esc to send a window to the bottom of the pile (an alternative to minimizing it).
- From time to time, Explorer (the application responsible for the Taskbar, Desktop, and Start menu) will crash, and the Taskbar and all your Desktop icons will disappear. Now there's a built-in safeguard that relaunches Explorer automatically if such a crash is detected, but it doesn't always work as it's designed. For example, if you have a separate Windows Explorer window open and the "Launch folder windows in a separate process" option (Control Panel → Folder Options → View tab) is enabled, and the Taskbar disappears, Windows will mistakenly open another Windows Explorer window instead of reinstating your Taskbar and Desktop. If this happens, you'll need to close all visible Windows Explorer windows. Then, press Ctrl-Art-Del, and
click Task Manager. In the Windows Task Manager application that appears, go to File → New Task (Run), type explorer, and click OK.

- Some applications have icons in the Notification Area (or Tray, discussed earlier in this chapter) instead of Taskbar buttons. A few applications have both and some have neither. If an application window has no Taskbar button, it will not be accessible when you press Alt-Tab (used to switch between running applications).

- By default, the Taskbar "groups" similar task buttons together. But what does this mean? Most applications are capable of opening several documents simultaneously without having several separate instances of the application, a design known as multiple document interface (MDI). This not only saves memory and screen real estate, but it makes comparing documents side by side and sharing information between multiple documents much easier. In Office 7..., and now Office XP, Microsoft has unfortunately tried to abolish MDI in favor of separate single document interface (SDI) windows. The consequence was increased clutter on the Taskbar, so Microsoft came up with task button grouping, which consolidates all of the open documents of an SDI application into a single button. To enable or disable this option, go to Control Panel → Taskbar and Start Menu → Taskbar tab.

[8] Their reason for this change is reportedly due to confusion among new users regarding the use of the MDI interface. Unfortunately, in my opinion, their cure was much worse than the disease. Most third-party application developers have not instituted this design. Furthermore, Office 7... and Office XP both have the option of using the MDI interface. See http://www.annoyances.org/exec/show/article-8-101 for details.

- See Taskbar and Start Menu Properties in Chapter 6 for more settings that affect the Taskbar. Among the more useful are the "Auto-hide the Taskbar" and "Keep the Taskbar on top of other windows options.

---

**Text Boxes**

See Input Fields.

---

**Title Bars**

See Windows.

---

**Toolbars**
Toolbars are used to provide quick access to frequently used functions in a program. Windows comes with several toolbars, including those found in Windows Explorer, Internet Explorer, Wordpad (and other applications), and the Quick Launch toolbars on the Taskbar (see Figure 5-54).

Figure 5-54. Wordpad’s toolbar provides access to eleven of the most commonly used functions, such as Open, Save, Print, and Find.

Usually, the buttons in a toolbar don’t provide any functionality that isn’t otherwise accessible through the menus or via a keystroke or two. Toolbars are almost exclusively mouse oriented, so a toolbar that works with the keyboard is a rare occurrence.

The toolbars in most modern applications are configurable; that is, you can rearrange the tools to your liking, add new items, and remove the ones you don’t use. It’s definitely worth taking a few minutes to configure the toolbar with the features that you use the most, especially since the default toolbars in most applications are set up to showcase the most marketable features of the product rather than to make the program easier to use.

The configuration and features of a particular toolbar is typically the responsibility of the application that owns it, although most modern applications use Microsoft’s toolbar controls, which afford a good degree of consistency.

You can often right-click on an empty portion of a toolbar to change its properties or to add or remove buttons. Toolbars can usually be "docked" to the top, bottom, or sides of an application, or they can float. Play around with toolbars to get a feel for how they respond to being dragged and resized; there’s no substitute for 50 seconds of fooling around. Some newer toolbars can be "locked" so that they can’t be accidentally moved, resized, or closed. I can’t tell you how many phone calls I’ve gotten from frantic friends and relatives telling me that they’ve lost their toolbars! Locking is a welcome feature, indeed.

Many larger applications, such as WordPerfect Office and Microsoft Office, support multiple toolbars, including custom toolbars you can create as needed. These toolbars can typically be rearranged by dragging them around, although you may not get any visual feedback until you let go. To hide a toolbar, try right-clicking on it, or just drag it (if it’s docked) so that it floats and then click the close button in the toolbar’s titlebar.

A quick way to customize the buttons on toolbars is to hold the Alt key while dragging or right-clicking (to move a button or changes its properties, respectively). Pressing the Alt key puts the toolbar into "edit" mode temporarily; in fact, you can even drag buttons from one toolbar to another with this method. Note that Taskbar toolbars (see below) are always in edit mode, so the Alt key is not needed.

**Toolbars on the Taskbar**
In addition to the Desktop and Start menu, shortcuts to frequently used programs can also be placed in configurable toolbars that are either docked on the Taskbar (discussed earlier in this chapter) or are allowed to float. By default, there are four Taskbar toolbars. Right-click an empty area of the Taskbar and select Toolbars to show or hide any of them. The four toolbars are as follows:

**Address**

The Address Bar on the Taskbar is the same as the one in Windows Explorer and Internet Explorer and works very much like Start Run. See Address Bar, earlier in this chapter, for details.

**Links**

The Links toolbar is designed to hold your favorite Favorites, or, more specifically, links (Internet Shortcuts) to your favorite web sites. This is the same toolbar as the Links toolbar in Internet Explorer (see Internet Explorer in Chapter 4). Shortcuts displayed on this toolbar are stored in `{username}\Favorites\Links`.

**Quick Launch**

The Quick Launch toolbar works very much like the Programs menu in the Start menu: it shows any number of shortcuts to your most frequently used programs.

The Quick Launch toolbar, as well as any other custom toolbars you create (except Desktop, discussed below) are mirrors of folders on your hard disk. For example, the contents of the Quick Launch toolbar are stored in `{username}\Application Data\Microsoft\Internet Explorer\Quick Launch`. You can get there quickly by right-clicking on an empty portion of the Quick Launch toolbar and selecting Open Folder (see below for other items on this menu).

One of the niftiest icons on the Quick Launch Toolbar is the Show Desktop icon: 🌏. Don't delete this one — it's not a shortcut, but rather a Windows Explorer Command (.scf) file. It has the same effect as right-clicking on the Taskbar and selecting Show Desktop (see Taskbar, earlier in this chapter, for details); it pops the Desktop on top of all other windows, allowing access to Desktop icons without having to minimize anything. I find this icon far superior to displaying the Desktop Toolbar.

You can create your own custom toolbars by right-clicking on the Taskbar and selecting Toolbars ➔ New Toolbar. Simply specify an existing folder whose contents you want made into a toolbar (such as Control Panel, Dial-Up Networking, or one of the folders in your Start menu), or click Make New Folder if you want to start with a blank toolbar.

One of the limitations of custom toolbars is that if they're ever closed, Windows won't display them on the list of available toolbars, as with the preconfigured toolbars discussed here. If you ever close a custom toolbar, you'll have to start over and go through the New Toolbar process to get it back (though all your shortcuts will still be there). For a more sophisticated toolbar launcher, go to [http://www.creativelement.com/software/rout8.html](http://www.creativelement.com/software/rout8.html)

**Desktop**

The Desktop Toolbar was intended as a handy way to get at the contents of your Desktop when it's covered with open windows. It's really just another custom toolbar (like Quick Launch, discussed above), except that it mirrors the contents of your Desktop folder. Of course, if you have a lot of things on
your Desktop, this toolbar can itself get pretty unwieldy, so I don't find it too useful. Your mileage may vary. You'll probably prefer to just use Show Desktop (either the button in the Quick Launch toolbar or the entry on the Taskbar's context menu) for quick access to items on your Desktop.

Once a toolbar is enabled, you can right-click on an empty portion to display a context menu with several options. (Right-clicking one of the toolbar buttons is the same as right-clicking the corresponding shortcut in Explorer.) In addition to the standard entries on the Taskbar context menu (see Taskbar earlier in this chapter), you'll find the following:

### View
- **Large Icons, View → Small Icons**
  Allows you to display either large (52 x 52) or small (8 x 8) icons. Neither choice is perfect; small icons can be very difficult to see and distinguish and large icons take up too much space and offer little advantage over Desktop icons. Choose whichever icons best suit your needs.

### Open Folder
Opens the folder to which the toolbar is linked. When customizing a toolbar, it's often easier to deal with the actual shortcuts in a real folder than it is to mess with the buttons on the Toolbar.

### Show Text
Displays a text label next to each icon. This is useful if you have a toolbar containing icons of the same type, and if you've got room on your Taskbar to spare. It's the default setting for the Links toolbar, but not for the Quick Launch toolbar.

### Show Title
Shows the name of the toolbar when it is docked on the Taskbar; this option has no effect when the toolbar is floating. It's really a waste of space for the standard toolbars, but perhaps it is useful if you set up a lot of custom toolbars. The title can also be used as a handle.

### Close Toolbar
Closes the Toolbar. You can also drag the toolbar off the Taskbar and then click the close button to get rid of it. As stated above, closed custom toolbars do not remain on the Toolbars list.

### Notes
- Taskbar toolbars can be docked on the Taskbar simply by dragging them there. You can also dock these toolbars along the sides or top of your Desktop, regardless of the position of the Taskbar.
- If a Taskbar toolbar doesn't seem to allow dragging or resizing, right-click on an empty portion of the Taskbar and turn off the "Lock the Taskbar" option.

---

**Tray**

See Notification Area.

---

**Trees**

---

See Notification Area.
Many different parts of the Windows XP interface are represented by hierarchical trees, like the one in Figure 5-51. This collapsible tree interface can be found in Explorer (representing drives and folders), the Registry Editor (representing Registry Keys), and Device Manager (representing installed devices).

Figure 5-51. The Folder Tree is an efficient and useful way to visualize and navigate the hierarchy of your filesystem

In most cases, displaying all entries in all branches of a tree would take too much time, and would certainly be unwieldy. Instead, branches are “collapsed” and only the top levels are shown; you can expand any branch by clicking the plus sign (+), and then collapse any branch by clicking the corresponding minus sign (-). You can also double-click any branch to expand it, and again to collapse it. If no plus sign (+) appears, then the entry has no "children" and cannot be expanded further. Navigating trees with the keyboard is often more convenient than using the mouse. As with listboxes (discussed earlier in this chapter), you can jump to any branch by typing the first letter (or first few letters) of its name. This works regardless of the depth of the entry, but only on entries that are currently visible. Use the right arrow key to expand the currently selected branch, or the left arrow key to collapse it; if the branch is already collapsed, the left arrow key jumps to the parent. The Backspace key also jumps to the parent, but it never collapses branches. Finally, the asterisk key (*) expands all branches from the current location.

**Turn Off Computer**

See Shut Down.

**Windows**

The window is the basis for the graphical user interface. Xerox developed the first graphical windowing user interface. This style of interface was first popularized by Apple and later by Microsoft, but Xerox developed the first graphical windowing
operating system more than a decade before the first Mac or Windows computer ever saw daylight.

Most windows are rectangular, but irregular shapes are allowed too. (See Windows Media Player in Chapter 6 for an example.) Standard windows have a titlebar across the top, which, in addition to identifying the window and the currently open document (if applicable), is used as a handle with which to move the window around the screen (see Figure 5-1). The titlebar also shows which window is currently active; depending on your color settings (set through Control Panel → Display → Appearance tab → Advanced), the titlebar of active window will typically appear darker than the others. (Small floating toolbars in some applications ignore this rule, always appearing either inactive or active.)

Figure 5-1. A garden-variety window, complete with title, menu, and client area

The elements commonly found on window titlebars are described below (any or all might be missing, depending on the type of window).

**Control Menu**

Click the icon on the upper-left corner of a window or press Alt-Spacebar to display the control menu, which duplicates the Minimize, Maximize, and Close buttons and provides Move and Resize options (see below). Double-click the control menu icon to close the window.

Dialog boxes typically don't have control menu icons, but the menu is still there and can be accessed with Alt-Spacebar. The standard entries in the control menu are present to make it possible to move, resize, minimize, maximize, and close the window with the keyboard. For example, press Alt-Space and then S to resize a window with the cursor keys.

Some windows have additional functions in this menu, especially if those applications don't have full-blown menus. Good examples are the control menus of Windows Explorer and single-folder windows, which are the same as the context menus of the icons that open them. Navigate to `C:\My\Stuff` and click the control menu, and you'll get the same options as though you right-clicked on the Stuff icon in the `C:\My` folder. This, for example, lets you delete a folder without having to first open its parent. You can also drag the control menu icon to move or copy the folder as though you were dragging the folder's icon.

If you see two control menus, one on top of the other, you're using an application (such as a word processor) that can have one or more document windows open simultaneously; see the description of Multiple Document Interface below.

**Minimize**

Click Minimize to hide a window so that only its task button on the Taskbar is visible. See Taskbar, earlier in this chapter, for details.

**Maximize/Restore**

Maximize a window to have it fill the screen. Click the maximize button again to restore it to its free-floating position and size. You can also double-click the titlebar to maximize and restore a window.

**Close**
Close a window. This is usually the same as selecting File → Close or File → Exit, or at least it's supposed to be. Double-clicking the control menu icon also closes windows, as does Alt-F4.

Most, but not all, windows can be resized by grabbing any edge with the mouse and dragging. Some windows have an additional resize handle on the lower-right corner, which can be a little easier to get a purchase on than the edges.

Multiple Document Interface (MDI) applications have windows within windows, usually allowing multiple documents to be open simultaneously. The MDI parent window, the container of the document windows, usually has a Window menu, which allows you to switch to any open documents and provides some features to arrange the documents visually (Cascade, Tile, etc.). Some applications (Corel's WordPerfect and Qualcomm's Eudora, to name a few) have incorporated a clever Taskbar for their MDI applications, making it easy to manage several documents without having to use the somewhat awkward Window menu. See Taskbar, earlier in this chapter, for more information on MDI applications and how some newer Microsoft applications are abandoning this design.

Here are some keyboard shortcuts for working with windows:

- Alt-Tab switches between open application windows. Hold Shift to go in reverse.
- Ctrl-Tab (or Ctrl-F1) switches between open documents in an MDI application window. Again, hold Shift to go in reverse.
- Alt-Esc sends the current window to the bottom of the pile and activates the next one in line.
- Alt-F4 closes the current application window. Ctrl-F4 closes the current document in an MDI application window.
- If a window has multiple panes (such as Windows Explorer), use F1 or Ctrl-Tab to switch between them.

Notes

- Some more stylish (read "weird") windows without Taskbars can usually be moved by clicking on any empty area of the window.
- Technically, the Desktop is a window, although it's always at the bottom of the pile (called the Z-order). Conversely, some windows (and even the Taskbar) can be set to "always on top," which means that they're always on top of the pile and can't be covered by other windows (except by other "always on top" windows).
- Also see Menus and Taskbar.
Chapter 4. Windows XP Applications and Tools

This chapter provides an alphabetical reference to all of the useful components that make up Windows XP: an encyclopedia of everything you can do with Windows out of the box. Some of the more prominent applications and utilities that come with Windows XP are available through shortcuts on the Start menu, but many useful tools aren't as conspicuous — available only to those who know where to look. What you'll undoubtedly find interesting is the large number of applications that aren't listed in the Start menu or documented in the manual or in most books. At the beginning of each entry, you'll find all the different methods of launching (or opening) these components, including their locations in the Start menu (if applicable), their executable filenames for starting them from the command prompt, or any other means of accessing the component. See Chapter 1 for an overview of all the ways to launch programs in Windows XP.

4.1 Using the Command Prompt

You may need to use the command prompt to run some of the programs listed in this chapter (see Figure 4-1). In addition to the command prompt application, cmd.exe, two other elements in Windows XP can also be used as command prompts. The Address Bar, typically found at the top of the Internet Explorer window, is where you type a web site address to instruct IE to open the corresponding web page. The Address Bar can also be used as a rudimentary command prompt, where you can type application filenames, document filenames, and even folder names to open them. The Address Bar can appear at the top of any Internet Explorer or Windows Explorer window, and can even be placed on the Taskbar. The other alternative to the command prompt is the Run entry in the Start menu, which behaves nearly identically to the Address Bar. To start an instance of the Command window, select Start → .cmd or type cmd in the Address Bar of any window.

Figure 4-1. Some tools can be used only at the Command Prompt, such as the Windows IP Configuration utility

Note that some of the components listed in this chapter are purely command-line based. That is, rather than having interactive windows of their own, they rely on the command prompt application to receive commands and display information. Many of these types of programs (often called console applications) simply close
when they've completed their task. This means that if you launch one of these programs from the Start menu or Address Bar, it will simply appear and disappear before you know what happened. To use one of these components, you must first open a command prompt window (cmd.exe) and type the command there. Chapter 1 provides more detail on how to use the command prompt and explains the more subtle differences between the command prompt application and the Address Bar. Chapter 7 documents the Address Bar further.

### Alphabetical Reference to Windows Components

The following reference lists all the useful, discrete components that come with Windows XP, sorted alphabetically by their common names (e.g., Minesweeper would be found under "M," not "W" for winmine.exe).

Note that some components are not installed by default. The set of components included with a basic Windows XP installation depends on the method by which Windows XP was installed, whether it was installed fresh, or over an older version of Windows. Any of the following components that appear to be missing can be added easily by using Add or Remove Programs (discussed later in this chapter) and clicking the Add/Remove Windows Components button. Table 4-1 provides an easy cross reference between the common name and the executable filename of an application or other component. Unlike previous editions of this book, control panel options are included in this chapter. For these items, the corresponding command line varies (and is documented more completely in the Control Panel section in this chapter), but usually consists of the .cpl filename, as specified in Table 4-1.

<table>
<thead>
<tr>
<th>Common application name</th>
<th>Executable filename / command line</th>
<th>Professional edition only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessibility Options</td>
<td>access.cpl</td>
<td></td>
</tr>
<tr>
<td>Accessibility Wizard</td>
<td>accwiz.exe</td>
<td></td>
</tr>
<tr>
<td>Activate Windows</td>
<td>msoobe.exe</td>
<td></td>
</tr>
<tr>
<td>Active Connections Utility</td>
<td>netstat.exe</td>
<td></td>
</tr>
<tr>
<td>Add Hardware Wizard</td>
<td>hdwwiz.cpl</td>
<td></td>
</tr>
<tr>
<td>Add or Remove Programs</td>
<td>appwiz.cpl</td>
<td></td>
</tr>
<tr>
<td>Address Book</td>
<td>wab.exe</td>
<td></td>
</tr>
<tr>
<td>Administrative Tools</td>
<td>n/a</td>
<td>✓</td>
</tr>
<tr>
<td>At</td>
<td>at.exe</td>
<td></td>
</tr>
<tr>
<td>Attrib</td>
<td>attrib.exe</td>
<td></td>
</tr>
<tr>
<td>Backup</td>
<td>ntbackup.exe</td>
<td>✓</td>
</tr>
<tr>
<td>Boot Configuration Manager</td>
<td>bootcfg.exe</td>
<td>✓</td>
</tr>
<tr>
<td>Cabinet (CAB) Maker</td>
<td>makecab.exe, diantz.exe</td>
<td></td>
</tr>
<tr>
<td>Calculator</td>
<td>calc.exe</td>
<td></td>
</tr>
<tr>
<td>Character Map</td>
<td>charmmap.exe</td>
<td></td>
</tr>
<tr>
<td>Chkdsk</td>
<td>chkdsk.exe</td>
<td></td>
</tr>
<tr>
<td>Chkntfs</td>
<td>chkntfs.exe</td>
<td></td>
</tr>
<tr>
<td>Clipbook Viewer</td>
<td>clipbrd.exe</td>
<td></td>
</tr>
<tr>
<td>Command Prompt</td>
<td>cmd.exe</td>
<td></td>
</tr>
<tr>
<td>Component Services</td>
<td>dcomcnfg.exe</td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td>Path or Command</td>
<td></td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>-------------------------</td>
<td></td>
</tr>
<tr>
<td>Computer Management</td>
<td>compmgmt.msc</td>
<td></td>
</tr>
<tr>
<td>Connection Manager Profile Installer</td>
<td>cmstp.exe</td>
<td></td>
</tr>
<tr>
<td>Control Panel</td>
<td>control.exe</td>
<td></td>
</tr>
<tr>
<td>Create Shared Folder</td>
<td>shrpubw.exe</td>
<td></td>
</tr>
<tr>
<td>Date and Time Properties</td>
<td>timedate.cpl</td>
<td></td>
</tr>
<tr>
<td>DDE Share</td>
<td>ddeshare.exe</td>
<td></td>
</tr>
<tr>
<td>Device Manager</td>
<td>devmgmt.msc</td>
<td></td>
</tr>
<tr>
<td>DirectX Management Tool</td>
<td>dxdiag.exe</td>
<td></td>
</tr>
<tr>
<td>Disk Cleanup</td>
<td>cleanmgr.exe</td>
<td></td>
</tr>
<tr>
<td>Disk Defragmenter</td>
<td>defrag.exe</td>
<td></td>
</tr>
<tr>
<td>DiskPart</td>
<td>diskpart.exe</td>
<td></td>
</tr>
<tr>
<td>Display Properties</td>
<td>desk.cpl</td>
<td></td>
</tr>
<tr>
<td>Dr. Watson</td>
<td>drwatson.exe, drwtsnrr.exe</td>
<td></td>
</tr>
<tr>
<td>Driver Verifier Manager</td>
<td>verifier.exe</td>
<td></td>
</tr>
<tr>
<td>DriverQuery</td>
<td>driverquery.exe</td>
<td></td>
</tr>
<tr>
<td>Event Viewer</td>
<td>eventvwr.exe</td>
<td></td>
</tr>
<tr>
<td>FAT to NTFS Conversion Utility</td>
<td>convert.exe</td>
<td></td>
</tr>
<tr>
<td>Fax Console</td>
<td>fxsc1nt.exe</td>
<td></td>
</tr>
<tr>
<td>Fax Cover Page Editor</td>
<td>fxscovr.exe</td>
<td></td>
</tr>
<tr>
<td>File Compare (comp)</td>
<td>comp.exe</td>
<td></td>
</tr>
<tr>
<td>File Compare (fc)</td>
<td>fc.exe</td>
<td></td>
</tr>
<tr>
<td>File Expansion Utility</td>
<td>expand.exe</td>
<td></td>
</tr>
<tr>
<td>File and Settings Transfer Wizard</td>
<td>migwiz.exe</td>
<td></td>
</tr>
<tr>
<td>Finger</td>
<td>finger.exe</td>
<td></td>
</tr>
<tr>
<td>Folder Options</td>
<td>control.exe folders</td>
<td></td>
</tr>
<tr>
<td>Font Viewer</td>
<td>fontview.exe</td>
<td></td>
</tr>
<tr>
<td>Fonts Folder</td>
<td>control.exe fonts</td>
<td></td>
</tr>
<tr>
<td>ForceDOS</td>
<td>forcedos.exe</td>
<td></td>
</tr>
<tr>
<td>Format</td>
<td>format.com</td>
<td></td>
</tr>
<tr>
<td>FreeCell</td>
<td>freecell.exe</td>
<td></td>
</tr>
<tr>
<td>FTP</td>
<td>ftp.exe, tftp.exe</td>
<td></td>
</tr>
<tr>
<td>Game Controllers</td>
<td>joy.cpl</td>
<td></td>
</tr>
<tr>
<td>Group Policy Refresh Utility</td>
<td>gpupdate.exe</td>
<td></td>
</tr>
<tr>
<td>Hearts</td>
<td>mshearts.exe</td>
<td></td>
</tr>
<tr>
<td>Help and Support Center</td>
<td>helpctr.exe</td>
<td></td>
</tr>
<tr>
<td>HyperTerminal</td>
<td>hypertrm.exe</td>
<td></td>
</tr>
<tr>
<td>IExpress</td>
<td>iexplore.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Backgammon</td>
<td>bckgzm.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Checkers</td>
<td>chkrzm.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Explorer</td>
<td>iexplore.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Hearts</td>
<td>hrtzzm.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Options</td>
<td>inetcpl.cpl</td>
<td></td>
</tr>
<tr>
<td>Internet Reversi</td>
<td>rvsezm.exe</td>
<td></td>
</tr>
<tr>
<td>Internet Spades</td>
<td>shvlzm.exe</td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td>Exe or Msc</td>
<td></td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-----------------------------------</td>
<td></td>
</tr>
<tr>
<td>Java Command-Line Loader</td>
<td>jview.exe, wjview.exe</td>
<td></td>
</tr>
<tr>
<td>Keyboard Properties</td>
<td>main.cpl keyboard</td>
<td></td>
</tr>
<tr>
<td>Label</td>
<td>label.exe</td>
<td></td>
</tr>
<tr>
<td>Local Security Policy</td>
<td>secpol.msc</td>
<td></td>
</tr>
<tr>
<td>Logoff</td>
<td>logoff.exe</td>
<td></td>
</tr>
<tr>
<td>Microsoft Chat</td>
<td>winchat.exe</td>
<td></td>
</tr>
<tr>
<td>Microsoft Magnifier</td>
<td>magnify.exe</td>
<td></td>
</tr>
<tr>
<td>Microsoft Management Console</td>
<td>mmc.exe</td>
<td></td>
</tr>
<tr>
<td>Microsoft NetMeeting</td>
<td>conf.exe</td>
<td></td>
</tr>
<tr>
<td>Minesweeper</td>
<td>winmine.exe</td>
<td></td>
</tr>
<tr>
<td>Mouse Properties</td>
<td>main.cpl</td>
<td></td>
</tr>
<tr>
<td>Msg</td>
<td>msg.exe</td>
<td></td>
</tr>
<tr>
<td>MSN Explorer</td>
<td>msn.exe</td>
<td></td>
</tr>
<tr>
<td>MSN Gaming Zone</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Narrator</td>
<td>narrator.exe</td>
<td></td>
</tr>
<tr>
<td>Net</td>
<td>net.exe</td>
<td></td>
</tr>
<tr>
<td>Network Connections</td>
<td>ncpa.cpl</td>
<td></td>
</tr>
<tr>
<td>Network Setup Wizard</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>New Connection Wizard</td>
<td>icwconn.exe</td>
<td></td>
</tr>
<tr>
<td>Notepad</td>
<td>notepad.exe</td>
<td></td>
</tr>
<tr>
<td>NSLookup</td>
<td>nslookup.exe</td>
<td></td>
</tr>
<tr>
<td>NTFS Compression Utility</td>
<td>compact.exe</td>
<td></td>
</tr>
<tr>
<td>NTFS Encryption Utility</td>
<td>cipher.exe</td>
<td></td>
</tr>
<tr>
<td>Object Packager</td>
<td>packager.exe</td>
<td></td>
</tr>
<tr>
<td>ODBC Data Source Administrator</td>
<td>odbcad52.exe</td>
<td></td>
</tr>
<tr>
<td>On-Screen Keyboard</td>
<td>osk.exe</td>
<td></td>
</tr>
<tr>
<td>OpenFiles</td>
<td>openfiles.exe</td>
<td></td>
</tr>
<tr>
<td>Outlook Express</td>
<td>msimn.exe</td>
<td></td>
</tr>
<tr>
<td>Paint</td>
<td>mspaint.exe</td>
<td></td>
</tr>
<tr>
<td>Pentium Bug Checker</td>
<td>pentnt.exe</td>
<td></td>
</tr>
<tr>
<td>Performance Log Manager</td>
<td>logman.exe</td>
<td></td>
</tr>
<tr>
<td>Performance Logs and Alerts</td>
<td>perfmon.msc</td>
<td></td>
</tr>
<tr>
<td>Phone and Modem Options</td>
<td>telephon.cpl</td>
<td></td>
</tr>
<tr>
<td>Phone Dialer</td>
<td>dialer.exe</td>
<td></td>
</tr>
<tr>
<td>Pinball</td>
<td>pinball.exe</td>
<td></td>
</tr>
<tr>
<td>Ping</td>
<td>ping.exe</td>
<td></td>
</tr>
<tr>
<td>Power Options</td>
<td>powercfg.cpl</td>
<td></td>
</tr>
<tr>
<td>Printers and Faxes</td>
<td>control.exe printers</td>
<td></td>
</tr>
<tr>
<td>Private Character Editor</td>
<td>eudcedit.exe</td>
<td></td>
</tr>
<tr>
<td>Program Manager</td>
<td>progman.exe, grpconv.exe</td>
<td></td>
</tr>
<tr>
<td>Query Process</td>
<td>qprocess.exe</td>
<td></td>
</tr>
<tr>
<td>Regional and Language Options</td>
<td>intl.cpl</td>
<td></td>
</tr>
<tr>
<td>Registry Console Utility</td>
<td>reg.exe</td>
<td></td>
</tr>
<tr>
<td>Registry Editor</td>
<td>regedit.exe</td>
<td></td>
</tr>
<tr>
<td>Remote Assistance</td>
<td>rcimby.exe</td>
<td></td>
</tr>
<tr>
<td>Application</td>
<td>Command</td>
<td></td>
</tr>
<tr>
<td>-----------------------------</td>
<td>----------------</td>
<td></td>
</tr>
<tr>
<td>Remote Copy</td>
<td>rcp.exe</td>
<td></td>
</tr>
<tr>
<td>Remote Desktop Connection</td>
<td>mstsc.exe</td>
<td></td>
</tr>
<tr>
<td>Route</td>
<td>route.exe</td>
<td></td>
</tr>
<tr>
<td>Rundll32</td>
<td>rundll32.exe</td>
<td></td>
</tr>
<tr>
<td>Run As</td>
<td>runas.exe</td>
<td></td>
</tr>
<tr>
<td>Scanners and Cameras</td>
<td>wiaacmgr.exe</td>
<td></td>
</tr>
<tr>
<td>Scheduled Tasks</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Scheduled Tasks Console</td>
<td>schtasks.exe</td>
<td></td>
</tr>
<tr>
<td>Security Template Utility</td>
<td>secedit.exe</td>
<td></td>
</tr>
<tr>
<td>Send a Fax</td>
<td>fxssend.exe</td>
<td></td>
</tr>
<tr>
<td>Services</td>
<td>services.msc</td>
<td></td>
</tr>
<tr>
<td>Shutdown</td>
<td>shutdown.exe</td>
<td></td>
</tr>
<tr>
<td>Signature Verification Tool</td>
<td>sigverif.exe</td>
<td></td>
</tr>
<tr>
<td>Solitaire</td>
<td>sol.exe</td>
<td></td>
</tr>
<tr>
<td>Sound Recorder</td>
<td>sndrecrr.exe</td>
<td></td>
</tr>
<tr>
<td>Sounds and Audio Devices</td>
<td>mmsys.cpl</td>
<td></td>
</tr>
<tr>
<td>Speech Properties</td>
<td>control.exe speech</td>
<td></td>
</tr>
<tr>
<td>Spider Solitaire</td>
<td>spider.exe</td>
<td></td>
</tr>
<tr>
<td>SQL Server Client Network Utility</td>
<td>cliconfg.exe</td>
<td></td>
</tr>
<tr>
<td>Subst</td>
<td>subst.exe</td>
<td></td>
</tr>
<tr>
<td>Synchronization Manager</td>
<td>mobsync.exe</td>
<td></td>
</tr>
<tr>
<td>System Properties</td>
<td>sysdm.cpl</td>
<td></td>
</tr>
<tr>
<td>System Configuration Editor</td>
<td>sysedit.exe</td>
<td></td>
</tr>
<tr>
<td>System Configuration Utility</td>
<td>msconfig.exe</td>
<td></td>
</tr>
<tr>
<td>System Information</td>
<td>winmsd.exe, msinfo.exe</td>
<td></td>
</tr>
<tr>
<td>System Restore</td>
<td>rstrui.exe</td>
<td></td>
</tr>
<tr>
<td>Task Manager</td>
<td>taskmgr.exe</td>
<td></td>
</tr>
<tr>
<td>Taskbar and Start Menu</td>
<td>n/a</td>
<td></td>
</tr>
<tr>
<td>Taskkill</td>
<td>taskkill.exe</td>
<td></td>
</tr>
<tr>
<td>Tasklist</td>
<td>tasklist.exe</td>
<td></td>
</tr>
<tr>
<td>Telnet</td>
<td>telnet.exe</td>
<td></td>
</tr>
<tr>
<td>Telnet Administrator</td>
<td>tlntadmn.exe</td>
<td></td>
</tr>
<tr>
<td>Tracert</td>
<td>tracert.exe</td>
<td></td>
</tr>
<tr>
<td>User Accounts</td>
<td>nusrmgr.cpl</td>
<td></td>
</tr>
<tr>
<td>Utility Manager</td>
<td>utilman.exe /start</td>
<td></td>
</tr>
<tr>
<td>Volume Control</td>
<td>sndvolrr.exe</td>
<td></td>
</tr>
<tr>
<td>Windows Explorer</td>
<td>explorer.exe</td>
<td></td>
</tr>
<tr>
<td>Windows File Checker</td>
<td>sfc.exe</td>
<td></td>
</tr>
<tr>
<td>Windows Help System</td>
<td>winhlprr.exe, hh.exe, winhelp.exe</td>
<td></td>
</tr>
<tr>
<td>Windows IP Configuration</td>
<td>ipconfig.exe</td>
<td></td>
</tr>
<tr>
<td>Windows Media Player</td>
<td>mplayrr.exe, wmplayer.exe</td>
<td></td>
</tr>
<tr>
<td>Windows Messenger</td>
<td>msmsgs.exe</td>
<td></td>
</tr>
<tr>
<td>Windows Movie Maker</td>
<td>moviemk.exe</td>
<td></td>
</tr>
</tbody>
</table>
Accessibility Options  \windows\system\access.cpl

Provides options for the accessibility tools in Windows XP

To Open

Control Panel ➔[Accessibility Options] ➔Accessibility Options
Command Prompt ➔access.cpl

Description

Accessibility is Microsoft's term for the collection of tools and settings designed to make a computer easier to use for those with poor eyesight, hearing, or some other physical challenge. The settings in this dialog are shown on the following five tabs:

**Keyboard**
- StickyKeys allows you to use keyboard combinations, such as Shift-Y and Alt-F4, without having to hold down more than one key simultaneously.
- FilterKeys lets you configure Windows' behavior when a key is held down, such as how long a key must be held down before it starts to repeat and how fast it repeats once it starts (settings are also available in Control Panel ➔[Printers and Other Hardware] ➔Keyboard ➔Speed). However, FilterKeys also lets you disable keyboard repeat completely.
- ToggleKeys instructs the Windows to play sounds whenever you press Caps Lock, Num Lock, or Scroll Lock.

**Sounds**
- SoundSentry lets you substitute visual warnings (e.g., flashing the titlebar or the entire screen) for sounds normally made for the system.
- ShowSounds lets you substitute captions for speech and other sounds in programs that support this feature (unfortunately, not many do).

**Display**
- High Contrast is a quick way to choose a color scheme with more contrasting colors, which may make text and other screen elements easier to see. These settings are also available through Control Panel ➔[Appearance and Themes] ➔Display ➔Appearance tab, but this feature also lets you toggle between high contrast and standard colors with a hotkey.
- The Cursor Options allow you to adjust the settings of the insertion point (text cursor) so that it is easier to see. To make the mouse pointer easier to see, use large pointers or enableMouse Trails (which leaves a ghost track when you move the pointer) by going to Control Panel ➔[Printers and Other Hardware] ➔Mouse and using the Pointers and Motion tabs, respectively.

**Mouse**
- MouseKeys lets you use keys on the numeric keypad to move the pointer around the screen (see Figure 4–2).
Move the pointer to an object and press Ins to start dragging. Press Del to end the drag. Press the - key to switch "clicking" to the right button. That is, - then 0 to right-click or - then + to right double-click. "Right-click" mode remains enabled until you press / to switch back to left-clicking. Hold down Shift while using the arrow keys to move the pointer pixel by pixel; hold down Ctrl to move in big jumps.

The Settings dialog box lets you control how fast the pointer moves and how quickly it speeds up when you hold down a key. Higher Top speed and a lower acceleration settings here will make your pointer easier to control. The "Use MouseKeys when Num Lock is [on/off ]" option allows you to use MouseKeys without giving up your numeric keypad for cursor movement or numeric entry, whichever you use more.

**General**

Automatic Reset instructs Windows to automatically turn off all accessibility features after a certain period of inactivity, a useful feature if several people use the same computer and you don't want to have to remember to turn off the features every time you're done using it.

Notification lets you specify whether messages or sounds should be used to let you know when an accessibility option is turned on or off.

SerialKey devices enables the use of special alternative input devices attached to a serial port, allowing you to take the place of your keyboard or mouse with a more appropriate device.

**Notes**

- All of the settings in this dialog are also covered in [Chapter a](#).
- As an alternative to the settings found here, the Accessibility Wizard can be used to help you choose which settings are right for you, one-by-one.

**See Also**
Accessibility Options, Control Panel

**Accessibility Wizard**  
\windows\system32\accwiz.exe

A step-by-step interface designed to help choose accessibility options

**To Open**

Start → Programs → Accessories → Accessibility → Accessibility Wizard  
Command Prompt → accwiz

**Description**

The Accessibility Wizard is simply an alternate interface to the settings provided in the Accessibility Options dialog (see Figure 4-5). Accessibility is Microsoft's term for the collection of tools and settings designed to make a computer easier to use for those with poor eyesight, hearing, or some other physical challenge. The advantage of the Wizard interface here is that it will walk you through the available options, one-by-one, lending assistance where you may not know which options you need. For example, you can change the font size with predetermined settings based on your needs or disability, rather than by simply changing a numeric value.

![Figure 4-5. The Accessibility Wizard asks questions and sets Accessibility options accordingly](image)

**Notes**

In addition to the settings and utilities normally found in the Accessibility Options window, the Accessibility Wizard also makes it easy to turn off "personalized menus," a feature found in later versions of Windows that shows or hides menu items based on how frequently they're used. Since personalized menus can make
Windows more difficult to use, you may want to disable this feature, whether or not you need the other accessibility options.

**See Also**

Accessibility Options

Activate Windows

\windows\system32\oobe\msoobe.exe

The copy protection scheme in Windows XP (see Figure 4-4).

**To Open**

Start ➔ Settings ➔ Activate Windows
Command Prompt ➔ \windows\system32\oobe\msoobe /A

**Description**

Product activation is a new and somewhat controversial feature in Windows XP. Intending to curb software piracy, Microsoft now requires that each installed copy of Windows XP be activated. This involves contacting Microsoft, either over the Internet or with a telephone call, to obtain a special key to unlock Windows. If Windows is not activated within a certain period, it will expire and refuse to load.

**Figure 4-4. Once you've activated Windows XP, you probably won't ever need to again**

The sequence of steps to install and activate Windows is as follows:

1. During the installation of Windows, type the 21-character CD Key provided with the Windows XP installation CD. The CD Key distinguishes one end-user license of Windows from another.
2. Windows then generates a 20-digit product ID based on the CD Key and the Windows version.
You, the user, transmit the "Installation ID," comprised of the 20-digit product ID plus an 1-digit hardware ID, to Microsoft. The hardware ID, a unique number based on values obtained from hardware in your computer (see below), distinguishes one computer from another.

Microsoft responds with a 42-digit Confirmation ID, which is fed into Windows to activate it.

Since the confirmation ID is based upon the unique CD key and the unique hardware ID, it represents a single, unique system. If someone attempts to activate Windows with the same CD Key and a different hardware key (representing the same copy of Windows being installed on more than one computer), the copy protection will kick in and the product activation will fail.

Notes

- The Hardware ID is based on a hardware hash, a long sequence of numbers based on information found in your computer's hardware. The specific devices used are as follows:
  - Display adapter (video card)
  - SCSI adapter (if available)
  - IDE adapter
  - Network adapter MAC address (if available)
  - RAM amount range
  - Processor type
  - Processor serial number
  - Hard drive
  - Hard drive volume serial number
  - CD-ROM, CD-RW, or DVD-ROM
- In theory, you should be able to upgrade one or two of these components without causing a problem. However, if you replace the motherboard or upgrade several components at once, the hardware ID will change significantly. Since Windows XP compares the confirmation ID against the hardware ID every time Windows is started, a change in the hardware ID will probably void the activation, and you'll have to reactivate Windows.
- It probably goes without saying that the automated activation will probably fail at this point, meaning that you'll have to speak with a Microsoft representative and explain that you're merely reinstalling and not pirating the software. It remains to be seen how much hassle reactivation will be; those who upgrade often will bear the brunt of that hassle.
- If a virus attacks or your computer crashes and you're forced to format your hard disk and reinstall Windows, you'll have to activate Windows again. However since the hardware will probably not have changed, there should be no problem.
- Aside from the hassle involved, the primary focus of the controversy lies in the process by which Microsoft gathers information about users' hardware configurations and how they monitor subsequent alterations. Although Microsoft insists that the online activation is benign, you may want to stick with the tedious telephone activation procedure to be on the safe side.
- Many users may not be confronted with product activation at all. Systems purchased with Windows XP preinstalled may be preactivated as well, in one of two possible ways. Either the manufacturer may choose to activate Windows using the method described above, or by a separate mechanism called System Locked Pre-installation (SLP). SLP ties the hardware ID to the system BIOS, rather than the discrete components listed above. The resulting system may be upgraded more freely, but if the motherboard is replaced or the BIOS is upgraded, the owner will have to reactivate windows...
as described above. The other exception is the version of Windows XP sold with a volume license, usually to large businesses, which doesn't include the product activation feature at all.

See Also


**Active Connections Utility**

Displays protocol statistics and current TCP/IP network connections.

**To Open**

Command Prompt → `netstat`

**Usage**


**Description**

Type `netstat` by itself to list the active incoming and outgoing network connections. This can be useful, for example, to determine exactly what is being transmitted or received across the network at any given time. The Active Connections Utility accepts these options:

- `-a` Display all connections and open ports (see Notes).
- `-e` Display Ethernet statistics; it can be combined with `-s`.
- `-n` Display addresses and ports in a numerical format (e.g., `192.168.1.1:88`).
- `-o` Display the process that owns each listed connection.
- `-p proto` Show the connections corresponding to the protocol; the protocol can be IP, IPv6, ICMP, ICMPv6, TCP, TCPv6, UDP, or UDPv6.
- `-r` Display the routing table (see Route, later in this chapter).
- `-s` Display statistics for each protocol. By default, statistics are shown for all protocols, but this display can be filtered with the `-p` option.

`interval` Repeatedly run `netstat`, pausing `interval` seconds between each display. Press Ctrl-C to stop the display at any time. If omitted, `netstat` will display the current statistics once and then quit.

Information is displayed in the following columns:

**Proto**
The protocol — usually TCP for the TCP/IP protocol used on the Internet and most local networks

**Local Address**
The name of the local machine, followed by a colon, and then the process ID of the application that has initiated the connection

**Foreign Address**
The name or IP address of the remote machine, followed by a colon, and then the port number

**State**
Shows whether the connection is established or broken

**Notes**

- You must have an open command prompt window to use netsat; otherwise, the window closes before you can read the program's output.
- The `-a` parameter is especially useful, as it lists all currently open ports. Open ports can sometimes compromise security, so it's best to know about any back doors. See Chapter v for more information.
- Type `netstat /?` at the command prompt for a description of the command-line options.

**See Also**

OpenFiles

**Add Hardware Wizard**

`\windows\system\hdwwiz.cpl`

Detect non-plug-and-play devices and install the appropriate drivers.

**To Open**

Control Panel ⟷ Add Hardware

Command Prompt ⟷ `hdwwiz.cpl`

**Description**

When you turn on your computer, Windows automatically scans for any newly added plug-and-play (PnP) devices and installs drivers for any that are found. If you're trying to install a device that isn't detected automatically, you'll need to run the Add Hardware Wizard (see Figure 4-6).

When you start the Add Hardware Wizard and click Next, it goes through the following steps:

1. The wizard scans your system for any newly attached PnP devices. If one or more devices are found, the appropriate drivers are located and installed. This process happens every time Windows is started.

**Figure 4-6. If Windows doesn't detect your newly installed hardware automatically, you'll need to use the Add Hardware Wizard**
If no new devices are found in Step 8, you'll be asked if the device has been connected to the system yet. If you choose no, the wizard quits.

The next step, assuming you selected yes in Step 2, displays a list of all of your existing devices. If you select one of the devices and click Next, the wizard will quit. Instead, scroll to the bottom of the list and select "Add a new hardware device" and click Next.

Your next choice is between having Windows search for and install your new hardware, or having it present a list from which you can manually select a driver. Choose the first option, "Search for and install..." if you don't already have a driver. Otherwise, choose the second option, "Install the hardware...," and click Next.

Chose the category of the device, or just select Show All Devices if you're feeling lazy, and click Next.

If you have the drivers for the device, either on a floppy, a CD, or on your hard disk, click Have Disk at this point. Otherwise, choose the manufacturer of the device from the list on the left and then the specific model number from the list on the right. If your device doesn't show up here, then drivers for it aren't included with Windows XP.

The last steps involve copying and installing the drivers, and then prompting you to restart (if applicable).

Notes

- When Windows discovers new hardware, either during startup or when using the Add Hardware Wizard, you'll usually be prompted to specify a driver. The "Install Software Automatically" option is usually the best choice, as it will attempt to use one of Window's built-in drivers. If no compatible driver can be found, you'll be prompted to insert a disk or point to a folder containing appropriate drivers, either shipped with the hardware product or downloaded from the manufacturer's web site, respectively.
- When installing some drivers, Windows XP may complain that the driver is not digitally signed. This confusing and rather harsh message simply informs you that the manufacturer of the driver you're installing hasn't added a digital signature to the driver software, which, in most cases, will pose no problem. Just click Continue Anyway to proceed. See Signature Verification Tool, later in this chapter, for more information on driver signing.
- See Control Panel, later in this chapter, for information on finding Add Hardware when using the Control Panel in Category View.
Some new devices, especially printers and USB peripherals, have specific installation procedures that must be followed. For example, you may need to install the included software first, and then connect the device. When Windows detects the device, the drivers are already in place and installation proceeds without a hitch. Make sure you review the installation instructions before you resort to the Add Hardware Wizard.

See Also

Control Panel

Add or Remove Programs

Uninstall applications and add or remove Windows XP components.

To Open

Control Panel → Add or Remove Programs
Command Prompt → appwiz.cpl

Description

The Add or Remove Programs window has three sections:

Change or Remove Programs

A list of all your installed applications, or at least those applications that were registered for uninstallation, is displayed here. The Add or Remove Programs dialog doesn't actually perform any software removal; rather, it launches the uninstall utility that was registered when the application was originally installed. Some uninstallers have the capability to selectively add or remove components of the application, while others simply delete all the files that were copied during installation.

Select an application by clicking its name. Note that this listing can take a little getting used to, as the entries change size when they're selected. If the application has provided such information, you'll see the amount of disk space consumed by the installation, as well as how often the program is used. Click Change/Remove to launch the uninstaller for the selected program.

Uninstaller programs vary widely, but most will display a progress indicator and explain what they're removing, what they're not removing, and whether or not you need to restart your computer. Along the way, though, you may be prompted to remove shared files. Each shared file is registered with Windows, along with a numeric counter; applications that use the file increase the counter when they're installed and decrease the counter when they're removed. When the counter reaches zero, uninstallers assume the files are no longer needed and prompts for their removal; unless you specifically know that a file should not be deleted for some reason, just answer yes (see Figure 4-7).

Figure 4-7. The Add or Remove Programs dialog lets you uninstall any application on your computer
Add New Programs
There's not much point to this section. The first button simply looks for the file, setup.exe, in your floppy drive and CD drive, and if found, launches it. The second button launches Windows Update (discussed later in this chapter).

Add/Remove Windows Components
The Windows Components Wizard lets you add or remove any of the optional programs that come with Windows XP. Select a category and click Details to selectively install or remove any particular component. Note the Description below the list for a one-line explanation of the component, or refer to the corresponding section in this chapter for more information.

Notes
- You can remove entries from the Change or Remove Programs list without actually uninstalling the corresponding applications using TweakUI (see Appendix D).
- Applications are registered in Add or Remove Programs with keys in the Registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall.

See Also
Control Panel

Address Book \program files\outlook express\wab.exe

A database containing names, addresses, and other contact information, used by Outlook Express and other Windows applications

To Open
Description

The main window in the Address Book is set up somewhat like Explorer, with a hierarchical view of folders in the left pane and a list of addresses contained in the currently selected folder in the right pane, as shown in Figure 4-1. The Address Book lets you organize your contacts and is used primarily with Outlook and Outlook Express.

Figure 4-1. The Address Book lets you organize your contacts and is used primarily with Outlook and Outlook Express

To add a new entry to your address book, select New Contact from the File menu, or right-click an empty area of the right pane, and select New, and then New Contact. In the window that appears, type all the relevant information about this contact in the spaces provided. If you're setting up an entry simply for emailing, it's only necessary to enter the name and an email address. (Be sure to click the Add button after you've typed the email address but before you click OK.)

Notes

- Contacts can be divided into folders, either to differentiate one user's contact list from another's or to organize contacts into categories. It's important to understand the distinction between folders and groups. A group is a single address book entry intended to contain multiple email addresses. For example, if you frequently find yourself sending messages to the same collection of people, create a group entry that lists all of those people. Specifying that group name as the single recipient of a message will send the message to all members of the group.
- The Address Book is linked to the applications that use it in two different ways. First, you can open the address book, select a name, and then choose the appropriate program from the action list (accessible either through the Action button on the Toolbar, or through the Tools menu). Second, when it comes time to enter a contact in your communications program (such as the recipient in an email message), there's often a button that allows you to easily select an entry for the address book. Note that not all applications that use addresses are designed to work with the Address Book application; naturally, you can simply copy and paste information as needed with any application.
- You can also access entries in your Address Book without opening the Address Book application. Select Search and then "For People" from the Start menu to look up a name (see Figure 4-1). Furthermore, you can use any of several online directory services, open Address Book and select Accounts from the Tools menu. These services are typically free, sponsored by advertising, and based on information already made publicly available in

Start → Programs → Accessories → Address Book
Start → Search → For People
Outlook Express → Tools menu → Address Book
Command Prompt → wab
phonebooks and other sources. Privacy advocates may wish to investigate their own inclusion in these lists and take appropriate actions, such as contacting these services to have personal information removed.

Figure 4-1. The Find People dialog lets you search your Address Book from the Start menu

- Note that some viruses use your Address Book to duplicate themselves by sending harmful attachments to everyone in your contact list via Outlook Express. Aside from not opening email attachments without first scanning them with antivirus software, you can avoid this problem by using a different program for your email and contact list.

See Also

Microsoft NetMeeting, Outlook Express, Phone Dialer

Administrative Tools

Shortcuts for several important administrative utilities in Windows XP Professional. (The Administrative Tools folder is included with Windows XP Professional only.)

To Open

Control Panel ➔ [Performance and Maintenance] ➔ Administrative Tools
Command Prompt ➔ control admintools

Description

The Administrative Tools entry in Control Panel is nothing more than a standard Start Menu folder full of shortcuts to programs listed elsewhere in this chapter. The folder is stored in |Documents and Settings|All Users|Start Menu|Programs|Administrative Tools, and the shortcuts included in this folder, by default, are:
- Component Services
- Computer Management
- Data Sources (ODBC)
- Event Viewer
- Local Security Policy
- Performance
- Services

Since this is a standard folder, you can remove any of these items or add any of your own shortcuts as you see fit.

**Notes**

- Like other Start menu folders, if the Administrative Tools folder is ever deleted or renamed (or if any of its contents are deleted or modified), Windows will not recreate it.
- See Taskbar and Start Menu Properties, later in this chapter, for an option to show or hide this item in the Start menu.

**See Also**

Control Panel, Microsoft Management Console

---

**At**

\windows\system 32 \at.exe

Schedules commands and programs to run on a computer at a specified time and date.

**To Open**

Command Prompt ➔ at

**Usage**

at [\computer] time [interactive] [every:date] "command"

at [\computer] [id] [delete] [yes]

**Description**

At is the command-line interface to the Scheduled Tasks feature, discussed later in this chapter. Given the somewhat tedious wizard interface used to create new tasks in the Scheduled Tasks window, At is a refreshing and user-friendly alternative. To use At, you can simply type something like:

at 11:10 /interactive notepad

which would instruct Windows XP to launch Notepad at 11:10 AM today. When you enter the command and press Enter, At responds with something like:

Added a new job with job ID = 1
and a corresponding entry appears in the Scheduled Tasks window. The ID is used only to subsequently delete tasks with At (using the second Usage, shown above), like this:
```
@ \delete
```
The following options extend the usefulness of At:

```
\computer
```
Specify the name of a remote computer on the network to add the new task to that computer's scheduled tasks list, rather than that of the local computer.

```
time
```
The time of day to run the task, specified in 24-hour (military) time. Type 0:0 for 0:0 in the morning, 12:0 for 0:0 in the afternoon, 12:00 for noon, and 0:00 for midnight.

```
/interactive
```
If you omit the /interactive option, the task will be run invisibly in the background. For example, if you were to launch Notepad with the example above without specifying /interactive, there would be no visible evidence that Notepad is running, except for its listing in the processes tab of the Task Manager (discussed later in this chapter). You may want to run an application in the background if you do not want to interfere with any foreground applications. Use caution when starting background processes, however, since won't be able to interact with them at all, other than closing them with Task Manager.

```
/every: date, /next: date
```
By default, At creates one-time tasks, executed only on the date when they were created; if you were to type the example above at 4:30 in the afternoon, for example, the task would never run. To specify the day or a range of days, use the /every or /next options.

For example, to run Disk Defragmenter at 11:10 PM every Thursday, type:
```
@ \\/every:thursday dfrg.msc
```
To run Disk Defragmenter at 11:10 AM on the 21st day of every month, type:
```
@ \\/every:21 dfrg.msc
```
To specify multiple days, separate them with commas. To run Solitaire at 3:50 in the afternoon (note the mandatory use of 24-hour time) on both Tuesdays and Thursdays, type:
```
@ \\/interactive /every:tuesday,thursday sol
```
The /next option works similarly, although /every and /next should not be used together. To run Chkdsk at 3:33 PM next Saturday, type:
```
@ \\/next:saturday chkdsk
```
```
/delete
```
Use /delete to remove one or all tasks. Specify the task ID (described earlier in this section) to end that task, or omit the ID to delete all tasks. If you try to delete all tasks, At will ask you to confirm; use the optional /yes option to bypass the prompt. Only tasks originally created with At can be deleted in this way; all other tasks will be left alone.

```
/yes
```
Include /yes to bypass the prompt that appears when you try to delete all tasks.

**Notes**

- The Schedule service must be running to use At. To see if it is running, open the Scheduled Tasks window and select the Advanced menu. If the first
menu item is "Stop using Task Scheduler," the service is active; click the item to turn the service off. Conversely, click "Start using Task Scheduler" to turn the service back on.

- To choose the user account under which tasks created with the At command are run, open the Scheduled Tasks window and select At Service Account from the Advanced menu.
- The Scheduled Tasks Console, discussed later in this chapter, is intended to replace At. Although the Scheduled Tasks Console is a little more full featured, At is much easier to use.

See Also

Scheduled Tasks

**Attrib**  
\windows\system \attrib.exe

Change or view the attributes of one or more files or folders.

To Open

Command Prompt → attrib

Usage

attrib [+r|-r] [+a|-a] [+s|-s] [+h|-h] [filename] [/s [/d]]

Description

Attrib allows you to change the file and folder attributes from the command line — settings otherwise only available in a file's or folder's Properties window. The attributes can be thought of as switches, independently turned on or off for any file or group of files. The individual attributes are as follows:

**R (read-only)**

Turn on the read-only attribute of a file or folder to protect it from accidental deletion or modification. If you attempt to delete a read-only file, Windows will prompt you before allowing you to delete it. Different applications handle read-only files in different ways; usually you will not be allowed to save your changes to the same filename.

**A (archive)**

The archive attribute has no effect on how file is used, but it is automatically turned on when a file is modified or created. It is used primarily by a backup software to determine which files have changed since a backup was last performed; most backup programs turn off the archive attribute on each file that is backup.

**S (system)**

Files with the system attribute are typically used to boot the computer. There's little reason ever to modify a file with the system attribute, or to ever turn on or off the system attribute for any file. If you turn off the system attribute of an important file, it may stop the file from working. See Notes, below, to display or hide system files.
H (hidden)

To hide any file or folder from plain view in Explorer or on the Desktop, turn on its hidden attribute. See Notes, below, to display or hide hidden files.

Examples

To hide a file in Explorer, right-click on it, select Properties, and turn on the hidden option. To hide the same file using the command line, type:

```
attrib +h filename
```

where `filename` is the full path and filename of the file to change. To specify multiple files, include a wildcard, such as `*.*` (for all files) or `*.txt` (for all files with the `.txt` filename extension). Note the use of the plus sign (+) to turn on an attribute; use the minus sign (-) to turn it off. For example, to turn off the hidden attribute and simultaneously turn on the archive attribute, type:

```
attrib -h +a filename
```

To display the attributes of a file or a group of files in Explorer, select Details from the View menu. Then, select Choose Details from the View menu and turn on the Attributes option. To display the attributes of a file or a group of files on the command line, type:

```
attrib filename
```

where `filename` is the full path and filename(s) of the files you wish to view. Omit `filename` to display the attributes of all the files in the current folder. If `filename` is not used, or if it contains wildcards (in other words, if the command is intended to act on more than one file), you can use the `/s` option to further include the contents of all subfolders of the current folder. The `/d` option instructs Attrib to act upon folders as well as files, but only has meaning if it is used in conjunction with the `/s` parameter.

Notes

- By default, files with the system or hidden attributes are not shown in Explorer. To display system and hidden files, go to Explorer → Folder Options → View and select "Show hidden files and folders." If hidden and system files are shown, they will appear with faded icons.
- Attrib allows you to change the system attribute, something you can't do by right-clicking and selecting Properties. Attrib does not, however, let you change the Advanced attributes, such as those concerned with indexing, compression, or encryption. Note that the "File is ready for archiving" option in the Advanced Attribute window (right-click → Properties → Advanced) is the same as the Archive attribute just discussed (see Figure 4-2).

Figure 4-2. These advanced attributes are only available from a file's Properties sheets in Windows Explorer
See Also

Backup

Backup (copy) files from your hard drive to a tape drive, second hard drive, or other removable storage device for the purpose of safeguarding or archiving your data. (Backup is included with Windows XP Professional only.)

To Open

Start ➔ Programs ➔ Accessories ➔ System Tools ➔ Backup Command Prompt ➔ ntdbackup

Description

Microsoft Backup works by creating a backup set — a collection of selected files to be backed up to a removable storage device. This backup set, along with all the selected options available in Backup (e.g., data compression, password protection, error report listing, etc.) are known collectively as a backup "job."

To begin creating a backup job, choose the Backup tab and use the familiar Explorer-like two-pane view to navigate through your folders. Click on the checkbox next to a file to select it for backup; click the checkbox next to a folder to select it and all of its contents for backup (see Figure 1-1). A blue checkmark appears next to each folder or file to be backed up; a gray checkmark appears next to each folder name with only some of its contents selected.

Figure 1-1. Choose the drives, folders, and files you wish to back up by placing checkmarks next to them in the Backup Utility
When you're done selecting files, choose Job → Save Selections to save your selections into a .bks file. Next, choose a Backup destination from the list below the folder tree. If you have more than one backup device, choose the desired drive here. If you have no dedicated backup hardware, the only option will be "File," which is used to back up to your hard disk. If you choose File, the "Backup media or filename" field is used to specify the name of the single file in which to store the backed up data (usually a .bkf file).

Finally, select Options from the Tools menu, and then choose the Backup Type tab to choose how files are backed up. The different backup types are as follows:

**Normal**
Backs up all the selected files. The archive attribute (see **Attrib**, earlier in this chapter) is automatically turned off for each file that is backed up.

**Copy**
The same as normal, above, except that the archive attribute is left alone.

**Differential**
Backs up only the files with a Last Modified date that is more recent than the last backup performed with the Backup application. This backup type affords a quicker backup, but since it relies on previous backups, it may not be the best choice when backing up important data.

**Incremental**
Backs up only those files with the archive attribute turned on. This option really only makes sense when used after a "Normal" backup, described above, as it relies heavily on the archive attribute. Like the differential backup, it is quicker than the Normal backup, but since it relies on previous backups, it may not be the best choice when backing up important data.

**Daily**
Backs up only those files with a Last Modified date the same as today's date. This option is useful only if you run backup every single day, or are only concerned with backing up files modified in the last few hours.

Note that the .bks file only saves the file selections; the other options are saved as defaults in the Backup program and must be changed manually every time if you need different options for different backup jobs.

When you're ready, click the Start Backup button to begin the backup process. If you've turned on the "Compute selection information" option (Tools → Options → General tab), Backup will count up the sizes of all the selected files so that it can provide an accurate estimate of the time to completion. If you've chosen to "Verify
data after the backup completes," Backup will compare the backed-up files against the originals on your hard disk; this will double the time taken for the backup job, but you'll be more certain that the backup contains a valid, complete copy of your data.

Choose the Restore tab to restore some or all of the files you've previously backed up. Backup keeps a catalog of all backed-up files, so you don't have to wait for Backup to read your tape or other media before you see a list of files you can restore. The catalogs are displayed in the left pane of the Restore window, arranged first by backup media, then by backup job, then by original location (see Figure 4-11). For example, if you've backed up a folder called My Stuff to a tape last Monday, you would open the tape drive branch and then open the branch dated last Monday. You would see the familiar folder hierarchy with the backed up files and folders. Simply place a checkmark next to those files and folders you wish to restore (like when you backed up originally) and click Start Restore when you're ready (see Figure 4-17).

**Figure 4-11.** Once files have been backed up, they are listed in the Restore and Manage Media tab for easy retrieval.

![Figure 4-11](image1)

**Figure 4-17.** Place checkmarks next to the items you wish to restore using an interface very similar to Explorer.

![Figure 4-17](image2)
Notes

- Files with the .bks extension are not associated with the Backup application by default. This means that you cannot double-click a .bks file to start the backup without first configuring your File Types. Go to Explorer → Tools → Folder Options → File Types tab. Click New, type BKS, and click OK. Then click Advanced and type Backup Set for the name of the file type. Click New, type Backup in the Action field, and type something like:

```
ntbackup.exe backup "@\1" /f "c:\mybackup.bkf"
```

which will open Backup and begin backing up the files specified in the .bks file (represented here by \1). In this example, the target is a backup file (c:\mybackup.bkf). Type nbackup /? at the command prompt to see a list of the available command line parameters and some examples of how they're used so you can form a command line appropriate to your needs and hardware.

- In addition to the drives shown in the folder tree, you'll see an additional item called "System State." Place a checkmark next to the System State entry to back up the Registry, Boot files, special System files that are under Windows File Protection, and several other databases. Although you could back up the Registry by backing up the hives (see Chapter v), for example, backing up the System State is a more graceful solution, especially since it makes restoration much easier. If you're backing up the drive on which Windows is installed, you should also back up the System State.

- Go to Tools → Options → Restore to choose whether the restored file will overwrite an existing file, overwrite an existing file only if it's older than the backed up file, or prompt you before overwriting.

- Tools → Options → Exclude Files lets you exclude specific files or groups of files from the backup. By default, Backup is set to exclude nearly twenty different files or file types, such as the swap file (pagefile.sys) and the file responsible for the Internet Explorer cache (index.dat).

- The Wizards available under the Welcome tab provide step-by-step walkthroughs of the backup and restore processes, but don't offer any special options or features.

- The Automated System Recovery Wizard helps create a special boot disk, allowing you to more easily restore your system if there's a disk crash or some other serious problem that requires the drive to be reformatted.

- Before you become complacent about your backups, make sure you've worked through the steps required to restore all the data you've gone to so much trouble to back up.

- There are wizards for performing a backup and restore: Tools → Backup Wizard and Tools → Restore Wizard, respectively.

**Boot Configuration Manager**

\windows\system32\bootcfg.exe
Configure and view entries in the boot.ini file, used by the Windows XP Boot Manager. (Boot Configuration Manager is included with Windows XP Professional only.)

To Open

Command Prompt → bootcfg

Usage

bootcfg /command[parameters]

Description

The Windows XP Boot Manager, responsible for supporting multiple operating systems on the same system, is installed when Windows XP is installed. If there is more than one boot entry, a menu appears before Windows is loaded, allowing the user to choose an operating system to load. The entries in the menu are configured in a file called boot.ini, located in the root directory of your boot drive. Boot.ini is a plain text file and can be edited with Notepad. However, the syntax can be complex, so the Boot Configuration Manager can be used to add, remove, or configure entries and options. Unfortunately, the Boot Configuration Manager doesn't have an interface to speak of. Rather, commands are issued by typing them at the command prompt, like this:

bootcfg /query

There are eleven primary commands, each with its own set of parameters. To list all the available commands, type:

bootcfg /?

To see the usage of any particular command, type the command followed by /?, like this:

bootcfg /query ?

Notes

- Among the commands available to the Boot Configuration Manager, the most interesting are the /copy, /delete, and /query commands, used to add, remove, and view the entries in boot.ini, respectively. The /query command is the default; if you simply type bootcfg with no command, it's the same as typing bootcfg/query.

- Boot.ini is a hidden file; see Attrib, earlier in this chapter, for details on hidden files.

- Some of the aspects of the boot menu (e.g., settings in the boot.ini file) can also be set by going to the Control Panel -> System -> Advanced tab, and clicking Settings in the Startup and Recovery section. The options in the System Startup section allow you to choose the default operating system and the timeout before the default is selected. (These settings duplicate the /default and /timeout commands, respectively.) Finally, click Edit to open the boot.ini file in Notepad.

- The obvious advantage of this utility is the ability to modify the boot menu with a batch file or WSH script.

- The BOOT.INI tab of the System Configuration Utility, discussed later in this chapter, also provides access to several boot preferences not otherwise available.
See Also

*Windows Me Annoyances* by David A. Karp (O'Reilly), Chapter r, for a discussion of .ini files; Control Panel, System Configuration Utility

**Cabinet (CAB) Maker**

| \windows\system 32\makecab.exe; | diantz.exe |

Cabinet file (.cab) compression utility

**To Open**

Command Prompt → makecab

**Usage**

makecab [/v[n]] [/d var=value] [/l dir] source [destination]
makecab [/v[n]] [/d var=value] /f directive_file

**Description**

A cabinet file is a compressed archive commonly used to package application installation files. Cabinets are similar to .zip files, although there are added features such as a rudimentary script system intended to install and register application components.

There are two ways to use the Cabinet Maker. First, you can compress one or more files directly, like this:

```
makecab \windows\greenstone.bmp greenstone.cab
```

which compresses the file, *greenstone.bmp*, into the *greenstone.cab* archive. The new cabinet file, *greenstone.cab*, is created automatically in the current directory; if it already exists, it is replaced with the new archive. Unfortunately, wildcards (*.*) aren't allowed in the source, so you can only specify one file at a time. This is where the second usage of the Cabinet Maker comes in: instead of specifying options and files directly, a single plain text file, called a directive file (.ddf) is used. The simplest directive file lists all the files to include. A line beginning with a semicolon is treated as a comment.

Assuming the lines:

```
;Example directive file
c:\windows\greenstone.bmp
c:\windows\rhododendron.bmp
```

are saved into a file called *test.ddf*, the Makecab command would then look like this:

```
makecab /f test.ddf
```

Multiple directive files can be specified in the same command, listed one after another.

**Notes**
- Diamond Cabinet Builder (*Diantz.exe*) is identical to *makecab.exe*; it's included only for legacy support.
- There are two ways to open Cabinet files and extract their contents. The easiest way is to double-click on any .cab file in Explorer to display a folder view of the contents. You can then drag files out of the .cab file (items cannot be added here, however). The other way is to use the File Expansion Utility (*expand.exe*).
- WinZip ([http://www.winzip.com](http://www.winzip.com)) can also be used to open .cab files, but it's not compatible with all variants of the .cab format, and thus won't open every .cab file you encounter.
- More complicated directive files, including the use of .inf installation routines, are possible with the Cabinet Maker. See [http://msdn.microsoft.com/](http://msdn.microsoft.com/) for details, including the use of the /v and /d parameters.

**See Also**

*File Expansion Utility*, *IExpress*

---

**Calculator**

\`\`\`windows\system32\calc.exe\`\`\`

Numerical scientific and nonscientific calculator.

**To Open**

Start ➔ Programs ➔ Accessories ➔ Calculator

Command Prompt ➔ *calc*

**Description**

By default, the Calculator starts in Standard mode, containing only the numeric keypad and some basic functions (add, subtract, invert, square root, etc.). Select Scientific from the View menu to use the calculator in Scientific mode, useful for more advanced functions, such as logarithmic, logical, trigonomic, and base functions (see *Figure 4-14*). Each time you subsequently open the calculator, it will appear in the previously used mode.

*Figure 4-14*. The scientific view of the Calculator provides access to many more functions than the standard view
Entering data and performing calculations

Data can be entered by clicking the buttons or by pressing keys on the keyboard. All keys have keyboard equivalents; key mappings that are not quite obvious (such as log) are documented in Table 4-2. Note that many of the functions below are only available in Scientific mode.

<table>
<thead>
<tr>
<th>Calc button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Esc</td>
<td>Clear all calculations</td>
</tr>
<tr>
<td>CE</td>
<td>Del</td>
<td>Clear the last entry</td>
</tr>
<tr>
<td>Back</td>
<td>Backspace</td>
<td>Clear the last digit</td>
</tr>
<tr>
<td>MR</td>
<td>Ctrl-R</td>
<td>Display the number stored in memory</td>
</tr>
<tr>
<td>MS</td>
<td>Ctrl-M</td>
<td>Store the current value in memory</td>
</tr>
<tr>
<td>M+</td>
<td>Ctrl-P</td>
<td>Add the current value to the number stored in memory</td>
</tr>
<tr>
<td>MC</td>
<td>Ctrl-L</td>
<td>Clear the memory</td>
</tr>
<tr>
<td>+/-</td>
<td>F9</td>
<td>Change the sign (negative)</td>
</tr>
</tbody>
</table>

When in Hex mode, hexadecimal values A-F can be entered from the keyboard or by using the A-F buttons on the calculator. Number systems and keyboard equivalents can be seen in Table 4-7. Table 4-8 and Table 4-9 show binary mode keyboard equivalents and bitwise (logic) functions and keyboard equivalents, respectively.

<table>
<thead>
<tr>
<th>Calc Button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hex</td>
<td>F0</td>
<td>Hexadecimal (base 16)</td>
</tr>
<tr>
<td>Dec</td>
<td>F1</td>
<td>Decimal (base 10)</td>
</tr>
<tr>
<td>Oct</td>
<td>Fv</td>
<td>Octal (base 8)</td>
</tr>
<tr>
<td>Bin</td>
<td>Fa</td>
<td>Binary (base 2)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Calc button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Qword</td>
<td>F82#</td>
<td>64-bit value</td>
</tr>
<tr>
<td>Dword</td>
<td>F91#</td>
<td>32-bit value</td>
</tr>
</tbody>
</table>
Word 
Byte

<table>
<thead>
<tr>
<th>Calc Button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mod</td>
<td>%</td>
<td>Modulus</td>
</tr>
<tr>
<td>And</td>
<td>&amp;</td>
<td>Bitwise AND</td>
</tr>
<tr>
<td>Or</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Xor</td>
<td>^</td>
<td>Bitwise exclusive OR</td>
</tr>
<tr>
<td>Lsh</td>
<td>&lt;</td>
<td>Left shift (right shift via Inv + Lsh or &gt;)</td>
</tr>
<tr>
<td>Not</td>
<td>~</td>
<td>Bitwise inverse</td>
</tr>
<tr>
<td>Int</td>
<td>;</td>
<td>Integer (remove the decimal portion)</td>
</tr>
</tbody>
</table>

When in Decimal mode, the Deg, Rad, and Grad radio buttons switch between degrees, radians, and gradients (see Table ε-1).

<table>
<thead>
<tr>
<th>Calc button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deg</td>
<td>Fr</td>
<td>Calculate trigonometric functions in degrees</td>
</tr>
<tr>
<td>Rad</td>
<td>Fr</td>
<td>Calculate trigonometric functions in radians</td>
</tr>
<tr>
<td>Grad</td>
<td>Fɛ</td>
<td>Calculate trigonometric functions in grads</td>
</tr>
</tbody>
</table>

### Statistical functions

To perform a statistical calculation, start by entering the first data, then click Sta to open the Statistics Box, click Dat to display the data in the Statistics Box, and then continue entering the data, clicking Dat after each entry. When you’ve finished entering all the numbers, click the statistical button you want to use (Ave, Sum, or S). The buttons available in the Statistics Box are listed in Table ε-v.

<table>
<thead>
<tr>
<th>Calc button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>RET</td>
<td>Returns the focus to the calculator</td>
</tr>
<tr>
<td>LOAD</td>
<td>Displays the selected number in the Statistics Box in the Calculator display area</td>
</tr>
<tr>
<td>CD</td>
<td>Clears the selected number (data)</td>
</tr>
<tr>
<td>CAD</td>
<td>Clears all numbers (data) in the Statistics Box</td>
</tr>
</tbody>
</table>

### Scientific calculation

Scientific calculations buttons and keyboard equivalents are shown in Table ε-1.

<table>
<thead>
<tr>
<th>Calc button</th>
<th>Keyboard key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inv</td>
<td>i</td>
<td>Sets the inverse function for sin, cos, tan, Pl, xy, x^, x^, Ln, log, sum, and s.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td><strong>Hyp</strong></td>
<td>Sets the hyperbolic function for ( \sin, \cos, ) and ( \tan ).</td>
<td></td>
</tr>
<tr>
<td><strong>F-E</strong></td>
<td>Turns scientific notation on and off. Can only be used with decimal numbers. Numbers larger than ( 1 \times 10^n ) are always displayed with exponents.</td>
<td></td>
</tr>
<tr>
<td><strong>()</strong></td>
<td>Starts and ends a new level of parentheses. The maximum number of nested parentheses is ( 10 ). The current number of levels appears in the box above the ) button.</td>
<td></td>
</tr>
<tr>
<td><strong>dms</strong></td>
<td>If the displayed number is in degrees, convert to degree-minute-second format. Use Inv + dms to reverse the operation.</td>
<td></td>
</tr>
<tr>
<td><strong>Exp</strong></td>
<td>The next digit(s) entered constitute the exponent. The exponent cannot be larger than ( 212 ). Decimal only.</td>
<td></td>
</tr>
<tr>
<td><strong>Ln</strong></td>
<td>Natural (base ( e )) logarithm. Inv + Ln calculates ( e ) raised to the ( n )th power, where ( n ) is the current number.</td>
<td></td>
</tr>
<tr>
<td><strong>sin</strong></td>
<td>Sine of the displayed number. Inv + sin gives arc sine. Hyp + sin gives hyperbolic sine. Inv + Hyp + sin gives arc hyperbolic sine.</td>
<td></td>
</tr>
<tr>
<td><strong>x^y</strong></td>
<td>( x ) to the ( y )th power. Inv + x^y calculates the ( y )th root of ( x ).</td>
<td></td>
</tr>
<tr>
<td><strong>Log</strong></td>
<td>The common (base ( 10 )) logarithm. Inv + log yields ( 10 ) to the ( x )th power, where ( x ) is the displayed number.</td>
<td></td>
</tr>
<tr>
<td><strong>Cos</strong></td>
<td>Cosine of the displayed number. Inv + cosin gives arc cosine. Hyp + cosin gives hyperbolic cosine. Inv + Hyp + cosin gives arc hyperbolic cosine.</td>
<td></td>
</tr>
<tr>
<td><strong>x^r</strong></td>
<td>Cubes the displayed number. Inv + x^r gives the cube root.</td>
<td></td>
</tr>
<tr>
<td><strong>n!</strong></td>
<td>Factorial of the displayed number.</td>
<td></td>
</tr>
<tr>
<td><strong>tan</strong></td>
<td>Tangent of the displayed number. Inv + tan gives arc tan. Hyp + tan gives hyperbolic tan. Inv + Hyp + tan gives arc hyperbolic tan.</td>
<td></td>
</tr>
<tr>
<td><strong>x^r</strong></td>
<td>Squares the displayed number. Inv + x^r gives the square root.</td>
<td></td>
</tr>
<tr>
<td><strong>1/x</strong></td>
<td>Reciprocal of displayed number.</td>
<td></td>
</tr>
<tr>
<td><strong>Pi</strong></td>
<td>The value of ( \pi (3.1415...) ). Inv + Pi gives ( \pi \times r ).</td>
<td></td>
</tr>
</tbody>
</table>

**Notes**

- If you convert a fractional decimal number to another number system, only the integer part will be used.
- Those serious about calculators will probably notice that there is no Reverse Polish Notation (RPN) mode. Fortunately, there are literally dozens of freely available alternatives on the Web (try the Aepryus Calculator from [http://www.aepryus.com/](http://www.aepryus.com/) or the Trig+ PC Calculator from [http://www.web-ee.com/](http://www.web-ee.com/)). Also see "Powertoy Calc," part of Microsoft’s Power Toys package described in Appendix D.

**Character Map**

\( \text{\textbackslash windows\textbackslash system} \r \text{\textbackslash charmap.exe} \)

Display all the characters and symbols in a particular font. This provides access to symbols not easily accessible with the keyboard.
To Open

Start → Programs → Accessories → System Tools → Character Map
Command Prompt → charmap

Description

Character Map displays a visual map of all the characters in any font, making it easy to paste them into other documents (see Figure 4-14).

Figure 4-14. Use Character Map to access the symbols you can't normally type from the keyboard

To use Character Map:

1. Select a font from the Font drop-down list. If you're inserting a character into an existing document, you should select the same font that is used in the document.
2. Find the character you wish to use; click once on any cell to magnify its character. If you can't find the desired character, remember to scroll down. If the selected font doesn't have the character you want, try another font.
3. Double-click the character you want (or click once and then click the Select button) to place the character in the "Characters to copy" box. You can place as many successive characters as you want in this box.
4. Click Copy to copy the character(s) to the Windows clipboard.
5. Switch to your other application, click where you want the character(s) to appear, and paste (using either the Edit menu or Ctrl-V).
6. If the font in the target application isn't the same as the one you've selected in Character Map, you'll need to highlight the newly inserted character(s), and then change them to the same font you used in Character Map. If the
character in your document doesn't look as it did in Character Map, it's because the wrong font is being used.

Notes

- Effective use of Character Map relies on correct font selection, especially when you're pasting characters into applications that don't support multiple fonts. For example, the default font used in Notepad is Lucida Console (changed by going to Notepad → Format → Font), and the default font used in most text boxes is Tahoma (changed by going to Control Panel → [Appearance and Themes] → Display).
- Character Map is helpful not only for selecting extended characters in standard fonts, but also for accessing dingbats, such as those found in the Webdings, Wingdings, Symbol, and Marlett fonts.
- Character Map is useful for finding out what key combination will produce a nonstandard character in any given font. This can eliminate the need to repeatedly go back to Character Map to retrieve the same character. Select a character in any cell and see the corresponding character code in the status bar. For example, the Yin-Yang symbol in Wingdings is character code 0x0B. Now, this is a hexadecimal code, so you'll need to use Calculator to convert it to a decimal number. In Calculator's scientific mode, click Hex, type the code (not including the 0x prefix - 0B in this case), and then click Dec to view the decimal equivalent (28 in this case). To then insert the character into an application using the keyboard, hold the Alt key, and type the code using the numeric keypad (the numbers above the letters won't work). In the case of the Yin-Yang, type Alt-91. Appendix E lists some of the most useful character codes.

See Also

Fonts Folder, Calculator, Private Character Editor

Chat

See Microsoft Chat.

Chkdsk \windows\system32\chkdsk.exe

Check the disk for errors and fix any that are found (replaces Scandisk).

To Open

Command Prompt → chkdsk
**Usage**

```
```

**Description**

Chkdsk scans the disk surface, checks the integrity of files and folders, and looks for lost clusters (among other things), correcting any problems that are found and sometimes even freeing disk space consumed by unusable fragments of data. If you run Chkdsk with no command-line parameters, it will check the current drive for errors. Or, specify a drive letter to check a specific drive, like this:

```
chkdsk e:
```

However, Chkdsk run this way will only report problems — it won't correct them. The report you'll get looks something like this:

*The type of the file system is NTFS.*

*Volume label is Hard Disk.*

**WARNING!** F parameter not specified.

Running CHKDSK in read-only mode.

CHKDSK is verifying files (stage 1 of 5)...

File verification completed.

CHKDSK is verifying indexes (stage 2 of 5)...

Index verification completed.

CHKDSK is verifying security descriptors (stage 3 of 5)...

Security descriptor verification completed.

Correcting errors in the Volume Bitmap.

Windows found problems with the file system.

Run CHKDSK with the /F (fix) option to correct these.

225.02121 KB total disk space.

222,858 KB in 824,183 files.

1852 KB in 8520 indexes.

0 KB in bad sectors.

245,182 KB in use by the system.

115,519 KB occupied by the log file.

245,182 KB available on disk.

402 bytes in each allocation unit.

521 total allocation units on disk.

1184 allocation units available on disk.

The report starts with a warning about the /f parameter (see below), followed by descriptions of the stages of the scan. Note that an error has been found, but according to the report, it wasn't fixed. Next comes the summary of the total disk space, used space, and other statistics, which are fairly self-explanatory.

To use Chkdsk effectively, you'll need to use the following optional parameters:

```
/f
```

Fix any errors found. If /f is omitted, errors are merely reported and no changes to the disk are made.
Locates bad sectors and recovers readable information. Using the /r parameter implies /f (see above). Think of the /r parameter as a beefed-up version of /f. Keep in mind that bad sectors represent physical errors on the disk surface, and safe recovery of the data residing in those areas is not guaranteed. Only use the /r option if you have reason to believe you have one or more bad sectors, either because Chkdsk is reporting this problem or if you encounter another symptom, such as your computer crashing or freezing every time you attempt to access a certain file.

/x
Forces the volume to dismount before the scan is performed. Using the /x parameter implies /f (see above). This effectively disconnects the drive from Explorer and all other programs, closing any open files stored on the drive, before any changes are made. You may wish to use this option when checking or repairing a shared drive used frequently by the several users on a network; otherwise, access to the drive might interrupt Chkdsk, or even corrupt data further.

/i
Performs a less vigorous check of index entries. The /i option can be used only on NTFS disks, as index entries only exist on NTFS volumes. Typically, you'll probably never need this option, although you may choose to use it to reduce the amount of time required to check the disk.

/c
Skips checking of cycles within the folder structure. Like /i, the /c option can be used only on NTFS disks. Likewise, you'll probably never need this option either, although you may choose to use it to reduce the amount of time required to check the disk.

/v
Use of the /v parameter abandons Chkdsk's primary purpose, and instead simply displays a list of every file on the entire hard disk (in no particular order). Note that the /v parameter can be used only on a disk with a FAT or FAT32 file system; it has no meaning on an NTFS disk.

Notes

- Chkdsk can also be used to check a single file or a specific group of files for fragmentation (see Disk Defragmenter, later in this chapter), but only on FAT or FAT32 disks. To do this, specify the full path and filename (or use wildcards, such as *, to specify multiple files) instead of the drive letter on the command line.
- In Windows 9x/Me, regular usage of Scandisk was recommended, but that's not necessarily the case with Chkdsk and Windows XP. Whenever Windows isn't properly shutdown, or when Windows detects a potential problem during startup, Chkdsk is run automatically during the boot process. Additionally, given the added stability of Windows XP, you may not ever need to run Chkdsk manually unless you suspect a problem.
- When Chkdsk is launched during Windows startup, it is preceded by a message and a 1-second delay, giving you the option of skipping the scan. While Chkdsk is running, either during Windows startup or any other time, it can be corrupted by pressing Ctrl-C.
- During normal use of Chkdsk, you'll see references to various terms describing problems on your hard disk. Among the more popular players are lost clusters (pieces of data no longer associated with any file), bad sectors (actual flaws in the disk surface), cross-linked files (two files claiming
ownership of the same chunk of data), invalid file dates and filenames, and a few other more secure errors.

- The \( /v \) parameter is a funny option, especially considering it has very little to do, at least in terms of results, with the other functions of this program. However, when used in conjunction with pipe operators (see \textit{Appendix C}), this feature can generate filtered reports of the contents of a drive.
- If you wish to schedule Chkdsk at regular intervals to help ensure a healthy disk, you can configure the Task Scheduler (discussed later in this chapter) to run Chkdsk, say, every Friday at 5:30.

\textbf{See Also}

\texttt{Chkntfs}

\texttt{Chkntfs} \ \texttt{\textbackslash windows\system32\chkntfs.exe}

Display or change the checking of a disk (using \texttt{Chkdsk}) at Windows startup

\textbf{To Open}

Command Prompt \rightarrow \texttt{chkntfs}

\textbf{Usage}

\texttt{chkntfs [drive | /d | /t:\textit{time} | /x drive | /c drive]}

\textbf{Description}

\texttt{Chkdsk}, described earlier in this chapter, is run automatically during Windows startup, either if the previous session was not ended gracefully (the computer was turned off without shutting down) or if errors are detected. \texttt{Chkntfs} is used to modify this behavior for one or all of your drives.

If you run \texttt{Chkntfs} with only a drive letter (e.g., \texttt{chkntfs c:}), you get a somewhat cryptic report, like this:

- The type of the file system is NTFS.
- C: is not dirty.

The identification of the filesystem type on the first line is fairly self-evident. The "not dirty" report implies that the drive was properly "cleaned up" the last time the system shut down. In other words, the system shut down properly. If the system isn't shut down properly, any drives in use (drives containing one or more files that were open when the computer lost power, for example) are marked "dirty," and those drives are scanned the next time Windows starts. To change this behavior, use one of the following options. Note that all options, including the specification of the drive letter above, are exclusive; only one can be used in any time.

\texttt{\textbf{/d}}

Type \texttt{chkntfs /d} to restore the default behavior of the entire machine; all drives automatically check to boot time, and any drives found to be "dirty" are checked with Chkdsk.

\texttt{\textbf{/t: time}}

- Type \texttt{chkntfs /t: time} to specify the time when Chkdsk should be run. This option is used in conjunction with the \texttt{/d} option to set a schedule for automatic checking of drives at boot time.

\texttt{\textbf{/x drive}}

- Type \texttt{chkntfs /x drive} to exclude a specific drive from automatic checking at boot time. This option is used in conjunction with the \texttt{/d} option to set a schedule for automatic checking of all drives except the specified one at boot time.

\texttt{\textbf{/c drive}}

- Type \texttt{chkntfs /c drive} to specify the checking of a specific drive at boot time. This option is used in conjunction with the \texttt{/d} option to set a schedule for automatic checking of only the specified drive at boot time.
Used to change the countdown before this scan is started, during which time the user can press the Spacebar to skip the scan. Time is simply any number, in seconds: `chkntfs /t:A` configures Windows to wait five seconds before running Chkdsk.

`/x drive` Excludes a particular drive from those checked at startup. For example, type `chkntfs /x e:` to exclude drive E: from the auto-check.

`/c drive` Includes a particular drive in those checked at startup; `/c` is the opposite of `/x`. For example, type `chkntfs /c e:` to instruct Windows to check drive E: during startup, and if found "dirty," to run `chkdsk e: /f`.

See Also

Chkdsk

Clipbook Viewer

\windows\system32\clipbrd.exe

View the contents of the Clipboard, manage clipboard data, and share data with other users.

To Open

Command Prompt → `clipbrd`

Description

The Clipboard is merely a place in memory; it's where data is stored when it is cut or copied from most Windows applications. It's not a discrete application and has no interface of its own to speak of. However, the Clipbook Viewer is provided as a "window" into the clipboard, so to speak, as it allows you to view whatever has been placed in the Clipboard without disrupting or interfering with it any way. Furthermore, you can save data into special `.clp` files, making retrieval at a later time — without having to open the original application — easy. This effectively affords us multiple clipboards.

When you first start Clipbook Viewer, it contains a single document called "Clipboard," which displays the current contents of the clipboard at any time. In fact, you can leave open and watch the contents change as you copy and paste items from various programs. For example, if you cut or copy a file in Explorer, you'll see the full path and filename of the object listed in the Clipboard document window. The same goes for plain text, rich text, images, spreadsheet cells, or most other types of data.

Although Clipbook Viewer won't be able to display all types of data accurately, it does correctly preserve the format of the data, so you can safely save and retrieve your clipboards without altering the data. To save the data in the clipboard, select Save from the File menu, type a filename (with the `.clp` extension), and click OK. Then, at a later time, open the file using the Clipbook Viewer (or by double-clicking the `.clp` file in Explorer). You'll be asked whether or not you wish to clear the contents of the clipboard; if you answer yes, the contents of the clipboard will be
replaced with the data stored in the file you've opened. Otherwise, the operation is canceled. Sharing, a mechanism by which clipboard data can be transferred between computers on a network, is not an automatic process. Instead, you must manually paste data to be shared into the Local Clipbook window, a document that should appear alongside the Clipboard document window in the Clipbook Viewer. The security menu allows you to set permissions for your shared data so that only authorized users can get access to it. To access the data on another computer's Local Clipbook, select Connect from the File menu.

**Notes**

- If the Local Clipbook window does not appear in the Clipbook Viewer, the Clickbook Viewer is unable to establish a connection with another computer on your network. Make sure sharing is enabled and properly configured on all computers involved.
- Note that some applications use an "internal" clipboard, allowing information to be copied and pasted only within the application. Data originating from these applications will not show up in the ClickBook Viewer.

---

**Command Prompt**

```plaintext
\windows\system32\cmd.exe
```

The Windows XP command line interface, commonly known as a DOS box.

**To Open**

Start → Programs → Accessories → Command Prompt
Command Prompt → cmd

**Usage**

```
[[/s][/c[/k]] string]
```

**Description**

The Command Prompt (see Figure 4-10) is a simple application in which you type commands rather than pointing and clicking. While the Command Prompt is sparse and may be somewhat intimidating to new users, it carries out several very important functions in Windows XP, including access to otherwise inaccessible programs and utilities and even some advanced file management functions. Appendix C fully documents the command prompt, its commands, and the related Address Bar.

**Figure 4-10.** Use the DIR command to view the contents of the current directory in the Command Prompt
Cmd accepts the following parameters:

```
string
```
When used with /c or /k, specifies a command to be carried out when the command prompt window is first opened. Multiple commands can be specified here if they're separated by &&, and string, as a whole, is surrounded by quotation marks. string must be the last parameter on the command line. See Chapter 7 for more information on the types of commands that can be typed at the command prompt.

```
/c
```
Carries out the command specified by string and then stops.

```
/k
```
Carries out the command specified by string and continues.

```
/s
```
Strips any quotation marks in string. Type `cmd /?` for details.

```
/q
```
Turns the echo off; see echo in Chapter 7.

```
/d
```
Disables execution of AutoRun commands. Without /d, any programs or commands listed in the Registry keys, HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun and HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun are executed every time a command prompt window is opened.

```
/a
```
Formats all command prompt output so that it is American National Standards Institute (ANSI)-compliant.

```
/u
```
Formats all command prompt output so that it is Unicode-compliant.

```
/e:on|off
```
Enables or disables command extensions (the default is on). Turn off command extensions to disable certain advanced features of the commands discussed in Chapter 7.

```
/f:on|off
```
Enables or disables file and directory name completion (the default is off). Type `cmd /?` for details.

```
/v:on|off
```
Enables or disables delayed environment variable expansion (the default is off). Type `cmd /?` for details.

```
/t:
```
Sets the foreground and background colors (f and g, respectively) of the command prompt window. The single-digit values for f and g are as follows:
- 0 = Black,
- 1 = Blue,
- 2 = Green,
- 3 = Aqua,
- 4 = Red,
- 5 = Purple,
- 6 = Yellow,
- 7 = White,
- 8 = Blue,
- 9 = Green,
- a = Aqua,
- b = Red,
- c = Purple,
- d = Yellow,
- e = White,
\* Gray, \* Light blue, A = Light green, B = Light aqua, C = Light red, D = Light purple, E = Light yellow, and F = Bright white.

**Notes**

- Also included with Windows XP is *command.com*, the command prompt used in Windows \*x/Me. It's used similarly to *cmd.exe*, but has limited support of long filenames and other XP features. *Command.com* is included for legacy purposes only and should be avoided; *cmd.exe* is the preferred Command Prompt in Windows XP.
- Refer to the beginning of this chapter for more information on how the command prompt is used to access those programs that don't have Start menu entries.

**See Also**

*Chapter 7*

**Component Services** \`\windows\system\dcomcnfg.exe\`

See [Microsoft Management Console](#).

**Computer Management** \`\windows\system\compmgmt.exe\`

See [Microsoft Management Console](#).

**Connection Manager Profile Installer** \`\windows\system\cmstp.exe\`

An automated connection profile installation utility.

**To Open**

Command Prompt → `cmstp`

**Description**
The Connection Manager Profile Installer is used to automate the installation (or removal) of connection profiles. For example, an Internet service provider or network administrator may build an .inf file containing all the necessary information to connect to another computer or service, and then use the Connection Manager Profile Installer to integrate the information into a particular computer. Type cmstp at any prompt for information on its usage.

**Control Panel**

The Connection Manager Profile Installer is used to automate the installation (or removal) of connection profiles. For example, an Internet service provider or network administrator may build an .inf file containing all the necessary information to connect to another computer or service, and then use the Connection Manager Profile Installer to integrate the information into a particular computer. Type cmstp at any prompt for information on its usage.

**Control Panel**

The central interface for most of the preferences, hardware configuration, and other settings in Windows XP.

**To Open**

Start → Control Panel (when using the new Windows XP Start menu)
Start → Settings → Control Panel (when using the classic Start menu)
Windows Explorer → navigate to the Desktop\My Computer\Control Panel folder
My Computer → Control Panel[i]

[i] Control Panel only appears in the My Computer window if the “Show Control Panel in My Computer” setting is enabled in the Control Panel → [Appearance and Themes] → Folder Options → View tab. Regardless of this setting, however, Control Panel appears under the My Computer branch in Explorer.

**Usage**

`control [filename.cpl] [applet_name]`

`control [keyword]`

**Description**

The Control Panel has no settings of its own; it's merely a container for any number of options windows (commonly called applets or Control Panel extensions), most of which can be accessed without even opening the Control Panel folder. Unfortunately, the Control Panel can look vastly different from one computer to another, based on preferences scattered throughout several dialog boxes. Furthermore, the default settings vary (depending on how Windows XP was installed) (see Figure 4-17). In order to simplify notation in this book, I'm making certain assumptions about your preferences. It's best to familiarize yourself with the various options described below so that you won't be confused when a setting in the Control Panel is referenced.

**Figure 4-16. The category view of the Control Panel (top) is more inviting but also more cumbersome than the standard Control Panel (bottom)**
There are several different ways to access the Control Panel and its contents:

**Start menu**

The way the Control Panel appears in the Start menu depends on several different settings, resulting in no fewer than five different possibilities. If you're using the new Windows XP-style Start menu, right-click on the Start button and select Properties. Click Customize, and then choose the Advanced tab. In the Start menu items list, there are three possibilities for the display of the Control Panel: "Display as a link," which opens the Control Panel folder when clicked, "Display as a menu," which skips the folder and displays the contents as menu items, and "Don't display this item," which hides it from the Start menu altogether. If enabled, the Control Panel entry appears in the second column in the Start menu (see Figure 4-11v).

Figure 4-11v. The Control Panel can be accessed through the Start menu; you'll never see categories here.
If you're using the Classic Start menu (a simpler, cleaner layout, resembling earlier versions of Windows), go to Start → Settings → Taskbar and Start Menu → Start Menu tab, and click Customize. By default, the Control Panel entry, which also appears in the Settings menu, opens the Control Panel folder. If, instead, you want a menu to appear, turn on the "Expand Control Panel" option in the list of "Advanced Start menu options."

**Explorer**

The Control Panel appears as another folder under the My Computer branch. Whether or not the Control Panel icon is configured to be displayed in the My Computer window, it will appear here. Select the folder to display its contents.

**My Computer**

Double-click the My Computer icon on your Desktop; if it's not there, select My Computer from the Start menu. If the Control Panel icon does not appear in the My Computer window, it can be added: go to Tools → Folder Options → View tab and turn on the "Show Control Panel in My Computer" option.

**Command prompt**

At any command prompt, type `control` to open the Control Panel. See [Command-line usage](#), below, for information on opening specific Control Panel applets from the Command Prompt.

**Shortcuts**

In addition to accessing a particular entry by first opening Control Panel, it's possible to open a specific applet directly, either with a standard Windows shortcut, or with one of the many links built into the Windows interface. For example, "Folder Options" is also available in the Tools menu of Windows Explorer, and "Internet Options" is available in the Tools menu of Internet Explorer. To make a standard Windows Shortcut to a Control Panel applet, simply drag the desired icon from the Control Panel folder onto your Desktop or into any folder. Then double-click the icon to open the applet, skipping the Control Panel folder altogether.
Categories

A new, optional feature in Windows XP divides the contents of the Control Panel into discrete categories. Unfortunately, these categories are used only under certain circumstances. In other words, depending on how you access the Control Panel (see above), you may or may not have to make a category selection before you can open the desired applet.

If you have Explorer's "Show common tasks in folders" option turned on (Explorer → Tools → Folder Options → General tab), a separate pane will appear to the left of the contents of any folder, containing links and some summary information. In the case of the Control Panel folder, the first entry in the tasks pane (named either "Switch to Classic View" or "Switch to Category View") allows you to turn categories off or on, respectively. If, on the other hand, the "use Windows classic folders" option is selected (as opposed to the "common tasks" option, above), categories will never appear in the Control Panel. Furthermore, regardless of these settings, categories will never appear when the Control Panel is viewed as a menu through the Start menu.

In addition to containing the icons for most of (but not all) the standard Control Panel applets, the categories have additional links based on the task to be performed. Essentially, these links point to the same icons, only using different language. For a more comprehensive task index than is possible with categories, see Chapter 6.

Since categories are simply an extra, and basically unnecessary, step, you may wish to turn off the category view. This makes the Control Panel easier to use (since you won't have to hunt for applets), allows you to access all Control Panel settings, and ensures that the applets are presented consistently, no matter how you open the Control Panel. See Table 1-2 for the categories in which each applet can be found (where applicable). Note also that two applets, Fonts and Add Hardware, are not found in any category; see Notes, below, for details.

Regardless of the setting you prefer, it's important understand the notation adopted throughout this book. For example, the following instruction shows the category name in square brackets (commonly used to denote an optional step or parameter):

Go to Control Panel → [Appearance and Themes] → Display

If you are using Control Panel categories, include the step in brackets; if you have categories turned off, ignore the bracketed step.

Command-line usage

This section explains how to use control.exe from the command line, most notably for creating Windows shortcuts to specific Control Panel applets. Note that most, but not all, applets can be launched from the command line; see Notes for a workaround. Control.exe supports two command-line methods (see Usage, at the beginning of this section), but no method covers all applets. Control.exe accepts the following parameters:

`filename.cpl`

The filename of the .cpl file (found in \Windows\System\rrr) containing the applet you wish to open. For example, type:

control main.cpl

to open the Mouse Properties dialog. If there's more than one Control Panel applet contained in treelistv.exe .cpl file, and the one you want is not the default, you'll need to specify the `applet_name` (see below) to open it.

`applet_name, tab`

The formal name of the applet you want to launch, spelled and capitalized exactly as described in the table below. This parameter is necessary only if
there's more than one applet contained in a given .cpl file. If you omit applet_name, the default applet in the specified .cpl file will be used. For example, type:
control main.cpl Keyboard
to open the Keyboard Properties dialog. Note that the main.cpl file is the same file as the one in the previous example, but the use of applet_name allows applets other than the default to be opened.
For some tabbed dialogs (but not all), you can also specify the specific tab to open by including a space and then a comma after the .cpl filename (the preceding space is required), and then a number. Specify 1 for the first tab (or omit the tab completely), 1 for the second, and so on. For example, type
control.exe sysdm.cpl, 1 to open the System Properties window to the Advanced tab.

**keyword**

**Keyword** is an alternate way of opening a specific Control Panel applet from the command line. Instead of using filename.cpl and applet_name, simply include one of the following names: admintools, color, date/time, desktop, folders, fonts, international, keyboard, mouse, netconnections, printers, schedtasks, telephony, or userpasswords.

See Table 4-1 for a list of all available Control Panel applets, the category in which they can be found, and how to open them directly from the command line.

<table>
<thead>
<tr>
<th>Applet name</th>
<th>Category</th>
<th>Command line</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessibility Options</td>
<td>Accessibility Options</td>
<td>control access.cpl</td>
</tr>
<tr>
<td>Add Hardware</td>
<td>n/a (see Notes)</td>
<td>control hdwwiz.cpl</td>
</tr>
<tr>
<td>Add or Remove Programs</td>
<td>Add or Remove Programs</td>
<td>control appwiz.cpl</td>
</tr>
</tbody>
</table>
| Administrative Tools | Performance and Maintenance           | control admintools 
 or explorer "\Documents and Settings\All Users\Start Menu Programs\Administrative Tools” |
| Date and Time        | Date, Time, Language, and Regional Options| control timedate.cpl 
 or control date/time |
| Display              | Appearance and Themes                 | control desk.cpl 
 or control desktop 
 or control color (opens the Appearance tab automatically) |
| Folder Options       | Appearance and Themes                 | control folders                                   |
| Fonts                | n/a (See Notes)                       | explorer "\windows\fonts” 
 or control fonts |
| Game Controllers     | Printers and Other Hardware           | control joy.cpl                                   |
| Internet Options     | Network and Internet Connections      | control inetcpl.cpl                               |
All of the applets mentioned here are discussed elsewhere in this chapter. Additionally, all the settings in all Control Panel applets that come with Windows XP are documented in Chapter 1 (arranged alphabetically). Rather than being listed by their location in the interface, settings are arranged alphabetically. That way, you'll be able to find the setting you need without having to figure out where Microsoft decided to place it.

Notes

- Those items with "n/a" in the Command line column of Table 4-4 can't be launched from the command line using `control.exe`. However, it's still possible to launch these (and any other) applets from the command line using a Windows shortcut. Simply drag the desired icon onto your Desktop or into a folder to create a shortcut. Then, to launch the shortcut from the command line, just type its full path and filename, including the `.lnk` filename extension. For example, to launch a shortcut named "Taskbar and
Start Menu" (presumably linked to the applet of the same name), stored in your Stuff folder, type the following to open it:

$stuff$printers and faxes.lnk

- Three Control Panel applets are not in categories, but appear on the top level: Accessibility Options, Add or Remove Programs, and User Accounts.
- Neither Fonts nor Add Hardware are listed in any category, and if you're viewing the Control Panel in Windows Explorer, there's no way to activate either applet without disabling the category view altogether. However, if you have the "Show common tasks in folders" option turned on (Control Panel → [Appearance and Themes] → Folder Options → General tab), and you're viewing Control Panel in a single folder window (no folder tree on the left), Fonts and Add Hardware appear as one of the tasks on the common tasks pane in the "Appearance and Themes" and "Printers and Other Hardware" categories, respectively.
- In previous versions of Windows, control.exe had a property_tab parameter, which allowed you to jump to a specific tab in a tabbed dialog. This parameter appears to be ignored in Windows XP, although you may find some older third-party applets that still support it.
- If you've configured Control Panel to open as a menu in the Start menu, you can open the Control Panel folder by right-clicking on Control Panel and selecting Open or Explore.
- Some applications, software drivers, and hardware drivers come with their own applets, so you may have additional applets in your Control Panel not listed here. Also, depending on your version of Windows XP (Home or Professional), as well as any installed optional components (via Control Panel → Add or Remove Programs), some of the items listed here might not be present in your Control Panel. See the specific entries, elsewhere in this chapter, for details on each of the applets mentioned here.
- Selective Control Panel icons can be hidden with TweakUI (see Appendix D).
- If you've upgraded from an earlier version of Windows and several Control Panel applets appear to be missing, open the Registry Editor, navigate to HKEY_CURRENT_USER\Control Panel and delete the don't load key entirely:

See Also

Chapter 6

Create Shared Folder \windows\system32\shrpubw.exe

Share a folder with other users on the network, either locally or remotely.

To Open

Command Prompt → shrpubw

Usage

shrpubw [/s computer_name]
Description

The easiest way to begin sharing a folder or drive is to right-click on its icon in Explorer, select Sharing and Security, and turn on the "Share this folder on the network" option. However, this procedure only allows you to share local folders. If you need to access an unshared folder on a computer on the other side of the building, for example, you would have to walk over to that computer and enable sharing for the folder while sitting in front of it.

The Create Shared Folder utility not only provides an alternative interface for sharing folders, it also lets you enable sharing of a folder on the remote computer (see Figure 4-1A). Create Shared Folder can almost be thought of as a "back door," enabling access to computer where no such access has been explicitly defined.

Naturally, if you don't have administrative rights on the target computer, you won't be able to do anything. (See Notes, below.)

Figure 4-1A. The Create Shared Folder dialog provides an alternate way to share any folder on your hard disk with other computers on your network

If you run Create Shared Folder with no arguments, it will only let you share resources on the local computer. To share resources on a remote computer, use the /s parameter, like this:

```
shpubw /s lenny
```

When Create Shared Folder starts, the computer named Lenny will appear in the Computer field, and you'll be able to enable the sharing of any available resources on that computer.

Regardless of the computer being manipulated with Create Shared Folder, the interface is extremely simple. Below the Computer field (which can't be changed once the program has started), there are three other fields:

- **Folder to share**
  Enter the full path of the folder you wish to begin sharing (e.g., `c:\my stuff\`) or click Browse to navigate the folder tree.

- **Share name**
  Enter the name under which the folder will be known on the network (e.g., `my stuff`).

- **Share description**
  The description is optional, but a quick note, describing the purpose of the folder, can be very helpful, especially in large organizations. For example:

  `Lenny's Stuff`.

When you're done, click Next to view the second and final page. Here, you can specify the security options for the share, such as which users will be able to read and/or modify the data in the shared folder. Click Finish when you're done, and the new shared folder will appear in the My Network Places folder.

Notes
Based on the type of network you're using, administrative rights may be a little confusing. For example, on a peer-to-peer network, there is no central database of user accounts and passwords. In this case, you would need an identical username and password on each machine, and that user account must have administrative privileges to be recognized as an administrator.

Obviously, this utility redefines security on a network. Just because you haven't explicitly shared a folder doesn't mean someone else can't get access to it. A word to the wise: if your computer resides in a networking environment, which can include ordinary Internet access, you need to be very careful about how you configure user accounts on your system. A further security hazard is the fact that all user accounts in Windows XP Home Edition have administrative privileges.

See Also

Chapter v, User Accounts

**Date and Time Properties**

\windows\system\timedate.cpl

Set your system's clock, choose a time zone, and enable Internet time synchronization (see Figure 4-19).

**To Open**

Control Panel → [Date, Time, Language and Regional Options] → Date and Time
Double-click on the clock in the notification area (Tray)
Command Prompt → timedate.cpl
Command Prompt → control date/time

**Description**

The Date and Time dialog is pretty straightforward. Set your system's clock with the Date & Time tab and your time zone with the Time Zone tab.

**Figure 4-19.** A new feature in Windows XP, Internet Time, will automatically synchronize your PC's clock with Microsoft time
The Internet Time tab allows you to synchronize your PC's clock with one of several Internet time servers automatically. If you turn on the "Automatically synchronize with an Internet time server" option, Windows will synchronize your clock once a week. Naturally, you must be connected to the Internet for this option to work; if you're not connected when Windows attempts to connect to the time server, it will just try again next week. Also, your time zone and daylight savings settings must be set properly; otherwise, the time synchronization will set the wrong time.

Notes

- All settings in this dialog are covered in Chapter 6.
- The default Internet time server, time.windows.com, is Microsoft's own server for Internet time synchronization, but it is not your only choice. You can type the address of any time server here, which is useful if your connection to Microsoft's server is slow or if you get errors when you try to synchronize your PC's clock. There are literally hundreds of time servers on the Internet. To find one that is geographically close to you, find an Internet Time Server list, such as the one at http://www.eecis.udel.edu/~mills/ntp/clock8.htm.

See Also

Control Panel

DDE Share \windows\system 32\deshare.exe

Facilitates Dynamic Data Exchange (DDE) communication over a network.

To Open

Command Prompt ➔ dde.exe

Description

Dynamic Data Exchange is a mechanism that allows one application to send instructions to another. DDE Share extends this functionality by facilitating this
communication across a local network, using the NetDDE protocol. NetDDE is a cross-platform tool, capable of communicating with applications on Windows, DOS, OS/2, Solaris, VMS, and HP/UX systems.

When you start DDE Share, you'll see a simple window with a menu and two unlabeled icons. The two icons correspond to the first two entries in the Shares menu: double-click the icon with the hand holding the blank window to display the DDE Shares window, or double-click the icon with the hand holding the "checked" window to display the DDE Trusted Shares window.

Notes

- The NetDDE service must be running on both machines. (See the Microsoft Management Console, later in this chapter, for more information on services.)
- One of the two computers assumes the role of server, and the other assumes the role of client. On the server machine only, DDE shares must be created; these shares work similarly to shared folders and printers (see Chapter 7), where a particular resource is given a "share name." In the case of Microsoft Chat, this is already done (shared as Chat$).

   If the required entries are not present, you'll need to create them. Unfortunately, DDE conversations are proprietary; that is, the commands involved are decided by the application developer, so you'll have to refer to the documentation that comes with a particular application you're using to determine what type to use in the DDE Share dialogs.

   - Once the shares have been established, the client machine must be set up to use the share from the server. For example, if you're using Chat and the server machine is named Karl, the service/topic pair would be \%\%Karl\%\%NDDE$ and Chat$, respectively.

**Device Manager**

\windows\system\32\devmgmt.msc

Configure all hardware installed in or attached to a computer.

**To Open**

Start → Programs → Administrative Tools → Computer Management → Device Manager
Control Panel → [Performance and Maintenance] → System → Hardware tab → Device Manager
Command Prompt → devmgmt. msc
Keyboard shortcut: Windows logo key + Pause/Break

**Description**

Device Manager is the central interface for gathering information about and making changes to all the hardware installed in a system. Device Manager has an Explorer-style tree listing all of the various hardware categories, as shown in Figure 8-7.
expand any category branch to display all installed devices that fit in that category. For example, expand the Network adapters branch to list all installed network cards in the system. Right-click any device and choose one of the following actions:

**Update Driver**

If you have a newer driver than what is currently installed (find out by using Properties), select Update Driver to locate and install the new driver. This is the preferred way to update drivers in Windows XP, though some devices may have proprietary installation programs and don't support their drivers being updated in this way.

Note that if you've got a driver disk or have downloaded updated drivers for a device, choose the second option, "Install from a list or specific location" on the first page of the Hardware Update Wizard (see Figure 4-28). If you choose the first option, "Install the software automatically," you won't be able to specify the location of the newer driver files.

**Figure 4-20.** Device Manager lets you view and change the settings for nearly any hardware device attached to your system

**Disable**

Select Disable to effectively turn off this device, usually releasing hardware resources it normally consumes. This can be very handy when attempting to resolve hardware conflicts; if you removed the device using Uninstall, discussed below, Windows XP would simply reinstall the device the next time Windows starts.

Disable plays an important role in the use of Hardware Profiles (Control Panel ➔ [Performance and Maintenance] ➔ System ➔ Hardware tab ➔ Hardware Profiles), with which you can set up multiple hardware configurations, each with its own set of enabled devices. For example, say you're using a laptop with a built-in touchpad; when you're on the go, the touchpad is your primary pointing device. However, in your office, your docking station has a mouse attached to it. You could set up two hardware profiles — one that loads the driver for the touchpad and disables the one for the mouse and one that enables the mouse (and other devices...
attached to the docking station) and disables the touchpad. You may not need to go through all this trouble for situations like this, but in the case of the touchpad, you may prefer to have it turned off when you don't need it, as touchpads can sometimes interfere with frequent typing.

**Figure 4-28.** The Hardware Update Wizard walks you through the process of choosing a new driver for an already-attached device

Uninstall
Uninstall is more useful than it might seem on the surface. When you uninstall a device from Device Manager, it completely removes the driver from the system and erases all the corresponding configuration settings for that device. In addition to using Uninstall when you're physically removing a device from your system, it's also very handy when you're experiencing a problem with the device. When you remove a device from Device Manager and restart your computer, Windows will redetect the device and install it as though it were plugged in for the first time; this can be a very useful tool for repairing corrupt installations and fixing all sorts of problems with devices and their drivers.

Note that Uninstall is not the way to force Windows to stop recognizing the uninstall device, since Windows will just reload the driver the next time it starts. Instead, use Disable for this purpose.

Scan for hardware changes
Highlight a device and select "Scan for hardware changes" to force Windows to rescan the device, checking to see if it has been removed, turned on, turned off, or reconfigured in some way.

Highlight a category and select "Scan for hardware changes" to not only scan for changes in the installed hardware, but to force Windows to look for new devices in this category as well. Typically, you'd use Add Hardware Wizard to install new devices. However, this procedure is useful for reattaching devices that have already been installed, such as USB devices or removable hard disks that are attached and reattached repeatedly. Likewise, highlight the root (the entry at the top of the tree, named for your computer) and select "Scan for hardware changes" to scan all categories for newly attached, recently changed, or recently disconnected devices.

Properties
The Properties sheet for any device contains lots of information about the device's driver, the status of the device, and several troubleshooting
features (including those mentioned previously). Information and settings are divided into the following tabbed pages, some of which may or may not be present, depending on the device (see Figure 4-22).

**Figure 4-22.** The Properties sheet for a device on your system also shows whether Windows thinks the device is working

![Communication Port (COM2) Properties](image)

The General tab shows the name, type, and physical location of the device (if applicable). Selecting "Do not use this device" from the Device usage list is the same as selecting Disable, as described previously. The Device status box shows relevant messages stating whether or not the driver is installed properly or whether the device is functioning. The Troubleshoot button only displays on interactive help documents (see Help and Support Center, later in this chapter) relevant to the category in which the device appears, but does not have any specific troubleshooting information for your particular device. Instead, you should check the manufacturer's web site for an updated driver, updated firmware, or more specific troubleshooting information.

The Advanced tab contains settings specific to the device. For example, the Advanced tab for network adapters contains several settings that select which connector type to use (and some other options).

The Driver tab displays several pieces information about the currently installed driver, such as the provider (which corresponds to the distributor, not the manufacturer, of the software), the driver date and version, and whether or not the driver has a digital signature (used to verify the integrity of the driver, available only on drivers designed especially for Windows XP). Click Driver Details to see the individual files that make up the driver, or click Roll Back Driver to uninstall the current driver and replace it with the previously used driver (available only if the driver has been updated since Windows was installed). The Update Driver and Uninstall buttons have the same effect as the actions of the same name, described above.

Finally, the Resources tab lists all the hardware resources consumed by the selected device. Most devices use one or more of the following: a range of memory (expressed as a hexadecimal address), an I/O range (again, expressed as a hexadecimal address), a direct memory access line (DMA) or an interrupt request line (IRQ). Use information on this page to help
diagnose hardware conflicts, where two or more devices try to use the same address or IRQ.

**Notes**

- Open the View menu to rearrange the devices by type (the default) or connection. (Group all PCI devices together and all USB devices together, for example.) You can also arrange devices by the resources they consume. This is useful for resolving conflicts. See the discussion of the Resources tab, under Properties, above, for more information.
- The Show hidden devices entry in the View menu is used to display all currently installed drivers, including those for some of the more obscure "Non-Plug and Play Drivers."

When you remove a drive, card, or other piece of hardware from your computer, Windows does not automatically remove the corresponding drivers, but deactivates them. To remove the drivers for a device you don't plan on reinstalling later on, you should locate the device in Device Manager, right-click, and select Uninstall before you physically disconnect the device.

- Device Manager is a Snap-in, used with the Microsoft Management Console, discussed later in this chapter.
- While Device Manager can be used to configure and remove installed devices, and even add devices by using "Scan for hardware changes," the preferred way to add new hardware is to use the Add Hardware Wizard.
- All branches in Device Manager are collapsed by default; to expand the branches, highlight the root entry and press the asterisk (*) key.

**DirectX Management Tool**  
`\windows\system32\dxdiag.exe`

Test, diagnose, and tweak DirectX drivers.

**To Open**

Command Prompt → dxdiag

**Description**

DirectX is the system that allows applications, usually games, to directly access graphic, audio, and input devices to maximize performance. Unless you're experiencing a problem with DirectX or a program that uses DirectX, you should never need to use the DirectX Management Tool. If you do indeed encounter a problem, such as poor performance, an apparent glitch in a game, an error
message, or some other compatibility problem, use the following steps to diagnose and treat the condition:

1. DirectX relies on hardware drivers, so the first thing you should do whenever you encounter problems with DirectX is make sure you have the latest drivers for your display adapter, sound card, and game controller (if applicable).

2. Next, go to http://www.microsoft.com/directx/ and see if there's a more recent version of DirectX than the one installed on your system. To determine the currently installed version of DirectX, open the DirectX Management Tool and read the DirectX Version of the bottom of the System tab. The initial release of Windows XP ships with DirectX 1.8.

3. If you're experiencing problems only with a certain application or game, check with the manufacturer of that software to see if there's an update or compatibility issue with your specific hardware. Often, manufacturers will post workarounds, patches, or other fixes on their web sites.

4. If you wish to start exploring troubleshooting options, choose the appropriate tab (e.g., display, sound, etc.) in the DirectX management tool and try running the tests. Some of the pages have options that can be turned on or off. You may wish to try disabling certain DirectX features to see if it solves the particular problem you're having.

5. Choose the More Help tab to try one of the interactive troubleshooters, each a series of questions designed to help diagnose and solve DirectX-related problems.

---

**Disk Cleanup**

\windows\system32\cleanmgr.exe

Reclaim disk space by removing unwanted files from your hard drive.

**To Open**

Start → Programs → Accessories → System Tools → Disk Cleanup
Command Prompt → cleanmgr

**Description**

Disk Cleanup summarizes the disk space used by several predefined types of files, such as Temporary Internet Files and items in the Recycle Bin. If you have more than one hard drive, Disk Cleanup prompts you to choose one (see Figure 6-11).

The main window presents a list of file categories from which desired items can be checked to have the corresponding files deleted. The approximate space to be reclaimed by any categories, shown to the right. Here are descriptions of the various categories:

*Downloaded Program Files*

This folder contains mostly ActiveX and Java applets downloaded from the Internet. If you clean out this folder, these components will simply be downloaded again when you revisit the sites that use them.

*Figure 6-11. The Disk Cleanup dialog shows several locations of files that can probably be safely deleted*
Temporary Internet Files
Temporary Internet Files, commonly known as the browser cache, are web pages and images from recently visited web sites, stored in your hard disk for the sole purpose of improving performance when browsing the Web. Deleting the files will have no adverse effects other than requiring that they be downloaded again the next time the corresponding web sites are visited. You can set the maximum size of this folder using Control Panel → [Network and Internet Connections] → Internet Options → General → Settings → Amount of disk space to use. Note that copies of cookie files (regularly stored in \Windows\Cookies\) for IE are also stored in this folder, but are not deleted along with other Internet files.

Recycle Bin
By default, files that are deleted aren't really deleted; they are simply moved to the recycle bin for deletion at a later time. You can empty the Recycle Bin by right-clicking the Recycle Bin icon on your Desktop and selecting Empty Recycle Bin. Right-click the Recycle Bin and select properties to change the maximum amount of disk space allocated to the storage of deleted files (or to disable the Recycle Bin and have files permanently erased immediately).

Temporary Files
Many applications open files to store temporary data, but aren't especially meticulous about deleting those files when they're no longer needed. Application crashes and power outages are other reasons why temporary files might be left behind. The disk space consumed by temporary files, especially after several weeks without maintenance, can be several megabytes.

WebClient/Publisher Temporary Files
These files are essentially the same as the Temporary Internet Files, kept around only for performance reasons, and can be safely deleted as well.

Temporary Offline Files, Offline Files
Temporary offline files are local copies of recently used documents normally stored on remote computers, and marked "Offline." If you take advantage of the "Offline Files" feature in Windows XP, you may wish to examine the files in these folders before you indiscriminately delete them with this utility.

Compress old files
A feature of the NTFS filesystem is that files can be selectively compressed in place. This is a much more advanced version of DriveSpace (the disk
compression utility included with Windows 9x/Me), and somewhat more transparent than .zip files. One of the features of NTFS compression is that "old" files can be compressed automatically to save disk space; the downside is a slight performance hit. Turn on this option to enable compression of all files; don't bother if you don't need the disk space. Click Options to specify the age past which a file is considered "old." See the NTFS Compression Utility, later in this chapter, for more information.

Catalog files for the Content Indexer
The indexing service speeds up file searches by maintaining an index of some files on your hard disk. The index files can be safely deleted and rebuilt automatically.

In addition to the aforementioned categories, the More Options tab provides access to three other tools that can also reclaim disk space:

Windows components
Click Clean up to selectively add or remove optional Windows components; this is the same as Control Panel → Add or Remove Programs → Add/Remove Windows Components.

Installed programs
Click Clean up to selectively add or remove installed applications; this is the same as Control Panel → Add or Remove Programs.

System Restore
This tool allows you to "roll back" your system to an earlier state (say, three weeks ago) before you installed those last seven applications. Although technically, use of this feature can result in reclaimed disk space, it is not an appropriate measure to take simply to increase the amount of free disk space, and should be used with extreme caution.

Disk Defragmenter \windows\system32\dfrg.msc

Reorganize the files and pieces of files on a disk to optimize disk performance and reliability.

To Open
Start → Programs → Accessories → System Tools → Disk Defragmenter
Command Prompt → dfrg.msc

Description

As files on your hard disk are created, modified, and deleted, they become fragmented (so that a single file is physically stored on the disk surface in several noncontiguous pieces). As more files become fragmented, reliability and performance of the drive both diminish. Disk Defragmenter reorganizes the files and folders on any drive so that not only are the files stored contiguously, but free space is also contiguous (see Figure 4-24).

Figure 4-24. Disk Defragmenter rearranges the data on your hard disk for quicker, more reliable operations
Use of Disk Defragmenter is extremely simple. At the top of the window, you'll see a list of the hard drives installed on your system (on many systems, only one drive, c:, will be shown). Highlight a drive and click Defragment to begin the defragmentation process. Or, click Analyze to view a fragmentation report and a recommendation; note that Disk Defragmenter will claim that defragmentation is unnecessary if the percentage of fragmented files in the drive is lower than about 1 percent. Note the map, signifying the files on your disk; refer to the legend of the bottom of the window for the meanings of the various colors. Defragmentation can take anywhere from 81 seconds to an hour, depending on the speed of your drive, the level of fragmentation, and the amount of data to move.

Notes

- Disk Defragmenter is a "snap-in," a component used with the Microsoft Management Console (discussed later in this chapter). You can open it via its icon on the Start menu, by launching dfrg.msc, or by opening MMC and installing the Disk Defragmenter snap-in.
- You can run other programs while Disk Defragmenter runs in the background, but this is not recommended for several reasons. Not only will writing to the disk interfere with Disk Defragmenter, causing it to restart repeatedly, but defragmenting a drive can slow system performance substantially.
- With Scheduled Tasks, you can run Disk Defragmenter when you're away from your system (for example, every Sunday night).

See Also

Chkdsk, Scheduled Tasks

**DiskPart**

\windows\system 32\diskpart.exe

Prepare and partition a hard disk.

To Open
Command Prompt → diskpart

**Description**

DiskPart is a full-featured program used to prepare hard disks and, optionally, divide them into two or more partitions. It's a command-line program and has no interface to speak of. When you start DiskPart, you'll see a simple prompt: `DISKPART>`. Type `help` and press Enter to view a list of all the available commands:

- **add**
  Add a mirror to a simple volume (Windows XP Server / Advanced Server only).

- **active**
  Activate the current basic partition so that it can be used as a boot disk; using it is not necessary if there's only one partition in the volume.

- **assign**
  Assign a drive letter or mount point to the selected volume. Note that it may be easier to use the Disk Management tool; see the Microsoft Management Console for details.

- **break**
  Break a mirror set (undoes the `add` command).

- **clean**
  Clear the configuration information, or all information, off the disk; this effectively erases the disk.

- **convert**
  Convert between different disk formats; most users will never need this command.

- **create**
  Create a volume or partition; this is the first step in preparing a hard disk.

- **delete**
  Delete an object (undo the `create` command).

- **detail**
  Display details about a disk, partition, or volume. Note that you'll need to use `select` first.

- **exit**
  Exit DiskPart (Ctrl-C also works).

- **extend**
  Extend a volume.

- **import**
  Import a disk group.

- **list**
  Print out a list of object; similar to `detail`.

- **online**
  Change the status of the disk from offline to online.

- **remove**
  Remove a drive letter or mount point assignment (undo the `assign` command). Note that it may be easier to use the Disk Management tool; see Microsoft Management Console for details.

- **rescan**
  Rescan the computer looking for disks and volumes.

- **retain**
  Place a retainer partition under a simple volume.

- **select**
  Choose a disk, partition, or volume to view or modify. Even if you have only one disk or partition, you'll still need to `select` the object before carrying out any other commands. Use `list` to obtain object numbers for use with `select`, and then use `detail` to get more information.
Each of these commands (with the exception of `exit`) has one or more subcommands. For example, if you simply type `detail` at the prompt, you'll get a list of the subcommands for use with the `list` command: `disk`, `partition`, and `volume`. So, to display a list of all the disk volumes on the system, you would type:

```
list volume
```

and you'll get a report that looks something like this:

```
Volume ##  Ltr Label       Fs     Type       Size     Status   Info
--------- ------ --------- -------- ------- -------- ------- -------
Volume 1  D  XPPCORP_EN  CDFS   CD-ROM   422 MB    
Volume 1  C  Hard Disk   NTFS   Partition  21 GB    Healthy System
```

From the report, it is clear that drive C: is Volume 1; the next step is to select the volume, like this:

```
select volume 1
```

Subsequent commands will then apply to the currently selected volume.

**Notes**

- Disk partitioning is tricky business and unless you're preparing a new drive, you'll probably never need to use DiskPart. If you need to repartition a drive that you're currently using, DiskPart is not the way to go, as it will erase any drive you attempt to repartition. A better choice is to use PartitionMagic by PowerQuest (http://www.powerquest.com/), which allows you to add, remove, and resize partitions without destroying the data they contain.
- DiskPart replaces the Fdisk utility found in Windows 2x/Me.

**See Also**

Microsoft Management Console

**Display Properties**

Change the appearance of the Desktop and most application windows, choose a screensaver, and change the settings of your display adapter and monitor.

**To Open**

Control Panel ➔ [Appearance and Themes] ➔ Display
Right-click on an empty portion of your Desktop ➔ Properties
Command Prompt ➔ `desk.cpl`
Command Prompt ➔ `control desktop`
Command Prompt ➔ `control color`

[i] This opens the Display Properties window and automatically switches to the Appearance tab.

**Description**
The Display Properties window allows you to configure a wide variety of settings that affect the Desktop, display, and appearance of just about anything on the screen (see Figure 4.21).

Figure 4.21. Configure the appearance of most screen elements in Windows with Display Properties

Settings are divided into the following tabs:

**Themes**

A theme is a name under which a collection of display settings is saved. After you've selected the preferences in the other tabs in this dialog, click Save As to create a new theme. Then, if you ever make a subsequent change, you can easily revert back to your saved preferences by selecting the desired theme from the Theme list. Don't confuse themes with styles (available in the Appearance tab).

Saving your theme is a good idea, as it will allow you to restore your settings easily if they're ever changed. It also allows you to quickly switch between multiple groups of settings, which is useful, for example, if you use two different monitors. When you click Save As, you'll be prompted to enter a filename with the .theme filename extension. However, the default folder for these files is My Documents, which is not where Windows looks for themes when it populates the Theme drop-down listbox. To have your theme listed in the Theme list, save your .theme file in the \Windows\Resources\Themes folder.

Due to a strange quirk in the way Windows XP handles themes, several other Control Panel settings will be reset whenever you change the theme. Preferences like your mouse pointers (see Mouse Properties), sound scheme (see Sounds and Audio Devices), and your Media Player skin (see Windows Media Player) will all revert to their defaults. What's even more confusing is that while these settings appear to be linked to the Themes setting in Display Properties, none of them are actually saved with your theme when you click Save As.

**Desktop**

The Desktop tab allows you to select a background image. If no background image is selected, a solid color is used (set by the Color option here or by Appearance ➔ Advanced). The background image (also called wallpaper) can be centered (displayed actual size in the middle, surrounded by the background color if it's not big enough), tiled (repeated so it fills the
Click Customize Desktop to selectively show or hide the My Documents, My Computer, My Network Places, and Internet Explorer icons on the Desktop (see Figure 4-21). You can also change the icons for My Computer, My Documents, My Network Places, and the Recycle Bin. The Desktop cleanup section helps remove less frequently used Desktop icons.

Note that most items on the Desktop are merely shortcuts and other files, stored in the folders \Documents and Settings\{username\}\Desktop and \Documents and Settings\All Users\Desktop. See Desktop in Chapter 7 for details.

**Figure 4-21.** Selectively show or hide certain Desktop icons with the Desktop Items dialog

---

**Screen Saver**

Years ago, monochrome monitors, when left on for long periods of time, would be ruined when the images displayed would get "burned in." So, screensavers were invented, which blanked the screen after a certain period of inactivity. It wasn't long before screensavers started showing animations instead of just a blank screen. Today, the concept of monitor burn-in is obsolete, but screensavers are still fun and can even provide security from prying eyes by obscuring the screen when you walk away from your computer. Choose from one of the available screensavers here and click Settings to configure it or Preview to see it in action (see Figure 4-21).

---

[At one time, the After Dark screensaver (made by Berkeley Systems, famous for their "Flying Toaster" animation) was the bestselling software program in the world. For some reason, the screensaver frenzy appears to have died down.]

**Figure 4-21.** Select and configure a screensaver with the Screen Saver tab
Choose the length of inactivity before the selected screensaver is activated. A computer is considered inactive if no mouse or keyboard entry is received; updates to the screen, such as progress indicators or animations don't count and won't stop a screensaver from being invoked. Use the "On resume, password protect" feature to lock up access to the computer once a screensaver has been invoked.

Third-party screensavers are plentiful; one of my favorites is Jim Sachs' fabulous SereneScreen Aquarium (http://www.serenescreen.com/), of which a scaled-down version is included in the Microsoft Plus! add-on for Windows XP, and even comes preinstalled with some copies of Windows XP. Note that the screensaver can interfere with some programs, so you may want to temporarily disable it if you're experiencing a problem backing up to tape or burning a CD, for example.

Any particular screensaver can also be started from the command line or from Windows Explorer by launching the corresponding .scr file.

Appearance
The following settings are available in the Appearance tab:

Windows and buttons
See the discussion of Styles at the beginning of Chapter 7.

Color scheme
Save your color selections into a scheme, which is a subset of the theme selection (see the Themes tab, above).

Font size
If you're having trouble reading the text on your screen, try adjusting the font size here. Better yet, click Advanced and choose the typeface and size for each screen element independently.

Effects
Choose visual goodies, such as animation, fading, and shadows. These settings are really just eye candy and can significantly slow down your system (see Figure E-YA). See System Properties, later in this chapter, as well as TweakUI in Appendix D, for additional related options.

Figure E-YA. You can make Windows seem faster and more responsive by turning off some of the visual effects
Advanced

This window allows you to choose the colors and fonts for all of the various screen elements. Choose the desired element from the Item list and change any available options to your liking. In addition to colors and fonts, you can also change the spacing of Desktop icons, the thickness of titlebars and menus, and even the colors of buttons (see Figure 4.22).

Figure 4-22. Even though the preview here always shows the classic style, this dialog can be used to configure some aspects of the new Windows XP style as well.

Although the preview in the Advanced dialog is shown using the "Classic" style, most settings will apply regardless of the selected style. For example, you can shrink down the huge titlebars that are the default in the Windows XP style by choosing "Active Title Bar" from the Item menu and changing Size to something more reasonable, such as 20. Note, however, that you can't change any of the colors when using the Windows XP style (other than using the "Color scheme" listbox under the Appearance tab, discussed above), a limitation that will hopefully be lifted in subsequent versions of Windows.

Settings

Last, but not least, comes the Settings tab, which allows you to change your display hardware settings (see Figure 4-23). Here, you can choose the resolution and color depth of your screen. There are two limitations of your video card that may affect the settings here. First, the amount of memory
on your video card dictates the maximum color depth and resolution you can use. The memory required by a particular setting is calculated by multiplying the horizontal size times the vertical size times the bytes per pixel. If you're in $\pi$-bit color mode, then each pixel will require $\pi$ bits, or $\epsilon$ bytes (there are $\lambda$ bits/byte). At a resolution of $1,245 \times 787$, that's $1,245 \times 787 \times \epsilon$ bytes/pixel, or about $1,\epsilon\lambda\epsilon\MB$. Therefore, a video card with $\epsilon\MB$ of video memory will be able to handle the display setting, but a card with only $\gamma\MB$ will not. As you adjust your color depth, Windows may automatically adjust other settings depending on your card’s capabilities. If you increase your color depth, your resolution might automatically decrease; likewise, if you raise the resolution, your color depth might go down.

**Figure 4-50.** Choose your screen resolution, color depth, and multiple monitor setup with the Settings tab

The other limitation that may affect your available settings is the refresh rate that your card will be able to generate. Although the maximum refresh rate does not depend on the amount of your card’s memory, you may have to lower your resolution to achieve the desired rate. Windows should automatically adjust your refresh rate to the highest setting your card supports, but this is not always the case. If you notice that your display appears to be flickering, especially under fluorescent lights, you'll need to raise your refresh rate, either by adjusting the refresh rate setting directly or by lowering your resolution or color depth. (Note that this does not apply to flat-panel or laptop displays, which never flicker.) Consequently, if you hear a slight whine from your monitor, it means your refresh rate is too high. The minimum refresh rate you should tolerate is $\pi\nu$ Hz. People with corrective lenses seem to be more sensitive and might require a higher setting to be comfortable. Most cards available today support refresh rates of $\nu\nu\nu$ Hz and higher, so this is usually not a problem. Click Advanced and choose the Adapter tab. If your display driver supports it, you can adjust your refresh rate with the Refresh Rate setting. If the setting is not there, you'll either need to obtain a more recent video driver, reduce your resolution or color depth, or get yourself a better video card. If you have more than one monitor, either using two separate video cards or a single video card that supports two monitors, all configured screens will be
shown in the preview area. Click any screen icon to activate it; the settings below apply only to the selected monitor. You can even drag-drop monitor icons to rearrange them so that, for example, a different monitor assumes the role of the upper left. Click Identify, below, if you’re not sure which monitor is #1 and which is #r.

The Advanced button allows you to view the hardware properties for your video adapter(s) and monitor(s). You’ll really never need to adjust these settings unless you’re updating a driver for your monitor or display adapter, adjusting your refresh rate (see above), or configuring color profiles (for matching the color output of your printer with your scanner and monitor).

**Notes**

- All of the settings in this dialog are also covered in Chapter 9.
- A bug in Windows’ handling of themes may cause your sound scheme and mouse pointer schemes to revert to their defaults whenever you change the display theme. However, neither the sound nor mouse schemes are saved with the display theme.
- No piece of hardware inside or attached to your computer is more important, in my opinion, than your monitor (with the possible exception of the keyboard and pointing device). A bad monitor can give you headaches, not to mention neck and back pain. I strongly recommend one of the newer flat-panel displays, if you can afford them; in addition to consuming less desk space and power, the better ones actually provide superior image quality and color reproduction than any CRT.

**See Also**

[Control Panel](#), [Chapter r](#)

**Dr. Watson**

\windows\system\d\drwatson.exe; \d\r\w\\t\s\n\r\n\e\x\e;

Records system error information when a system error occurs.

**To Open**

Command Prompt ➔ drwatson (start daemon)
Command Prompt ➔ drwtsnrr (change settings)
Start ➔ Programs ➔ Accessories ➔ System Tools ➔ System Information ➔ Tools menu ➔ Dr Watson (change settings)

**Description**

Dr. Watson is a diagnostic tool that records information on the internal state of Windows when a system error occurs. It collects information such as system details, running applications, startup applications, kernel drivers, and user drivers. Although the reports that Dr. Watson produces are of little use to most users, they diagnostic information that may be helpful to developers and Microsoft support technicians for diagnosis of the problem.
If activated, Dr. Watson waits invisibly in the background until a system error occurs, at which time a dialog box appears, asking for comments on the activities prior to the error. The comments you type will be added to a file as long as you select File → Save or File → Save As from the dialog. The two available formats include Dr. Watson log files (.wlg) and plain text files (.txt). The default is a .wlg file, and is recommended if you want to subsequently use the Dr. Watson application to view a GUI version of the information. If Dr. Watson detects a fault that might not be fatal, you'll have the opportunity to ignore the fault or close the application. If you choose to ignore the fault, Windows continues without performing the faulting instruction. You might be able to save your work in a new file at this point, but you should then restart Windows.

**See Also**

[System Properties](#), (Specifically, the topic of error reporting in the Advanced tab).

**Driver Verifier Manager**

\windows\system32\verifier.exe

A tool for monitoring Windows kernel-modedrivers and graphics drivers.

**To Open**

Command Prompt → verifier

**Description**

Driver Verifier Manager is included with Windows XP (primarily for hardware manufacturers to test their drivers to ensure that drivers are not making illegal function calls or causing system corruption).

**Notes**

For more information on using the Driver Verifier Manager, see [http://www.microsoft.com/hwdev/driver/Verifier.asp](http://www.microsoft.com/hwdev/driver/Verifier.asp).

**DriverQuery**

\windows\system32\driverquery.exe

Display a list of the installed device drivers and their properties. (DriverQuery is included with Windows XP Professional only.)

**To Open**

Command Prompt → driverquery
Usage


Description

Although Device Manager (see Microsoft Management Console) displays a hierarchal view of all of the devices attached to the system, only Driver Query provides a comprehensive list for every installed driver, either on a local machine or on any remote computer on the network.
Run DriverQuery without any options to print out the basic list, or use one of the following options:

/fo format
   Specify the format of the display: type /fo table (the default) for a formatted table, /fo list for a plain text list, or /fo csv for a comma-separated report, suitable for importing into a spreadsheet or database.

/nh
   If using the /fo table or /fo csv format (above), the /nh option turns off the column headers.

/v
   Display additional details about driver other than signed drivers.

/si
   Display additional details about signed drivers.

/s system
   Connect to a remote system, where system is the name of the computer.

/u user
   Specify a user account (include an optional domain before the username) under which the command should execute.

/p password
   Specify the password for the user account specified with the /u parameter; prompts for the password if omitted.

Notes

Refer to Appendix C for information on redirecting the output of this program to a text file, making it easy to save or import into a spreadsheet or database application.

Event Viewer

\windows\system32\eventvwr.exe

See Microsoft Management Console.

Explorer

See Windows Explorer.
**FAT to NTFS Conversion Utility**

Convert a drive using the File Allocation Table (FAT) filesystem to the more robust NT File System (NTFS).

**To Open**

Command Prompt → `convert`

**Usage**


**Description**

The filesystem is the invisible mechanism on any drive that is responsible for keeping track of all the data stored on the drive. Think of the filesystem as a massive table of contents, matching up each filename with its corresponding data stored somewhere on the disk surface. The File Allocation Table (FAT) file system first appeared in DOS, and has been the basis for each successive version of Windows, including Windows 9x, Windows 98, and Windows Me. A slightly improved version of FAT, called FAT16, was introduced in Windows 9x OSR2 and included support for larger drives and smaller cluster sizes.

Meanwhile, the Windows NT/Windows 2000 line of operating systems also supported the newer and more robust NTFS filesystem. Among other things, NTFS provides much more sophisticated security than FAT or FAT16 does, as well as encryption and compression. However, NTFS and FAT/FAT16 are not compatible with each other, and since Windows 9x/Me doesn't support NTFS, you'll need to stick with FAT or FAT16 if you intend to have a dual-boot system. Furthermore, if you've upgraded from Windows 9x/Me, your drive probably still uses the FAT or FAT16 filesystem.

This tool is used to convert a FAT or FAT16 drive to an NTFS drive without damaging the data stored on it. To convert drive c:, for example, type the following:

```convert c: /fs:ntfs```

The following options are also available:

- `/v` Run the Conversion Utility in verbose mode (provide more information).
- `/cvtarea: filename` Specify a contiguous file in the root directory as the placeholder for NTFS system files.
- `/nosecurity` Include this parameter if you want the initial security privileges for all files and folders on the newly converted volume to be set so the files and folders are accessible by everyone.
- `/x` Force the volume to dismount first — if necessary, closing any opened files on the volume. Use this option if you're on a network and concerned that
other users may disrupt the conversion by accessing your drive during the process.

Notes

To determine the filesystem currently used on any drive, right-click the drive icon in My Computer or Explorer, and select Properties.

See Also

Chntfs, DiskPart

Fax Console \windows\system32\fxsclnt.exe

Manage incoming and outgoing faxes using the Microsoft Fax service.

To Open

Start ➔ Programs ➔ Accessories ➔ Communications ➔ Fax ➔ Fax Console
Command Prompt ➔ fsclnt

Description

The Fax Console is the central interface for sending, receiving, and managing faxes using the Microsoft Fax service (see Figure 4-58). The Fax Console is set up like Outlook Express, with folders shown in a hierarchical tree in the left pane and the contents of the currently selected folder shown in the right pane.

Figure 4-58. View and manage all incoming and outgoing faxes with the Fax Console

The first time you run Fax Console, the Fax Configuration Wizard will appear, which will ask for your personal contact information, primarily for use with cover pages. All of the fields are optional and can be left blank. This information can be entered later by going to Tools ➔ Sender Information.

There are two ways to send a fax using the Microsoft Fax service. The first, using File ➔ Send a Fax (which is the same as running fsasendm.exe or selecting Start ➔ Programs ➔ Accessories ➔ Communications ➔ Fax ➔ Send a Fax), walks you through selecting a document and then creating a corresponding fax job.

The preferred method of sending a fax, though, is to start the application used to create the original document (e.g., your word processor or spreadsheet) and print
to your fax printer. Indeed, the fax is really only a remote printer connected with a phone line. After your application has sent the document to the fax printer driver, a new Wizard appears and asks you for the recipient name and phone number, as well as any queuing options (useful if you wish to postpone sending the fax until off-peak hours).

Start the Fax Monitor (Tools → Fax Monitor) to automatically answer incoming calls and receive faxes. If you don't want the Microsoft Fax service to automatically answer incoming calls, you can selectively receive faxes by going to File → Receive a fax now.

Notes

- Not surprisingly, if you don't have a modem, you won't be able to send or receive faxes. However, Fax Console will let you view and export fax documents you may have already stored on your hard disk; use File → Import to view faxes created in previous versions of Windows and File → Save As to export them to a more usable format.
- If you wish to receive faxes but don't have a modem, or if you just don't want to leave the Microsoft Fax service running all the time, there are Internet-based fax services (such as http://www.efax.com), some of which are completely free, that send incoming faxes to you as email attachments.
- An alternative to using faxes is to email documents and scans. A program like Adobe Acrobat (http://www.adobe.com) is especially useful for preserving fonts and formatting in computer-generated documents, and can even accommodate scanned pages, making it easy for the recipient to view or even print them. Not only will this result in higher quality documents and lower phone bills, but it might save a few trees.
- To send a fax on the fly, place a shortcut to the Fax icon in your Printers and Faxes folder in your Send To menu. Then right-click any file and select Send To → Fax to quickly fax the document. Note that this won't work for all document types, so a little experimentation may be required.

See Also

Fax Cover Page Editor, Windows Picture and Fax Viewer

Fax Cover Page Editor \windows\system \r\fxcover.exe

Create and modify cover pages for use with the Microsoft Fax service.

To Open

Start → Programs → Accessories → Communications → Fax → Fax Cover Page Editor
Fax Console → Tools → Personal Cover Pages → New (or) Open
Command Prompt → fxcover

Description
The Fax Cover Page Editor works like an ordinary drawing/layout program, in that you can indiscriminately place text, shapes, and images on a blank page. Pages created with the Cover Page Editor are used automatically when sending faxes with the Microsoft Fax service. What makes the Cover Page Editor different from other drawing/layout programs to which you might be accustomed is its support for fields. Naturally, it wouldn't do you much good to create a custom cover page for only a single recipient; rather, it is desirable to create a single cover page (or series of cover pages) that can be used with any number of recipients. Use the Insert menu to place text fields on the page; fields are divided into the following three categories (menus):

**Recipient**
Place the name or phone number fields on your cover page and Microsoft Fax will insert those details of the recipient on each fax that is sent out.

**Sender**
The information in the Sender menu does not change from fax to fax; rather, it is set in the Fax Console application (discussed earlier in this chapter) by going to Fax Console → Tools → Sender Information. Note that it's generally preferred to use fields rather than static text, even if the information contained therein is the same for all faxes — it not only makes it easier to change later on, but means that your cover pages can be used easily by others.

**Message**
Like items in the Recipient menu, above, Message details the message change from fax to fax, such as the subject, time, date, and number of pages.

When you've created or modified the cover pages desired, you must save it into a Cover Page (.cov) file, stored, by default, in Documents and Settings\{username\}\My Documents\Fax\Personal Coverpages. Then, when sending a fax, simply specify the desired Cover Page file, and it will be used as the first page in your outgoing fax. You may wish to preview outgoing faxes immediately after creating or modifying a cover page to make sure information is inserted into the fields properly.

**See Also**

Fax Console

**File Compare (comp)** \windows\system  \comp.exe

Compare the contents of two files (or sets of files) byte-by-byte and display the differences between them.

**To Open**
Command Prompt → comp

**Usage**
Description

File Compare (comp.exe) compares two files (or more, using wildcards), and reports whether or not the files are identical. If the files are identical, comp.exe will report Files compare OK. If the files are the same size but have different contents, comp.exe displays the differences, character-by-character, by reporting Compare Error at OFFSET n (where n is byte offset — the location of the difference, in characters, from the beginning of the file). If the files are different sizes, comp.exe reports Files are different sizes, and the comparison stops there.

Here are the options for comp.exe:

`file1, file2`
Specify the filenames of the files to compare. For any files that aren't in the current directory, you'll need to include the full path. If `file1` includes a wildcard, all matching files are compared to `file2`. Likewise, if `file2` includes a wildcard, each matching file is compared to `file1`. If one or both of these parameters are omitted, Comp.exe will prompt you for the files to be compared.

`/n= number`
Include the /n option to compare only the first specified number of lines in the files, or omit to compare the entire files. For example, specify `/n=5` to check on the first five lines in each file.

`/c`
Disregard the case of ASCII characters; upper and lower case letters are treated as identical.

`/offline`
Comp.exe normally skips files marked as "offline." Specify /offline (or just /off) to include offline files as well. (See Synchronization Manager, later in this chapter for more information on offline files.)

`/d`
Displays differences in decimal format.

`/a`
Displays differences in ASCII characters. The /a option is the default, so specifying it has no effect.

`/l`
Include line numbers in any output.

Notes

- Windows XP actually comes with two file comparison utilities, comp.exe (this one) and fc.exe (discussed in the next section). Comp.exe performs a character-by-character comparison, but only displays differences if the files are exactly the same size. Fc.exe performs a line-by-line comparison and works regardless of the file sizes. For most users, fc.exe will be the tool of choice, as it displays the differences between the files and doesn't have any prompts, so it can be used from a WSH script or batch file.

- Regardless of the outcome of the comparison, comp.exe will ask if you want to perform another comparison. There's no way to disable this prompt, but you can use the input redirection character (see Appendix C), like this:

  ```
  comp file1 file2 <n
  ```

  which "types" the letter n at the prompt automatically, disabling the prompt.
**File Compare (fc)**

Compare the contents two files (or sets of files) line by line and display the differences between them.

**To Open**

Command Prompt → fc

**Usage**

```plaintext
```

**Description**

File Compare (fc.exe) compares the contents of two files (or more, using wildcards) and displays the differences (if any). If the files are identical, fc.exe will report **FC: no differences encountered**. If the files are different, fc.exe lists the differing lines. Here's an example of how fc.exe is used:

Start with an ordinary text file, say, `Bill.txt`. Open it in Notepad, change one line, and save it into a new filename, say, `Marty.txt`. Then open a command prompt window, make sure you're in the same directory as the two files, and type the following:

```plaintext
fc bill.txt marty.txt
```

The output will look something like this:

Comparing files Bill.txt and Marty.txt

***** Bill.txt
Way down Louisiana close to New Orleans
Way back up in the woods among the evergreens
There stood a log cabin made of earth and wood
***** Marty.txt
Way down Louisiana close to New Orleans
Way back up in the woods among the antihistamines
There stood a log cabin made of earth and wood
*****

For each line or sequence of lines that is found to differ in the two files, fc.exe prints out a pair of excerpts from each of the files. The first and last line in each excerpt are what the two files have in common and are included for context. The lines in between (only a single line in this example) show the differences. The report will include one pair of excerpts for each difference found; if there are three
nonconsecutive differing lines, there will be six excerpts. Here are the options for
**Comp.exe:**

```
file1, file2
```

Specify the filenames of the files to compare. For any files that aren't in the
current directory, you'll need to include the full path. If `file1` includes a
wildcard, all matching files are compared to `file2`. Likewise, if `file2` includes
a wildcard, each matching file is compared to `file1`. Both parameters are
required.

/a

Display only first and last lines for each set of differences, as opposed to the
default of every different line. This option is only applicable if a single
sequence of differing lines (resulting in a single excerpt pair) is three lines or
longer; otherwise, /a has no effect.

/c

Disregards the case of ASCII characters; upper- and lowercase letters are
treated as identical.

/lb n

Specify the maximum consecutive mismatches; /lb\# will list only the first \#
differing lines. If omitted, the default is 10 maximum mismatches.

/n

Include line numbers in the report.

/t

Preserve any tabs in the files being compared. By default, tabs are treated
as spaces with \1 tab = \ spaces.

/w

Compress whitespace (tabs and spaces) to a single space for comparison.
Possibly useful when comparing .html files, as web browsers will eliminate
redundant tabs in spaces as well.

/offline

**Fc.exe** normally skips files marked as "offline." Specify /offline (or simply
/off) to include offline files as well. (See **Synchronization Manager**, later in
this chapter, for more information on offline files.)

/nnn

Specify the number of consecutive lines that must match after a mismatch.
For example, if you specify /\#, a mismatched line followed by \# matching
lines, followed by one or more mismatched lines, is treated as though it
were a single sequence of mismatched lines in the report.

/l

Treat the files as ASCII (plain text). Since /l is the default, it has no effect.

/u

Treat the files as unicode text.

/b

Treat the files as binary and perform the comparison on a byte-by-byte
basis (similar to **comp.exe**, the other file comparison utility). Instead of the
pairs of excerpts explained above, differing bytes are displayed in parallel
columns. A binary comparison is typically only appropriate for files of the
same sizes, but unlike **comp.exe**, the comparison will still be performed if
they are different sizes. The /b option can't be used in conjunction with any
of the other options.

**Notes**

- Windows XP actually comes with two file comparison utilities, **comp.exe**
discussed in the previous section) and **fc.exe** (this one). **comp.exe** performs
a character-by-character comparison, but only displays differences if the
files are exactly the same size. fc.exe performs a line-by-line comparison and works regardless of the file sizes. For most users, fc.exe will be the tool of choice, as it displays the differences between the files and doesn't have any prompts, so it can be used from a WSH script or batch file.

- **Fc.exe** is most useful when comparing two different, but similar, text files. For example, you can compare two Registry patches (since .reg files are plain text files) made at two different times to see what changes have been made. See Chapter A for more information on Registry Patches.

- Although fc.exe can compare two binary files, if you try to compare two word processor documents (.doc and .wpd files are binary files), the results won't be terribly helpful. Try converting the documents to an ASCII-based format, such as .rtf or .html, and then perform an ASCII comparison. Naturally, most modern word processors have their own document comparison tools, but they can often be limited; while word processors may miss subtle formatting changes, fc.exe will catch every single difference.

### File Expansion Utility

Extract one or more compressed files from a cabinet (.cab) file.

**To Open**

Command Prompt ➔ expand

**Usage**

```
expand -d source.cab [-f:files]
expand [-r] source.cab [destination]
expand [-r] source.cab [destination]
expand source.cab -f:files destination
```

**Description**

A cabinet file is a compressed archive commonly used to package application installation files. The File Expansion Utility is used to extract files embedded in these cabinet files and takes the following options:

- **source.cab**
  - The name of the cabinet (.cab) file from which to extract the files.

- **destination**
  - The name of the folder in which to place the extracted files, a new filename to use for the extracted files, or a combination of the two. If using the `-f` option, **destination** is mandatory and must include a filename (with or without wildcards).

- **-d**
  - Display (list) the contents of the specified cabinet file.

- **-r**
  - Specify `-r` (recursive) without **destination** to extract all the files contained in the specified cabinet file. For example:
expand -r package.cab
Specify -r along with destination to rename the files according to the file specification included in destination. For example, the following extracts all the files in package.cab and renames their file extensions to .txt:
expand -r package.cab *.txt

-f: files
Use the -f option to specify one or more files to extract; use this if you don’t want to extract all the files from the cabinet file. For example, the following extracts the file uno.txt from package.cab:
expand package.cab -f:uno.txt uno.txt
Note that the destination parameter is mandatory when using the -f option and is used to specify the target filename. In this example, as well as most times this program will be used, files and destination will be the same.

Notes

The easiest method for extracting files from cabinets is to simply double click the .cab file in Explorer and then drag the desired file(s) out. Since expand.exe is a command-line program, it is better suited for use with WSH scripts and batch files. It can also be used when installing or repairing Windows XP when Explorer isn’t available.

See Also

Cabinet (CAB) Maker, System Configuration Utility

File and Settings Transfer Wizard \windows\system32\usmt\migwiz.exe

Helps you transfer files and settings from one computer to another.

To Open

Start ➔ Programs ➔ Accessories ➔ System Tools ➔ File and Settings Transfer Wizard
Command Prompt ➔ %windows%\system32\usmt\migwiz

Description

The File and Settings Transfer Wizard is a step-by-step guide that walks you through the process of transferring your personal documents, contents of your Favorites folder, Internet Explorer and Outlook Express settings, Desktop and display preferences, dial-up connections, and other settings from one computer to another (see Figure 4-11). The wizard is intended to assist the migration of these files and settings from an "old" computer to a "new" computer, but could be used to duplicate a configuration across several computers just as easily, or even to assist you in upgrading your hard disk.
The File and Settings Transfer Wizard helps you migrate your personal documents and preferences to a new computer.

![The File and Settings Transfer Wizard](image)

The first question the wizard asks is whether the computer being used is the "new computer" (the machine to receive the files and settings) or the "old computer" (the machine on which the files and settings are currently stored). Although you can begin the process from either computer, it makes more sense to start off from the old computer (unless the old computer is not running Windows XP).

If you choose "Old Computer," the next step is a choice between the following:

**Direct cable**

A direct cable connection uses a cable, commonly known as a null modem cable or LapLink cable, to connect two computers for the purpose of the transfer of data. Although it's much cheaper to set up than a network, the speed is glacial by comparison.

**Home or small office network**

This option uses a Microsoft Windows peer-to-peer network to transfer data between the two machines. Note that this choice may be disabled if another Windows XP system is not found on the network or if the network does not have all the required protocols installed. If this option is unavailable, you can still utilize your network using "Other," below.

**Floppy drive or other removable media**

If you have a zip drive, writable CD drive, writable DVD drive, removable hard disk, or some other removable cartridge drive, the wizard will place the necessary files on the media for later use on the new machine. Note that either the target (new) computer must also have the same drive or you'll need to transfer the drive to the new system.

**Other**

Use this option to simply specify a path in which to place the files. This can be a network path, a path to a removable drive, or a folder on your hard disk.

If you choose "New Computer," the next step is a choice between the following:

**I want to create a Wizard Disk**

Select this option to use your floppy drive to transfer the wizard program to the old computer, which is useful if the old computer is running earlier version of Windows. The wizard works on Windows 98/Me, Windows NT 4.0, Windows 2000, and Windows XP.

**I already have a Wizard disk**
This option simply quits the wizard and instructs you to use the wizard disk you already have on the old computer.

**I'll use the wizard from the Windows XP CD**
This option also quits the wizard and instructs you how to use the wizard located on the Windows XP installation CD on the old computer.

**I don't need the Wizard disk**
This is the only option of the four on this page that is used if you've already run the wizard on the old computer, as it will simply prompt you to locate the files and settings that have been packaged by the wizard.

Once you've chosen an option, follow the prompts on the screen to complete the process.

**Notes**

- Naturally, you can simply use Explorer and an active network connection or removable drive to transfer the files manually. Furthermore, using carefully selected registry patches, you can transfer many Windows settings and files from one machine to another. While this wizard will make the migration of documents, and especially settings, pretty easy, it may not end up being as flexible or complete as a manual migration.
- Another option is to use Backup (discussed earlier in this chapter) to transfer some or all of your files from one system to another.

---

**Finger**

\`\`windows\`\system\`\finger.exe

Display information about a user account.

**To Open**

Command Prompt → `finger`

**Usage**

`finger [-l] [user][@host]`

**Description**

The Finger client uses a standard protocol to retrieve publicly available information from any networked computer. Let's say you want to find out about a username "Woodrow" on your own system; you would simply type:

`finger woodrow`

Finger accepts the following options:

- `user`
  
  The username you wish to query. Omit to list all the users currently logged in on the specified host.

- `@host`
  
  The target machine containing the user account(s) you wish to query. Omit to query the local machine (localhost).
Displays information in a long list format
The finger protocol has been around for long time and is supported by all versions of Windows NT, Windows 2000, Windows XP, Unix, Solaris, and other platforms. The output from a Finger request varies widely (if you get a response at all); it depends on the operating system running on the specified host and the specific settings imposed by that machine's administrator.
Finger, when it works, commonly retrieves a report that looks something like this:
Login: woodrow Name: Gordie Howe
Directory: /usr/local/home/woodrow Shell: /bin/csh
Never logged in.
New mail received Mon Oct 1 23:50 2008 (PDT)

Unread since Wed Nov 20 11:04 1991 (PDT)
No Plan.
Although most the information included in this simple report is self-evident, the last line makes mention of a plan. The plan is a text file to be shown when one's account is fingered. It might contain contact information, office hours, personal statistics, or anything else the user wants. My plan file, for example, has several of my favorite quotes, including my favorite poem by Robert Creeley, "I Know a Man."

Notes
- The Finger daemon is the service responsible for responding to finger requests. This service is disabled by default, but can be enabled or otherwise configured using the services component of the Microsoft Management Console. Note that enabling the service on your computer may pose a security hazard, allowing outsiders to gain some information about one or more users on your system.
- As more users and administrators become security savvy, you'll find fewer occasions when a finger request actually gets a response. Typically, you'll receive a "connection refused" message.

Folder Options
Control the way folders appear in Explorer and configure file type associations.

To Open
Control Panel ➞[Appearance and Themes] ➞Folder Options
Windows Explorer ➞Tools ➞Folder Options
Command Prompt ➞control folders

Description
The Folder Options window has four tabs:
General
Of the three settings on this page, the one that may not be entirely self-explanatory is the Tasks section (see Figure 4-55). Microsoft has removed the highly criticized Web View found in earlier versions of Windows and added an optional feature called Common Tasks. When enabled, a common tasks pane appears along the left side of folder listings in Explorer and single-folder windows, which contains information and links related to the currently selected folder. Those new to Windows might appreciate the extra information, although advanced users will probably prefer to turn off Common Tasks to reduce screen clutter.

Figure 4-55. Among other things, the General tab lets you turn off the common tasks pane shown in many single folder windows

Of note in the Common Tasks pane is the feature to turn on or off the category view in Control Panel (covered earlier in this chapter), an otherwise unavailable setting.

Figure 4-56. Many settings that affect the display of folders and files are located in the Folder Options' View tab
After you've selected all your preferences in the General and View tabs, as well as Explorer's View menu, click Apply to All Folders to make your settings the default. Otherwise, all your settings will be lost as soon as you switch to a different folder (see Figure 4.5).

The Advanced settings here are actually quite important, as many of their default values can actually end up making Windows more difficult to use. Many of these settings are self-explanatory; some of the more interesting ones are as follows:

**Display the simple folder view in Explorer's Folders list**

This rather oddly named option simply shows or hides the dotted lines shown in the collapsible folder tree (see Trees in Chapter 5) in Windows Explorer. The default is on, but if turned off, the tree appears more like it did in earlier versions of Windows. In my opinion, the lines make the tree a little clearer and easier to use, so I recommend turning this option off.

**Display the contents of system folders**

Turn this option on to eliminate the warning that appears when you attempt to view the contents of certain folders, such as C: and \Windows. The default is off.

**Display the full path in the Address Bar / titlebar**

By default, both of these settings are disabled, which, to me, is utterly baffling. For example, when viewing the folder, c:\Documents and Settings\Bubba\Documents\Stuff in Windows Explorer, only "Stuff" will appear in the titlebar and Address Bar. This can be extremely confusing, especially when you also have a d:\Additional Files\Latest\Stuff folder. I strongly recommend enabling both "full path" options.

**Hidden files and folders**
Windows does not show hidden files by default in Explorer. Change this option if you need to access hidden files; see Attrib, earlier in this chapter, for details on hidden files.

**Hide extensions for known file types**

In one of Microsoft's biggest blunders, this option has been turned on, by default, since Windows 4.0. See the discussion of the File Types tab, below, for why it should be turned off.

**Launch folder windows in a separate process**

Turn on this option to start a new instance of the Windows Explorer application every time you open a new folder window. Although this takes slightly more memory, it means that if one Explorer window crashes, they won't all crash.

**Remember each folder's view settings**

If this option is enabled and you use Explorer's View menu to alter the display of a particular folder, those settings will be saved with that folder for the next time it's opened. If you're looking for a way to save your View settings as the default for all folders, this option won't do it — instead, use the Apply to All Folders button (see Figure 4-54).

**Use Simple File Sharing**

Despite the "Recommended" note here, it is strongly recommended that this option be disabled for security purposes. See Chapter v for more information on sharing resources over a network.

**File Types**

The term *file types* describes the collection of associations between documents and the applications that use them (see Figure 4-50). For example, Windows knows to run Notepad when you double-click on a file with the .txt extension.

Launching the correct program for a particular file begins with file extensions, the letters (usually three) that follow the period in most filenames. For example, the extension of the file Readme.txt is .txt, signifying a plain text file; the extension of Resume.wpd is .wpd, signifying a document created in WordPerfect. By default, Windows hides the extensions of registered file types in Explorer and on the Desktop, but it's best to have them displayed (turn off the "Hide extensions for known file types" option under the View tab).

File extensions allow you to easily determine what kind of file you're dealing with (because icons are almost never descriptive enough). They also allow you to change Windows' perception of the type of a file by simply renaming the extension. Note that changing a file's extension doesn't actually change the contents or the format of the file, only how Windows interacts with it. By hiding file extensions, Microsoft hoped to make Windows easier to use — a plan that backfired for several reasons. Because only the extensions of registered files are hidden, the extensions of files that aren't yet in the File Types database are still shown. What's even more confusing is that, when an application finally claims a certain file type, it can appear to the inexperienced user as though all of the old files of that type have been renamed. It also creates a "knowledge gap" between those who understand file types and those who don't. (Try telling someone whose computer still has hidden extensions to find Readme.txt in a directory full of files.) Other problems have arisen, such as trying to differentiate Excel.exe and Excel.xls in Explorer when the extensions are hidden; one file is an application and the other is a document, but they may have the same icon.

**Figure 4-50. The File Types tab lets you change the associations between documents and the programs that open them**
In the File Types window, all registered file extensions and their descriptions are shown in the list.
Here's how to customize a file type:

1. Select the desired file type from the list and click Advanced. (The Change button only displays the limited Open With dialog box.) You can sort the entries by filename extension or file type description to make any given file type easier to find.

2. Keep in mind that some file types may be claiming more than one extension. For example, the .htm and .html extensions are most likely associated with the same file type. If you are editing such a file type, it won't matter which extension you select.

3. The Actions list box contains a list of the customizable context menu items. Each one has a name and a command line (the application filename followed by command-line parameters, if applicable).

A typical command line (the one for the .txt file type) might look like this: `notepad /p “%1”`. This line tells Windows to launch Notepad with the /p parameter (see Notepad, later in this chapter) when you double-click on a .txt file.

The `%1` is where you want Windows to insert the name of the clicked file, and is actually optional. However, the quotation marks, which ensure compatibility with any spaces in the filenames, are not used by default in Windows; if you want to be able to double-click on any file with a space in its filename, add “%1” to the end of the command line here. If you double-clicked on a file called `stuff.txt`, located in the folder, `e:\things`, this file type action would result in the following command being executed: `notepad /p “e:\things\stuff.txt”`.

4. Some actions have dynamic data exchange (DDE) commands, which are used only by certain applications — you probably won't have to bother with this setting. You can also change the icon for all the files of a particular type by clicking Change icon. See Icons in Chapter 5 for more information.

5. The bold item is the default action, also shown in bold at the top of the context menu. If there's no bold item, and therefore no default,
double-clicking a file of that type will do nothing. To make "no action" the default, you'll have to delete the current default (bold) action. If you don't want to remove any actions, just add a new, temporary action, make it the default, and then delete it.

7. Click OK when you're done. The changes should take effect immediately; your Desktop and any open Explorer or single-folder windows will automatically refresh within a few seconds.

**Offline Files**

See [Synchronization Manager](#), later in this chapter, for more information on Offline Files.

**Notes**

All of the settings in this dialog are also covered in [Chapter 6](#).

**See Also**

[Control Panel](#), [Windows Explorer](#)

**Font Viewer**

\windows\system\fontview.exe

Display a preview and summary of any supported font file.

**To Open**

Control Panel → Fonts → Double-click any font file

**Usage**

fontview [/p] filename

**Description**

Font Viewer is most easily used by double-clicking on a font file (see [Figure 5-31](#)). You can view any font formats normally supported by Windows XP, including TrueType fonts (.ttf), bitmap fonts (.fon), and Type 1 fonts (.pfa).

In addition to the font name and summary information displayed at the top of the report, a preview of the font is shown with the full alphabet in uppercase and lowercase, the full set of numbers, a few symbols, and the phrase "the quick brown fox jumps over the lazy dog. 123456789." in several different sizes.

[Figure 5-31. Double-click any font file to view a preview like this](#)
To run Font Viewer from the command line, you must specify the full path and filename of the font file, including its extension (such as .fon or .ttf). To send the report to the printer, use the /p option (which is the same as clicking the print button in the Font Viewer window).

Notes

- Windows XP typically keeps its installed font files in \Windows\Fonts, which is most easily accessible by going to Control Panel → Fonts. File Viewer can also be used to view fonts before they're installed, simply by double-clicking them in Explorer.
- Although Adobe Type fonts are actually stored in the font binaries (.pfb), Font Viewer works only with the font metrics (.pfm).
- Font Viewer does not display every character in the font, only the predefined subset described above. To display every character in the font, use Character Map. (However, Character Map only works on installed fonts.)

See Also

Fonts Folder, Character Map

Fonts Folder

Displays all the installed fonts.

To Open

Control Panel → Fonts

See Control Panel, earlier in this chapter, for information on finding fonts using the Control Panel in Category View.
Command Prompt ➔ control fonts
Command Prompt ➔ explorer ¥windows¥fonts

Description

The Fonts folder is merely a folder on your hard disk (specifically, \Windows\fonts). However, when viewed in Explorer, it’s configured to display a list of installed fonts instead of a list of the contents of the folder. (The two aren’t necessarily the same thing.) Select View ➔ Details for more the most useful listing, which, among other things, allows you to match up a font name with the file in which it’s stored (see Figure 5-17).

Figure 5-17. The Details view of the Fonts folder shows the relationships between your font names and font filenames

Right-click a font file and select Properties to see bunch of additional information pertaining to the font, such as hinting and font smoothing properties, copyright information, font vendor information, and whether such fonts can be embedded. To view a preview of an installed font, just double-click its name; see Font Viewer, earlier in this chapter, for more information. To delete a font, delete it as you’d delete any file (press the Del key or drag-drop it into the Recycle Bin).

To install a font (as long as it’s one of the supported types), just drag-drop it into the Fonts folder. Supported typeface formats include TrueType (.ttf), Adobe Type 1 (.pkm and .pfb), OpenType (also known as TrueType v1), and ugly old raster fonts (.fon) used in early versions of Windows.

Notes

- If a font file icon has a shortcut arrow (see Shortcuts in Chapter 7), it means the font is installed, but not actually stored in the \Windows\Fonts folder.
- Unlike some earlier versions of Windows, Windows XP comes with built-in support for Adobe Type 1 fonts, so a product like Adobe Type Manager is no longer needed.
- The View ➔ List Fonts by Similarity feature, while a good idea in principle, rarely provides any useful information.
- If you’re sharing documents with other users, you may need to send them copies of the font files you’ve used as well. If you drag-drop the desired files from the fonts folder onto, say, your Desktop, make sure to hold the Ctrl
key (or drag with the right mouse button and select Copy Here) so the font file is copied and not moved (which would uninstall it). Keep in mind that some fonts are commercial products and copying them constitutes software piracy and copyright violation.

- Use a program like Adobe Acrobat (not the free reader application, but the full version available at http://www.adobe.com/) to share documents without having to share the fonts used.
- If the Fonts folder appears to be displaying an ordinary list of files rather than the specialized font listing, it can be fixed with TweakUI (see Appendix D).
- Any non-font files, that, for whatever reason, have been stored in the Fonts folder, will not show up at all, nor will they appear in any search results. To display a normal listing of the files in the Fonts folder, use the dir command in the Command Prompt (See Chapter 1.)
- Thousands of freeware fonts are available for download on the Internet, from such sites as http://www.pcfonts.com/ and http://www.microsoft.com/typography/. You can also create your own fonts with an application like Fontographer (http://www.macromedia.com/).
- Fonts for icons, menus, and other screen elements are selected by going to Control Panel → [Appearance and Themes] → Display → Appearance tab.

See Also
Control Panel

**ForceDOS**

\windows\system 32\forcedos.exe

Force a misbehaving DOS application to run in MS-DOS mode.

**To Open**

Command Prompt → forcedos

**Usage**

forcedos [/d directory] filename [parameters]

**Description**

Use the ForceDOS utility when Windows XP fails to recognize a DOS program and is unable to start or run it reliably. ForceDOS accepts the following options:

- **filename**
  The filename of the executable to launch; include the full path if necessary.

- **/d directory**
  Use the /d option to specify the working directory, necessary for many DOS programs that access files.

**Parameters**

Specify any parameters here to be passed on to the launched program.
Prepare floppy diskettes, hard disks, and some removable media for use.

**To Open**

Command Prompt → `format.com`

**Usage**


**Description**

Before data can be stored on a floppy disk, hard disk, or many removable media disks (like Zip disks), the disk must be formatted. This process creates various low-level data structures on the disk, such as the filesystem (FAT, FAT32, NTFS, etc.). It also tests the disk surface for errors and stores bad sectors in a table that will keep them from being used. If there's any data on the disk, it will be erased.

The options for Format are:

- **volume**
  The drive letter, followed by a colon, containing the media to be formatted.
  For example, to format the floppy in drive `A:` type: `format a:`
  If the specified drive is a hard disk, you'll be prompted to verify that you actually want to erase the disk.

- **/q**
  Performs a "quick" format, a process that only wipes out the file table, resulting in an empty disk. This option does not check for bad sectors, nor does it rewrite the filesystem. Also, it does not write over data on the disk, meaning that files could potentially be recovered or "undeleted." The advantage of the `/q` option is that you can erase a disk in a few seconds.

- **/c**
  Files created on the new volume are compressed by default (NTFS volumes only).

- **/x**
  Forces the volume to dismount first, if necessary. All opened handles to the volume would no longer be valid. This effectively disconnects the drive from Explorer and all other programs, closing any open files stored on the drive, before any changes are made.

- **/v: label**
  Specifies the volume label, an arbitrary title you assign to any disk. It can be up to 11 characters and can include spaces. The volume label will show up next to the drive icons in Explorer (hard disks only) and at the top of `dir` listings (see Appendix C). See `Label`, later in this chapter, for more information. If the `/v` option is omitted, or the label isn't specified, a prompt for a volume label is displayed after the formatting is completed. If a label is specified with `/v` and more than one disk is formatted in a session, all disks will be given the same volume label.

- **/f: size**
  Size
Specifies the size of the floppy disk to format (such as 16.7, 18.2, 22.1, 28.6, 17.1, 1.44, 1.25). The format size (specified with the /f option) must be equal to or less than the capacity of the disk drive containing the disk to be formatted. For example, a 1.44MB capacity drive will format a 230K disk, but a 230K drive will not format a 1.44MB disk.

/fs: filesystem
Specifies the type of the filesystem; can be fat, fat16, or ntfs.

/a: size
Overrides the default allocation unit size, which, when multiplied by the number of clusters, equals the final capacity of the disk. Allowed values for size depend on the filesystem:

- NTFS supports 012, 1.24, 2.48, 3.76, 16K, 32K, and 64K.
- FAT and FAT16 supports 012, 1.24, 2.48, 3.76, 16K, 32K, and 64K (and 128K and 256K for sector size > 128 bytes).
- Note that the FAT and FAT16 filesystems impose the following restrictions on the number of clusters on a volume:
  - FAT: Number of clusters <= 60,000
  - FAT16: 60,001 < Number of clusters < 4,194,918
- NTFS compression is not supported for allocation unit sizes above 4.96.

Notes

- The /f, /t, and /n parameters are also available for use with Format, but are essentially obsolete. Type format /? for more information.
- If formatting an ordinary 5.25" floppy diskette, the disk will always be formatted to a capacity of 1.44MB. The DMF diskette format, which squeezes about 1.25MB on a standard floppy, is not directly supported by Format. If formatting a pre-formatted DMF diskette, use the /q parameter to preserve the format and only erase the files. To create new DMF diskettes, you'll need the WinImage utility (Version 7.7 or later), which can be downloaded from http://www.annoyances.org.
- The easiest way to format a disk is to right-click on the drive icon in Explorer or My Computer and select Format. However, using Format from the command line is more flexible, and in some cases, faster.

See Also

FAT to NTFS Conversion Utility, Label

FreeCell \windows\system\freecell.exe

A solitaire card game, considered by many users to be more addictive than traditional Solitaire (Klondike).

To Open

Start ➔ Programs ➔ Games ➔ FreeCell
Command Prompt → freecell

Description

FreeCell is a solitaire card game (see Figure 4-51), but is played differently from the traditional Klondike game (see Solitaire, later in this chapter). The object of the game is to move all the cards to the home cells.

Figure 4-51. Some people buy their computers just to get the FreeCell game

Like Klondike, cards are rearranged by placing cards of descending value and alternating color (the 4 of clubs can be placed on the 9 of hearts or the 9 of diamonds). Click a card to highlight it and click another card to move the highlighted card. Multiple cards can be moved, but only those that are arranged accordingly. Cards can also be moved to one of the four "free cells," temporary storage slots that fill up fast.

FreeCell is somewhat like a cross between Klondike and the Towers of Hanoi puzzle.

Notes

In FreeCell, cards are not dealt randomly. Rather, there are 525000 distinct numbered games, each representing a different predetermined deal of the cards. According to the help, "It is believed (although not proven) that every game is winnable." In fact, it has been proven that game #688212 is indeed not winnable.

See also

Solitaire, Spider Solitaire

FTP /windows\system 32\ftp.exe

File Transfer Protocol; transfer files between two computers, typically across the Internet.

To Open
Command Prompt → ftp

Usage

ftp url

Description

FTP is used to transfer files to and from a remote computer, typically on the Internet. Like many Internet applications, FTP is a client application that requires a corresponding FTP server to work. When you start FTP, you are connecting to a remote host and then issuing commands to instruct the host to send or receive files, display directory listings, and so on.

Although each FTP session requires a username and password, there's a very common workaround that allows anonymous connections. Typically, one enters anonymous as the username and an email address (or, frankly, any bogus text) as the password to log in (assuming anonymous access is allowed on the server at all).

Once you've logged in, commands are issued by typing in the prompt; the complete list of FTP commands is documented later in this section. The exception is when FTP is run in noninteractive mode using the url option.

Command-line parameters for FTP are as follows:

url
A web-style address (URL) to a specific file located on an anonymous FTP server, which looks something like this:
ftp://server.com/path/file
If you specify a complete URL, FTP will download the file and then quit automatically, rather than going into interactive mode.

host
Specify the hostname or IP address of the remotehost (server) to which to connect. If omitted, it can be entered once FTP has started by using the open command. Example:
ftp ftp.microsoft.com
Note the common ftp. prefix, while not mandatory with FTP, is merely a hostname that signifies a specific machine, often solely devoted to serving FTP requests.

-v
Suppress the display of remote server responses to commands — useful if you're running FTP from a script.

-n
Suppress auto-login upon initial connection. To connect, you'll need to use the user command once FTP is running.

-i
Turn off interactive prompting during multiple file transfers when using the mget and mput FTP commands.

-d
Enable debugging, displaying all FTP commands passed between the client and server (for troubleshooting purposes).

-g
Disable filename globbing, which permits the use of wildcard characters in local file- and pathnames. (See the FTP glob command.)

-s: filename
Specify an FTP script, a plain text file containing sequential FTP commands, one per line. The commands are issued as though they were typed at the keyboard.

-a
Use any local interface when establishing a connection.
-A
Login as anonymous (note capital A). This is the same as logging in normally and manually typing in anonymous as the username and an email address as the password.
-w: size
Override the default transfer buffer size of 4096. Change only if you encounter performance problems.

Note that you can start FTP without any command-line parameters to enter interactive mode, but you won’t be able to use most of the commands until you log in with the open command (see below).

FTP commands

The following list shows the commands available once FTP is running. Most require that a connection has been established and not all will work with every FTP server. The most important commands to know are put, get, mput, mget, cd, lcd, dir, and bye. If you are transferring binary files across platforms (from a Unix host to a Windows-based client, for example), be sure to use the binary command first, or the files may be corrupted in transit.

! [command]
Run the specified command (e.g., cd) on the local computer, as though you temporarily jumped out of FTP, ran a command, and then jumped back in — all without disconnecting. Naturally, you could just open a second command prompt window, but some contextual commands, such as cd (see Appendix C) require the use of the ! command to be effective. Type ! by itself to start a mini-DOS session in which you can type multiple commands; type EXIT to return to the active FTP session.

? [command]
Same as help.

append
Append a local file to a file on the remote computer.

ascii
Set the file transfer type to ASCII (plain text), the default (except in noninteractive mode). ASCII mode is the default and is useful if you're transferring plain text files between Unix and Windows systems, as minor translation must be performed on these types of files. Note that this translation can corrupt binary files, so you should use the binary command if you're not transferring ASCII files.

bell
Turn on or off the beep after each file transfer command is completed. By default, the bell is off.

binary
Set the file transfer type to binary, a crucial step for transferring nontext files (such as .zip, .gif, and .doc) between Unix and Windows-based machines. Although it's not necessary if the server is also a Windows system, it's a good idea to get into the habit of typing binary (or simply bin) every time you use FTP. Note that binary is the default in noninteractive mode, when used with the url command-line parameter. See also ascii.

bye
End the FTP session, and if necessary, disconnect from the remote computer. The standard DOS exit and quit commands won't work here.

```bash
cd [ directory]
```
Change the working directory on the remote computer (to cd on the local machine, use ! cd or !lcd).

```bash
close
```
Disconnect from the remote computer without exiting FTP. Use open to connect to a different FTP server or bye to exit FTP.

```bash
debug
```
Toggle debugging. When debugging is on, each internal command sent to the remote computer is displayed, preceded by the string --->. By default, debugging is off.

```bash
delete remote_file
```
Delete a file on the remote computer. Only a single file can be deleted at a time with delete (no wildcards are allowed); use mdelete to delete multiple files at once.

```bash
dir
```
Display a list of the contents of the working directory on the remote computer, with details. Use ls for a simple listing. Occasionally, directory listings for anonymous users may be disabled, in which case dir will not work; if you wish to download, you'll need to know the particular filename(s) beforehand.

```bash
disconnect
```
Same as close.

```bash
get remote_file[ local_file]
```
Transfer remote_file from the server to the local machine. If local_file is not specified, the local file will be given the same name as the original. The file will be placed in the local working directory; to choose a different destination, use !lcd. Only a single file can be downloaded at a time with get (no wildcards are allowed); use mget to delete multiple files at once. If transferring binary (nontext) files, use the binary command first.

```bash
glob
```
Toggle filename "globbing." Globbing permits use of wildcard characters in local file or pathnames. By default, globbing is on. Globbing can also be disabled with the -g command-line parameter.

```bash
hash
```
Turn on or off FTP's crude progress bar for file transfers. A hashmark (#) character is displayed for each 2k of data transferred, so large files will have longer progress bars than small files. By default, hashmark printing is off.

```bash
help [ command]
```
Display all the available commands. Include command to get help with a single command (e.g., help get). Same as ?.

```bash
cd [ directory]
```
Change the working directory on the local computer. Enter a full path as directory (e.g., c:\downloads) to effectively instruct FTP to place downloaded files there. Omit directory to simply display the current working directory. By default, the working directory is in use when FTP is started; if FTP is opened from Start Run, the working directory is c:\documents and settings\{username\}.

```bash
literal command_line
```
Send so-called "arbitrary" commands to the remote FTP server (such as retr, stor, pasv, and port). A single FTP reply code is expected in return. Typical use of FTP does not involve using literal, but it can provide access to some advanced functions; among the more interesting is the ability to
transfer files between two remote computers without having to first transfer them to the local machine.

**ls**
Display an abbreviated list of a remote directory's files and subdirectories. This is useful when a directory contains a lot of files. Type `ls -l` (or use `dir`) to show the "long" listing, including file details. Occasionally, directory listings for anonymous users may be disabled, in which case `ls` will not work; if you wish to download, you'll need to know the particular filename(s) beforehand.

**mdelete [ files]**
Delete multiple files on remote computers. Unlike `delete`, wildcards can be used (e.g., `*.txt` for all `.txt` files).

**mdir** `remote_files local_file`
Store a listing of the remote working directory's contents (with details) into a file; both parameters are required. The `remote_files` parameter is used to modify the listing, either by specifying a wildcard (use `*` to list all files) or by specifying the name of another directory. `local_file` is the target filename in which the directory listing is stored.

**mget** `remote_files`
Transfer one or more remote files to the local computer. Unlike `get`, wildcards can be used (e.g., `*.txt` for all `.txt` files). You will be asked to confirm each transfer unless you turn off prompting with the `prompt` command. Local files will be given the same names as their remote counterparts. If transferring binary (nontext) files, use the `binary` command first.

**mkdir** `directory`
Create a remote directory. Note that anonymous users are usually not permitted to create directories on remote systems.

**mls** `remote_dir local_file`
Same as `mdir`, except that a short listing (no details) is stored.

**mput** `local_files`
Transfer one or more local files to the remote computer. Unlike `put`, wildcards can be used (e.g., `*.txt` for all `.txt` files). You will be asked to confirm each transfer unless you turn off prompting with the `prompt` command. Remote files will be given the same names as their local counterparts. If transferring binary (nontext) files, use the `binary` command first.

**open** `hostname or IP address`
Connect to the specified FTP server. This is the same as specifying a server in the FTP command line; use `open` if you omitted the `host` parameter. `Open` can be used whenever there's no current connection, either if you disconnected using `disconnect` or `close` or if the initial connection attempt was unsuccessful.

**prompt**
Turn on or off prompting for multiple file transfers. When you use the `mput` or `mget` commands, FTP will prompt you before transferring each file. By default, prompt is turned on; type `prompt` before using `mput` or `mget` to transfer multiple files without being prompted.

**put** `local_file [ remote_file]`
Transfers `local_file` from the server to the local machine. If `remote_file` is not specified, the remote file will be given the same name as the original. The file will be placed in the remote working directory; to choose a different destination, use `cd`. Only a single file can be uploaded at a time with `put` (no wildcards are allowed); use `mput` to delete multiple files at once. If transferring binary (nontext) files, use the `binary` command first.
pwd
Print Working Directory (PWD) displays the remote working directory; use cd to change to a different remote directory.

quit
End the ftp session with the remote computer and exit ftp.

quote command_line
Same as literal.

recv remote_file [ local_file]
Same as get.

remotehelp [ command]
Display help for remote commands supported by the server. This is probably similar to the commands available on the client, but may not be identical. As with ? and help, supplying no arguments returns a list of command names. Use remotehelp command to get more info on each command.

rename from_name to_name
Rename a remote file. Note that anonymous users are usually not permitted to rename files on remote systems.

rmdir remote_directory
Delete a remote directory. Note that anonymous users are usually not permitted to delete directories on remote systems.

send local_file [ remote_file]
Same as put.

status
Display the current status of the connection and the current settings of options like prompt, verbose, and ascii|binary.

trace
Turn on or off packet tracing, which displays the route of each packet when executing an FTP command. By default, trace is off.

type [ type]
Display whether transfers are performed in binary or ascii mode. Use type binary (or just binary) to transfer binary files.

user username [ password]
Specify the username on the remote computer; if no password is specified, you will be prompted for one. Typically, FTP prompts for the username and password when a connection is first established; however, if you type an incorrect username and password, you can try again with the user command without having to reconnect.

verbose
Turn on or off verbose mode. If verbose is on (the default), all FTP responses are displayed, such as when a file transfer completes and any statistics regarding the efficiency of the transfer.

Examples
To copy the file preface.doc from the directory /pub/nutchell on a remote computer to \temp\docs on your local computer, once you’re logged on to a server, you would perform the following from the DOS prompt (note that cd within ftp is for the remote computer):
C:\>cd \temp\docs
C:\temp\docs>ftp remote_computer
username
password
ftp>binary
ftp> cd /pub/nuthshell
ftp> get preface.doc

Run a script containing ftp commands:
C:\> ftp -s:myfile.scr
This will load ftp and run myfile.scr, executing any ftp commands in the file.

Notes

- Most web browsers support the ftp:// protocol, which provides limited FTP functionality without having to use an FTP client. For example, you can retrieve a single file from an anonymous FTP server by opening this address in any web browser: ftp://server.com/path/filename.ext.
- Furthermore, you can specify a username and (optionally) a password, like this: ftp://username:password@server.com/path/filename.ext.
- Some browsers will even let you upload files when connected to an FTP server (assuming the server permits you to do so). In Netscape 4.x, select "Upload File" from the File menu. In Internet Explorer, you can simply drag-drop files into an FTP window as though it were a folder on your hard disk.
- All ftp command names can be abbreviated to the first four letters; sometimes fewer.
- If any nonoptional arguments are omitted from most FTP commands, you'll be prompted for them.
- When using the get or mget commands, transferred files will be placed in whatever directory was the working directory when you launched FTP. Once an FTP session has begun, you can change the working directory with the lcd command: to switch from the local C:\ to the A:\ drive, for example, you would type:

  C:\>lcd a:

- In FTP, to maintain consistency with its Unix heritage, you must use the forward slash (/) instead of the backslash (\) when specifying pathnames. Furthermore, directory and filenames are case sensitive when connecting to a Unix FTP server; readme.txt is a different file than Readme.TXT.
- Many FTP servers impose an "idle timeout" on FTP connections; that is, if you open an FTP connection and let it sit for several minutes without typing any commands, the FTP server will disconnect you.

Game Controllers

Configure any joysticks, steering wheels, and game pads attached to your system.

To Open

Control Panel ➔[Printers and Other Hardware] ➔Game Controllers
Command Prompt ➔control joy.cpl

Description
Before a joystick or other game controller can be used with Windows-based games, its driver must be installed here. If your game controller doesn't appear in this list, click Add (see Figure 4-52). If your device doesn't show up on the list and the manufacturer doesn't provide native Windows XP drivers, try Custom to set up a rudimentary configuration for the device.

**Figure 4-52.** Windows supports many types of joysticks, gamepads, steering wheels, and flight yokes for your games

**Notes**

Not all game controllers have settings that can be changed, so the Properties button may be grayed out.

**See Also**

- Control Panel

**Group Policy Refresh Utility**

`\windows\system32\gpupdate.exe`

Refresh group policies and settings. (Group Policy Refresh Utility is included with Windows XP Professional only.)

**To Open**

Command Prompt → `gpupdate`

**Usage**

Description

Type `gpupdate` at the command prompt to refresh group policy settings. The Group Policy Refresh Utility accepts the following options:

- **/target:computer** or **/target:user**
  - Refresh only user or only computer policy settings; by default, both are refreshed.

- **/force**
  - Reapply all policy settings — by default, only policy settings that have changed since the last refresh are applied.

- **/wait: value**
  - Wait a specified number of seconds for policy processing to finish before being returned to the command prompt. The default is 1 second; specify 0 (zero) not to wait at all, or 1 (one) to wait indefinitely.

- **/logoff**
  - Log off the current user after the Group Policy settings have been refreshed.

- **/boot**
  - Restart Windows after the Group Policy settings have been refreshed.

- **/sync**
  - Cause the next foreground policy application (occurring at computer startup and user logon) to be done synchronously. If `/sync` is specified, `/force` and `/wait` parameters will be ignored.

---

**Hearts**

```
\windows\system32\mshearts.exe
```

A card game played with three opponents.

**To Open**

Start → Programs → Games → Hearts
Command Prompt → mshearts

**Description**

Hearts is a trick-based game, like Spades or WizardTM, but the object is to have the lowest score at the end of each hand. The online help tells you how to play the game and provides strategy and tips (see Figure ε-ε).
Notes

- Normally, the object of Hearts is to stick your opponents with as many points (hearts) as possible. However, if one player takes all the points in a hand, it's called "shooting the moon": that player gets zero points and everyone else gets 2 points.
- In previous versions of Windows, Hearts was a network game that allowed you to play against other players on a network. This functionality has been removed from the Windows XP-version of Hearts; however, a new version of the game, Internet Hearts, has been added.

Help and Support Center

The primary online documentation for Windows XP.

To Open

Start ➔ Help and Support
Command Prompt ➔ helpctr

Description
Rather than a standard help file, Help and Support Center is more like a web site, providing documentation for some of the components included in Windows XP, a collection of tips and tricks, some troubleshooting information, and rudimentary walk-throughs for such tasks as keeping your computer up to date and adding hardware and software (see Figure 2-41).

**Figure 2-41. The search tool in the Help and Support Center shows the most relevant information in the included documentation and in Microsoft's online knowledge base**

While Help and Support Center does have some minimal troubleshooting content, it's mostly simple solutions to common problems (i.e., if you can't print, check to see if your printer is turned on and is loaded with paper). However, if you're connected to the Internet, the Search tool at the top of the window will also search the Microsoft Knowledge Base, an immense database of troubleshooting information, frequently asked questions, bug reports, compatibility lists, and other technical support issues. In fact, since I access the Microsoft KB frequently, I find this built-in interface to be faster and more convenient than using the search function on Microsoft's web site! To view the results from searches other than the standard help content, click the gray bar above or below the displayed results (in the case of the KB, you would simply click Microsoft Knowledge Base). This is a terrific feature and can even be customized by going to Options → Set search options; you may want to increase the default of 10 results per provider (the Microsoft KB counts as a provider).

**Notes**

- If your job description involves supporting other computers, including those running other versions of Windows, the Help and Support Center can be augmented with documentation from other editions of Windows XP by going to Options → Install and share Windows Help. Furthermore, you can share your help content with others for precisely the same reason.
- From time to time, you'll find an especially useful page in the Help and Support Center window, either part of Windows' built-in documentation or a page on Microsoft's support web site. When available, click the Add to Favorites button to bookmark the page you're viewing; then, open Favorites
(not the same as your main Favorites folder) and click the bookmark at any time to return to that page.

- If you need help with a specific Windows component, such as WordPad or Explorer, use that application's Help menu, rather than the more general Help and Support Center.

**HyperTerminal**  `\Program Files\windows nt\hypertrm.exe`

Terminal access to remote computers, typically via a modem; also a substitute for Telnet.

**To Open**

Start  ➔ Programs ➔ Accessories ➔ Communications ➔ HyperTerminal
Command Prompt  ➔ hypertrm

**Description**

With HyperTerminal and a modem, you can connect to a remote computer that supports terminal access, sends and receives files, and so on. HyperTerminal is useful for connecting to computer bulletin boards (popular in the '80s and '90s); however, this type of terminal access has largely been replaced by the Internet. When HyperTerminal is first started (or when you use File ➔ New), it prompts you to name your connection and choose an icon, the first of two steps necessary to initiate a connection. The name is arbitrary and can be anything; it's really useful only if you intend to save your connection settings for use at a later time, but you have to enter something to proceed.

Next comes the Connect To dialog. The first option you should set is ironically the last one: in the Connect using list, choose either TCP/IP (Winsock) to initiate a session over your Internet connection, or choose a COM port (usually COM1) to use your modem (if installed). If you choose TCP/IP, HyperTerminal will be used as a Telnet client (see Telnet, later in this chapter, for more information), and you'll be asked for a Host address (server name or IP address) and a Port number (use 23 for normal Telnet access). If you choose a COM port, you will be prompted for an area code and phone number used to place the subsequent phone call. If the Phone number field is disabled, the selected COM port either doesn't have a modem attached to it or your modem is not properly set up.

Once you've established a connection, HyperTerminal is merely a portal through which you can type commands and view information. The specific commands and information depend on the type of connection you're using and what the host computer supports.

All the options in HyperTerminal deal with managing connection profiles (saved as .ht files) and configuring the display (e.g., choosing fonts, colors, etc.). The transfer menu is used to help transfer files with the remote computer and is used only with terminal access. To transfer files with computers accessed with Telnet, use FTP.

**Notes**

For support and upgrades to HyperTerminal, go to [http://www.hilgraeve.com/](http://www.hilgraeve.com/).
Create a self-extracting/self-installing package, used to distribute files and install applications.

To Open

Command Prompt → iexpress

Usage

iexpress.exe [/n] [/q] [/m] file[/o:override file,section]

Description

A self-extracting/self-installing package is actually an application, commonly known as an installer or setup program, that is used to install one or more files onto a Windows system and, optionally, to execute a setup script. IExpress is an interactive program that helps you create these packages, making it easy to, among other things, distribute files to other computers (see Figure 4-42).

Figure 4-42. The IExpress Wizard lets you package up a collection of files for easy distribution

Say you wish to put together a collection of documents that can be sent to another user, either via email, or by using a floppy disk or CD. Rather than simply sending the files separately or compressing them into a .zip file, both of which would require additional instructions, not to mention a reasonably knowledgeable and patient recipient, you can make a full-featured, professional-looking installer with IExpress. When you start IExpress, the IExpress Wizard guides you through the steps to creating a self-extracting package. The first step prompts for a Self Extraction Directive (.sed) file, a file that contains all the options and files to include. If you don't have one, select "Create new Self Extraction Directive file" and click Next.
The next page, "Package purpose," asks what you want the installer to do with the files on the target computer when the package is opened by its recipient. If you select the first option, "Extract files and run an installation command," the files will be copied to a temporary folder and a separate installer program that you provide will be launched. If you don't have a separate installation program, choose "Extract files only" and click Next. The last option, "Create compressed files only," is used by application developers to assist in the distribution of application components and is of little use to most users.

The subsequent steps allow you to specify a package title, type welcome and "finished" messages, and even include a license agreement. When you reach the "Packaged files" page, use the Add button to select one or more files to be included in the package; you can choose as many files as you like, and they can be any format. In fact, IExpress will compress the files so that they take up less space (like .zip files). Then, IExpress will ask you to specify a package name, which is the path and filename of the package (.exe) to be created. IExpress will also optionally save your choices into a Self Extraction Directive (.sed) file, making it easy to recreate this package without having to answer all the above prompts again.

When the process is complete, you'll end up with a new .exe file that can then be run on any Windows system. This package can now be emailed, FTP'd, distributed on a CD or a floppy, or even posted on a web site; the recipient won't need any special tools or elaborate instructions to extract the files from the package. IExpress also has an automated, noninteractive mode for advanced users who wish to skip the somewhat cumbersome wizard interface and instead, create a package using the following command line parameters:

```
file
/n
/q
/m
/o
```

The full path and filename of a Self Extraction Directive (.sed) file. If you don't have a .sed file, you'll have to use the wizard interface to create one.

Build package now (file must be specified). If you omit /n, IExpress will open in the interactive wizard interface.

Quiet mode (no prompts); used only with /n.

Use minimized windows; used only with /n.

Override.

If you've already created a .sed file (say, c:\stuff\thing.sed), and you wish to generate the corresponding package without walking through the wizard or being bothered with any prompts, type the following at a command prompt:

```
iexpress /n /q c:\stuff\thing.sed
```

The filename of the resulting package will be as specified in the .sed file.

**Notes**

Self Extraction Directive (.sed) files are just plain text files, similar in format to Configuration Files (.ini), and can be edited with a plain text editor, such as Notepad. The easiest way to get started with .sed files is to use the IExpress Wizard to create one and then edit (if necessary) to suit your needs.

**See Also**

*Cabinet (CAB) Maker*

**Internet**

\program files\msn gaming
**Backgammon**

See [MSN Gaming Zone](#).

**Internet Checkers**

See [MSN Gaming Zone](#).

**Internet Explorer**

A web browser used to view web content.

**To Open**

Start ➔ Programs ➔ Internet Explorer

Use the Internet Explorer icon on the Desktop or on the QuickLaunch Toolbar

Command Prompt ➔ `iexplore`

**Usage**

`iexplore [-nohome] [url]`

**Description**

Internet Explorer (IE) is a full-featured web browser that can be used to navigate the web, as well as view web content on your local network or hard drive. Web content is typically in the form of web pages (.html), but can also be images (.gif and .jpg), FTP sites, or even streaming video or audio (via the Windows Media Player) (see Figure 4-5).

Figure 4-5. Internet Explorer is the default web browser in Windows XP
Navigation in IE is accomplished by clicking hyperlinks in web pages or by typing addresses in IE's Address Bar. Frequently visited sites can be "bookmarked" by creating Internet Shortcuts (similar to Windows Shortcuts), stored in your Favorites folder, your Desktop, or anywhere else on your hard disk.

Use the Back and Next buttons (Alt-left arrow and Alt-right arrow, respectively) to navigate through the history, which is empty in each new IE window that is opened. Use the Stop button (or press ESC) to stop the loading of a page, and use the Refresh button (or press F5) to reload the page, displaying any changes that might have been made or displaying an updated version of a dynamically generated page.

The Home button loads the currently configured home page into the browser window. The home page is merely a shortcut to a single web site and can be changed by going to Tools → Internet Options. Finally, the Media button opens the Media Explorer bar, a pane on the left side of the window that displays advertising and entertainment from Microsoft's WindowsMedia.com site.

If you start IE from the command line, you can use either of the following options:

- **nohome**
  Start IE without loading the home page (blank). You can also configure Internet Explorer to use a blank page (about:blank) as its homepage, effectively causing Internet Explorer to always start without loading a home page.

- **url**
  The Uniform Resource Locator — the address of a page to load. If you omit url, IE will display the home page.

Here are descriptions of some of the features of Internet Explorer:

**Windows Update**

Updates to Internet Explorer are frequently made available on the Windows Update site. The initial release of Windows XP comes with Internet Explorer 7, but subsequent versions will add support for new standards, new features, bug fixes, and probably a few new bugs. If upgrading to a new version, always take advantage of the feature that saves the old system files, allowing the new version to be uninstalled in case you run into a problem or incompatibility.

**AutoComplete**

IE has an autocompletion feature, which encompasses several features to help reduce typing. While you're typing web addresses, IE checks your browser history for any matches and displays them below the Address Bar. The more characters you type in the Address Bar, the narrower the list of suggestions will be, until the list disappears. To choose a URL from the list,
just use the arrow keys on your keyboard and press Enter, or use your mouse.
You can also type an address without the http:// prefix, the .com extension, and even www (if applicable) in your addresses, and the site will still be found and loaded, as long as the site is in the .com, .edu, or .org domain. To add new domains to be included in AutoComplete, use the Registry Editor to add them to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate (see Chapter 4).
AutoComplete goes further to remember usernames, passwords, and even some form data. Be careful when having IE "remember" sensitive data, as others will be able to access it as well. For example, don’t store your bank PIN or credit card number if others have access to your computer. The AutoComplete options can be configured by going to Tools → Internet Options → Content → AutoComplete.

The AutoSearch feature extends AutoComplete by allowing you to initiate web searches (using your favorite search engine) from the Address Bar. To use AutoSearch, start by typing a keyword into the Address Bar (such as bozo), and when Search for "bozo" appears in the AutoComplete box, click it. To configure or disable AutoSearch, go to Tools → Internet Options → Advanced and choose Desired Option from the Search From the Address Bar section. You may wish to experiment with these settings until you find one you can live with. Unlike Netscape or Mozilla, IE doesn’t allow you to choose the search engine used to perform these searches; IE can only use MSN search (http://search.msn.com).

**Offline Files**
You can make any entry in your Favorites menu available offline (when you’re not connected to the Internet) by right-clicking it and selecting the "Make available offline" option. This launches a wizard that walks you through the following options:

1. Make other linked pages available offline. If yes, choose between 1 and 10 links deep, but be careful because this can take up a lot of disk space.
2. Select synchronization options. The default option allows synchronization only when chosen from the Tools menu. You can create your own schedule, which will take you to a dialog where you can set the synchronization between 1 and 90 days, set the time, and be given the option to automatically connect if you aren’t connected to the Internet.
3. Set a password for synchronization. You can require a password to be given before the site can be viewed offline by entering a username and password.

When you’re ready to work offline (a formal step that must be taken regardless of the status of your Internet connection), select File → Work Offline. You can then view any of your offline pages from the Favorites folder (they have the red dot on the corner of the icon). To work online again, just select File → Work Offline again. See Synchronization Manager later in this chapter, for more information.

**Cookies**
Cookies, first introduced by Netscape, allow a web site to store specific information on your hard disk. For example, if you visit an online store that has a shopping cart, that web site will be able to keep track of who you are by storing one or more cookies on your computer. This allows thousands of people to simultaneously access a site, yet have a separate and distinct shopping cart for each user. Cookies are often the target of privacy
advocates, since it's possible for website administrators to use cookies to track which pages certain visitors view at their site. However, cookies are only available to the sites that assign them (a cookie defined at Amazon.com cannot be read by any other web site), so the actual risk is minimal. You can adjust how Internet Explorer handles cookies by going to Tools → Internet Options → Privacy tab.

**Notes**

- If IE is the default browser, you can also go to Start → Run and type any web address to open the pages that addressed in IE. However, any browser can be set as the default. Typically, during installation of another browser, such as Netscape (http://www.netscape.com/), Mozilla (http://www.mozilla.org/), or Opera (http://www.opera.com/), there will be an option to make that browser the default. Once one of these other browsers is installed, the procedure to make them the default varies. In Internet Explorer, go to Tools → Internet Options → Programs tab, and turn on the "Internet Explorer should check to see whether it is the default browser" option. Then, after closing all open Internet Explorer Windows, open a new Internet Explorer window; when prompted, verify that you try to make Internet Explorer the default.
- Go to Tools → Internet Options (see Internet Options, later in this chapter) to set the various options relating to the display of web pages, security on the Internet, related Internet applications, and other, more technical Internet-related settings. All settings are fully documented in Chapter 6.
- The Forward and Back buttons have a drop-down list feature (see Figure 4-44) that lets you quickly jump several sites forward or backward, skipping over sites you don't want to load.

**Figure 4-44.** The last few pages viewed can be quickly accessed with the Back button's drop-down list

- The files that make up web pages, .html files, are simply plain text files, and can be viewed or modified with a plain text editor, such as Notepad. In fact, if you select View → Source, IE will display the code for the current page in a new Notepad window. However, if you're not familiar with HyperText Markup Language (HTML) code, you can use any modern word processor to create and modify web pages. Most Internet Service Providers will even host your pages for you, effectively giving you your own website.
- When you type the name of a folder on your hard disk into IE's Address Bar, the IE window will be replaced with a standard folder window and the
contents of the folder will be displayed. Likewise, if you type an Internet address into the Address Bar of an Explorer window or a single folder window, the window will be replaced with IE and the page will load.

- From any web page, you can select the Tools → Show Related Links option, which will open the Search pane and fill it with a list links compiled by a centralized database at http://www.alexa.com/.
- If you find the text size on any page to be too small, go to View → Text Size and enlarge (or shrink) the text size to your liking.
- From time to time, and depending on the Internet Explorer features you use and the web sites you visit, you may be prompted to sign up for a Microsoft .NET Passport account. Unfortunately, this has caused some confusion among many users. A Passport account is absolutely not required for any feature of Windows, with the exception of the MSN Explorer and Windows Messenger components. Passport is an optional service (and Microsoft has been widely criticized for making it appear otherwise). Unless you wish to use MSN, Messenger, or the Hotmail service, you'll most likely have no use for a Passport account.

See Also

Internet Options, Network Connections, Windows Explorer

<table>
<thead>
<tr>
<th>Internet Hearts</th>
<th>\program files\msn gaming zone\windows\hrtzzm.exe</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internet Reversi</td>
<td>\program files\msn gaming zone\windows\rvsezm.exe</td>
</tr>
</tbody>
</table>

See MSN Gaming Zone.

<table>
<thead>
<tr>
<th>Internet Options</th>
</tr>
</thead>
</table>

Change the settings that affect Internet Explorer and your dial-up Internet Connection.

To Open
Control Panel → [Network and Internet Connections] → Internet Options
Command Prompt → `control inetcpl.cpl`
Internet Explorer → Tools → Internet Options

Description

The Internet Options dialog is a densely packed dialog with about every conceivable option for Internet Explorer. Settings are divided into the following tabs:

**General**

The Home page section allows you to choose the page that loads automatically whenever an Internet Explorer window is opened, as well as the page linked to the Home button on the toolbar.

Temporary Internet files, also known as your browser cache, is a folder on your hard disk that stores copies of recently visited web pages for quicker access the next time they’re visited. The Temporary Internet Files folder is located at `\Documents and Settings\{username}\Local Settings\Temporary Internet Files` by default. Cookies, a feature unrelated to Temporary Internet files, are pieces of information stored on your computer to allow certain web sites to remember your identity or preferences; click DeleteCookies to clear all cookies stored on your computer. To selectively remove cookies, open the `\Documents and Settings\{username}\Cookies` folder in Windows Explorer. See the Privacy tab for more Cookie settings.

Internet Explorer keeps track of pages you’ve visited and displays links to those pages in a different color (purple, by default, as opposed to the standard blue for links to pages you haven’t yet visited). Items in your History are also accessed with the AutoComplete feature discussed in Internet Explorer, earlier in this chapter. The History section controls how long before pages are removed from Internet Explorer’s history (see Figure 4-40).

**Figure 4-40.** Internet Options' General tab lets you choose a default home page, manage cookies, and clear out your browser history
The remaining buttons allow you to control the default colors, fonts, and languages with which pages are shown. The Accessibility button essentially limits the control web pages have over their appearance.

Security

Lets you specify the security settings for different predefined zones of Internet content. There are four basic zones: Internet, Intranet, Trusted, and Restricted. By default, all sites are placed into one of the first two zones. All sites found on your local network are placed into the Intranet zone. All other sites are placed into the Internet Zone. You can manually add sites to the Trusted and Restricted zones. Security settings for each zone are preset, but you can change these settings if you wish. For each zone, you can specify High, Medium, Low, or Custom security settings. Security settings govern such things as whether ActiveX controls, Java applets, and JavaScript programs are used, how files are downloaded, and how user authentication takes place.

Privacy

The Privacy tab essentially controls when and how Internet Explorer accepts cookies. Play around with the slider to choose between six different preconfigured privacy policies, or click Advanced to choose your own settings. The Medium or Low policies should be suitable for most users. You can also click Edit in the Web Sites section to selectively choose which web sites can store and retrieve cookies, and which can not. You can view the cookies currently stored on your hard disk by opening the Documents and Settings\{username\}\Cookies folder in Windows Explorer.

Content

The Content tab contains a number of functions that allow you to control what can and can't be viewed by IE. Many of the features here are not widely used and still have a few kinks to be worked out.

Content Advisor

Lets you use an Internet ratings service to screen out potentially offensive content. The first time you use this function, you will be asked to define a supervisor-level password that will later be used to change any of the content ratings.

By default, the only content advisor installed is the Recreational Software Advisory Council Internet advisor (RSACI). RSACI depends on voluntary ratings by sites as to the amount of violence, nudity, sex, and profanity they contain. While this may seem silly, sites with potentially objectionable content (such as porn sites) are embracing such "self-regulation" to forestall more stringent government regulation.

The rating system is fairly self-explanatory — you choose one of four levels for each of four types of "objectionable" content (Language, Nudity, Sex, or Violence); by default, every slider is set to the lowest level. One problem with this system is that the browser expects a rating from every site and requires a password to access sites with no ratings. Since few sites have RSACI ratings, this can become quite a hassle.

Ratings services publish their ratings in files of type .rat. A source for additional rating service files is http://www.classify.org/pics.htm. Download the .rat file for a given service, save it in \Windows\System, then go to the Advanced tab ➔ Ratings Systems button to add the ratings file to the Content Advisor ➔ Ratings tab.

Certificates

It's fairly easy for one site to masquerade as another. Digital certificates, which use cryptography to create unique identifiers that can't be forged, can be used by sites that want to prove their identity to you. Here, you can identify which certificate authorities (certificate issuers) you want to trust. If IE receives a certificate by an authority it doesn't know about, it will either display a warning or will not display the associated web page at all,
depending on your settings here. Companies sometimes self-certify their pages, especially in an Intranet context.

**Personal Information**
Microsoft Profile Assistant is used to store personal information, such as your name and email address, that is often required by forms on web sites. Web sites that support the use of the Profile Assistant can automatically draw this information from the assistant.

Right now, very few sites make full use of the functionality provided by the Profile Assistant. This may change in the future, but for now, these tools can still be useful as just a convenient location to store these types of information. Due to privacy concerns, however, you may understandably not feel comfortable doing this.

See **Internet Explorer**, earlier in this chapter, for more information on the AutoComplete feature.

**Connections**
The Connections tab allows you to choose to have your dial-up connection dialed automatically. If you're not using a dial-up connection, but rather using DSL, cable, or a direct LAN connection, most of this page will be of no use to you. The exception is the LAN Settings dialog, which lets you configure your proxy (if you have one).

If you have one or more dial-up connections, they will be listed here. If you have two or more connections and you want to use the Auto Dial feature, choose one and click Set Default. Then, click either "Dial whenever a network connection is not present" or "Always dial my default connection," whichever you prefer.

Select a connection and then click Settings Advanced to choose how many times Windows will dial before giving up and whether it should disconnect automatically if it detects that the connection is no longer needed.

The Setup button starts the New Connection Wizard, discussed later in this chapter. See **Chapter v** for more information on setting up new Internet connections.

> It's a bit dangerous to use the automatic idle disconnect feature if you are using Internet applications other than IE, since IE doesn’t recognize activity in other applications (such as Telnet). This can cause connections to close unexpectedly.

**Programs**
The settings in the Programs tab let you choose the default programs to use for sending mail, reading Internet news, placing Internet calls, viewing calendar scheduling, and viewing contact information (see **Figure 5-4**). For example, if you click a "mailto" link in a web page, Internet Explorer will activate the email program specified here. If your favorite applications don't appear in these lists, you may have to reinstall them or obtain updates from the respective manufacturers.

**Figure 5-4**. Choose the default email application and web page editor with the Programs tab
If the "Internet Explorer should check to see whether it is the default browser" box is checked, any time you start up IE (as long as it isn't already your default browser), it will ask you whether you want to make it your default browser. Thus, this setting is really just a shortcut to change file/program associations; see Control Panel → [Appearance and Themes] → Folder Options → File Types tab. Unless you're fond of what has come to be called "nagware," I recommend leaving this box unchecked.

**Advanced**

Advanced contains additional security settings in a hierarchical tree (see **Figure 4-5**). Many of these settings are rarely used and most are self-explanatory. Useful settings include:

**Figure 4-5.** The Advanced tab contains many settings that affect all aspects of web browsing with Internet Explorer
Notify when downloads complete

Normally, a message pops up when a download is complete, interrupting whatever you are doing. Disabling this feature is particularly helpful when you perform multiple downloads at once.

Use Smooth Scrolling

Specifies whether a page slides gradually when you click the scrollbar, a feature that can be especially distracting.

Underline Links

Specifies whether links on pages should be underlined always, never, or only when you hover your mouse pointer over them.

Multimedia

Multimedia can be a great part of the Web experience, but it can also slow down the delivery of web pages. The multimedia section lets you control whether certain multimedia elements, such as pictures, videos, and sounds, are downloaded for display. Thankfully, all those awful sounds in web pages can be silenced for good!

Printing

Enables or disables the printing of background colors and images when you print a web page. Print speed can be increased considerably with this option disabled. The settings that control Java, JavaScript (found under the Advanced tab in some earlier versions of Windows), can be found in Security Custom Level.

Notes

- All of the settings in this dialog are also covered in Chapter 9.
- Only the settings in the Connections tab affect your dial-up Internet Connection (if you have one), which affects all your Internet applications. All the other tabs affect only the Internet Explorer application. Settings that control the security and privacy features of other browsers, such as Netscape or Mozilla, can be found in those applications' options windows.

See Also
Control Panel, Internet Explorer

Internet Spades
\program files\msn gaming zone\windows\shvlzm.exe

See MSN Gaming Zone.

Java Command-Line Loader
\windows\system32\jview.exe;
\windows\system32\wjview.exe

Run Java programs without using a web browser.

To Open
Command Prompt ➔ jview
Command Prompt ➔ wjview

Usage
jview [options] filename [arguments]
wjview [options] filename [arguments]

Description
Java is a programming language that allows developers to create programs that can run on any platform, including Windows, Unix, and MacOS. Since Java applications (*.class files) aren't formal Windows programs, they can't be opened by themselves; rather, you must use the Java Command-Line Loader to run them. The exceptions are so-called Java applets, which are Java programs included in web pages and run internally by your web browser.

Windows XP comes with two Java command-line loaders, jview.exe and wjview.exe. Both versions do the same thing and accept exactly the same parameters (see below). The difference is that jview.exe is a command-line-based program and wjview.exe is a Windows-based program. The Java Command-Line Loader takes the following options:

classname
The full path and filename of the .class file to be executed.

/a
Executes AppletViewer.

/d:< name>=< value>
Defines a system variable to be used by the Java program.

/n < namespace>
The namespace in which to run.
/p  Pauses before terminating if an error occurs.
/v  Verifies the Java program before executing it.
arguments  The command-line arguments to be passed onto the Java program.
/vst  Prints verbose stack traces (requires debug classes).
/cp  Sets the class path.
/cp:a  Appends path to the class path.
/cp:p  Prepends path to the class path.

Notes

- The Java Command-Line Loader uses Microsoft's version of the Java Virtual Machine (JVM), which is very fast, since it uses Just-In-Time compiler technology.
- Unfortunately, there is not an option or Registry setting that enables Java logging. However, you can redirect the output (see Appendix C) when invoking an application, as in the following example:

  C:\jview main > javalog.txt

- When you run a Java application using the Java Command-Line Loader from within the Microsoft Developer Studio IDE, the command prompt window closes immediately after the Java application terminates. To prevent the MS-DOS window from closing immediately, you can have an input statement as the last statement in your Java application.

  For example:

  system.in.read( );

- A second option is to run your Java application externally (outside the Developer Studio environment).
- For the Microsoft SDK containing the latest Java compiler and Virtual Machine for using Java with the WIN32 API only, go to http://www.microsoft.com/java/download.htm.

Keyboard Properties

Change the keyboard repeat rate and text cursor blink rate.

To Open
Control Panel ➔ [Printers and Other Hardware] ➔ Keyboard  
Command Prompt ➔ control main.cpl Keyboard  
Command Prompt ➔ control keyboard

Description

The Keyboard Properties dialog controls the way characters are repeated when keys are held down, as well as how quickly the text cursor (insertion point) blinks. Tip: move the Repeat rate slider all the way to the right (towards Fast) and your computer will actually seem faster (see Figure 4-41).

Figure 4-41. Move both sliders all the way to the right in Keyboard Properties to make your computer seem faster

The Hardware tab simply provides access to the Properties sheet for your keyboard (the same one you’ll get in Device Manager, discussed earlier in this chapter).

Notes

- All settings in this dialog are also covered in Chapter 5.
- Additional features that affect the keyboard repeat rate and text cursor can be found in Accessibility Options, discussed earlier in this chapter.
- Some keyboards, especially those with additional function buttons (such as web links and CD player controls), come with their own software. Some of this software includes hardware drivers and is absolutely necessary for operation, while other software is purely optional, adding only trivial features. Given the potential compatibility problems with Windows XP, it’s best only to install such software if it’s necessary or if it provides features you can’t live without.

See Also

Control Panel
**Label**

\windows\system\label.exe

Change the label of any hard disk, floppy disk, or removable media.

**To Open**

Command Prompt → label

**Usage**

label [drive] [label]

**Description**

Every disk has a label, the name shown in Explorer next to the drive letter (except for floppies). To change the label for any disk, right-click on its icon in Explorer (or the My Computer window), select Properties, and type a new name in the unlabeled field at the top of the properties window. The Label tool duplicates this functionality from the command line. For example, to change the label of drive c: to "shoebox," type:

label c: shoebox

If you omit label, you will be prompted to enter a new label. If you omit drive, label will use the current drive.

**Notes**

A disk's label has no effect on the operation of the disk; for hard disks, it's purely decorative. For CDs and other removable media, it's used to quickly identify what's in the drive.

**Local Security Policy**

\windows\system\secpol.msc

See Microsoft Management Console.

**Logoff**

\windows\system\logoff.exe

Log out the current user (or another user).

**To Open**
Command Prompt ➔ logoff

Usage

logoff [session] id [server.name] [v]

Description

Among other things, Logoff is the quickest way to log off the current user, rather than selecting "Shut Down from the Start Menu," choosing "Log off" from the list, and clicking OK. In fact, you can create a shortcut to Logoff on your Desktop and simply double-click it to enter current session.

Logoff can also be used to end the session of a remotely connected user, either through terminal services or through the Telnet daemon. For example, if someone has connected to a Windows XP computer using Telnet, you can disconnect them, either from another Telnet session or from the command prompt, by using Logoff and the following options:

- **session**: The name of the session to end; use either `session` or `id` to end a session, but not both.
- **id**: The ID of the session to end; use either `session` or `id` to end a session, but not both.
- **server.name**: Specifies the terminal server containing the session to end; the default is current.
- **v**: Displays additional information about the actions being performed.

See Also

Shutdown, Shut Down in Chapter r

Microsoft Chat

\windows\system 32\winchat.exe

Conduct a text-based chat session with another user over a network.

To Open

Command Prompt ➔ winchat

Description

Microsoft Chat is a simple chat program that allows two users to have a text-based conversation using two computers connected over a network (see Figure c-43). It's similar to the Unix talk command, where the screen is split in two panes and each user types and watches as the other types. Both screens are updated in real time, so you can see letters as they are typed by your partner.
Figure 4-49. The Chat tool is used to facilitate text conversations between two users on a network.

To initiate a chat session, click the Dial button on the toolbar or select Dial from the Conversation menu, select the target computer from the list (other computers in your workgroup will be shown here), and click OK. Then the user of the computer that has been dialed will see a Chat button in their Taskbar; that user must click the button to "answer" the call.

Notes

- If you're looking for the comic-strip style graphical IRC chat client included with some earlier versions of Windows (cchat.exe), this application is not included with Windows XP. However, there are several third-party alternatives that can be obtained from the Internet, such as LeafChat (http://www.leafdigital.com/) and mIRC (http://www.mirc.org/).
- To receive a Microsoft Chat call, you'll either need to have Chat running or have the Network DDE service started (see Microsoft Management Console for more information on services).

See Also

Microsoft NetMeeting, Msg, DDE Share

Microsoft Magnifier \windows\system32\magnify.exe

Show an enlarged version of the area of the screen near the mouse cursor.

To Open

Start ➔ Programs ➔ Accessories ➔ Accessibility ➔ Magnifier
Command Prompt ➔ magnify

Description

The Microsoft Magnifier is used to assist those with the visual impairments by magnifying a portion of the screen. When you start Magnifier, the top 10 percent of the screen turns into an automatic magnifying glass, which follows the mouse cursor around screen. If you have trouble seeing something on the screen, just float the cursor over it to magnify it (see Figure 4-49).
The Magnifier tool can follow your mouse cursor, enlarging any portion of the screen you point to.

The Magnifier can be resized or moved with the mouse. Furthermore, when Magnifier is first opened, the Magnifier settings window appears, allowing you to change magnification level and choose whether or not Magnifier follows the mouse cursor, keyboard focus, or the text cursor. To hide the settings window, just minimize it; if you close it, Magnifier will close.

Notes

Magnifier can also be very handy for application developers and web site authors, who may need to see pixel detail in their work.

See Also

Narrator, On-Screen Keyboard, Utility Manager

Microsoft Management Console

A single interface for dozens of administrative tools in Windows XP.

To Open

Start ➔ Programs ➔ Administrative Tools ➔ Computer Management
Command Prompt ➔ mm

Usage

mmc filename [/a] [/n] [/r]

Description
The Microsoft Management Console (MMC) is a host for most of the administrative tools that come with Windows XP (see Figure 4-01). Each of the tools that works with MMC is called a Snap-in; Several Snap-ins can be shown in MMC at any given time and appear as entries in the Explorer-style tree in the left pane.

Figure 4-01. The Microsoft Management Console houses many important troubleshooting and system-maintenance tools

A collection of one or more Snap-ins can be saved into a Console (.msc) file, which is a small file that simply lists Snap-ins to display in the Console window. Double-click any .msc file to open it in MMC. Windows XP ships with more than a dozen predefined Console files, and you can modify them (or even create your own) by adding or removing snap-ins or creating custom Taskpad Views — pages with lists of shortcuts to programs or other snap-ins.

There are about two dozen Snap-ins included in Windows XP. To add a Snap-in to the current Console file (select File → New to start a new Console), go to File → Add/Remove Snap-in, and click Add (see Figure 4-07). Then, choose one of the available Snap-ins (note that not all Snap-ins described here are available in all versions of Windows XP), and click Add to add it to the list in the previous Window. A wizard or other dialog may appear when certain items are added, used to configure this instance of the Snap-in being added; any preferences set here are saved into the Console file. You can continue to add additional items as needed; when you’re done, click Close. Note that it’s possible to add the same Snap-in more than once, so you may want to position the Windows side-by-side so you can see what has been installed.

Figure 4-07. Add tools to the current view by installing Snap-ins
Here are the Snap-ins included with Windows XP; most of the following are documented further in the Microsoft Management Console online help. Note that all Console (.msc) files mentioned are in the \windows\system32 folder unless otherwise mentioned.

**ActiveX Control**
Use this Snap-in to add an ActiveX control to your console file. Although Windows XP ships with many ActiveX controls, most of them aren't appropriate for MMC. More advanced users may wish to use this feature to create custom Snap-ins. Most users are likely to find the System Monitor Control to be the only useful ActiveX Snap-in included with Windows XP.

**Certificates**
Installed by default in certmgr.msc. Browse all the security certificates used by Internet Explorer and IIS, the web server included with Windows XP (Professional only).

**Component Services**
Installed by default in \windows\system32\com\comexp.msc. Manage installed component object model (COM) components.

**Computer Management**
Installed by default in compmgmt.msc. Computer Management doesn't have any functionality by itself; rather, it is a collection of the following thirteen Snap-ins: Event Viewer, Shared Folders, Local Users and Groups, Performance Logs and Alerts, Device Manager, Removable Storage, Disk Defragmenter, Disk Management, Services, WMI Control, Indexing Service, Message Queuing, and Internet Information Services.

**Device Manager**
Installed by default in devmgmt.msc and compmgmt.msc. See Device Manager, earlier in this chapter.

**Disk Defragmenter**
Installed by default in drfg.msc and compmgmt.msc. See Disk Defragmenter, earlier in this chapter.

**Disk Management**
Installed by default in `diskmgmt.msc` and `compmgmt.msc`. The Disk Management Snap-in lists all the installed drives, including hard disks, CD drives, and other removable storage devices (floppies are not included). Right-click on any drive (except the one on which Windows is installed) to change its drive letter. Go to View ➔ Top and View ➔ Bottom to choose whether drives are viewed as disks (physical devices), volumes (local drives, including partitions), and disks using a graphical view. Disk Management also has the ability to create and delete partitions (see also DiskPart, earlier in this chapter), but cannot make any modifications that affect the volume on which Windows is installed. PartitionMagic (http://www.powerquest.com/) allows more complete control over the creation and modification of partitions.

Among the features of the Disk Management console is the ability to change drive letters of your CD or DVD drive, removable cartridge drive, and even hard disk partitions. Just right-click a volume in the upper pane (for hard disk partitions) or one of the large buttons on the left side of the lower pane (for CD drives and the like) and select Change Drive Letter and Paths. Then, click Change to choose a new drive letter. If there's a drive letter conflict, you may have to click Remove first, resolve the conflict, and then return to the Change Drive Letter and Paths dialog and click Add to choose a drive letter.

**Event Viewer**

Installed by default in `eventvwr.msc` and `compmgmt.msc`. Views the three system event logs: Application, Security, and System. The Application log lists every application crash, status reports and warnings generated by services (see Services below), and other events logged by some applications. The Security log records events such as valid and invalid logon attempts, as well as events related to the use of shared resources. The system log contains events logged by Windows XP system components, such as driver failures and system startup errors.

A computer running Windows configured as a domain controller records events in two additional logs, Directory service and File Replication service. A computer running Windows configured as a Domain Name System (DNS) server records events in an additional log, DNS server. Event Viewer logs contain five types of events: Errors (driver and service failures), Warnings (indications of possible future problems), Information entries (the successful operation of an application, driver, or service), and Success Audits and Failure Audits (audited security access attempts that succeed and fail, respectively).

**Folder**

A folder is used to organize Snap-ins in the tree display. To use a folder, first add it using the procedure explained above. Then, close the Add Standalone Snap-in dialog, select the new folder from the "Snap-ins added to" list, and click Add again; this time, added items will appear in the new folder. Unfortunately, you can't drag-drop items from one folder to another, so the only way to move an item is to remove it from one folder and then add it to another. Folders can be renamed only from the main MMC window.

**FrontPage Server Extensions**

This Snap-in is used to manage the various FrontPage Server extensions and their settings.

**Group Policy (also known as Local Computer Policy)**

Installed by default in `gpedit.msc`. A collection of policy settings, controlling startup and shutdown scripts, security settings for Internet Explorer, and user account policies. Group Policy replaces the System Policy Editor found in earlier versions of Windows. See Chapter 5 for documentation on the settings in this Snap-in.

**Indexing Service**
The Indexing Service collects information from the documents on your hard disk and compiles a database used to enhance searches. The Indexing Service indexes .html files, .txt files, Microsoft Office documents, Internet mail and news, and any other document for which a document filter is available. The Indexing Service Snap-in allows you to manage the directories that are routinely scanned and query the database catalog.

**Internet Information Services**
Installed by default in compmgmt.msc and \windows\system32\inetsrv\iis.msc.
IIS is the Web/FTP/SMTP server built into Windows XP, and the Internet Information Services Snap-in allows you to administer the various functions associated with the server service. For example, you can configure how CGI scripts are running from web pages posted on the server.

**IP Security Monitor**
Monitor the IP Security status; see IP Security Policy Management, below, for more information.

**IP Security Policy Management**
Manage Internet Protocol Security (IPSec) policies for secure communication with other computers. IPSec can be thought of as a minimalistic firewall, allowing and disallowing certain communication over an Internet connection.

**Link to Web Address**
The Link to Web Address Snap-in allows you to insert, not surprisingly, the web site as an entry in the tree. For example, you may wish to include a link to a software downloads site, an HTTP-based administration page for a web site, or another troubleshooting web site, such as http://www.annoyances.org/.

**Local Computer Policy**
See "Group Policy (also known as Local Computer Policy)", above.

**Local Users and Groups**
Installed by default in lusrmgr.msc and compmgmt.msc.
This plug-in provides more advanced settings, using a simpler and more direct interface, than Control Panel → User Accounts. Here, you can set preferences relating to the expiration of passwords, the assignment of certain users to groups, logon scripts, location of a user's home folder, and other advanced options.

**Performance Logs and Alerts**
Installed by default in perfmon.msc and compmgmt.msc.
Performance Logs and Alerts allow you to collect performance data automatically from certain applications, and then create logs that can be exported then analyzed. The applications, designed to generate performance logs, are typically associated with web servers when an administrator would need to know exactly how the system resources are being utilized at any given time. See Help for more information on setting up performance data.

**Removable Storage Management**
Installed by default in ntmsmgr.msc and compmgmt.msc.
The Removable Storage Management Snap-in enables you to view all the devices that support removable media, such as CD and DVD drives, CD and DVD writers, tape drives, Zip drives, flash memory readers, and other similar devices. Removable Storage labels, catalogs, and tracks media and stores this information into libraries. Media Pools, collections of removable media to have the same management policies, are used to organize these libraries. For example, the catalogs in the Backup component rely on Removable Storage Management.

**Resultant Set of Policy**
Installed by default in rsop.msc.
This Snap-in allows you to view and change the policy settings for a particular user. See "Group Policy (also known as Local Computer Policy)", above, for more information.

**Security Configuration and Analysis**

This Snap-in is used to view and manage security databases for computers using Security Templates (see below) and is especially helpful for tracking changes to security.

**Security Templates**

Installed by default in secpol.msc. Security Templates are used to create a security policy for computers. They are used mostly by administrators for Windows XP-based servers. See Help for detailed information.

**Services**

Installed by default in services.msc and compmgmt.msc. A service is a program that runs invisibly in the background, usually started when Windows starts. You can set up any program to run automatically when Windows starts by placing a shortcut in your Startup folder, but such a program would only be run when you log in. A service is run when Windows starts and is already running when the login prompt is shown. Windows XP comes with nearly 40 preinstalled services, some of which are active by default (called "Started" in the Services window), and some of which are not.

Double-click any service in the list to view its properties, such as its status (Started or Stopped), whether or not it's started automatically, under which user accounts it is enabled, what actions to take if the service encounters a problem, and which other components the service depends on (if any). Common services include the plug-and-play manager, the task scheduler, the print spooler, automatic updates, an FTP server, a web server, a mail server, and many other programs responsible for keeping Windows XP running. You can start or stop any service by right-clicking on it and selecting Start or Stop, respectively. Stopping unnecessary services will not only increase system performance, but will close potential security "backdoors" that could be used to break into a computer. Naturally, you should use caution when disabling any enabled service, but most home users won't need the "mail server" service to be running all the time. See Appendix G for a list of the default services in Windows XP, their corresponding filenames, and their descriptions.

**Shared Folders**

Installed by default in fsmmgmt.msc and compmgmt.msc. As described in Chapter v, any folder or drive can be shared, allowing access to it from another computer on the network. The Shared Folders Snap-in lists all of the shared resources in one place, as well as any open connections to those resources from other computers. Rather than "sharing and forgetting," this tool allows you to keep a more active watch on how shared resources are being used.

One thing to note is the existence of administrative shares, those items listed in the Shares portion of the Shared Folders Snap-in, denoted by a dollar sign ($) at the end of the share name. Administrator shares cannot be disabled, and when used in conjunction with Create Shared Folder (discussed earlier in this chapter), can even be a security risk, in which someone else with your username and password can access to any file or folder on your computer without ever sitting in front of it. Suffice it to say, if you're on a network, or even an Internet connection, you should investigate the security settings in your computer and try to close as many back doors as you can without disabling functions that you still need. If you're concerned about security, you may wish to use Windows XP's built-in firewall (see Chapter v) or invest in third-party firewall software (such as Norton...
Personal Firewall (http://www.symantec.com/), each of which actively helps prevent unauthorized access your computer.

**WMI Control**

Installed by default in `wmimgmt.msc` and `compmgmt.msc`. WMI (Windows Management Instrumentation) is set of standards for accessing and sharing management information over an enterprise network. WMI will be of little use to most users; for more information, see Help.

One of the most interesting features of the Microsoft Management Console is its ability to access most of these tools remotely. For example, you can use it to run Device Manager on a machine other than the one you're using. Naturally, this would be most useful to an administrator, who can now configure and maintain a whole group of computers from a single machine. However, as home networks become more common, ordinary users are being turned into administrators. For instance, if you were responsible for setting up a network between the two or three computers used by the members of your family, you'd be able to run Disk Defragmenter on all the machines without having to jump around between them. Nevertheless, it provides more power than is normally available via My Network Places.

Connecting to another computer with MMC depends on the particular Snap-in you're using. Most Snap-ins that support remote administration will prompt you when you first add them, asking whether the Snap-in should be used with the current computer or with another on the network. In the case of Computer Management (`compmgmt.msc`), just right-click on the Computer Management root entry of the tree, select "Connect to another computer," and type the name of the computer in the box that appears. When connected to another computer, the root entry will be named `Computer Management (computername)`.

The Microsoft Management Console also has a few command-line options:

/`a`

Some Console (.msc) files have been configured so that the Snap-in tree normally shown is not only hidden, but inaccessible. Furthermore, you may not have access to the standard MMC menus, meaning that you will not be able to add or remove Snap-ins as desired. The /`a` option opens MMC in "author" mode, allowing you to treat any saved Console file as though you created it, giving you power to modify the Console by adding or removing Snap-ins.

/`s`

The /`s` parameter is included with some shortcuts to .msc files in the Start menu, but it does not appear to have any effect.

/32 or /50

Run MMC in 32-bit or 16-bit mode, respectively; it is only available on 16-bit systems.

**Notes**

- Eventually, you'll probably want to create your own Console file with the Snap-ins you use most. While it can create a new Console file from scratch, it may be easier to modify one of the supplied .msc files and then save it with a new name. To modify a saved Console file, start MMC with the /`a` switch, as described above.
- Programmers who wish to learn how to create custom Snap-ins can find more information at http://msdn.microsoft.com/.

```bash
Microsoft \program files\netmeeting\conf.exe
```
**NetMeeting**

Voice and video conference application.

**To Open**

Start → Programs → Accessories → Communications → NetMeeting
Command Prompt → conf

**Description**

NetMeeting allows videoconferencing (videophone) and voice conferencing (net phone) over a network or Internet connection (see Figure 4-15). The connection is made via either a central directory service (Microsoft provides several) or directly to another user’s IP address.

All you need to initiate a voice conference (audio only) is an Internet connection and a sound card, speakers, and a microphone on each end. For video conferencing, all you need in addition are two videoconferencing cameras (USB cameras are surprisingly cheap). As you might expect, videoconferencing requires more bandwidth than voice conferencing alone. Make sure your Internet connection and all your sound and video hardware are properly installed before you try to use them with NetMeeting.

Figure 4-15. NetMeeting facilitates voice and video conferencing over an Internet or LAN connection

The first time you start NetMeeting, you’ll be asked several questions about your identity. If privacy is a concern, you don’t have to fill out all the fields, but the email address will help others find you if they don’t have your IP address (using a directory server).

The next page in the setup wizard allows you to choose how you’ll use directory services. For NetMeeting to establish a connection between two computers, one
user must call another; and in order for that to happen, the caller must either know the recipient's IP address or must specify the recipient's email address. Since a user's IP address can change every time that user connects to the Internet (only with dynamic IP assignment), a directory server can be used to automatically look up a user's IP address by supplying only the user's email address. If you choose to "Log onto a directory server when NetMeeting starts," NetMeeting will update the directory server with your current IP address every time you start a session; turn this option off if you have a static (unchanging) IP address or if you wish to manually inform prospective callers of your IP address every time you need to use NetMeeting. If you choose to use a directory server, you can use Microsoft's default (Microsoft's Internet Directory) or specify your own server (see Notes). Unless you wish to have strangers calling you, you'll probably want to place a checkmark next to the "Do not list my name in the directory" option. After that, you will be asked to specify the speed of your connection and whether or not you what to create a Desktop icon. Next, you'll be walked through the Audio Tuning Wizard, the tool that will help you adjust the levels of your microphone and speakers so that NetMeeting will work properly. If you make any changes to your sound hardware, you can run the Audio Tuning Wizard again by going to Tools → Audio Tuning Wizard.

Using NetMeeting is not hard. To start a conference, one user must call another; if you're the caller, type the recipient's email address or IP address into the text field at the top of the window and press enter or click the little telephone button. The recipient must also be running NetMeeting; when a call is placed, the recipient's copy of NetMeeting will "ring" and the recipient will be given the chance to accept or ignore the incoming call. Hang up any call by clicking the Hang Up button or by selecting Hang Up from the Call menu.

The "Windows NetMeeting" box in the middle of the NetMeeting window is for the video of the other person in the conversation and can be turned off with View → Data Only. The Play/Pause button underneath is used to start and stop the video portion of the conference. If you are videoconferencing, you'll probably want to select My Video from the View menu to see what your partner is seeing.

In addition to facilitating a person-to-person conference, NetMeeting allows you to set up a meeting in which any number of users can join and video or voice conference. Rather than placing calls, however, the meeting is initiated when one user decides to host a meeting (Call → Host Meeting). Furthermore, several collaboration tools are made available with meetings:

**Sharing**

Also called "Remote Desktop Sharing," this feature is a basic remote control program, in which you can see another user's Desktop and control it as though you were sitting in front of it. Alternatives to Remote Desktop Sharing includepcAnywhere (commercial software, [http://www.symantec.com/](http://www.symantec.com/)), VNC (freeware, [http://www.uk.research.att.com/vnc/](http://www.uk.research.att.com/vnc/)), and Remote Desktop Connection (included with Windows XP Professional and discussed later in this chapter).

**Whiteboard**

The NetMeeting Whiteboard is not unlike a real whiteboard: it allows users to collaborate by using drawing tools on blank white page. All members of the meeting see the same whiteboard and can watch as others draw.

**Chat**

Like Microsoft Chat, the Chat feature in NetMeeting allows users to communicate by typing. While it may seem archaic, it's really an easy way to share short pieces of text, such as web addresses, phone numbers, or excerpts from documents.

**File Transfer**

What communication tool would be complete without a way to share files? NetMeeting allows you to send and receive files with those who have joined your meeting by going to Tools → File Transfer → Send File. You can also
send a file to all members by simply dragging the file into the call window; once a file is sent, recipients can individually accept or decline the transfer. Note that, unless you have an exceptionally fast connection, the transfer of files during a meeting will significantly slow down your connection and the quality of the video and sound will go down. Naturally, you can also send and receive files via email or FTP.

To join the meeting in progress, place a call to the user hosting the meeting as you would when initiating a one-on-one conference, as described above.

Notes

- To use a videocamera or other video source with NetMeeting, the driver must be compatible with either the H.261 or H.263 compression/decompression (codec) protocols.
- If you don't wish to use the directory service, you can have others connect to you by providing your IP address. To find out what your IP address is, select About from NetMeeting's Help menu or use the Windows IP Configuration, described later in this chapter. If you have a dynamic IP address, you can use a service like DynIP (http://www.dynip.com) or HomeIP (http://www.homeip.net) to associate a domain with your IP address, a link that is updated every time you connect to the Internet.
- There are circumstances when others will not be able to connect to you, usually because of a problem with your IP address or because of a firewall. For example, if you're using computer connected to the Internet through Internet Connection Sharing (see Chapter 1), you may not have a valid IP address. Likewise, a firewall, which is designed to prevent certain types of network communication, can easily interfere with NetMeeting. The solution, if you encounter one of these problems, is for you to place the call and for your partner to answer.
- While NetMeeting is designed to facilitate conferencing over the Internet, it also supports local area networks. If you wish to call another NetMeeting user on your local network, simply type that user's computer name instead of the IP address or email address.
- Microsoft Internet Directory is a dedicated directory server that allows users to host meetings and allows other users to view a directory of all users on the server, similar to the way a chat server works. You can browse the directory of users and join any meetings they are hosting. ILS is part of Microsoft Site Server and is also available for free download from http://www.microsoft.com/, if you are interested in running your own server on the Internet or a local network. When you first run NetMeeting, you can choose from a list of popular ILSs to which to connect (most are run by Microsoft). Once connected, the NetMeeting directory view lists users that are hosting meetings on the server.
- If you want NetMeeting to run automatically when you start Windows, select Tools ➔ Options ➔ General ➔ Run when Windows starts. This will also set NetMeeting to alert you of incoming calls. The other thing you may wish to do is set NetMeeting to automatically log onto a directory server by going to Tools ➔ Options and turning on the "Log onto directory server when NetMeeting starts" option. This turns NetMeeting into a "messenger" or "buddy list" application.
- When using Netmeeting, you may be prompted to sign up for a Microsoft .NET Passport account. Unfortunately, this has caused some confusion among many users. A Passport account is absolutely not required for any features of Windows, with the exception of the MSN Explorer and Windows Messenger components. Passport is a totally optional service (and Microsoft has been widely criticized for making it appear otherwise), and unless you
wish to use MSN, Messenger, or the Hotmail service, you'll most likely have no use for a Passport account.

See Also

Microsoft Chat, Msg, Phone Dialer

Minesweeper

\windows\system32\winmine.exe

A silly little game relying on the process of elimination.

To Open

Start ➔ Programs ➔ Games ➔ Minesweeper
Address ➔ winmine

Description

The object of Minesweeper is to uncover "safe" areas on a playing field without hitting on any landmines. Start by clicking a square with the left mouse button to uncover it; if it's a mine, the game is over. Otherwise you'll either see a number, corresponding to the number of mines immediately adjacent to the clicked square, or the square will be blank, meaning that there are no adjacent mines. If you click a square with no adjacent mines, all the connecting squares are automatically uncovered until a numbered square is reached. Use the numbers as hints to where the mines are located; use the process of elimination to uncover all the squares that aren't mines. Use the right mouse button to mark uncertain squares, which has the added benefit of preventing them from being clicked accidentally (see Figure 5-04).

Figure 5-04. Try to clear the mine field without upsetting the little smiley guy

Notes
The beginner game uses an 8 x 8 grid with 80 mines; intermediate uses an 8 x 8 grid with 40 mines; expert uses a 50 x 8 grid with 22 mines. You can also create custom games, such as an easy 50 x 50 grid with only 80 mines, or a difficult 8 x 8 grid with 8 mines.

If a number appears on a square, it specifies how many mines are in the eight squares that surround the numbered square.

**Mouse Properties**

Change settings that affect the behavior of your pointing device and the appearance of the mouse cursor.

**To Open**

Control Panel ➔ [Printers and Other Hardware] ➔ Mouse

Command Prompt ➔ control main.cpl

Command Prompt ➔ control mouse

**Description**

The Mouse Properties dialog controls the buttons and motion of your pointing device and the appearance of the various mouse cursors, such as the arrow and hourglass. Settings are distributed into the following sections:

**Buttons**

The three settings on this page allow you to switch the left and right mouse buttons (useful for southpaws or those with unusual pointing devices), change the speed at which items respond to double-clicks, and control the ClickLock feature (which enables dragging without having to hold down any buttons).

**Pointers**

The Pointers tab lets you choose how your mouse pointer looks. This affects not only the standard arrow cursor, but the hourglass, the arrow/hourglass combination, all of the resize arrows, and even the hand cursor used in Internet Explorer. Cursors that ship with Windows are stored in the \Windows\Cursors folder and additional cursors are available on the Internet from such web sites as http://www.anicursor.com/. You can also get a cursor editor, allowing you to create your own static and animated mouse pointers (try AX-Cursors, at http://www.axialis.com/axcursors/, or Microangelo, at http://www.impactsoftware.com)(see Figure 4-11).

**Figure 4-11.** Choosing custom mouse pointers can go a long way to improving your sanity when sitting in front of a computer.
The pointer shadow is actually kind of cool, but it isn't compatible with all display drivers.

**Pointer Options**

These settings are used to adjust how the mouse pointer responds to the physical motion of your pointing device. A fast pointer speed makes the cursor more sensitive. The Enhance pointer precision option enables minor mouse acceleration and deceleration, which moves the pointer more slowly when you move only a short distance.

**Wheel**

The mouse wheel, present on some mice and trackballs, is intended to aid scrolling. Just roll the wheel to scroll up or down in a listbox, document, or web page instead of controlling the scrollbar directly with the mouse pointer. If your pointing device doesn't have a wheel, these settings are ignored.

**Hardware**

Finally, the Hardware tab simply lists the pointing devices attached to the system. Note that the Properties page is the same one you'll get in Device Manager (discussed earlier in this chapter). The Troubleshoot button simply opens up a Help and Support Center window with a step-by-step troubleshooting tutorial.

**Notes**

- All settings in this dialog are also covered in Chapter 6.
- Many pointing devices come with their own software. Some of this software includes hardware drivers and is absolutely necessary for operation, while other software is purely optional, adding only trivial features. Given the potential compatibility problems with Windows XP, it's best to install such software only if it's necessary or if it provides features you can't live without.

**See Also**

*Control Panel*
**Msg**
\windows\system 32\msg.exe

Send a text message to one or all local users.

To Open

Command Prompt  → msg

Usage

msg recipient [server: name] [time: sec] [/v] [/w] [message]

Description

Msg is used to send a text message to a user currently logged onto the local computer; it can also be used to send a message simultaneously to all logged-in users.

Note that Msg is not intended to send messages to other computers, but to users remotely logged onto your computer. The exception is a user on another machine currently logged into your computer (or the machine specified by /server), assuming that machine is set up as a Terminal Server. To send a message to another computer, use Microsoft Chat (or just send an email).

Msg accepts the following options:

- **message**
  The text message to send. If omitted, Msg prompts for it. Also can read from stdin; see Appendix C.

- **recipient**
  Recipient can be a username, a session name, a session ID, or a filename (pointing to a file containing a list of usernames, session names, or session IDs). Or, specify an asterisk (*) to send a message to all sessions on the specified server.

- **/server:**  name
  Specifies /server:name to send the message to users on another machine, where name is the name of a Terminal Server (see Services in Microsoft Management Console earlier in this chapter).

- **/time:**  sec
  Indicates the amount of time, in seconds, to wait for the recipient to acknowledge the message being sent.

- **/v**
  Verbose mode; displays additional information about the actions being performed.

- **/w**
  Waits for a response from the recipient, useful with /v.

See Also

Microsoft Chat, Microsoft NetMeeting
**MSN Explorer** \program files\msn\msncorefiles\msn 5.exe

The graphical interface to the MSN online service.

**To Open**

Little butterfly icon in the quicklaunch toolbar
Command Prompt → msn

**Description**

The MSN online service, in addition to providing basic Internet access, supplies online content, somewhat like American Online (AOL). The MSN Explorer is an integrated web browser, email program, and messenger ("buddy list") for use with the MSN service (see Figure 4-1).

**Figure 4-1.** The MSN online service works like Internet Explorer, but has more brightly colored icons and is linked up with Microsoft’s Passport service

You don't have to be a subscriber to MSN to use MSN Explorer, but you have to complete the initial signup wizard. Although it's free, it does require several pieces of personal information, such as your geographic location, birthdate, and occupation. Once you complete the sign-in process, the MSN Explorer window resembles the Internet Explorer web browser, except the menu is gone, the toolbar is simplified, and an additional task pane is shown on the left.

**Notes**

- The MSN Explorer offers very little functionality above and beyond Internet Explorer. It is merely a friendlier, less intimidating interface designed to appeal to novices and children. One potential advantage is the total lack of knowledge required to get up and running with MSN Explorer; for example, most features on the toolbar are automatically configured for the currently logged-in user, so all one needs to do is click the buttons.
- The toolbar buttons, images, and default pages are all rather large. The minimum recommended resolution to use MSN Explorer is 800 x 600, and that's only appropriate if the window is maximized.
• The Email button is essentially a shortcut to Hotmail, Microsoft's free web-based email client. Likewise, the Online Buddies, the People & Chat, and the Money buttons all are shortcuts to corresponding web sites at http://www.msn.com/.

• When you close MSN Explorer, it remains in memory. To sign out of MSN and shut down the MSN Explorer completely, right-click on the MSN icon in the Tray (next to the clock) and select Exit MSN Explorer.

• In order to use MSN Explorer or Windows Messenger, you'll need to set up a Microsoft .NET Passport account. There has been some confusion regarding Passport among many users, however. A Passport account is absolutely not required for any other features of Windows; in fact, Microsoft has been widely criticized for making it appear otherwise.

See Also

Internet Explorer, Outlook Express, MSN Gaming Zone

**MSN Gaming Zone**

A collection of games that can be played with other users over the Internet.

**To Open**

Start → Programs → Games → Internet Backgammon
Start → Programs → Games → Internet Checkers
Start → Programs → Games → Internet Hearts
Start → Programs → Games → Internet Reversi
Start → Programs → Games → Internet Spades

**Description**

Windows XP ships with eleven games, five of which are part of the MSN Gaming Zone and support play with other users over the Internet. All five games, while different in gameplay, work similarly. When you first start one of the games, you are automatically connected to a gaming server provided by Microsoft that is designed to post the communication between all of the different users. In addition to allowing collaborative play, a simple chat session is initiated in which the players can type text messages to communicate. Consult Help in any game window for playing tips.

**Notes**

• The MSN Gaming Zone randomly assigns players to games, so you never know who you're up against. By default, the selected skill level is beginner, which unfortunately pits you against other users who're most likely just goofing around, probably trying these games for the first time. Your best bet to find a more serious opponents is to select an Intermediate or Advanced skill level by going to Game → Skill Level.

• If the gaming server can't find a human opponent at any given time, one or more computer opponents will be used. However, there is no way to specify a computer opponent. Whether you've been assigned a computer or a
person as an opponent, you can have a new one assigned to you by going to Game → Find New Opponent.

- None of the MSN Gaming Zone games can be played without an Internet connection, so if you don't wish to play against a human opponent, you'll need to obtain a non-network version of the particular game. (Hundreds of downloadable, single-player games are available on the Internet.)

**See Also**

MSN Explorer, Hearts, Microsoft Chat

**My Computer**

See Windows Explorer.

**My Network Places**

See Windows Explorer.

**Narrator**

`\windows\system 32\narrator.exe`

A text-to-speech program intended for use by visually impaired users.

**To Open**

Start → Programs → Accessories → Accessibility → Magnifier

Command Prompt → narrator

**Description**

The Narrator is used to assist those with the visual impairments by using a voice synthesizer and your computer's sound hardware to read aloud text and the titles of screen elements (see Figure 4-1). Narrator reads the following types of text:

- **Events on screen**
  Check the "Announced events on screen" option to have Narrator speak messages that appear, the titles of Windows when they are activated, and the captions of many types of screen elements.

- **Typed characters**
Narrator can optionally speak each letter and number as its corresponding key is pressed on the keyboard.

**Figure 4-0v. The Narrator uses speech to read the captions of various screen elements over your speakers**

In addition to these functions, the following keyboard shortcuts can be used to read additional items:

- To read an entire window, click the window and then press Ctrl-Shift-Spacebar.
- To read the caption of the control with the focus, or to read the contents of a text field, press Ctrl-Shift-Enter.
- To get a more detailed description of an item, press Ctrl-Shift-Insert.
- To read the titlebar of a window, press Alt-Home.
- To read the status bar of a window, press Alt-End.
- To silence the speech, press the Ctrl key by itself.

**Notes**

- Narrator is supported only in the English version of Windows XP.
- A far more impressive, related technology is that used in speech recognition software, in which the computer will take dictation, translating anything spoken into a microphone into text on the screen. Although initially developed for physically challenged users, speech recognition has become very popular among all types of users, partly because of the novelty, partly because of the speed (some can type up to 11 words per minute), and partly to help reduce repetitive stress injuries. In fact, some of this book was dictated with the assistance of Dragon NaturallySpeaking (http://www.dragonsys.com/). Microsoft Office XP also comes with a new voice recognition feature, although it’s not nearly as sophisticated as NaturallySpeaking or IBM’s ViaVoice (http://www.ibm.com/speech).

**See Also**

Microsoft Magnifier, On-Screen Keyboard, Utility Manager

**Net**

```
\windows\system \r\net.exe
```

Display, modify, and troubleshoot your current workgroup settings.
To Open

Command Prompt ➔ net

Usage

net command[parameters]

Description

Net is a general purpose diagnostic tool used to configure, control, and troubleshoot the networking settings on a Windows XP system. The Net tool is largely obsolete, although it may appeal to more advanced users or those who need to control network settings from the command line.

To use Net, you must specify one of the following commands, followed by any of the applicable parameters. To get more information about any of these commands, use the help command, like this:

net help command

Here are the commands used with Net:

accounts
Use net accounts to update the user accounts database and modify password and logon requirements for all accounts. If used without parameters, the current settings for password, logon limitations, and domain information are displayed.

computer
Use net computer to add or delete computers from a domain database; only available on Windows XP Server and Advanced Server.

cfg
The net config command displays configuration information about the workstation or server service. See Examples, below.

continue
Type net continue to reactivate a Windows service that has been suspended by net pause.

file
Closes a shared file and removes any file locks. When used without options, net file lists the open files on a server (see OpenFiles, later in this chapter). The listing includes the ID number, location, number of locks, and the user currently accessing the file.

group
Adds, displays, or modifies global groups on servers. When used without options, net group displays a list of the groups on the server.

help
Displays more information about any command. When used without options, net help displays all the available commands.

helpmsg
The net helpmsg command displays information about error, warning, and alert messages relating to a Windows network. For example, type net helpmsg &lt;#&gt; to display an explanation of error &lt;#&gt; and any possible remedies.

localgroup
Modifies local groups on computers. When used without options, net localgroup displays a list of the groups on the server.

cfg
The net name command adds or deletes a messaging name, an alias to which messages are sent (via net send). When used without options, a list of names accepting messages at the computer is displayed.

pause

Use net pause to temporarily suspend a Windows service or resource and use net continue to reactivate it when you’re ready.

print

The net print command displays print jobs and shared printer queues.

send

Sends messages to other users, computers, or messaging names (see net name) on the network. You can use net send to send a message only to a name that is active on the network; if the message is sent to a username, that user must be logged on and running the Messenger service to receive the message.

session

Net session lists or disconnects sessions between the computer and other computers on the network.

share

The net share command makes a server’s resources available to network users. When used without options, it lists information about all resources being shared. See also Create Shared Folder, earlier in this chapter.

start

Use net start to start a service. When used without options, it lists services that have already been started.

statistics

Displays the statistics log for the local workstation or server service. Used without parameters, net statistics displays the services for which statistics are available.

stop

Use net stop to stop a service that has been started with net start. Note that stopping some services will cause others to be stopped, and some services cannot be stopped at all.

time

Probably the most interesting command in the bunch, net time is used to synchronize the computer’s clock with that of another computer or domain. You can also use net time to set the NTP timeserver for the computer.

use

The net use command connects (or disconnects) a computer to a shared resource (shared with net share). When used without options, it lists the computer’s active connections.

user

Creates and modifies user accounts. When used without options, net user lists the user accounts for the computer. The user account information is stored in the same user accounts database used by Control Panel User Accounts; see User Accounts, later in this chapter.

view

Net view displays a list of resources being shared on a remote computer. When used without options, it displays a list of computers in the current domain or network.

Examples

To display your computer’s current workgroup settings:

C:\>net config

Computer name \WHISTLER
Full Computer name                   whistler
User name                            Administrator
Workstation active on
   NetbiosSmb (.............)
      NetBT_Tcpip_{0.12345678-9F-4C.F-A987-9878486456DE} (01.01.E01.8)
Software version                     Windows 2002
Workstation domain                   WORKGROUP
Workstation Domain DNS Name           (null)
Logon domain                         WHISTLER
COM Open Timeout (sec)               0
COM Send Count (byte)                16
COM Send Timeout (msec)              200
The command completed successfully.

See Also

Network Connections, Chapter v

Netstat

See Active Connections Utility.

Network Connections \windows\system\ncpa.cpl

Manage connections to varying network resources.

To Launch

Control Panel  ➔ [Network and Internet Connections] ➔ Network Connections
Start ➔ Settings ➔ Network Connections

This only appears when you're using the Classic Start menu, and then only sometimes.

Right-click the My Network Places icon ➔ Properties
Command Prompt ➔ ncpa.cpl
Command Prompt ➔ control netconnections

Description
The Network Connections folder is used to connect your computer to the Internet, to another computer on a local area network, and to many other types of network resources (see Figure 4-10). See Chapter 5 for a comprehensive discussion of the Network Connections window and the networking features built into Windows XP.

**Figure 4-10.** The Network Connections window allows you to connect your computer to a local network or to the Internet

![Network Connections Window](image)

### Network Setup Wizard

Automatically configure your Internet connection and local network settings based on one of several predefined scenarios.

**To Open**

1. My Network Places ➔ Network Setup Wizard
2. Start ➔ Programs ➔ Accessories ➔ Communications ➔ Network Setup Wizard

   ![Command Prompt](image)

   *rundll32 hnetwiz.dll,HomeNetWizardRunDll*

**Description**

The Network Setup Wizard walks you through some basic networking settings and is intended to make it easy to set up Windows to work with your Internet connection or to gain access to other computers on your network (see Figure 4-09).

**Figure 4-09.** The Network Setup Wizard asks you a few networking questions and configures your network settings accordingly
The first page of the Network Setup Wizard implies that the wizard will set up a network for you, help you set up Internet connection sharing, install a firewall, and share files and printers. In fact, it will do none of these things; rather, it will simply ensure that some of the necessary protocols are installed and properly configured for the type of network to which you plan on attaching your computer. Before you use the Network Setup Wizard, you'll need to make sure all of your networking hardware is properly installed, as described in Chapter 5.

The "Select a connection method" page asks you to define a role for the computer, in so much as how the computer is to be connected to the Internet. Note that if you choose the second option, which specifies that the computer is to connect to the Internet through another computer or a gateway, you still have to set up that other computer or gateway to provide the Internet connection. If neither of the first two options presented applies to your system, choose Other to display three other scenarios.

One of the nice things about the Network Setup Wizard is that it controls settings that relate both to your Internet connection and to your connection to your local network (if applicable). While it can't recognize and set up every possible configuration, it is programmed to recognize when your selections are not compatible with the hardware it detects.

Continue to answer questions until the summary page is displayed, and if you have no objections, click Finish to apply the settings. Naturally, you can always run the wizard again or modify the settings manually to get it to work.

Notes

- If the Network Setup Wizard prompts you to create a setup disk for use on other computers, answer "Just finish the wizard," as the disk is of little use.
- The Network Setup Wizard won't help you set up an Internet connection, but the New Connection Wizard (discussed later in this chapter) will.
- The Network Setup Wizard replaces the Home Networking Wizard found in Windows Me.

See Also

Chapter 5

New Connection Wizard

\Program Files\Internet Explorer\Connection
Set up

a new network connection.

To Open

Control Panel → [Network and Internet Connections] → Network Connections → New Connection Wizard

If you have the "Show common tasks in folders" option turned on (see Folder Options), click the "Create a new connection" link to start the New Connection Wizard.

Start → Programs → Accessories → Communications → Connection Wizard → icwconn

Description

Windows XP handles network and Internet access with distinct "connections," listed in the Network Connections window (discussed earlier in this chapter). The New Connection Wizard will guide you through the process of setting up a new connection; the following four types, presented on the first page of the wizard, are available:

Connect to the Internet

Use this option to set up a new Internet connection (see Figure 4-1). The next page shows three options. Most users want to pick the second, "Set up my connection manually," as it will set up a basic connection, compatible with most Internet service providers. The first option, "Choose from a list...," is used only if you wish to sign up for MSN (Microsoft's online service) or if you want to cruise Microsoft's list of service providers (see Notes). The third option, "Use the CD I got from an ISP," merely starts the setup program on whatever CD is inserted in the drive.

Figure 4-1. Add an Internet connection with the New Connection Wizard
Connect to the network at my workplace
This option helps set up a remote connection to a business network, either through a dialup connection or through Virtual Private Networking (VPN). Note that your business network must be set up to accept such connections; contact your administrator for specific instructions.

Set up a home or small office network
Choose this option to close the New Connection Wizard and run the Network Setup Wizard (explained earlier in this chapter).

Set up an advanced connection
The last option on this page lets you set up other types of connections, such as those that use a single serial or parallel cable (called "Direct Cable Connection" in previous versions of Windows) or those that communicate wirelessly with an infrared port. While these types of connections aren't strictly network connections, Windows XP treats them as such — not only in this wizard, but in Explorer (after they've been set up) as well. There is one tangible difference with this type of connection, at least concerning this wizard: one computer must be first set up to "accept incoming connections" before another computer can be connected to it.

You may notice that there's no way to add a standard Ethernet connection. This is because a new connection icon is automatically added for each network interface card installed in your computer; install two network cards, and you'll see two connection icons here.

The first thing you may wish to do after creating a new connection is to rename it so that it is easier to identify later on and easier to distinguish from the other connections. To make any other changes to the new connection, right-click on it and select Properties. See Chapter 9 for more information on the various protocols and settings in these properties sheets necessary for setting up a network.

Notes

- All the choices made in this wizard result in the creation of a new connection icon in the Network Connections window; no changes to any other connections are made (except where new hardware has been added). This means that, even after completing this wizard, you can undo your changes simply by deleting the new connection.
- The New Connection Wizard is designed to create a new connection, not to modify an existing one. See Network Setup Wizard, discussed earlier in this chapter, if you're having trouble configuring your network or Internet connection, or if you can't get Internet Connection Sharing to work.
The New Connection Wizard replaces the Internet Connection Wizard found in earlier versions of Windows.

See Also

Chapter v

Notepad

\windows\notepad.exe

A rudimentary plain text editor.

To Open

Start → Program → Accessories → Notepad
Command Prompt → notepad

Usage

notepad [/p] [filename]

Description

Notepad is one of the simplest, yet useful tools included with Windows XP. Those familiar with word processors may find Notepad to be laughably limited at first glance, as it has no support for even the simplest formatting. However, the fact that it supports only text in the documents that it creates is an absolute necessity for many of the tasks for which it is used on a daily basis (see Figure 4-81).

Figure 4-81. Use Notepad to edit text files without the bother of a word processor

Among the file types Notepad can edit are .txt files (plain text files), .reg files (see registry patch files in Chapter v), .bat files (see batch files in Appendix C), .ini files (configuration files), .html files (web pages), and any other ASCII text-based file type.

Notepad is the default application for .txt and .log files and is set up as the Edit context menu action for .bat, .inf, and .reg files, among others. Furthermore, via the /p command-line parameter, Notepad is used to print most text-based file types via the Print context menu action.

Notes
In some previous versions of Windows, Notepad had a limit as to the size of documents it could open. The Windows XP version of Notepad has no such limit, and can be used to open a file of any size.

Notepad has no intrinsic formatting of its own, so any file that is opened in Notepad is displayed exactly as it is stored on the hard disk, with the proviso that only visible characters will be shown. This means that you can open any file, text-based or otherwise, in Notepad; if you try to open a binary file, however, you'll see mostly gibberish. There are times, though, when this can be useful; if you suspect that an image file or a movie file has the wrong extension, you can open it in Notepad to verify its contents. (Naturally, some experience is required to correctly identify different types of files.)

The Word Wrap feature (Edit → Word Wrap) will break apart long lines of text so that they are visible in the Notepad window without horizontal scrolling. However, no permanent changes will be made to the file, so you can use the Word Wrap feature without fear of damaging the integrity of the document.

If you type the text, .LOG (in uppercase and including the period) as the first line in a text file, Notepad will automatically place the time and date at the end of the file (with the cursor right below it) every time you open it, forming a simple log file. Furthermore, you can use the F0 key to manually place a date/time stamp at the current cursor location while editing any file.

Notepad is a simple program, but by no means a full-featured text editor. UltraEdit (http://www.ultraedit.com/) is a much more sophisticated text editor, and can also be used as a hex (binary) editor.

See Also

WordPad

NSLookup \windows\system32\nslookup.exe

Perform a Domain Name Server (DNS) lookup, used to convert domain names to IP addresses, and vice-versa.

To Open

Command Prompt → nslookup

Usage

nslookup address

Description

When you type a web address into a browser's address bar and press Enter, Windows looks up the server name to determine the corresponding IP address. Then the IP address is used to initiate communication with the server. If the lookup fails, either because the name servers (the machines containing the DNS lookup tables) are down or because the specified domain does not exist, the connection attempt will fail as well.
NSLookup is a simple tool that allows you to look up the IP address of any domain name or server name, as well as find the server name associated with any particular IP address. To use NSLookup, just specify the domain name at the prompt, like this:

c:\> nslookup annoyances.org
Name:    annoyances.org
Address:  202.855.15.850

Likewise, you can specify an IP address and NSLookup will report the associated domain (called a reverse lookup):

c:\> nslookup 202.204.84#22
Name:    www.oreilly.com
Address:  202.204.84#22

Notes

- Every time you initiate communication with a server, there will be a delay while Windows performs an NSLookup. To eliminate the delay, use NSLookup to determine the IP address and then replace the reference with the IP address. This is especially useful with applications that frequently access the same server; for example, use an IP address as the mail server in your email program (or as the server name in your web browser homepage) for the best performance.
- Most Internet service providers employ at least two name servers, which are used for lookups for all of their customers. If one goes down, the other takes up the slack. However, if both name servers are down for some reason, or even just performing poorly, it can disable most Internet communication. If, however, you use IP addresses as described in the previous note, you eliminate your susceptibility to this problem.
- Since NSLookup, as well as the automatic lookups performed behind the scenes, all depend on your ISP's name servers, they are susceptible to receiving outdated information. If you're having trouble accessing a particular server, you can use an NSLookup gateway to double check your findings. An NSLookup gateway is simply a web-enabled version of NSLookup. It can also be used to perform lookups; however, if the gateway site is outside your Internet service provider, it will use its own name servers and therefore may provide more up-to-date information. To find such a site, perform a web search for "NSLookup gateway."
- NSLookup also performs a lookup of the IP address of your local computer and displays it before performing the requested look up. In many cases, though, it will fail, which means that you may see an error message every time you run NSLookup (such as "Can't find server name..."). However, this won't interfere with NSLookup's primary function.
- Windows caches some lookups, which means that you may see outdated information. To flush the cache, type ipconfig /flushdns at the command prompt. See Windows IP Configuration, later in this chapter, for more information.

See Also

Ping, Tracert, Windows IP Configuration

NTFS Compression \windows\system32\compact.exe
Utility

View or configure the automatic file compression on NTFS drives.

To Open

Command Prompt → compact

Usage

compact [/c | /u] [/s[:dir]] [/a] [/i] [/f] [filename]

Description

One of the features of the NTFS filesystem (see FAT to NTFS Conversion Utility, earlier in this chapter) is its support for automatic compression of individual files; older files can be optionally compressed to take up less disk space at the expense of speed to access them.

Right-click on any file or folder, select Properties, and then click the Advanced button. The "Compress contents to save disk space" option is used to instruct Windows to compress the selected item. If a folder is selected, all of its contents will be compressed (you'll be prompted about any subfolders); furthermore any files added to that folder will be automatically compressed as well.

The NTFS Compression Utility is the command-line equivalent of this setting, useful for automating the compression or decompression of several files with the help of a WSH script or batch file. The NTFS Compression Utility takes the following options:

filename

- Specifies a file, folder, or group of files (using wildcards) to compress or uncompress.

/c

- Compresses the specified file(s). If a folder is specified for filename, the folder will be marked so that subsequent files added to the folder will be compressed automatically. Include the /s parameter to compress files already in the folder.

/u

- Uncompresses the specified file(s). If a folder is specified for filename, the folder will be marked so that subsequent files added to the folder will not be compressed automatically. Include the /s parameter to uncompress files already in the folder.

/s

- If a folder is specified for filename, the /c and /u parameters will act only on new files added to the folder. Include the /s parameter as well to compress or uncompress files already in the folder. If filename is omitted, use the /s option to act on all files in the current folder.

/a

- Includes files with hidden or system attributes set; otherwise, ignored by compact.exe.

/i

- Ignores errors; otherwise, compact.exe will stop when the first errors are encountered.
/f Forces compression on all specified files; otherwise, files that are already compressed will be skipped.
/q Quiet mode; use this option to report only the most essential information. If you run the NTFS Compression Utility without any options, it will display the compression settings for the current directory and all of its contents.

Notes

- This type of file compression is supported on NTFS drives only. If you wish to compress files on a non-NTFS drive, you can either upgrade to NTFS or use a third-party compression utility (such as WinZip).
- Go to Control Panel ➔ [Appearance and Themes] ➔ Folder Options ➔ View tab and turn on the "Show encrypted or compressed NTFS files in color" option to visually differentiate such files from unencrypted, uncompressed files.
- For tangible proof that a given folder or file is actually compressed, right-click on it in Explorer and select Properties. If the "Size on disk" value is less than the "Size" value, then the item is compressed.

See Also

FAT to NTFS Conversion Utility, "Compress old files" in Disk Cleanup, NTFS Encryption Utility

NTFS Encryption Utility \windows\system32\cipher.exe

View or configure the automatic file encryption on NTFS drives. (NTFS Encryption Utility is included with Windows XP Professional only.)

To Open

Command Prompt ➔ cipher

Usage

cipher /k
cipher /k
cipher /r:efs_file
cipher /k
cipher /r:efs_file
cipher /w:dir
cipher /k
cipher /r:efs_file
cipher /w:dir
cipher /u [/n]

**Description**

Encryption is used to prevent unauthorized access to your data, and one of the features of the NTFS filesystem (see [FAT to NTFS Conversion Utility](#), earlier in this chapter) is its built-in support for automatic encryption of files and folders using "public key cryptography." NTFS encryption is invisible and encrypted files are opened as easily as decrypted files. The difference is that other users, either those who access your computer remotely (via My Network Places, Telnet, or FTP) or those who also log into your computer under a different user account, will not be able to open or read encrypted files on your system.

Right-click on any file or folder, select Properties, and then click the Advanced button. The "Encrypt contents to secure data" option is used to instruct Windows to encrypt the selected item. If a folder is selected, all of its contents will be encrypted (you'll be prompted about any subfolders); furthermore, any files added to that folder will be automatically encrypted as well.

The NTFS Encryption Utility is the command-line equivalent of this setting, but it adds several powerful features not normally available through Explorer. It's also useful for automating the encryption or decryption of several files with the help of a WSH script or batch file. The NTFS Encryption Utility takes the following options:

- **filename**
  - Specifies a file, folder, or group of files (using wildcards) to compress or uncompress. Omit `filename` to act on the current directory.
- **/e**
  - Encrypts the specified file(s). If a folder is specified for `filename`, the folder will be marked so that subsequent files added to the folder will be encrypted automatically. Include the `/a` parameter to encrypt files already in the folder and the `/s` parameter to act on subdirectories as well.
- **/d**
  - Decrypts the specified file(s). If a folder is specified for `filename`, the folder will be marked so that subsequent files added to the folder will be decrypted automatically. Include the `/a` parameter to decrypt files already in the folder and the `/s` parameter to act on subdirectories as well.
- **/s**
  - By default, if `filename` is a directory, the `/e` or `/d` options act on the specified directory, but not on any subdirectories. Include `/s` to include all subdirectories as well. Use the `/a` option to encrypt the files stored in these directories.
- **/a**
  - Operates on files as well as folders. If folders and files are not both marked to be encrypted, it's possible for an encrypted file to become decrypted when it is modified if its parent folder is not encrypted.
- **/i**
  - Ignores errors; otherwise, `cipher.exe` will stop when the first errors are encountered.
- **/f**
  - Forces encryption on all specified files; otherwise, files that are already encrypted will be skipped.
- **/q**
  - Quiet mode; use this option to report only the most essential information.
- **/h**
  - Includes files with hidden or system attributes set; otherwise, ignored by `cipher.exe`. 
Generates and displays a new file encryption key (certificate thumbprint) for the current user. The /k option cannot be used with any other options.

/r: efs_file
Generates an Encrypting File System (EFS) recovery agent key and certificate, and then writes them to efs_file.pfx (containing the certificate and private key) and efs_file.cer file (containing only the certificate). Since the /r option will automatically add the appropriate file extensions, all you need to specify is the path and file prefix for efs_file. See Notes for more information.

/w: dir
"Wipes" the drive containing directory dir. When a file is deleted in Windows, only that file's entry in the filesystem table is deleted; the actual data contained in the file remains on the hard disk until it is overwritten with another file. Wiping a drive writes over all unused portions of the disk, possibly containing deleted files so that previously deleted data cannot be recovered. The /w option does not harm existing data, nor does it affect any files currently stored in the Recycle Bin. This is an extreme form of data security and should be used on a regular basis if security is a big concern.

/u
Updates all encrypted files on all local drives. /u is used to ensure that your file encryption key or recovery agent key are current. The /u option cannot be used with any other options, except for /n.

/n
Modifies /u so that encrypted files are only listed, not updated. Type cipher /u /n to list all the encrypted files on your system. The /n option can only be used in conjunction with /u.

If you run the NTFS Encryption Utility without any options, it will display the encryption settings for the current directory and all of its contents.

Notes

- Windows supports placing encrypted files in nonencrypted folders, but you'll be warned, by default, if you try to do so. The reason for this is that, when modifying a file, some applications delete the file and then re-create it, and if the folder is not marked to encrypt new files, the once-encrypted file will become decrypted without warning.
- If you encrypt some or all of the files on your drive and your hard disk crashes, or you encounter some other program that requires Windows to be reinstalled, you may not be able to access your previously encrypted files (assuming they're still intact). You can avoid this by using the /r parameter to generate a "recovery agent key," a cryptographic key that can be used to unlock files in the event of an emergency. You should be able to use this key to subsequently gain access to your encrypted files when necessary. For more information, go to Start Help and Support and search for "cryptography."
- The /w option, used to wipe unused data on a drive, isn't strictly a form of encryption and can be used whether or not you employ Windows XP's built-in encryption.
- NTFS drives support both encryption and compression, but a given file cannot be compressed and encrypted at the same time. If you attempt to encrypt a compressed file, Windows will first uncompress the file.
- This type of file encryption is supported on NTFS drives only. If you wish to encrypt files on a non-NTFS drive, you can either upgrade to NTFS or use a
third-party file encryption utility (such as Encryption Plus Folders, a freeware program available at http://www.pcguardian.com/).

- Go to Control Panel ➔ [Appearance and Themes] ➔ Folder Options ➔ View tab and turn on the "Show encrypted or compressed NTFS files in color" option to visually differentiate such files from unencrypted, uncompressed files.

See Also

FAT to NTFS Conversion Utility, NTFS Compression Utility

Object Packager \windows\system32\packager.exe

Create "packages" for insertion into documents.

To Open

Command Prompt ➔ packager

Description

Many larger applications support the dragging and dropping of data from one program to another. For example, you can highlight a dozen cells in Microsoft Excel, drag them into a Microsoft Word document, and Word will insert the dropped data as a new table. Furthermore, under certain circumstances, there will be an active link between the two applications so that you could make a change to one of the spreadsheet cells and the change would be reflected in the Word document immediately.

As you might expect, there's more going on behind the scenes to make all this possible than might be immediately apparent. Indeed, Windows creates a "package" containing the selected data and then inserts that package into the target document. Microsoft has given many names to this technology, but their first, Object Linking and Embedding (OLE), is the one that has stuck in many users' minds.

Object Packager is a tool used to create such a package manually, useful if you need more flexibility than is achieved with drag-and-drop.

The Object Packager window has two panes: the Appearance pane displays the icon that will represent the package and the Content pane displays the name of the file that contains the information you want to package. To choose an icon, click the Insert Icon button. To choose a file, go to File ➔ Import.

When you're done, go to Edit ➔ Copy Package to prepare the package. The last step is to switch to the target application and paste the newly prepared package into your document. Once the package icon appears in the target document, you can activate the package by double-clicking it, which will open the packaged file according to your Files Types settings. For example, if the packaged file is a bitmap, activating the package will open that bitmap in Paint (discussed later in this chapter).

This preservation of the original file's format, and its associated application, is the whole point of Object Packager. Otherwise, pasting a bitmap into a document would be a one-way procedure; if you needed to update the bitmap at a later time, you
would most likely need to delete the bitmap from the target document and then repaste it.

Another advantage of Object Packager is its ability to override the default association for the inserted file. Go to Edit → Command Line to enter any new application filename or other command to be executed when the package is activated.

**ODBC Data Source Administrator**

\windows\system32\odbcad32.exe

Add, remove, or configure sources of database management system data.

**To Open**

Start → Programs → Administrative Tools → Data Sources (ODBC)

Command Prompt → odbcad32

**Description**

Open Database Connectivity (ODBC) is a system that connects ODBC-enabled applications to the database management systems that provide the data. The ODBC Data Source Administrator is used to configure your applications so that they can get data from a variety of database management systems. For example, if you're using an application that accesses data in an SQL database, the ODBC Data Sources Administrator lets you connect that application to a different data source, such as a Microsoft Excel spreadsheet or a Paradox database.

In the ODBC Data Source Administrator, the different sources of data are called "data providers." To add a new provider, click Add under the User DSN, the System DSN, or the File DSN tab. A list of the available drivers is listed under the Drivers tab; new drivers can be installed separately. The Tracing allows you to log the communication between applications and the ODBC data sources they use. The Connection Pooling tab is used to improve performance with ODBC servers. Finally, the About tab is used to check the versions of the installed ODBC components.

**On-Screen Keyboard**

\windows\system32\osk.exe

A full, onscreen keyboard controlled by the pointing device.

**To Open**

Start → Programs → Accessories → Accessibility → On-Screen Keyboard

Command Prompt → osk

**Description**
Among the tools provided with Windows XP to assist those with physical disabilities is the On-Screen Keyboard. Intended to be used by those who are unable to comfortably use a keyboard, the On-Screen Keyboard allows any key normally available on the keyboard to be pressed with a click of the mouse, or whatever pointing device is currently being used (see Figure 4-2).

What makes the On-Screen Keyboard especially appropriate as a primary input device is that you can click keys when another application has the focus. For example, open the On-Screen Keyboard, and then open your word processor; the keyboard will float above the word processor, allowing you to click any key to "type" it into your document.

Configuring the On-Screen Keyboard is straightforward. Use the Keyboard menu to change the layout of the keys, or Settings ➔Font to change the font of the key labels. Go to Settings ➔Typing Mode to choose how keys are pressed; by default, each key must be clicked, but you can set it up so that you can hover over keys to select them, or even use a joystick to control the keyboard.

**Figure 4-2.** The On-Screen Keyboard lets you type by pointing and clicking

**Notes**

Also included with Windows XP is the Character Map (discussed earlier in this chapter), which allows access to symbols and other characters not normally available on a standard keyboard. However, only the On-Screen Keyboard is designed to be a primary input device.

**See Also**

Microsoft Magnifier, Narrator, Utility Manager, Character Map

**OpenFiles**

\windows\system32\openfiles.exe

List all currently open files, either shared and accessed by other users on a network or (optionally) opened locally. (OpenFiles is included with Windows XP Professional only.)

**To Open**

Command Prompt ➔openfiles

**Usage**
openfiles /local [ on | off ]
openfiles /query [/s system [/u user [/p [pass]]]]
openfiles /query [/s system [/u user [/p [pass]]]]
[fo format] [/nh] [/v]
openfiles /query [/s system [/u user [/p [pass]]]]
[fo format] [/nh] [/v]
openfiles /disconnect [/s system [/u user [/p [pass]]]]
openfiles /query [/s system [/u user [/p [pass]]]]
[fo format] [/nh] [/v]
openfiles /disconnect [/s system [/u user [/p [pass]]]]
{[/id id] [/a accessedby] [/o openmode] [/op openfile]}

Description

The OpenFiles tool lets you view a list of all the shared files that are currently open across the network and, optionally, files that are opened locally. This prevents, say, one user deleting a document that another user is working on. Type `openfiles` without any options to display a report like this:

Files Opened Remotely via local share points:

<table>
<thead>
<tr>
<th>ID</th>
<th>Accessed By</th>
<th>Type</th>
<th>Open File (Path\executable)</th>
</tr>
</thead>
<tbody>
<tr>
<td>21</td>
<td>LOU</td>
<td>Windows</td>
<td>C:\Stuff to Eat\frittatas.txt</td>
</tr>
<tr>
<td>808</td>
<td>EDDIE</td>
<td>Windows</td>
<td>C:\Stuff to Drink\milkshakes.txt</td>
</tr>
<tr>
<td>80#</td>
<td>CLANCY</td>
<td>Windows</td>
<td>C:\Stuff to Eat\pork chops.txt</td>
</tr>
</tbody>
</table>

OpenFiles accepts one of three primary commands, each of which has a range of parameters:

/local [ parameters]

Turn on or off the inclusion of local files in reports. Type:
openfiles /local on
to turn on the 'maintain objects list' global flag; this setting is turned off by default and requires Windows to be restarted when changed. Note that turning on this setting may slightly reduce performance.

/query [ parameters]

Display a list of opened files and folders; specify /query for more flexibility than using openfiles without any options, such as the ability to connect to a different machine. Type `openfiles /query /?` for more information on the available parameters.

/disconnect [ parameters]

Selectively disconnect files and folders that have been opened remotely. When viewing the list of open files, each entry has an ID; that ID can be used to close open files. Type `openfiles /disconnect /?` for more information on the available parameters.

Notes

OpenFiles is available only to a user with administrator privileges.
See Also

Net

**Outlook Express**  
\(\text{\textbackslash program files\outlook express\msimn.exe}\)

An Internet email client and newsgroup reader.

To Open

Start  ➔ Programs  ➔ Outlook Express  
Double-click the Outlook Express icon on the Desktop  
Quick Launch Bar  ➔ "Launch Outlook Express"  
Command Prompt  ➔ `msimn`

Description

Outlook Express is the email client included with Windows XP (see [Figure 4-13](#)). Outlook Express uses a familiar Explorer-like tree interface to manage the folders into which email messages are organized. Highlight any folder name to display its messages; the currently highlighted message is then shown in the preview pane. Double-click the message to open it in a new window for easier reading and other options.

**Figure 4-13. Outlook Express is the rudimentary email application that comes with Windows**
Newly received messages are stored in the Inbox folder. Files queued to be sent are stored in the Outbox folder, and are then moved to the Sent Items folder when they have been sent. The Deleted Items folder is like the Recycle Bin because it stores deleted messages until it is emptied manually. The Drafts folder stores messages as they're being composed. To add a new folder, select Local Folders in the tree and go to File → New → Folder. Messages can be moved from folder to folder by dragging and dropping.

The first time you open Outlook Express, a wizard walks you through setting up your first account. An account in Outlook Express is not actually an email account, but rather an entry in the Tools → Accounts → Mail tab that corresponds to an existing email account. Outlook Express uses either the Post Office Protocol 5 (POP 5) or the Internet Message Access Protocol 4 (IMAP 4) Internet mail protocols to receive mail and the Simple Mail Transfer Protocol (SMTP) to send mail. Nearly all Internet Service Providers and many online services (like AOL and MSN) use POP 5 and SMTP for mail transfer.

In addition to mail accounts, you can set up Directory Service accounts, which allow you to look up contact information using any of several online global contact lists. Outlook Express also functions as a newsreader for participating in Internet newsgroups; you'll need to add a News Account to Outlook Express before you can read any newsgroups (contact your ISP for details).

Much of Outlook Express is fairly intuitive, and given that it would require more space than we have here to cover Outlook Express in its entirety, the following sections highlight only some of the most useful and interesting aspects of the program.

**Accounts (Tools → Accounts)**

As stated above, the Accounts window stores information about all of your email, news, and Directory Service accounts. Choose the All tab to list them all together. You can modify any account entry by double-clicking it. To add a new account entry, click Add and choose the account type. Unfortunately, the only way to set up an account entry is to use the cumbersome wizard; there's no way to skip ahead and use the Properties window to enter information. When you're done with the wizard, you'll probably have to use the Properties window anyway to set some of the more advanced options, such as whether or not to automatically check mail from this account, whether to leave copies of your mail on the server, or whether to use a different email address when replying to messages sent to this account.

If you have more than one mail account, you can choose the default by highlighting it and clicking Set as Default. Thereafter, that account will be used as your return address when sending outgoing email (unless you change it on a per-message basis).

The Set Order button, which lets you choose the search order when looking up contacts in your Directory Services, may be a little confusing at first. Since only an entry is shown, there's nothing to rearrange; to include more entries in Set Order, double-click each entry and turn on the "Check names against this server when sending mail" option (see Figure 4-16).

**Figure 4-16. Configure multiple email accounts with the Internet Accounts dialog**
Address Book (Tools → Address Book)

The Address Book is used to store names and contact information for people to whom you send email on a regular basis. See Address Book, earlier in this chapter, for more information.

Options (Tools → Options)

Specify options that govern the behavior of Outlook Express and apply to all mail and news accounts. This is where you control things like how often Outlook Express checks for mail when it's running and whether it is the default email program. The Dial Up tab lets you specify whether a connection is dialed automatically when you start Outlook Express, whether it should hang up after getting your messages, and whether it should dial automatically when you do a Send and Receive.

Identity Management (File → Identities → Manage Identities)

In addition to its support of multiple email accounts, Outlook Express supports multiple identities, a feature that lets more than one person use Outlook Express on the same machine. Each identity has its own set of accounts, settings, and mail. The preferred approach is to forget the Identities feature, and instead set up multiple users in Windows XP (Control Panel → User Accounts), wherein each user would have his/her own Desktop, Start menu, and Explorer settings, as well as separate accounts and mail in Outlook Express. The Identity feature in Outlook Express is for people who don't want to go to the trouble of dealing with multiple Windows users, which would require a second user to log out and then log back in in order to check your mail (see Figure 5-16).

Figure 5-16. If more than one person needs to access their email on the same machine, use the Manage Identities dialog to switch between them
It's tempting to use Identities if you want to send out mail using more than one persona; but this really isn't what the feature is designed for. Instead, you should set up multiple accounts, one for each "persona" you wish to assume.

Say you have three different email addresses — one for work, one for personal email, and one left over from a previous job — all of which are still being used to receive email. You'd like to retrieve all your mail at once and store it all in the same place. In addition, you want to preserve both your work and personal email addresses, so when you respond to messages sent to either address, the return address and "real name" are set appropriately. In this case, you would set up three accounts in Outlook Express, but only one Identity.

To add a new identity, go to File → Identities → Add New Identity. You can then enter the name of the new user and select a password, if needed. To switch identities at any time, select File → Switch Identity. Note that the first time you use a new identity, Outlook Express will act as though it's the first time you've started the program, prompting you for personal contact information and account settings. The identity in use at any given time will be shown in the titlebar of the main Outlook Express window.

To share contacts in your Address Book between identities, open the Address Book and select View → Folders and groups. Contacts, by default, are only made available to the user that created them, but they can be shared by moving (or copying) them into the Shared Contacts folder.

Message Rules (Tools → Message Rules)
Outlook Express can be set up to automatically handle incoming mail in a number of different ways. For example, you can set up rules instructing Outlook Express to store all email retrieved from your business account in a certain folder, all email retrieved from your personal account in a different folder, and all junk mail (spam) in the trash. Furthermore, you can have
Outlook Express automatically respond to certain messages and mark some messages as urgent and others as potentially annoying. Go to Tools → Message Rules → Mail to view the mail rules currently in effect. If you haven’t yet set up any rules, you would be prompted to do so now; otherwise, click New to create a new rule. Each rule is set up as follows:

1. **Select the conditions for your rule.** Choose one or more conditions that, when met, will instruct Outlook Express to take the desired action. For example, to create a rule that applies to all email from Grandma, Place a checkmark next to "Where the From line contains people."

2. **Select the actions for your rule.** After you’ve chosen one or more conditions (above), these options allow you to decide what to do with messages that meet those conditions. For example, you may wish to place all of Grandma’s email in a certain folder, in which case you would place a checkmark next to "Move it to the specified folder." On the other hand, if Grandma drives you nuts, you may wish to place a checkmark next to "Delete it."

3. **Rule description.** The third box displays a summary of the conditions and actions you’ve chosen, and allows you to input the specifics. For example, if you’ve chosen to move all of Grandma’s email into a certain folder, the phrase "contains people" will be underlined and hyperlinked, as will the word "specified." Before you can complete this rule, you must click each of these links; in the case of "contains people," you would type Grandma’s email address. Likewise, in the case of "specified," you would select the image of the folder in which to store Grandma’s email.

4. **Name of the rule.** Finally, choose a label for the rule; although the name makes no difference, it will allow you to easily identify and differentiate the rules.

Don’t expect to get all your rules right the first time. For example, after setting up several rules to delete spam, you may find that some legitimate messages are being inadvertently deleted as well. After creating a new rule, scrutinize its performance as new mail is retrieved.

You can also create new rules on the fly, using some of the context-based tools in Outlook Express. Start by opening a message, and then go to Message → Create Rule from Message. Here, the familiar rule dialog box is shown, but some fields have been filled in with information from the selected message. Likewise, you can go to Message → Block Sender to place the sender on the Blocked Sender List (Tools → Message Rules → Blocked Sender List), which causes subsequent email from the sender to be deleted automatically. While not technically a new rule, the Blocked Sender List does have a similar effect and is easier to implement and manage.

Be sure to read the message that pops up right after you add a sender to the Blocked Senders List. Selecting the Yes button will automatically move every message in any folder from this sender into the Deleted Items folder. This is especially dangerous (if
you select Yes by mistake) if you've checked the Tools → Options → Maintenance → "Empty messages from the Deleted Items folder on exit" box.

Message → Flag Message
This does exactly what it sounds like. Select one or several messages and click the Flag Message command to add a little flag in a column (as long as the column is activated at View → Columns) near the message to remind yourself that the message needs a follow-up. You can also just click in the flag column to add a flag to a message. To remove the flag, select the message(s) and click the command again, or just click on the flag itself. You can sort the messages by this column to group all the flagged messages for later review.

Conversations (Message → Watch Conversation, Message → Ignore Conversation)
A conversation is a continuous series of email or newsgroup messages, often called a thread. For example if you were to write an email with the subject "Propane Elaine," it might spark a series of messages between you and the recipient, all of which would have the subject, "Re: Propane Elaine." This thread of messages is called a "conversation" in Outlook Express, and there are tools included for dealing with conversations.
You can "watch" a conversation that is of interest to you by highlighting a message and going to Message → Watch Conversation. Likewise, you can "ignore" a conversation by going to Message → Ignoring Conversation. Either of these will place an icon in the Watch/Ignore column: sunglasses or a red circle with a line through it, respectively. Click the icon to toggle between Watch, Ignore, and nothing.

For the most part, this is merely a decorative setting; it doesn't affect the way Outlook Express handles these messages. However, you can choose to highlight Watched conversations and hide Ignored conversations, as follows.
You can customize the color of messages in watched conversations by going to Tools → Options → Read tab → Highlight watched messages. To hide all messages in a conversation marked as Ignored, go to View → Current View → Hide Read or Ignored Messages. Then, go to View → Current View → Customize Current View, place a checkmark next to "Where the messages watched or ignored," and click the links (see above) so that description reads: "Where the message is ignored, Hide the message."
Finally, if you select View → Current View → Group Messages by Conversation, messages in conversations will be grouped in expandable branches, like the folders in Explorer.

Signatures and Stationary
A signature is a bit of text that is automatically placed at the end of every outgoing message you write. Go to Tools → Options → Signature tab (see Figure 4-11) to create and edit signatures. Make sure you turn on the "Add signatures to all outgoing messages" option. You can have as many signatures as you want and you can even have a different default signature for each account; just click Advanced and choose the account with which the current signature should be associated. To use a signature on a per-message basis, go to Insert → Signature in the message composition window.

Figure 4-11. Use signatures to add a footer to every email you send
Stationery is just as you expect; it imposes a visual style on your message, including colors and even images. Stationary files are just .html files (web pages), stored by default in \Program Files\Common Files\Microsoft Shared\Stationary. They can be edited with any web page editor or plain text editor. To create new stationery or to use one of the supplied templates, go to Tools → Options → Compose tab. Click Create New to start a wizard to build a new stationery file for you. Place to checkmark next to Mail or News, and then click Select to choose an .html file to set as the default stationery. Unfortunately, you can't set default stationery for each account (something Eudora lets you do), but you can choose stationary on a per-message basis by going to Format → Apply Stationary in the message composition window.

Both signatures and stationery are shown in your message as you write, so you can modify them as needed without disrupting the permanent signature or stationary file. To make a template, useful when repeatedly sending messages that are similar, open a stationary file in a web page editor (or plain text editor, if you're familiar with HTML) and type whatever text content you need.

Notes

- Alternatives to Outlook Express include the popular Eudora Email (http://www.eudora.com) by Qualcomm, the web-based Hotmail email service (http://www.hotmail.com) by Microsoft, and PINE for those die-hard Unix users.
- Since it is an integrated component of Windows, Outlook Express is often the target of virus and Trojan horse attacks. Many of the recent widespread virus infestations have exploited the vulnerabilities in Outlook Express to replicate themselves, sometimes by sending a virus-infested attachment to everyone in your contact list. The same applies to Outlook, OE's big sister, which is included with Microsoft Office. To protect yourself, you should consider installing antivirus software, or even using a different email program.
- If you have more than one account setup in Outlook Express, only one account can be the default at any time. Although you can choose a From
account each time you compose outgoing mail, the default account is the one that is used if you don't make a choice. Unfortunately, there's no way to set up a Message Rule (see above) to change the default account used when responding to incoming messages; for that, you'll need a more full-featured email program like Eudora.

- The filename msimn.exe gives a taste of the history of this program. Originally called Microsoft Internet Mail and News, it was renamed Outlook Express to position it as the "lite" version of Microsoft's Outlook application. In fact, the two programs share nothing but the name.
- By default, Outlook Express automatically compacts your mail and news files when it detects that 20 percent of your storage space is being wasted. You can adjust this percentage using Tools → Options → Maintenance → "Compact files when...". You can also click Clean Up Now here to perform the compression whenever you want.
- If you want to use Outlook Express when you're not connected to the Internet, go to File → Work Offline. If you are using a dial-up connection, you may even want to further reduce online time by configuring Outlook Express to hang up after sending and receiving messages. To do this, go to Tools → Options → Connection tab and turn on the "Hang up after sending and receiving" options. If autodial is enabled, Outlook Express will reconnect automatically when you go to Tools → Send and Receive.
- If you access the same account from two different computers, you may wish to set up one computer to download messages, but not delete them from the server. Set up your other system to delete messages after downloading them. This way, one system always has a complete set of messages. Do this by using Tools → Accounts → any account → Properties → Advanced tab → Leave a copy of messages on server.
- If you have multiple accounts set up and do not want one included when you click Send and Receive, go to Tools → Accounts → any account → Properties → General tab, and deselect "Include this account when receiving mail or synchronizing."
- To send a file along with an email message, go to Insert → File Attachment in the message composition window, or just drag the file from your Desktop or Explorer into the body of message. If Outlook Express is your default email program, you can also send a file as an email attachment by right-clicking it and selecting Send To → Mail Recipient. This opens a new, blank message with the file attachment included.
- Outlook Express supports rich text email, which adds fonts, color, images, and other formatting to otherwise plain text-based email. There is a drawback, however, in that users of older email programs may not be able to read rich text email, instead seeing only gibberish. You can configure or turn off the support for rich text email by going to Tools → Options → Send tab. Also note when you send an attachment with a rich-text email message, recipients who view messages in plain text will often not receive your attachments intact. If you are have that problem, you can either disable Outlook Express's support for rich text email or simply change the format for an individual message using that message window's Format menu.
- It can be annoying to wade through the thousands of messages that can exist in a single newsgroup. Custom views work like Rules (above) and let you weed out some of the extraneous messages. For example, you can hide messages written by certain users (in Usenet parlance, this is referred to as a "bozo filter"), contain certain words in the subject, are over a certain length, or are over a certain age. Go to View → Current View → Customize Current View to set your preferences.
Paint

A rudimentary image editor, used to create and modify .bmp, .jpg, .gif, .tif, and .png image files.

To Open

Start ➔ Programs ➔ Accessories ➔ Paint
Command Prompt ➔ mspaint

Description

Paint is a basic image editor (often called a “paint program”) capable of creating and modifying most Windows Bitmap (.bmp), Joint Photographic Experts Group (.jpg), Compuserve Graphics Interchange Format (.gif), Tagged Image File Format (.tif), and Portable Network Graphics (.png) image files. In essence, Paint is to image files as Notepad is to text files (see Figure 4-7).

Figure 4-7. The Paint utility provides a few rudimentary tools for working with image files

The first time you start Paint, you'll get a blank (white) image, 400 x 500 pixels in size. Depending on the size of the Paint window, you may see the entire canvas, surrounded by a gray border. To change the size of the image, go to Image ➔ Attributes, and type new values. The default units are pixels, but if you choose inches or centimeters, the size of the image will be calculated using the resolution displayed at the top of the window. For example, if you specify an image size of 1" x 1.25" at 36 dots per inch (1 dot = 1 pixel), the resulting image dimensions will be 1" x 1.25", or 0.91 x 1.25 pixels. The pixels are the only thing that is important if the image is to be displayed on the screen or in a web page; the dimensions in inches or centimeters are only important if you're printing the image.
At the bottom of the window, you'll see a color palette; the leftmost box shows the currently selected foreground and background colors. Choose a new foreground color by left-clicking on any color in the palette; choose a new background color by right-clicking. The roles of the foreground and background colors depend on the currently selected tool (see below). For example, if you draw a filled-in ellipse (choose the ellipse tool and then select the second variation), the foreground color will appear as the border and the background color will be used to fill the ellipse. You can mix your own colors by going to Colors ➔ Edit Colors.

To the left of the document area is a simple toolbox. Each tool has a different function used to manipulate the image in some way. The first two tools are used to select portions of the image: the star selects an irregular shape and the rectangle selects a rectangle. The eraser tool works like a paintbrush, except that it paints with the background color. The paint bucket is used to fill a bounded area with a solid color. The eyedropper is used to set the foreground or background colors to an area in the image. The magnifying glass zooms in and out; left-click to zoom and right-click to zoom out. The pencil icon draws single-pixel-width lines, and the paintbrush draws with a variety of brush sizes, chosen in the brush palette beneath the toolbox; the left mouse button draws with the foreground color, and the right mouse button draws with the background color. The spray can draws by splattering random dots. The A tool is used to add text to an image, although once text has been applied, it becomes part of the image and can't be changed. The line tool is used to draw a straight line between two points; choose the squiggly line tool to first draw a straight line, and then distort the line with a third click. The last four tools are shapes; choose the shape, and then choose whether or not it will be filled or have a border by using the brush palette below.

In addition to these basic tools, there are some other goodies. Go to File ➔ Set as Background (Tiled or Centered) sets the current image as the Windows Desktop wallpaper (it only works if the file has been first saved as a .bmp file). Use View ➔ View Bitmap to temporarily fill the screen with the image; click or press any key to go back. Entries in the Image menu let you perform some extra functions, such as flipping, rotating, and stretching the image.

Notes

- If you're creating an image file to be used on a web page, that file must be saved using the .jpg or .gif format, a selection that is made in the File ➔ Save As box. .bmp files, while visible in some versions of Internet Explorer, are not a suitable file format for web pages, mostly because most web browsers will not be able to read them. Note that it is not enough to simply rename a file to a different format; you must open it and save it as the new format.
- If you paste an image into MSPaint that is larger than the bitmap you currently have open, you are prompted and can choose to have the bitmap enlarged.
- If you'd like the Explorer to show miniature previews (icons) of .bmp files in Explorer and on your Desktop, make the following changes to your Registry:
  1. Open the Registry Editor (see Chapter 3 for details).
  2. Navigate to HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon.
  3. Double-click the Default value and change the value data to '18' (with the quotes).
  4. Close the Registry Editor when you're done.
- To change the icon to its default, repeat the above steps, instead typing mspaint.exe, 1 for the value data in Step 3.
- For a more advanced image editing and image format conversion tool, download the shareware version of Paint Shop Pro from http://www.jasc.com/.
See Also

Windows Picture and Fax Viewer

**Pentium Bug Checker**  \`windows\ystem\pentnt.exe\`

Check your processor for the Floating Point Division Pentium bug.

**To Open**

Command Prompt ➔ pentnt

**Description**

Back in 1994, a bug was discovered in a certain number of Intel Pentium processors in which certain mathematical operations would yield an incorrect result. The bug was fixed in all Pentium processors produced after 1994. In the unlikely event that you’re running Windows XP on a computer that old, open a command prompt and type pentnt to test your processor for the bug.

**Notes**

For more information on the FDIV bug, go to [http://www.ukans.edu/cwis/units/IPPBR/pentium_fdiv/pentgrph.html](http://www.ukans.edu/cwis/units/IPPBR/pentium_fdiv/pentgrph.html).

**Performance Log Manager**  \`windows\ystem\logman.exe\`

Manage the “Performance Logs and Alerts” service for creating and managing Event Trace Session logs and Performance logs. (Performance Log Manager is included with Windows XP Professional only.)

**To Open**

Command Prompt ➔ logman

**Usage**

logman command collection_name [options]

**Description**
The Performance Log Manager is a command-line utility used to manage Performance Logs and Event Trace Session logs. Commands can be any of the following (type \logman\ command /? for help with each one):

**create**
- Creates a new collection.

**start**
- Starts an existing collection and sets the begin time to manual.

**stop**
- Stops an existing collection and sets the end time to manual.

**delete**
- Deletes an existing collection.

**query**
- Queries collection properties. If `collection_name` is omitted, all collections are listed.

**update**
- Updates the properties of an existing collection.

**Notes**

The Performance Log Manager is largely replaced by the "Performance Logs and Alerts" Console (perfmon.msc); see Microsoft Management Console, earlier in this chapter, for details.

**Performance Logs and Alerts**

\windows\system32\perfmon.msc

See Microsoft Management Console.

**Phone and Modem Options**

\windows\system\telephon.cpl

Configure your modem and telephony devices and choose dialing preferences.

**To Open**

Control Panel ➔ [Printers and Other Hardware] ➔ Phone and Modem Options
Command Prompt ➔ telephon.cpl
Command Prompt ➔ control telephony

**Description**

Although DSL and cable Internet access are rapidly making modems obsolete, they’re still used by more users than any other type of device to connect to the
Internet and send computer-based faxes. These settings affect how Windows uses your modem(s):

**Dialing Rules**

Assuming your modem is properly installed (see the Modems tab), Windows will use these settings to determine how to dial. Click Edit to change the dialing rules for the selected location (see Figure 4-1). Multiple locations can be configured if you have a portable computer and need to dial out from within different area codes or from varying phone numbers with different dialing requirements.

**Figure 4-1. If you use a portable computer, you may want to configure multiple locations for dialing**

As you undoubtedly know, if you dial a phone number in your own area code, you usually don't need to include the area code. For this reason, Windows needs to know which area code it's in, as well as any special numbers that are required to dial outside lines, place international calls, place calling-card calls, or disable call waiting (so you won't get interrupted by incoming calls).

**Modems**

Before a modem can be used with Network Connections (which replaces Dial-Up Networking, found in earlier versions of Windows) or with Microsoft's fax service, it must be configured here. The items listed here are the same as those listed in the Modems branch in Device Manager (discussed earlier in this chapter), so if Windows has detected your modem through plug-and-play, for example, there's probably nothing left to do here. If your modem doesn't show up in the list, it's probably not plug-and-play compliant; click Add to start the Add Hardware Wizard (discussed earlier in this chapter) to scan your system and install the appropriate drivers.

Select your modem from the list and click Properties to view the device's Properties sheet, which is the same as the one in Device Manager. Of special interest here is the Diagnostics tab, which will communicate with your modem and provide troubleshooting data, and the Advanced tab, which allows you to specify a modem initialization string (refer to your modem's documentation). Don't waste your time trying to get an old modem to work with Windows XP; brand-new plug-and-play PCI modems are ridiculously cheap and extremely easy to install.
Advanced

The Advanced tab lists the telephony drivers currently installed on your system. Drivers can be added, removed, or configured here. Note that unless you use a telephony application, you’ll never need to touch these settings.

Notes

All of the settings in this dialog are also covered in Chapter 6.

See Also

Control Panel

Phone Dialer \program files\windows nt\dialer.exe

Make voice calls, video calls, and conference calls using a phone line or Internet connection.

To Open

Start ➔ Programs ➔ Accessories ➔ Communications ➔ Phone Dialer
Command Prompt ➔ dialer

Description

Phone Dialer is a surprisingly complete program, given that most people don’t even know it exists. The primary Phone Dialer window is essentially a contact list, which allows you to initiate a call or conference with one or more people (see Figure 4-19). To place a call, click the Dial button or select Phone ➔ Dial; if no contact is selected (from either the Speed Dial folder or from one of the Internet Directories folders), you’ll be prompted to enter the other party’s contact information. Another Phone Dialer user can be contacted in one of the following ways (specified either in the Dial window or when editing a Speed Dial entry):

Figure 4-19. The Phone Dialer is not used to dial your phone, but to initiate voice and video conferences over a network

Phone Call
Choose this option to use your modem to call another user's modem over standard telephone lines. Naturally, it's simpler to just pick up the phone and place an old-fashioned phone call; and while Phone Dialer supports video, few analog modems are fast enough to accommodate two-way video communication.

**Internet Call**

Whether you're connecting over the Internet or over a local network, choose Internet Call to initiate a call. If you're connecting over the Internet, enter the other user's IP address; if you're connecting over a local network, enter the other user's computer name (without the `\` prefix).

For the call to go through, the other user must also have Phone Dialer open. When a call is received, the recipient can accept or reject the incoming call. A conference, as opposed to a call, allows you to communicate with several users at once. To start a conference, click New in the toolbar or go to Phone → New Conference. Then, other users call you to join the conference.

**Notes**

- Like Microsoft NetMeeting, discussed earlier in this chapter, Phone Dialer lets you use your computer as a telephone, initiating and conducting voice and video conversations over an Internet connection (or even using standard phone lines, although I fail to see the point). Of the two, NetMeeting has more features and is easier to use, but Phone Dialer is the only one that works over phone lines.
- The hardware requirements for voice and video calls with Phone Dialer are the same as those with Microsoft NetMeeting. However, NetMeeting and Phone Dialer are not compatible with one another; calls placed with NetMeeting can't be answered by Phone Dialer, and vice versa.
- Phone Dialer is nothing like the utility of the same name included in Windows 9x/Me, which was only a telephone autodialer. It is, however, identical to the Phone Dialer included with Windows 2000.
- Although the main Phone Dialer window looks suspiciously like the Address Book (discussed earlier in this chapter), it does not share contacts or any other information with the Address Book.

**See Also**

Microsoft NetMeeting

**Pinball**

```
\program files\windows nt\pinball\pinball.exe
```

A "Space Cadet 3D Pinball" game.

**To Open**

Start → Programs → Games → Pinball
Command Prompt → pinball

**Description**
The ball is launched by holding the Spacebar for a second or two to pull back the plunger and letting go. By default, the left and right flippers are controlled with the Z and / keys, respectively. You can change the keys use play the game by going to Options → Player Controls (see Figure 4-#0).

Figure 4-#0. Although it hardly duplicates the thrill of a real metal ball bouncing in a box, the 3D Pinball game is fun to look at.

Notes

- If the game is paused, none of the above keys will work until you press F5 to resume the game.
- Select Options → Full Screen or press F5 to play Pinball in full-screen mode. Press F5 again to revert back to the normal display. Note that full-screen mode will temporarily change the resolution of your display and may not work on all display adapters.
- The "boss" key is Esc; press it to quickly minimize the game in case your boss walks by.

Ping

\windows\system32\ping.exe

Test the "reachability" of another computer on the network or across the Internet.

To Open

Command Prompt → ping

Usage
ping target [-t] [-a] [-n count] [-l size] [-f] [-w timeout]
[-r count] [-s count] [-j host_list] [-k host_list]
[-i ttl] [-v tos]

**Description**

The primary function of Ping is to see if another computer is "alive" and reachable. Ping works on local networks and across Internet connections. For example, type the following at a command prompt:

```
ping oreilly.com
```

and you'll get a report that looks something like this:

```
Pinging oreilly.com [202.204.84.22] with 52 bytes of data:
Reply from 202.204.84.22: bytes=52 time=1 ms TTL=251
Reply from 202.204.84.22: bytes=52 time=58 ms TTL=251
Reply from 202.204.84.22: bytes=52 time=81 ms TTL=251
Reply from 202.204.84.22: bytes=52 time=1 ms TTL=251
```

Ping statistics for 202.204.84.22:

```
Packets: Sent = 4, Received = 4, Lost = 0 (0.0% loss),
```

Approximate round trip times in milli-seconds:

```
Minimum = 10 ms, Maximum = 11 ms, Average = 10 ms
```

Here, Ping sent out four pings (the default), reported the time it took for them to return (in milliseconds), and then displayed various statistics about the session.

Ping is especially useful if you're having trouble contacting a server and you want to see if the server is alive (running and accepting connections). If the server does not reply (meaning that it is down or the connection has been severed), you'll see Request timed out. Ping accepts the following options:

- **target**
  The machine to ping; it can be the name of a computer on your network, an IP address (e.g., 192.168.1.1), or an Internet address (e.g., oreilly.com).

- **-t**
  Normally, Ping sends out four pings and then quits. Include the -t option to ping continually until Ping is interrupted by pressing Ctrl-C. Press Ctrl-Break to display statistics without interrupting.

- **-a**
  Resolve addresses to hostnames.

- **-n count**
  The number of pings to send; the default is four.

- **-l size**
  The size of the packets to send, in bytes; the default is 56 bytes.

- **-f**
  Turn on the "Don't Fragment" flag in packet.

- **-w timeout**
  The amount of time to wait, in milliseconds, before Ping gives up and displays Request timed out; the default is 100 milliseconds (8/10 second).

- **-r count**
  Display the route taken to reach the server (see Tracert, later in this chapter). The count is the maximum number of hops to record, and can range from 1 to 9.

- **-s count**
Display a time stamp for *count* hops.

- **j** *host_list*
  Impose a "loose" route (see the *-r* option) along which to ping.

- **k** *host-list*
  Impose a "strict" route (see the *-r* option) along which to ping.

- **i** *ttl*
  Specify the Time To Live (TTL); valid range is from 1 to 255.

- **v** *tos*
  Specify the Type of Service (TOS); valid range is from 0 to 255.

**Notes**

The name "ping" comes from submarine lingo, when sonar was used to detect nearby objects, such as ships and other submarines. Pulses of sound were sent through the water; those that returned indicated the existence of an object off which the pulses were reflected. *ping.exe* works very similarly, except it sends packets instead of sonic pulses.

**See Also**

Tracert, NSLookup

**Power Options**  
\`\`windows\system\powercfg.cpl\`

Control Windows' support for Advanced Power Management (APM).

**To Open**

Control Panel → [Performance and Maintenance] → Power Options

Command Prompt → `powercfg.cpl`

**Description**

Advanced Power Management relies on cooperation between your computer's BIOS and operating system. APM covers everything from your computer's power switch to the power-saving features that reduce power consumption or extend the life of your computer's battery (see *Figure 1-vel*).

**Figure 1-vel.** The Power Options window lets you configure the various power-saving features of your computer.
Before you mess with any settings here, make sure that APM support is enabled in your system BIOS. For best results, enable the main "APM support" option, but disable all APM options in your BIOS. Refer to the documentation that came with your computer or motherboard for details. Settings in this window are divided into the following tabs:

**Power Schemes**

The Power schemes listbox allows you to save your power management settings into one or more schemes, much like Themes (see Display Properties) and Sound Schemes (see Hibernate). Click Save As to create a new scheme or Delete to remove the currently selected scheme. The Settings below allow you set timed power-saving features for the currently selected scheme. Note that not all computers support the System standby and System hibernates features; even those that claim to may not do it very well. If your computer crashes coming out of standby or hibernation mode (see Sounds and Audio Devices below), or simply doesn't come out at all, check with your computer or motherboard manufacturer for a BIOS update.

**Advanced**

The settings on this page are pretty self-explanatory. See Hibernate, below, for details on the hibernation feature.

**Hibernate**

Hibernation, also known as "Instant On," allows you to completely shut off your computer and then turn it back on later (and resume work in seconds as though it was never shut off). It does this by saving an image of your system's memory into a file called hiberfil.sys, located in the root directory of your windows drive (usually C:\); when the computer comes out of hibernation, the file is read back into memory and your previous session is restored, all without having to reload Windows or any of your applications.

**UPS**

Windows XP includes built-in support for Un-interruptible Power Supplies (UPSSs), which keep your computer running in the event of a power outage or other disruption. Depending on the capacity of your UPS, you may have anywhere from a few minutes to a half hour to save your work and shut down your computer gracefully. A UPS is a good investment if you live in a stormy climate or other area where power interruptions are frequent. Although a UPS doesn't really have to interact with Windows at all, support configured through this dialog enables some advanced features, such as monitoring tools that alert you when a power outage has occurred and inform you of how much power is left in the UPS battery.
Notes

All settings in this dialog are also covered in Chapter 6.

See Also

Control Panel

Printers and Faxes

Manage local and network printers.

To Open

Start ➔ Settings ➔ Printers and Faxes (Classic Start menu only)
Control Panel ➔ [Printers and Other Hardware] ➔ Printers and Faxes
Command Prompt ➔ control printers

Description

The Printers and Faxes folder contains icons representing your installed printers and fax devices. Once a printer is installed here, you can print to it from within your applications, drag documents to its icon to print them, or double-click on the printer icon to see or change the status of current print jobs (see Figure 6-2).

**Figure 6-2. Use the Printers and Faxes folder to add, configure, and troubleshoot your printers**

The Add Printer wizard helps you select the appropriate printer driver for a local or network printer. The context menu for each printer, among other things, allows you to select that printer as the default printer — the one that appears, by default, in all your applications’ print dialogs.

File ➔ Print is the standard way to print for most applications. Right-clicking on a file then selecting Print from its context menu allows you to send a file to the printer without opening it first, although this can have mixed results. You can also create a shortcut to a printer on the Desktop and then drag-and-drop a file on the printer icon.

If you drag more than one file to a printer icon, the...
system will open a separate copy of the application for each file. This may be OK for text files and a small application like Notepad, but drag a group of Word or Excel files to the printer, and it may bring your system to its knees.

Double-click on any printer icon for a view of the printer's job queue. You'll see the document name, status (printing, paused, and so on), the owner of the job, progress (in number of pages printed), and when the job was started. You can drag your own jobs up and down to change their priority. Use the Printer menu to pause the printer or purge all print jobs. Use the Document menu to pause or cancel (delete) any selected documents.

Notes

- To have more than one computer print to the same printer, just connect the printer directly to one of the computers. After it has been installed, right-click its icon, select Sharing, and click the Share this printer option. Once a printer has been shared, it can be installed as a network printer on all the other computers on the network (see Figure 8-yr). See Chapter v for more details.

Figure 8-yr. Let others on your network print to your computer with the Sharing tab

- You can choose whether print spooling ("offline printing") should be enabled for any printer. If offline printing is selected, you can print to a network printer even when you aren't connected, or to a local printer when it is turned off. When the printer then becomes available, you will be asked whether to print any files in the queue.

See Also

Control Panel
**Private Character Editor**

Create special characters, such as logos or symbols, that can be inserted into ordinary documents.

**To Open**

Command Prompt → eudcedit

**Description**

The Private Character Editor is like a small-image editor (see Paint, earlier in this chapter), except that the images created with it are used like symbol fonts, making it easy to insert any custom logo or symbol into your documents.

When you first start the Private Character Editor, you'll be presented with a rather confusing Select Code window. This is used to associate the new (or existing) character you'll be editing with a particular slot, and is somewhat akin to the main Character Map window. Select any slot and click OK to proceed.

The main window contains the character editor and a simple set of drawing tools (like those found in Paint, discussed earlier in this chapter). Each character is a 10x10 black and white bitmap. Draw in black with any of the available tools and the left mouse button; draw in white with the right mouse button. You can copy and paste bitmap selections between the Private Character Editor and other image editing programs, such as Paint.

When you're done, save your work into the slot you chose in the first screen by going to Edit → Save Character (Ctrl-S). Or, save it into a different slot by going to Edit → Save Character As. At any time, you can choose a different slot to edit with Edit → Select Code, or with View → Next Code (Ctrl-N) and View → Prev Code (Ctrl-P). As you choose slots in which to place your new characters, you can use another font as a reference to decide the most convenient slots to use. Select Window → Reference to view the orientation of an existing font on your computer.

To use your new character in another application, open Character Map (charmap.exe) and choose "All Fonts (Private Characters)" from the top of the list. If this entry is not present, you didn't save your work. See Character Map, earlier in this chapter, for more information on pasting characters into other applications.

**See Also**

Character Map

**Product Activation**

See Activate Windows.
The obsolete Program Manager interface, found in Windows \text{r.x} and Windows NT \text{r.x}.

**To Open**

Command Prompt \rightarrow \text{progman}

The Program Manager is a simple icon-based menu system used in Microsoft Windows \text{r.x} and Windows NT \text{r.x}. All of the more modern releases of Windows have abandoned Program Manager (with good cause) in favor of the Start menu and other features of Windows Explorer. Program Manager is still included for legacy purposes. Of course, a simple folder filled with Windows Shortcuts serves the same purpose and does a much better job of it, too.

**See Also**

Windows Explorer

**Query Process** \text{\backslash windows\backslash system\backslash x}\text{d-o process.exe}

Display a list of running processes.

**To Open**

Command Prompt \rightarrow \text{qprocess}

**Usage**

\text{qprocess [target] [/server:computer] [/system]}

**Description**

Query Process is a simple, command-line utility used to display a list of the running processes. A process is essentially any program running in the foreground or running invisibly in the background. Task Manager, discussed later in this chapter, does the same thing, but is much easier to use. Query Process takes the following parameters:

\text{target}

Target can be any of the following: Specify a username to display the processes started by that user. Specify a session name or number (via \text{/id:sessionid}) to display all the processes started in that session. Specify a program name to display all the processes associated with that program. Specify an asterisk (*) to list all processes. Finally, omit \text{target} to display all the processes started by the current user.
/server: computer
Query a remote computer, where computer is the network name of the machine. Omit to display processes for the local computer.

/system
Include system processes. Type qprocess * /system to display all the currently running processes.

See Also
Task Manager, Taskkill, and Tasklist

Regional and Language Options \windows\system\intl.cpl

Language and localization settings affecting the display of numbers, currency, times, and dates.

To Open
Control Panel ➔[Date, Time, Language, and Regional Options] ➔Regional and Language Options
Command Prompt ➔intl.cpl
Command Prompt ➔control international

Description
Numbers, times, dates, and currency are displayed differently in different parts of the world, and the Regional and Language Options dialog (see Figure ε-ψ) allows you to choose your display preferences in painful detail.

Figure ε-ψ. Choose the way dates, times, and currency are displayed with the Regional and Language Options dialog
This dialog has the following tabs:

**Regional Settings**
Select your language from the list and click Customize to start choosing your preferences. The settings in this dialog are fairly self-explanatory, although it's important to realize that the entries in the language list are not "themes." That is, if you customize your settings and then change the language in the list, those customized settings will be lost.

**Languages**
Click Details if you wish to change the desired language or to add support for additional languages. If more than one language is installed, the Language Bar and Key Settings features will be available, which can be used to easily switch between the installed languages with a Desktop bar or keyboard shortcut, respectively.

**Advanced**
Most programs should be able to detect the preferred language, and if supported, adjust their interfaces accordingly. The "Language for non-Unicode programs" option is used to add support for older programs that don't recognize the settings made in the Languages tab. The Code page conversion tables, when installed, can be accessed in word processors and web browsers, enabling the display of foreign language content. Most users won't have a need to alter these settings, although you may need to if a particular document or web page isn't being displayed correctly.

**Notes**
All of the settings in this dialog are also covered in Chapter 6.

**See Also**

Control Panel
Recycle Bin

See Windows Explorer.

Registry Console Utility \windows\system32\reg.exe

A command-line utility to access and modify portions of the Windows Registry.

To Open

Command Prompt → reg

Usage

reg command[options]

Description

The Registry Console Utility performs all of the functions of the Registry Editor, discussed later in chapter and in Chapter 4, but can be used from the command line. It also does a few things Registry Editor can’t do, such as making a duplicate of a registry key (via copy, below). To use the Registry Console Utility, type reg, followed by one of the following commands and any applicable parameters:

- **query**
  
  Displays the data stored in a Registry value, where **keyname** is the full path of a registry key and **valuename** is the name of the value to query. Omit **/v valuename** to display list of all the values in **keyname** or specify **/ve** to query the (Default) value. Include **/s** to query all subkeys and values as well. Valuename can also specify the remote computer like this: query computer\keyname.

- **add**
  
  Adds a new value. The **keyname**, **/v**, and **/ve** options are the same as with query, above. The **/d** option assigns **data** to the new value; if omitted, the new value will be empty. Use **/t** to specify the data type for the value; if omitted, a string value (REG_SZ) will be added. Use the **/s** option to specify a separator, used if you're creating a REG_MULTI_SZ value. If the value being added already exists, you'll be prompted to overwrite, unless the **/f** parameter is specified.

- **delete**
  
  Deletes an existing value. All options are the same as with add, above. The **/va** parameter instructs the Registry Console Utility to delete all values in the specified key.

- **copy**
  
  Copies the Registry Console Utility to delete all values in the specified key.
Duplicates a key and all its values, where `keyname1` is the full path of the source key and `keyname2` is the full path of the new key. Specify `/s` to include all subkeys and their values and use the `/f` option to force the copy without first being prompted.

```
save keyname filename
```

Saves a portion of the registry into a file, where `keyname` is the full path of the key to save, and `filename` is the name of the new hive file. Note that this command does not create a registry patch (.reg) file, but a binary hive file that can only be read with `restore`, below. Note also that the root key in `keyname` must be a four-letter abbreviation (e.g., HKLM, HKCU, HKCR, HKU, or HKCC).

```
restore keyname filename
```

Reads a hive file (created with `save`, above) into the Registry. Note that `keyname` doesn't have to be the same as the key from which the file was originally created. See the notes for `save` for details. Only works on the local machine.

```
load keyname filename
```

Installs a hive file (created with `save`, above) onto the Registry. `Load` is similar to `restore`, above, except that any changes to the loaded keys or values are stored back into the hive file specified by `filename`. With `restore`, on the other hand, the new keys are added to a pre-existing hive.

```
unload keyname
```

Uninstalls a key, `keyname`, that has been installed with `load`, above.

```
compare keyname1 keyname2 [/v valuename | /ve] [/s] [ /output]
```

Compares two keys or values. The `keyname1` and `keyname2` options are the same as with `copy`, above. The `/v`, `/ve`, and `/s` options are the same as with `add`, above. The `/output` option can be `/oa` (output all differences and matches), `/od` (output only differences), `/os` (output only matches), or `/on` (no output); when omitted, `/od` is assumed. See `reg compare /?` for more information.

```
export keyname filename
```

Creates a registry patch (.reg) file, `filename`, from the key at `keyname`. Registry patches can be imported with `import`, below, or by double-clicking in Explorer (via Registry Editor).

```
import filename
```

Imports a registry patch (.reg) file, `filename`, created either with `export`, above, or with Registry Editor.

**Notes**

- All of the concepts in terms discussed here are explained in [Chapter 1](#).
- Many of the functions discussed here can only be accomplished with the Registry Console Utility and are not possible with Registry Editor. Among them are the `copy`, `save`, `restore`, `load`, `unload`, and `compare` commands.

**See Also**

- [Registry Editor, Chapter 1](#)

---

### Registry Editor

`\windows\regedit.exe`
View and modify the contents of the Registry.

To Open

Command Prompt → regedit

Description

Registry Editor provides a means to view and modify the contents of the Windows Registry, the master database that stores configuration settings for Windows XP and many of the applications on your computer. However, don't confuse Registry Editor with the Registry; Registry Editor is merely an application, like any other. See Chapter 1 for more information on the Registry and the use of Registry Editor. See Chapter 6 for many of the settings that can also be changed in the Registry.

See Also

Registry Console Utility

Remote Assistance

`\windows\system32\rcimlbs.exe -LaunchRA`

Allow others to connect to your computer using Remote Desktop Connection.

To Open

Start → Programs → Remote Assistance
Command Prompt → rcimlb -LaunchRA

Description

Remote Assistance is a page in the Help and Support Center (discussed earlier in this chapter) that works with several other Windows components to allow another user to connect to your computer. The idea is that you would invite a technical support representative, a friend, or co-worker, to help you with a computer problem by allowing them to connect to your computer as though they were sitting in front of it (see Figure ε-vo).

Figure ε-vo. Use Remote Assistance to invite another person to connect to your computer with Remote Desktop Sharing
The first step involves inviting another user to connect. While it may seem like an unnecessary formality, it takes care of the very important step of transmitting your IP address to the other user. You can either use Windows Messenger (discussed later in this chapter) to send an instant message or Outlook Express (discussed earlier in this chapter) to send an email. Once the invitation has been received, that user will have enough information to connect to your computer via Remote Desktop Connection (discussed later in this chapter).

Notes

- Both users must be running Windows XP to use Remote Assistance.
- Remote Assistance is a very interesting use of integration, where several seemingly disparate components can work together to accomplish a single task.
- Either Outlook Express or Windows Messenger are required to send an invitation, which means that at least one of these programs must be set up with your account information prior to using Remote Assistance. Note that you can skip this step if you wish to 1) transmit your IP address to the other user, and 2) set up your computer to accept connections via Remote Desktop Connection.
- Remote Assistance opens several back doors to your computer, potentially allowing unwanted access to your computer and data. Be sure to take advantage of the features in Remote Assistance to help protect your computer, such as requiring a password and allowing only remote connection within the next hour.
- When you send an invitation via email, the recipient receives a link to http://windows.microsoft.com/RemoteAssistance/RA.asp, as well as a file attachment (rcBuddy.MsRcIncident) with your connection information. The information stored in the file attachment is not easily readable; the recipient simply opens the attachment to initiate a connection.
- If you get the error "Your current system settings prevent you from sending an invitation," it means that the Remote Assistance feature has been disabled for security reasons. You can re-enable it by going to Control Panel → [Performance and Maintenance] → System → Remote tab and turning on both options on this page.
See Also

Remote Desktop Connection

**Remote Copy**  
\windows\system32\rcp.exe

Copies files between two remote computers.

**To Open**

Command Prompt → `rcp`

**Usage**

`rcp [-b] [-h] [-r] source destination`

**Description**

Remote Copy is a little tool you can use to copy one or more files from one remote computer to another remote computer without first transferring the files to your own computer. Remote Copy takes the following parameters:

- **source, destination**
  
  The full network path of the source file and destination, respectively. See the examples below for syntax. Specify a folder name for `source` to transfer that folder and all of its contents. You can specify wildcards here (to transfer multiple files at once), but only with an escape character (e.g., `apple.*` becomes `apple.\*`).

- **-b**
  
  Transfers the files with binary mode; the default is ASCII mode. See the discussion of ASCII and binary modes in *FTP*, discussed earlier in this chapter.

- **-h**
  
  Include the `-h` parameter to transfer hidden files.

- **-r**
  
  When copying a folder, include all the subfolders and their contents.

**Examples**

The following command transfers the file, `c:\docs\rings.txt`, from the computer called `cooder` to the `c:\stuff` folder in the computer called `spud`:

```
rcp -b \cooder\c\docs\rings.txt \spud\c\stuff
```

The following command does the same thing, but using IP addresses (when accessing computers on the Internet) instead of on a local network.

Note how the usernames (mandatory with IP addresses) are specified:

```
rcp -b 192.168.1.1.cooder.c\docs\rings.txt 192.168.1.1.spud:c\stuff
```
Both the source and destination computer must be running the RCP service.
The username must be specified if the host (either in the source or
destination) is an IP address.

See Also

FTP

Remote Desktop Connection \windows\system 32\mstsc.exe

Access another computer remotely, as though you were sitting in front of it.
(Remote Desktop Connection is included with Windows XP Professional only.)

To Open

Start ➔ Programs ➔ Accessories ➔ Communications ➔ Remote Desktop Connection
Command Prompt ➔ mstsc

Description

Remote Desktop Connection allows you to connect to another computer (or allows
someone else to connect your computer) and use it as though you were sitting in
front of it. Much more than simply a Telnet connection, Remote Desktop Connection
allows you to see a full Desktop, complete with icons and the Start menu, and even
run programs on the remote computer (see Figure 4-7).
To configure a computer to accept incoming connections via Remote Desktop Connection, go to Control Panel → [Performance and Maintenance] → System → Remote tab, and turn on the "Allow users to connect remotely to this computer" option. By default, the administrator always has access, but you can enable access for other users as well by clicking Select Remote Users.

Once a computer has been set up, you can connect to it by opening Remote Desktop Connection and typing that computer’s name (if connected on a local network) or that computer’s IP address (if connected to the Internet). Click Options to specify a username, password, domain (only for Windows NT domains), and even to save your connection settings to a file so you can connect more easily later. The Display tab lets you choose between full-screen mode and windowed mode. The Local Resources tab lets you choose whether sounds generated by the remote computer are played locally (which can slow the connection), whether certain keystroke combinations are interpreted locally or sent to the remote computer, and whether to automatically connect you to the remote computer’s disks, printers, or serial ports. Choose the Programs tab to set up a program to start automatically when a connection has been established. Finally, the Experience tab allows you to turn on or off features that will affect performance; depending on your connection, for example, you may wish to enable or disable the remote computer’s background wallpaper.

You can save the connection profile for a particular connection by clicking Save As. This will create an Remote Desktop Profile (.rdp) file, which can then be double-clicked to start the connection without having to retype the connection information. Right-click any .rdp file and select Edit to return to the Properties dialog for the profile.

Notes

- Currently, both computers involved in a Remote Desktop Connection must be running Windows XP, although Microsoft may release Remote Desktop Connection clients for other versions of Windows in the future.
feature of Microsoft NetMeeting (discussed earlier in this chapter). Unlike Remote Desktop Connection, these alternatives work on all modern versions of Windows. Furthermore, VNC works on Unix and Macintosh systems as well.

- Remote Desktop Connection replaces the Terminal Services client found in Windows NT and Windows 2000.

**See Also**

Remote Assistance, Telnet

**Route**

\`windows\system32\route.exe\`

Manipulate the TCP/IP routing table for the local computer.

**To Open**

Command Prompt → route

**Usage**

```
route [-f] [-p] [command] [destination] [gateway]
      [mask netmask] [metric metric] [if interface]
```

**Description**

Routing tables provide information necessary to connect to other computers on a network or the Internet. Route accepts the following options:

*command*

Specifies one of four commands:

- **print**
  Prints a route (similar to `netstat -r`). The route print command is useful if you are having a problem (e.g., "Host Unreachable" or "Request timed out") with the routes on your computer, since it will display all the different fields in the active route (see the example).

- **add**
  Adds a route to the routing table; used until the computer is shut down (unless the `-p` option is specified).

- **delete**
  Deletes a route from the routing table.

- **change**
  Modifies an existing route in the routing table.

*destination*

The remote computer that is reachable via `gateway`.

- **-f**
  Frees (clears) the routing tables of all gateway entries. If this is used in conjunction with one of the commands listed above, the tables are cleared prior to running the command.

- **-p**
When used with the add command, -p makes a route persistent across boots of the system. If you don't specify -p, any route you add will be valid only until the computer is restarted. The -p option has no effect on other commands, as they're all persistent.

gateway

The gateway computer to be used for traffic going to destination. It is possible to use a hostname for the gateway, but it is safer to use an IP address, as a hostname may resolve to multiple IP addresses. For example, you might type the following:

```
rout...
**See Also**

Tracert

---

**Rundll**

\windows\system32\rundll.exe

---

Run a single routine in a DLL file from the command line.

**To Open**

Command Prompt → rundll

**Usage**

rundll filename, function_name[function_arguments...]

**Description**

Rundll provides "string invocation," which lets you execute a command buried in a Dynamic Link Library (DLL) file.

Rundll accepts the following options:

- **filename**
  The filename of a DLL (.dll) file.

- **function_name**
  The case-sensitive name of a function in the DLL file.

- **function_arguments**
  Any parameters used by function_name; refer to the function's documentation for details. Note that any string parameters are case sensitive.

**Examples**

The following example starts the "Network Setup Wizard" (note that no parameters are required for this one):

rundll.exe hinetwiz.dll,HomeNetWizardRunDll

This batch file allows you to display an "Open As" dialog box for unknown file type .xyz without actually having a file of type .xyz handy (see Appendix C for more information on batch files):

echo blah blah blah > foobar.

rundll shell.dll,OpenAs_RunDLL foobar.

Then type the following at a command line:

C: \openas xyz

**Notes**

Rundll provides dynamic linking to functions exported from 16-bit Dynamic Link Libraries. Rundll, the 16-bit equivalent found in earlier versions of Windows, is not included in Windows XP.
Run As

\windows\system32\runas.exe

Run a program under a different user's account.

To Open

Command Prompt → runas

Usage

runas [/noprofile] [/env] [/netonly] /user:username program

[/user:username] program

Description

Windows XP is a multiuser environment. When you open an application, Windows runs that program in a "user context," which means that the settings and capabilities imposed upon an application are those associated with your user account. Use Run As to instruct Windows to open an application in another user's context. This is especially useful when running services or other background applications, where you can't always assume which user will be logged on at any time, but you want to make sure the settings and permissions are correct. Run As takes the following parameters:

**program**

The full path, filename, and optional command-line parameters for the .exe file to run.

**/user:** username

The username under which to run program; username should be of the form user@domain or domain\user.

**/noprofile**

Specifies that the user's profile should not be loaded. This causes the application to load more quickly, but can cause those applications that rely on settings stored in the HKEY_CURRENT_USER registry key to malfunction.

**/env**

Uses the current environment instead of username's.

**/netonly**

Specifies that the credentials specified are for remote access only.

**/savecred**

Uses credentials previously saved by the user. This option is not available on Windows XP Home Edition and will be ignored.

**/smartcard**

Specifies that the credentials are to be supplied from a smartcard.

Notes
Scheduled Tasks, discussed later in this chapter, also lets you run programs under different user accounts.